summaryrefslogtreecommitdiffstats
path: root/bsp/meta-arm/meta-arm-autonomy/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-arm/meta-arm-autonomy/recipes-kernel')
-rw-r--r--bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/bsp/arm-autonomy/arm64-autonomy-guest-standard.scc5
-rw-r--r--bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/bsp/arm-autonomy/arm64-autonomy-guest.cfg2
-rw-r--r--bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/bsp/arm-autonomy/arm64-autonomy-guest.scc6
-rw-r--r--bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/features/arm-autonomy/xen-guest.cfg54
-rw-r--r--bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/features/arm-autonomy/xen-guest.scc4
-rw-r--r--bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/features/arm-autonomy/xen-host.cfg38
-rw-r--r--bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/features/arm-autonomy/xen-host.scc4
-rw-r--r--bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/linux-%.bbappend3
-rw-r--r--bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/linux-arm-autonomy.inc22
9 files changed, 138 insertions, 0 deletions
diff --git a/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/bsp/arm-autonomy/arm64-autonomy-guest-standard.scc b/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/bsp/arm-autonomy/arm64-autonomy-guest-standard.scc
new file mode 100644
index 00000000..7c75d99f
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/bsp/arm-autonomy/arm64-autonomy-guest-standard.scc
@@ -0,0 +1,5 @@
+define KMACHINE arm64-autonomy-guest
+define KTYPE standard
+define KARCH arm64
+
+include arm64-autonomy-guest.scc
diff --git a/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/bsp/arm-autonomy/arm64-autonomy-guest.cfg b/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/bsp/arm-autonomy/arm64-autonomy-guest.cfg
new file mode 100644
index 00000000..fcdad985
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/bsp/arm-autonomy/arm64-autonomy-guest.cfg
@@ -0,0 +1,2 @@
+CONFIG_ARM64=y
+CONFIG_SMP=y
diff --git a/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/bsp/arm-autonomy/arm64-autonomy-guest.scc b/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/bsp/arm-autonomy/arm64-autonomy-guest.scc
new file mode 100644
index 00000000..e887b4e5
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/bsp/arm-autonomy/arm64-autonomy-guest.scc
@@ -0,0 +1,6 @@
+include ktypes/standard/standard.scc
+include features/input/input.scc
+include features/net/net.scc
+include cfg/timer/no_hz.scc
+
+kconf hardware arm64-autonomy-guest.cfg
diff --git a/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/features/arm-autonomy/xen-guest.cfg b/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/features/arm-autonomy/xen-guest.cfg
new file mode 100644
index 00000000..e4e44a9c
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/features/arm-autonomy/xen-guest.cfg
@@ -0,0 +1,54 @@
+CONFIG_PARAVIRT=y
+CONFIG_XEN=y
+
+CONFIG_BLOCK=y
+CONFIG_XEN_BLKDEV_FRONTEND=y
+
+CONFIG_SCSI=y
+CONFIG_XEN_SCSI_FRONTEND=y
+
+CONFIG_NET=y
+CONFIG_XEN_NETDEV_FRONTEND=y
+
+CONFIG_INPUT=y
+CONFIG_INPUT_MISC=y
+CONFIG_INPUT_XEN_KBDDEV_FRONTEND=y
+
+CONFIG_HVC_IRQ=y
+
+CONFIG_HVC_XEN=y
+CONFIG_HVC_XEN_FRONTEND=y
+
+CONFIG_WATCHDOG=y
+CONFIG_XEN_WDT=y
+
+CONFIG_FB_SYS_FILLRECT=y
+CONFIG_FB_SYS_COPYAREA=y
+CONFIG_FB_SYS_IMAGEBLIT=y
+CONFIG_FB_SYS_FOPS=y
+CONFIG_FB_DEFERRED_IO=y
+CONFIG_XEN_FBDEV_FRONTEND=y
+
+CONFIG_XEN_BALLOON=y
+
+CONFIG_XEN_DEV_EVTCHN=y
+
+CONFIG_XENFS=y
+CONFIG_XEN_COMPAT_XENFS=y
+
+CONFIG_XEN_SYS_HYPERVISOR=y
+CONFIG_XEN_XENBUS_FRONTEND=y
+CONFIG_XEN_GNTDEV=y
+CONFIG_XEN_GRANT_DEV_ALLOC=y
+CONFIG_SWIOTLB_XEN=y
+
+CONFIG_XEN_EFI=y
+CONFIG_XEN_AUTO_XLATE=y
+
+CONFIG_DRM=y
+CONFIG_DRM_XEN=y
+CONFIG_DRM_XEN_FRONTEND=y
+
+CONFIG_SOUND=y
+CONFIG_SND=y
+CONFIG_SND_XEN_FRONTEND=y
diff --git a/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/features/arm-autonomy/xen-guest.scc b/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/features/arm-autonomy/xen-guest.scc
new file mode 100644
index 00000000..935e78f8
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/features/arm-autonomy/xen-guest.scc
@@ -0,0 +1,4 @@
+define KFEATURE_DESCRIPTION "Enable XEN Guest Frontend Drivers"
+
+kconf non-hardware xen-guest.cfg
+
diff --git a/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/features/arm-autonomy/xen-host.cfg b/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/features/arm-autonomy/xen-host.cfg
new file mode 100644
index 00000000..d457cb84
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/features/arm-autonomy/xen-host.cfg
@@ -0,0 +1,38 @@
+CONFIG_PARAVIRT=y
+CONFIG_XEN=y
+
+CONFIG_BLOCK=y
+CONFIG_XEN_BLKDEV_BACKEND=y
+
+CONFIG_SCSI=y
+CONFIG_TARGET_CORE=y
+CONFIG_XEN_SCSI_BACKEND=y
+
+CONFIG_NET=y
+CONFIG_XEN_NETDEV_BACKEND=y
+
+CONFIG_HVC_IRQ=y
+
+CONFIG_HVC_XEN=y
+
+CONFIG_WATCHDOG=y
+CONFIG_XEN_WDT=y
+
+CONFIG_XEN_BALLOON=y
+
+CONFIG_XEN_DEV_EVTCHN=y
+
+CONFIG_XENFS=y
+CONFIG_XEN_COMPAT_XENFS=y
+
+CONFIG_XEN_SYS_HYPERVISOR=y
+CONFIG_XEN_GNTDEV=y
+CONFIG_XEN_GRANT_DEV_ALLOC=y
+CONFIG_SWIOTLB_XEN=y
+
+CONFIG_XEN_EFI=y
+CONFIG_XEN_AUTO_XLATE=y
+
+# For LVM2 we need Multiple Devices and Device Mapper support
+CONFIG_MD=y
+CONFIG_BLK_DEV_DM=y
diff --git a/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/features/arm-autonomy/xen-host.scc b/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/features/arm-autonomy/xen-host.scc
new file mode 100644
index 00000000..6fdbabc4
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/arm-autonomy-kmeta/features/arm-autonomy/xen-host.scc
@@ -0,0 +1,4 @@
+define KFEATURE_DESCRIPTION "Enable XEN Host Drivers on autonomy systems"
+
+kconf non-hardware xen-host.cfg
+
diff --git a/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/linux-%.bbappend b/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/linux-%.bbappend
new file mode 100644
index 00000000..add70425
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/linux-%.bbappend
@@ -0,0 +1,3 @@
+# Add arm-autonomy kernel support
+require linux-arm-autonomy.inc
+
diff --git a/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/linux-arm-autonomy.inc b/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/linux-arm-autonomy.inc
new file mode 100644
index 00000000..27634447
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-autonomy/recipes-kernel/linux/linux-arm-autonomy.inc
@@ -0,0 +1,22 @@
+# Add arm-autonomy specific features to the kernel
+
+FILESEXTRAPATHS_prepend := "${THISDIR}:"
+
+#
+# arm-autonomy kmeta
+#
+SRC_URI_append = " file://arm-autonomy-kmeta;type=kmeta;name=arm-autonomy-kmeta;destsuffix=arm-autonomy-kmeta"
+
+
+# Add xen host drivers to kernel if arm-autonomy-host is activated
+KERNEL_FEATURES += "${@bb.utils.contains('DISTRO_FEATURES', \
+ 'arm-autonomy-host', 'features/arm-autonomy/xen-host.scc', '', d)}"
+
+# Add xen guest drivers to kernel if arm-autonomy-guest is activated
+KERNEL_FEATURES += "${@bb.utils.contains('DISTRO_FEATURES', \
+ 'arm-autonomy-guest', 'features/arm-autonomy/xen-guest.scc', '', d)}"
+
+# Add support for arm64-autonomy-guest machine
+COMPATIBLE_MACHINE_arm64-autonomy-guest = "arm64-autonomy-guest"
+KMACHINE_arm64-autonomy-guest = "arm64-autonomy-guest"
+