summaryrefslogtreecommitdiffstats
path: root/bsp/meta-arm/meta-arm-bsp/conf
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-arm/meta-arm-bsp/conf')
-rw-r--r--bsp/meta-arm/meta-arm-bsp/conf/layer.conf13
-rw-r--r--bsp/meta-arm/meta-arm-bsp/conf/machine/a5ds.conf25
-rw-r--r--bsp/meta-arm/meta-arm-bsp/conf/machine/foundation-armv8.conf14
-rw-r--r--bsp/meta-arm/meta-arm-bsp/conf/machine/fvp-base.conf14
-rw-r--r--bsp/meta-arm/meta-arm-bsp/conf/machine/fvp-common/fvp.inc43
-rw-r--r--bsp/meta-arm/meta-arm-bsp/conf/machine/gem5-arm64.conf53
-rw-r--r--bsp/meta-arm/meta-arm-bsp/conf/machine/juno.conf28
-rw-r--r--bsp/meta-arm/meta-arm-bsp/conf/machine/n1sdp.conf23
8 files changed, 213 insertions, 0 deletions
diff --git a/bsp/meta-arm/meta-arm-bsp/conf/layer.conf b/bsp/meta-arm/meta-arm-bsp/conf/layer.conf
new file mode 100644
index 00000000..1a54ddcf
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-bsp/conf/layer.conf
@@ -0,0 +1,13 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "meta-arm-bsp"
+BBFILE_PATTERN_meta-arm-bsp = "^${LAYERDIR}/"
+BBFILE_PRIORITY_meta-arm-bsp = "6"
+
+LAYERDEPENDS_meta-arm-bsp = "core openembedded-layer meta-arm"
+LAYERSERIES_COMPAT_meta-arm-bsp = "warrior zeus dunfell"
diff --git a/bsp/meta-arm/meta-arm-bsp/conf/machine/a5ds.conf b/bsp/meta-arm/meta-arm-bsp/conf/machine/a5ds.conf
new file mode 100644
index 00000000..fa7d88e2
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-bsp/conf/machine/a5ds.conf
@@ -0,0 +1,25 @@
+# Configuration for Cortex-A5 DesignStart development board
+
+#@TYPE: Machine
+#@NAME: a5ds machine
+#@DESCRIPTION: Machine configuration for Cortex-A5 DesignStart
+
+require conf/machine/include/tune-cortexa5.inc
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-upstream-arm"
+PREFERRED_VERSION_linux-upstream-arm ?= "5.3%"
+KBUILD_DEFCONFIG = "multi_v7_defconfig"
+
+EXTRA_IMAGEDEPENDS += "virtual/trusted-firmware-a u-boot"
+
+SERIAL_CONSOLES = "115200;ttyAMA0"
+
+IMAGE_FSTYPES += "tar.bz2 cpio.gz"
+
+EXTRA_IMAGEDEPENDS += "u-boot"
+
+# Cortex-a5 u-boot configuration
+UBOOT_MACHINE = "designstart_ca5_defconfig"
+UBOOT_IMAGE_ENTRYPOINT = "0x84000000"
+UBOOT_IMAGE_LOADADDRESS = "0x84000000"
+
diff --git a/bsp/meta-arm/meta-arm-bsp/conf/machine/foundation-armv8.conf b/bsp/meta-arm/meta-arm-bsp/conf/machine/foundation-armv8.conf
new file mode 100644
index 00000000..73d2798c
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-bsp/conf/machine/foundation-armv8.conf
@@ -0,0 +1,14 @@
+# Configuration for Armv8-A Foundation
+
+#@TYPE: Machine
+#@NAME: Armv8-A Foundation Platform machine
+#@DESCRIPTION: Machine configuration for Armv8-A Foundation Platform model
+
+require conf/machine/fvp-common/fvp.inc
+
+KERNEL_DEVICETREE = "arm/foundation-v8-gicv3-psci.dtb"
+
+# Use haveged as a source of entropy instead of rng-tools (Needed for ssh).
+# rngd (Part of rng-tools) takes ~7 mins to init resulting in a slow boot time.
+PACKAGE_EXCLUDE_append = " rng-tools"
+IMAGE_INSTALL_append = " haveged"
diff --git a/bsp/meta-arm/meta-arm-bsp/conf/machine/fvp-base.conf b/bsp/meta-arm/meta-arm-bsp/conf/machine/fvp-base.conf
new file mode 100644
index 00000000..30396442
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-bsp/conf/machine/fvp-base.conf
@@ -0,0 +1,14 @@
+# Configuration for Armv8-A Base Platform FVP
+
+#@TYPE: Machine
+#@NAME: Armv8-A Base Platform FVP machine
+#@DESCRIPTION: Machine configuration for Armv8-A Base Platform FVP model
+
+require conf/machine/fvp-common/fvp.inc
+
+KERNEL_DEVICETREE = "arm/fvp-base-gicv3-psci-custom.dtb"
+
+# Use haveged as a source of entropy instead of rng-tools (Needed for ssh).
+# rngd (Part of rng-tools) takes ~7 mins to init resulting in a slow boot time.
+PACKAGE_EXCLUDE_append = " rng-tools"
+IMAGE_INSTALL_append = " haveged"
diff --git a/bsp/meta-arm/meta-arm-bsp/conf/machine/fvp-common/fvp.inc b/bsp/meta-arm/meta-arm-bsp/conf/machine/fvp-common/fvp.inc
new file mode 100644
index 00000000..08f8b15a
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-bsp/conf/machine/fvp-common/fvp.inc
@@ -0,0 +1,43 @@
+# FVP common parameters
+
+#
+# Capturing FVP common configurations (Armv8-A Base Platform FVP and
+# Armv8-A Foundation Platform).
+#
+
+TUNE_FEATURES = "aarch64"
+
+require conf/machine/include/arm/arch-armv8a.inc
+
+MACHINE_FEATURES = "optee"
+
+KERNEL_IMAGETYPE = "Image"
+
+IMAGE_CLASSES += "image_types_disk_img"
+IMAGE_FSTYPES += "disk.img"
+
+# Disk image configuration
+# We don't use the first partition
+DISK_IMG_PARTITION1_SIZE = "128"
+DISK_IMG_PARTITION1_FSTYPE = ""
+DISK_IMG_PARTITION1_CONTENT = ""
+
+# Second partition is used for rootfs
+DISK_IMG_PARTITION2_SIZE = "2048"
+DISK_IMG_PARTITION2_FSTYPE = "ext4"
+DISK_IMG_PARTITION2_CONTENT = "rootfs"
+
+# Empty third partition (8G - 2048M - 128M)
+DISK_IMG_PARTITION3_SIZE = "6016"
+DISK_IMG_PARTITION3_FSTYPE = ""
+DISK_IMG_PARTITION3_CONTENT = ""
+
+SERIAL_CONSOLES = "115200;ttyAMA0"
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
+PREFERRED_VERSION_linux-yocto ?= "5.4%"
+
+EXTRA_IMAGEDEPENDS += "virtual/trusted-firmware-a u-boot"
+
+# FVP u-boot configuration
+UBOOT_MACHINE = "vexpress_aemv8a_semi_defconfig"
diff --git a/bsp/meta-arm/meta-arm-bsp/conf/machine/gem5-arm64.conf b/bsp/meta-arm/meta-arm-bsp/conf/machine/gem5-arm64.conf
new file mode 100644
index 00000000..4db86c97
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-bsp/conf/machine/gem5-arm64.conf
@@ -0,0 +1,53 @@
+# Configuration for gem5 running on ARM64
+
+#@TYPE: Machine
+#@NAME: Gem5 arm64 machine
+#@DESCRIPTION: Machine configuration for Gem5 arm64
+
+TUNE_FEATURES = "aarch64"
+
+require conf/machine/include/arm/arch-armv8a.inc
+
+MACHINE_FEATURES = "optee pci"
+
+KERNEL_IMAGETYPES = "Image vmlinux"
+KERNEL_IMAGETYPE = "Image"
+
+IMAGE_FSTYPES += "tar.bz2 ext4"
+
+SERIAL_CONSOLES = "115200;ttyAMA0"
+
+EXTRA_IMAGEDEPENDS += "virtual/gem5-bootloader"
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
+PREFERRED_VERSION_linux-yocto ?= "5.4%"
+
+
+# Uncomment the following if you need to build gem5 provided bootloader, else
+# using standard bootloader by Linux aarch64
+# Use gem5 provided bootloader
+# PREFERRED_PROVIDER_virtual/gem5-bootloader = "gem5-aarch64-bootloader"
+
+# use the dtb stored in the kernel recipe
+# KERNEL_DEVICETREE ?= "gem5-arm64/armv8_gem5_v2_4cpu.dtb"
+
+# Use Linux aarch64 boot wrapper with FDT support and generated
+# dtb (gem5-aarch64-dtb.bb)
+PREFERRED_PROVIDER_virtual/gem5-bootloader = "boot-wrapper-aarch64"
+
+BOOT_WRAPPER_AARCH64_CMDLINE ?= "\
+ earlyprintk=pl011,0x1c090000 console=ttyAMA0 root=/dev/vda rw mem=1G \
+ "
+# Use baremetal profile and axf file so dtb is in axf file
+GEM5_RUN_PROFILE = "configs/example/arm/baremetal.py"
+GEM5_RUN_KERNEL = "linux-system.axf"
+GEM5_RUN_EXTRA = ""
+GEM5_RUN_DTB = ""
+GEM5_RUN_CMDLINE = ""
+
+EXTRA_IMAGEDEPENDS += "gem5-aarch64-native"
+
+# Use haveged as a source of entropy instead of rng-tools (Needed for ssh).
+# rngd (Part of rng-tools) takes ~7 mins to init resulting in a slow boot time.
+PACKAGE_EXCLUDE_append = " rng-tools"
+IMAGE_INSTALL_append = " haveged"
diff --git a/bsp/meta-arm/meta-arm-bsp/conf/machine/juno.conf b/bsp/meta-arm/meta-arm-bsp/conf/machine/juno.conf
new file mode 100644
index 00000000..898a863d
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-bsp/conf/machine/juno.conf
@@ -0,0 +1,28 @@
+# Configuration for juno development board
+
+#@TYPE: Machine
+#@NAME: Juno machine
+#@DESCRIPTION: Machine configuration for Juno
+
+TUNE_FEATURES = "aarch64"
+
+require conf/machine/include/arm/arch-armv8a.inc
+
+MACHINE_FEATURES = "usbhost usbgadget alsa screen wifi bluetooth optee pci"
+
+KERNEL_IMAGETYPE = "Image"
+KERNEL_DEVICETREE = "arm/juno.dtb arm/juno-r1.dtb arm/juno-r2.dtb"
+
+IMAGE_FSTYPES += "tar.bz2 ext4"
+
+SERIAL_CONSOLES = "115200;ttyAMA0"
+
+# Use kernel provided by linaro (Contains support for SCMi or HDMI)
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-linaro-arm"
+PREFERRED_VERSION_linux-linaro-arm ?= "4.19%"
+PREFERRED_VERSION_trusted-firmware-a ?= "2.1%"
+
+EXTRA_IMAGEDEPENDS += "virtual/trusted-firmware-a u-boot firmware-image-juno"
+
+# Juno u-boot configuration
+UBOOT_MACHINE = "vexpress_aemv8a_juno_defconfig"
diff --git a/bsp/meta-arm/meta-arm-bsp/conf/machine/n1sdp.conf b/bsp/meta-arm/meta-arm-bsp/conf/machine/n1sdp.conf
new file mode 100644
index 00000000..5fddcada
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-bsp/conf/machine/n1sdp.conf
@@ -0,0 +1,23 @@
+# Configuration for Arm N1SDP development board
+
+#@TYPE: Machine
+#@NAME: N1SDP machine
+#@DESCRIPTION: Machine configuration for N1SDP
+
+TUNE_FEATURES = "aarch64"
+
+require conf/machine/include/arm/arch-armv8a.inc
+
+KERNEL_IMAGETYPE = "Image"
+KERNEL_DEVICETREE = "n1sdp/n1sdp.dtb"
+
+IMAGE_FSTYPES += "tar.bz2 ext4"
+
+SERIAL_CONSOLES = "115200;ttyAMA0"
+
+# Use kernel provided by linaro (Contains support for SCMi or HDMI)
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-linaro-arm"
+PREFERRED_VERSION_linux-linaro-arm ?= "5.4%"
+
+# RTL8168E Gigabit Ethernet Controller is attached to the PCIe interface
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "linux-firmware-rtl8168"