summaryrefslogtreecommitdiffstats
path: root/bsp/meta-boundary/recipes-boundary/app-startup
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-boundary/recipes-boundary/app-startup')
-rw-r--r--bsp/meta-boundary/recipes-boundary/app-startup/app-startup.bb27
-rwxr-xr-xbsp/meta-boundary/recipes-boundary/app-startup/files/app46
-rw-r--r--bsp/meta-boundary/recipes-boundary/app-startup/files/root.profile5
3 files changed, 0 insertions, 78 deletions
diff --git a/bsp/meta-boundary/recipes-boundary/app-startup/app-startup.bb b/bsp/meta-boundary/recipes-boundary/app-startup/app-startup.bb
deleted file mode 100644
index 1e2e9c8e..00000000
--- a/bsp/meta-boundary/recipes-boundary/app-startup/app-startup.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright (C) 2014 Boundary Devices
-
-SUMMARY = "app-startup"
-SECTION = "base"
-LICENSE = "LGPLv3"
-LIC_FILES_CHKSUM = "file://app;beginline=11;endline=11;md5=1c2ccc7e2f30e48720e36f0c0e5d1b79"
-
-S = "${WORKDIR}"
-
-SRC_URI = " \
- file://app \
- file://root.profile \
-"
-
-do_install_append() {
- install -d ${D}${sysconfdir}/init.d/
- install -d ${D}/home/root/
- install -m 755 ${S}/app ${D}${sysconfdir}/init.d/
- install ${S}/root.profile ${D}/home/root/.profile
- update-rc.d -r ${D} app start 80 5 .
-}
-
-FILES_${PN} += " \
- ${sysconfdir}/init.d/app \
- /home/root/.profile \
-"
-
diff --git a/bsp/meta-boundary/recipes-boundary/app-startup/files/app b/bsp/meta-boundary/recipes-boundary/app-startup/files/app
deleted file mode 100755
index 32f7ae4a..00000000
--- a/bsp/meta-boundary/recipes-boundary/app-startup/files/app
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/bin/sh
-### BEGIN INIT INFO
-# Provides: app
-# Required-Start: wifi
-# Required-Stop: wifi
-# Default-Start: S
-# Default-Stop:
-#
-# install with update-rc.d app start 80 5 .
-#
-# SPDX-License-Identifier: LGPL-3.0+
-#
-### END INIT INFO
-
-case "$1" in
- start)
- echo -n "Starting application"
- daemonize /app/run-app
- echo "done"
- ;;
- stop)
- echo -n "Stopping application"
- /app/stop-app
- echo "done"
- ;;
- restart)
- $0 stop
- $0 start
- ;;
- status)
- pid=`pidof -x run-app`
- if [ -n "$pid" ]; then
- echo "run-app (pid $pid) is running ..."
- exit 2
- else
- echo "run-app is stopped"
- fi
- ;;
- *)
- echo "Usage: app { start | stop | restart | status }" >&2
- exit 1
- ;;
-esac
-
-exit 0
-
diff --git a/bsp/meta-boundary/recipes-boundary/app-startup/files/root.profile b/bsp/meta-boundary/recipes-boundary/app-startup/files/root.profile
deleted file mode 100644
index aaa98dd0..00000000
--- a/bsp/meta-boundary/recipes-boundary/app-startup/files/root.profile
+++ /dev/null
@@ -1,5 +0,0 @@
-killem() { /etc/init.d/app stop ; }
-startem() { /etc/init.d/app start ; }
-if [ -e /app/app.profile ]; then
- . /app/app.profile
-fi