summaryrefslogtreecommitdiffstats
path: root/bsp/meta-boundary/recipes-boundary
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-boundary/recipes-boundary')
-rw-r--r--bsp/meta-boundary/recipes-boundary/app-startup/app-startup.bb27
-rwxr-xr-xbsp/meta-boundary/recipes-boundary/app-startup/files/app46
-rw-r--r--bsp/meta-boundary/recipes-boundary/app-startup/files/root.profile5
-rw-r--r--bsp/meta-boundary/recipes-boundary/daemonize/daemonize.bb16
-rw-r--r--bsp/meta-boundary/recipes-boundary/devregs/devregs.bb22
-rw-r--r--bsp/meta-boundary/recipes-boundary/images/boundary-image-multimedia-full.bb17
-rw-r--r--bsp/meta-boundary/recipes-boundary/libmdi2300/libmdi2300_git.bb30
-rw-r--r--bsp/meta-boundary/recipes-boundary/printer-tools/printer-tools_git.bb30
-rw-r--r--bsp/meta-boundary/recipes-boundary/sysklogd-config-remote/files/COPYING282
-rw-r--r--bsp/meta-boundary/recipes-boundary/sysklogd-config-remote/files/syslogd4
-rw-r--r--bsp/meta-boundary/recipes-boundary/sysklogd-config-remote/sysklogd-config-remote.bb23
-rw-r--r--bsp/meta-boundary/recipes-boundary/video-input-icon/files/COPYING12
-rw-r--r--bsp/meta-boundary/recipes-boundary/video-input-icon/files/OV5640-MIPI-Test.desktop9
-rw-r--r--bsp/meta-boundary/recipes-boundary/video-input-icon/files/OV5642.desktop9
-rwxr-xr-xbsp/meta-boundary/recipes-boundary/video-input-icon/files/hdmi-input1
-rw-r--r--bsp/meta-boundary/recipes-boundary/video-input-icon/files/hdmi-input.desktop9
-rwxr-xr-xbsp/meta-boundary/recipes-boundary/video-input-icon/files/ov5640-mipi-test1
-rwxr-xr-xbsp/meta-boundary/recipes-boundary/video-input-icon/files/ov5642-test1
-rw-r--r--bsp/meta-boundary/recipes-boundary/video-input-icon/video-input-icon.bb60
19 files changed, 0 insertions, 604 deletions
diff --git a/bsp/meta-boundary/recipes-boundary/app-startup/app-startup.bb b/bsp/meta-boundary/recipes-boundary/app-startup/app-startup.bb
deleted file mode 100644
index 1e2e9c8e..00000000
--- a/bsp/meta-boundary/recipes-boundary/app-startup/app-startup.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright (C) 2014 Boundary Devices
-
-SUMMARY = "app-startup"
-SECTION = "base"
-LICENSE = "LGPLv3"
-LIC_FILES_CHKSUM = "file://app;beginline=11;endline=11;md5=1c2ccc7e2f30e48720e36f0c0e5d1b79"
-
-S = "${WORKDIR}"
-
-SRC_URI = " \
- file://app \
- file://root.profile \
-"
-
-do_install_append() {
- install -d ${D}${sysconfdir}/init.d/
- install -d ${D}/home/root/
- install -m 755 ${S}/app ${D}${sysconfdir}/init.d/
- install ${S}/root.profile ${D}/home/root/.profile
- update-rc.d -r ${D} app start 80 5 .
-}
-
-FILES_${PN} += " \
- ${sysconfdir}/init.d/app \
- /home/root/.profile \
-"
-
diff --git a/bsp/meta-boundary/recipes-boundary/app-startup/files/app b/bsp/meta-boundary/recipes-boundary/app-startup/files/app
deleted file mode 100755
index 32f7ae4a..00000000
--- a/bsp/meta-boundary/recipes-boundary/app-startup/files/app
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/bin/sh
-### BEGIN INIT INFO
-# Provides: app
-# Required-Start: wifi
-# Required-Stop: wifi
-# Default-Start: S
-# Default-Stop:
-#
-# install with update-rc.d app start 80 5 .
-#
-# SPDX-License-Identifier: LGPL-3.0+
-#
-### END INIT INFO
-
-case "$1" in
- start)
- echo -n "Starting application"
- daemonize /app/run-app
- echo "done"
- ;;
- stop)
- echo -n "Stopping application"
- /app/stop-app
- echo "done"
- ;;
- restart)
- $0 stop
- $0 start
- ;;
- status)
- pid=`pidof -x run-app`
- if [ -n "$pid" ]; then
- echo "run-app (pid $pid) is running ..."
- exit 2
- else
- echo "run-app is stopped"
- fi
- ;;
- *)
- echo "Usage: app { start | stop | restart | status }" >&2
- exit 1
- ;;
-esac
-
-exit 0
-
diff --git a/bsp/meta-boundary/recipes-boundary/app-startup/files/root.profile b/bsp/meta-boundary/recipes-boundary/app-startup/files/root.profile
deleted file mode 100644
index aaa98dd0..00000000
--- a/bsp/meta-boundary/recipes-boundary/app-startup/files/root.profile
+++ /dev/null
@@ -1,5 +0,0 @@
-killem() { /etc/init.d/app stop ; }
-startem() { /etc/init.d/app start ; }
-if [ -e /app/app.profile ]; then
- . /app/app.profile
-fi
diff --git a/bsp/meta-boundary/recipes-boundary/daemonize/daemonize.bb b/bsp/meta-boundary/recipes-boundary/daemonize/daemonize.bb
deleted file mode 100644
index 525fc0e6..00000000
--- a/bsp/meta-boundary/recipes-boundary/daemonize/daemonize.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright (C) 2014 Boundary Devices
-
-SUMMARY = "Daemonize"
-SECTION = "base"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=5003fa041d799dd5dd5f646b74e36924"
-
-S = "${WORKDIR}/git"
-
-SRC_URI = "git://github.com/boundarydevices/daemonize.git;branch=${SRCBRANCH}"
-SRCBRANCH = "master"
-SRCREV = "9c08934f6cbf3cf4bfbdeb92d411072e5d2f7ad0"
-
-inherit autotools-brokensep
-
-
diff --git a/bsp/meta-boundary/recipes-boundary/devregs/devregs.bb b/bsp/meta-boundary/recipes-boundary/devregs/devregs.bb
deleted file mode 100644
index f964f3c4..00000000
--- a/bsp/meta-boundary/recipes-boundary/devregs/devregs.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright (C) 2014 Boundary Devices
-
-SUMMARY = "Devregs"
-SECTION = "base"
-LICENSE = "GPL"
-LIC_FILES_CHKSUM = "file://COPYING;md5=5003fa041d799dd5dd5f646b74e36924"
-
-S = "${WORKDIR}/git"
-
-SRC_URI = "git://github.com/boundarydevices/devregs.git;branch=${SRCBRANCH}"
-SRCBRANCH = "master"
-SRCREV = "8e2537cec400a4cedd1e37a9cc823cea458732e9"
-
-inherit autotools-brokensep
-
-do_install_append() {
- cp -fv ${S}/dat/devregs_imx* ${D}${sysconfdir}/
-}
-
-FILES_${PN} += " \
- ${sysconfdir}/devregs_imx*.dat \
-"
diff --git a/bsp/meta-boundary/recipes-boundary/images/boundary-image-multimedia-full.bb b/bsp/meta-boundary/recipes-boundary/images/boundary-image-multimedia-full.bb
deleted file mode 100644
index 348f6cce..00000000
--- a/bsp/meta-boundary/recipes-boundary/images/boundary-image-multimedia-full.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-# This image extends fsl-image-multimedia-full with additional
-# Boundary Devices packages
-
-require recipes-fsl/images/fsl-image-multimedia-full.bb
-
-CORE_IMAGE_EXTRA_INSTALL += " \
- i2c-tools \
- iperf3 \
- imx-gpu-viv-demos \
- kernel-module-qcacld \
- linux-firmware-bdsdmac \
- mmc-utils \
- openssh \
- spitools \
- networkmanager \
- tslib-tests tslib-calibrate \
-"
diff --git a/bsp/meta-boundary/recipes-boundary/libmdi2300/libmdi2300_git.bb b/bsp/meta-boundary/recipes-boundary/libmdi2300/libmdi2300_git.bb
deleted file mode 100644
index 31b08c04..00000000
--- a/bsp/meta-boundary/recipes-boundary/libmdi2300/libmdi2300_git.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-SUMMARY = "Library for Opticon MDI-2300 Barcode scanner."
-HOMEPAGE = "https://github.com/boundarydevices/libmdi2300"
-LICENSE = "LGPLv2.1+"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e8d8feac5daeb0b39a13e1c1535e1f20"
-SECTION = "libs"
-
-SRCREV = "dce5071fc8e1ac1e87cce0920b975a8cf33cdecc"
-SRC_URI = "git://github.com/boundarydevices/libmdi2300.git;protocol=git;"
-
-S = "${WORKDIR}/git/"
-
-PACKAGES = "${PN} ${PN}-dbg ${PN}-examples"
-
-EXTRA_OEMAKE = " 'CC=${CC}' "
-
-do_compile () {
- oe_runmake all
- oe_runmake examples
-}
-
-do_install () {
- oe_runmake install DESTDIR=${D}/usr/
- oe_runmake install_examples DESTDIR=${D}/usr/
-}
-
-FILES_${PN} += "/usr/lib/ /usr/include"
-FILES_${PN}-dbg += "/usr/src/"
-FILES_${PN}-examples += "/usr/bin/"
-
-BBCLASSEXTEND = "native"
diff --git a/bsp/meta-boundary/recipes-boundary/printer-tools/printer-tools_git.bb b/bsp/meta-boundary/recipes-boundary/printer-tools/printer-tools_git.bb
deleted file mode 100644
index 661a3fe6..00000000
--- a/bsp/meta-boundary/recipes-boundary/printer-tools/printer-tools_git.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-SUMMARY = "Test/Debug tools for thermal printers."
-HOMEPAGE = "https://github.com/boundarydevices/printer-tools"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=4bc53cea4911b2abe17c307d0f49a5d8"
-SECTION = "base"
-
-SRCREV = "e219aea844d720e7b03da495862cc1586132e7dd"
-SRCBRANCH = "ftp628"
-SRC_URI = "git://github.com/boundarydevices/printer-tools.git;protocol=git;branch=${SRCBRANCH}"
-
-S = "${WORKDIR}/git/"
-
-DEPENDS += " libpng "
-
-EXTRA_OEMAKE = " 'CC=${CC}' 'CFLAGS=-I${STAGING_INCDIR}' \
- 'LDFLAGS=-L${STAGING_LIBDIR}' "
-
-do_compile () {
- oe_runmake all
-}
-
-do_install () {
- oe_runmake install DESTDIR=${D}/usr/
-}
-
-FILES_${PN} += "/usr/bin"
-
-INSANE_SKIP_${PN} = "ldflags"
-
-BBCLASSEXTEND = "native"
diff --git a/bsp/meta-boundary/recipes-boundary/sysklogd-config-remote/files/COPYING b/bsp/meta-boundary/recipes-boundary/sysklogd-config-remote/files/COPYING
deleted file mode 100644
index 6f195d36..00000000
--- a/bsp/meta-boundary/recipes-boundary/sysklogd-config-remote/files/COPYING
+++ /dev/null
@@ -1,282 +0,0 @@
-=======================================================================
-
- GNU GENERAL PUBLIC LICENSE
- Version 2, June 1991
-
- Copyright (C) 1989, 1991 Free Software Foundation, Inc.
- 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
- Everyone is permitted to copy and distribute verbatim copies
- of this license document, but changing it is not allowed.
-
- Preamble
-
- The licenses for most software are designed to take away your
-freedom to share and change it. By contrast, the GNU General Public
-License is intended to guarantee your freedom to share and change free
-software--to make sure the software is free for all its users. This
-General Public License applies to most of the Free Software
-Foundation's software and to any other program whose authors commit to
-using it. (Some other Free Software Foundation software is covered by
-the GNU Library General Public License instead.) You can apply it to
-your programs, too.
-
- When we speak of free software, we are referring to freedom, not
-price. Our General Public Licenses are designed to make sure that you
-have the freedom to distribute copies of free software (and charge for
-this service if you wish), that you receive source code or can get it
-if you want it, that you can change the software or use pieces of it
-in new free programs; and that you know you can do these things.
-
- To protect your rights, we need to make restrictions that forbid
-anyone to deny you these rights or to ask you to surrender the rights.
-These restrictions translate to certain responsibilities for you if you
-distribute copies of the software, or if you modify it.
-
- For example, if you distribute copies of such a program, whether
-gratis or for a fee, you must give the recipients all the rights that
-you have. You must make sure that they, too, receive or can get the
-source code. And you must show them these terms so they know their
-rights.
-
- We protect your rights with two steps: (1) copyright the software, and
-(2) offer you this license which gives you legal permission to copy,
-distribute and/or modify the software.
-
- Also, for each author's protection and ours, we want to make certain
-that everyone understands that there is no warranty for this free
-software. If the software is modified by someone else and passed on, we
-want its recipients to know that what they have is not the original, so
-that any problems introduced by others will not reflect on the original
-authors' reputations.
-
- Finally, any free program is threatened constantly by software
-patents. We wish to avoid the danger that redistributors of a free
-program will individually obtain patent licenses, in effect making the
-program proprietary. To prevent this, we have made it clear that any
-patent must be licensed for everyone's free use or not licensed at all.
-
- The precise terms and conditions for copying, distribution and
-modification follow.
-
- GNU GENERAL PUBLIC LICENSE
- TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
-
- 0. This License applies to any program or other work which contains
-a notice placed by the copyright holder saying it may be distributed
-under the terms of this General Public License. The "Program", below,
-refers to any such program or work, and a "work based on the Program"
-means either the Program or any derivative work under copyright law:
-that is to say, a work containing the Program or a portion of it,
-either verbatim or with modifications and/or translated into another
-language. (Hereinafter, translation is included without limitation in
-the term "modification".) Each licensee is addressed as "you".
-
-Activities other than copying, distribution and modification are not
-covered by this License; they are outside its scope. The act of
-running the Program is not restricted, and the output from the Program
-is covered only if its contents constitute a work based on the
-Program (independent of having been made by running the Program).
-Whether that is true depends on what the Program does.
-
- 1. You may copy and distribute verbatim copies of the Program's
-source code as you receive it, in any medium, provided that you
-conspicuously and appropriately publish on each copy an appropriate
-copyright notice and disclaimer of warranty; keep intact all the
-notices that refer to this License and to the absence of any warranty;
-and give any other recipients of the Program a copy of this License
-along with the Program.
-
-You may charge a fee for the physical act of transferring a copy, and
-you may at your option offer warranty protection in exchange for a fee.
-
- 2. You may modify your copy or copies of the Program or any portion
-of it, thus forming a work based on the Program, and copy and
-distribute such modifications or work under the terms of Section 1
-above, provided that you also meet all of these conditions:
-
- a) You must cause the modified files to carry prominent notices
- stating that you changed the files and the date of any change.
-
- b) You must cause any work that you distribute or publish, that in
- whole or in part contains or is derived from the Program or any
- part thereof, to be licensed as a whole at no charge to all third
- parties under the terms of this License.
-
- c) If the modified program normally reads commands interactively
- when run, you must cause it, when started running for such
- interactive use in the most ordinary way, to print or display an
- announcement including an appropriate copyright notice and a
- notice that there is no warranty (or else, saying that you provide
- a warranty) and that users may redistribute the program under
- these conditions, and telling the user how to view a copy of this
- License. (Exception: if the Program itself is interactive but
- does not normally print such an announcement, your work based on
- the Program is not required to print an announcement.)
-
-These requirements apply to the modified work as a whole. If
-identifiable sections of that work are not derived from the Program,
-and can be reasonably considered independent and separate works in
-themselves, then this License, and its terms, do not apply to those
-sections when you distribute them as separate works. But when you
-distribute the same sections as part of a whole which is a work based
-on the Program, the distribution of the whole must be on the terms of
-this License, whose permissions for other licensees extend to the
-entire whole, and thus to each and every part regardless of who wrote it.
-
-Thus, it is not the intent of this section to claim rights or contest
-your rights to work written entirely by you; rather, the intent is to
-exercise the right to control the distribution of derivative or
-collective works based on the Program.
-
-In addition, mere aggregation of another work not based on the Program
-with the Program (or with a work based on the Program) on a volume of
-a storage or distribution medium does not bring the other work under
-the scope of this License.
-
- 3. You may copy and distribute the Program (or a work based on it,
-under Section 2) in object code or executable form under the terms of
-Sections 1 and 2 above provided that you also do one of the following:
-
- a) Accompany it with the complete corresponding machine-readable
- source code, which must be distributed under the terms of Sections
- 1 and 2 above on a medium customarily used for software interchange; or,
-
- b) Accompany it with a written offer, valid for at least three
- years, to give any third party, for a charge no more than your
- cost of physically performing source distribution, a complete
- machine-readable copy of the corresponding source code, to be
- distributed under the terms of Sections 1 and 2 above on a medium
- customarily used for software interchange; or,
-
- c) Accompany it with the information you received as to the offer
- to distribute corresponding source code. (This alternative is
- allowed only for noncommercial distribution and only if you
- received the program in object code or executable form with such
- an offer, in accord with Subsection b above.)
-
-The source code for a work means the preferred form of the work for
-making modifications to it. For an executable work, complete source
-code means all the source code for all modules it contains, plus any
-associated interface definition files, plus the scripts used to
-control compilation and installation of the executable. However, as a
-special exception, the source code distributed need not include
-anything that is normally distributed (in either source or binary
-form) with the major components (compiler, kernel, and so on) of the
-operating system on which the executable runs, unless that component
-itself accompanies the executable.
-
-If distribution of executable or object code is made by offering
-access to copy from a designated place, then offering equivalent
-access to copy the source code from the same place counts as
-distribution of the source code, even though third parties are not
-compelled to copy the source along with the object code.
-
- 4. You may not copy, modify, sublicense, or distribute the Program
-except as expressly provided under this License. Any attempt
-otherwise to copy, modify, sublicense or distribute the Program is
-void, and will automatically terminate your rights under this License.
-However, parties who have received copies, or rights, from you under
-this License will not have their licenses terminated so long as such
-parties remain in full compliance.
-
- 5. You are not required to accept this License, since you have not
-signed it. However, nothing else grants you permission to modify or
-distribute the Program or its derivative works. These actions are
-prohibited by law if you do not accept this License. Therefore, by
-modifying or distributing the Program (or any work based on the
-Program), you indicate your acceptance of this License to do so, and
-all its terms and conditions for copying, distributing or modifying
-the Program or works based on it.
-
- 6. Each time you redistribute the Program (or any work based on the
-Program), the recipient automatically receives a license from the
-original licensor to copy, distribute or modify the Program subject to
-these terms and conditions. You may not impose any further
-restrictions on the recipients' exercise of the rights granted herein.
-You are not responsible for enforcing compliance by third parties to
-this License.
-
- 7. If, as a consequence of a court judgment or allegation of patent
-infringement or for any other reason (not limited to patent issues),
-conditions are imposed on you (whether by court order, agreement or
-otherwise) that contradict the conditions of this License, they do not
-excuse you from the conditions of this License. If you cannot
-distribute so as to satisfy simultaneously your obligations under this
-License and any other pertinent obligations, then as a consequence you
-may not distribute the Program at all. For example, if a patent
-license would not permit royalty-free redistribution of the Program by
-all those who receive copies directly or indirectly through you, then
-the only way you could satisfy both it and this License would be to
-refrain entirely from distribution of the Program.
-
-If any portion of this section is held invalid or unenforceable under
-any particular circumstance, the balance of the section is intended to
-apply and the section as a whole is intended to apply in other
-circumstances.
-
-It is not the purpose of this section to induce you to infringe any
-patents or other property right claims or to contest validity of any
-such claims; this section has the sole purpose of protecting the
-integrity of the free software distribution system, which is
-implemented by public license practices. Many people have made
-generous contributions to the wide range of software distributed
-through that system in reliance on consistent application of that
-system; it is up to the author/donor to decide if he or she is willing
-to distribute software through any other system and a licensee cannot
-impose that choice.
-
-This section is intended to make thoroughly clear what is believed to
-be a consequence of the rest of this License.
-
- 8. If the distribution and/or use of the Program is restricted in
-certain countries either by patents or by copyrighted interfaces, the
-original copyright holder who places the Program under this License
-may add an explicit geographical distribution limitation excluding
-those countries, so that distribution is permitted only in or among
-countries not thus excluded. In such case, this License incorporates
-the limitation as if written in the body of this License.
-
- 9. The Free Software Foundation may publish revised and/or new versions
-of the General Public License from time to time. Such new versions will
-be similar in spirit to the present version, but may differ in detail to
-address new problems or concerns.
-
-Each version is given a distinguishing version number. If the Program
-specifies a version number of this License which applies to it and "any
-later version", you have the option of following the terms and conditions
-either of that version or of any later version published by the Free
-Software Foundation. If the Program does not specify a version number of
-this License, you may choose any version ever published by the Free Software
-Foundation.
-
- 10. If you wish to incorporate parts of the Program into other free
-programs whose distribution conditions are different, write to the author
-to ask for permission. For software which is copyrighted by the Free
-Software Foundation, write to the Free Software Foundation; we sometimes
-make exceptions for this. Our decision will be guided by the two goals
-of preserving the free status of all derivatives of our free software and
-of promoting the sharing and reuse of software generally.
-
- NO WARRANTY
-
- 11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY
-FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN
-OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES
-PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED
-OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS
-TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE
-PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING,
-REPAIR OR CORRECTION.
-
- 12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING
-WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR
-REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES,
-INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING
-OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED
-TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY
-YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER
-PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE
-POSSIBILITY OF SUCH DAMAGES.
-
- END OF TERMS AND CONDITIONS
diff --git a/bsp/meta-boundary/recipes-boundary/sysklogd-config-remote/files/syslogd b/bsp/meta-boundary/recipes-boundary/sysklogd-config-remote/files/syslogd
deleted file mode 100644
index 6fb0b987..00000000
--- a/bsp/meta-boundary/recipes-boundary/sysklogd-config-remote/files/syslogd
+++ /dev/null
@@ -1,4 +0,0 @@
-#
-# For remote UDP logging use SYSLOGD="-r"
-#
-SYSLOGD="-r"
diff --git a/bsp/meta-boundary/recipes-boundary/sysklogd-config-remote/sysklogd-config-remote.bb b/bsp/meta-boundary/recipes-boundary/sysklogd-config-remote/sysklogd-config-remote.bb
deleted file mode 100644
index 67ea6c0e..00000000
--- a/bsp/meta-boundary/recipes-boundary/sysklogd-config-remote/sysklogd-config-remote.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright (C) 2015 Boundary Devices
-
-SUMMARY = "sysklogd-config-remote"
-SECTION = "base"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=5003fa041d799dd5dd5f646b74e36924"
-
-S = "${WORKDIR}"
-
-SRC_URI = " \
- file://syslogd \
- file://COPYING \
-"
-
-do_install_append() {
- install -d ${D}${sysconfdir}/default
- install ${S}/syslogd ${D}${sysconfdir}/default/
-}
-
-FILES_${PN} += " \
- ${sysconfdir}/default/syslogd \
-"
-
diff --git a/bsp/meta-boundary/recipes-boundary/video-input-icon/files/COPYING b/bsp/meta-boundary/recipes-boundary/video-input-icon/files/COPYING
deleted file mode 100644
index 90978d50..00000000
--- a/bsp/meta-boundary/recipes-boundary/video-input-icon/files/COPYING
+++ /dev/null
@@ -1,12 +0,0 @@
-Copyright (C) 2015 by Boundary Devices
-
-Permission to use, copy, modify, and/or distribute this software for any
-purpose with or without fee is hereby granted.
-
-THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
-WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
-MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
-ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
-WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
-ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
-OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/bsp/meta-boundary/recipes-boundary/video-input-icon/files/OV5640-MIPI-Test.desktop b/bsp/meta-boundary/recipes-boundary/video-input-icon/files/OV5640-MIPI-Test.desktop
deleted file mode 100644
index 677e9bbc..00000000
--- a/bsp/meta-boundary/recipes-boundary/video-input-icon/files/OV5640-MIPI-Test.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=OV5640 MIPI Test
-Comment=Launches gst-launch to show ov5640-mipi input on screen.
-Exec=/usr/bin/ov5640-mipi-test
-Icon=video-player
-Terminal=true
-Type=Application
-StartupNotify=true
-Categories=GTK;AudioVideo;Audio;Player;
diff --git a/bsp/meta-boundary/recipes-boundary/video-input-icon/files/OV5642.desktop b/bsp/meta-boundary/recipes-boundary/video-input-icon/files/OV5642.desktop
deleted file mode 100644
index 947f8b98..00000000
--- a/bsp/meta-boundary/recipes-boundary/video-input-icon/files/OV5642.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=OV5642 Test
-Comment=Launches gst-launch to show ov5642 input on screen.
-Exec=/usr/bin/ov5642-test
-Icon=video-player
-Terminal=true
-Type=Application
-StartupNotify=true
-Categories=GTK;AudioVideo;Audio;Player;
diff --git a/bsp/meta-boundary/recipes-boundary/video-input-icon/files/hdmi-input b/bsp/meta-boundary/recipes-boundary/video-input-icon/files/hdmi-input
deleted file mode 100755
index f1fc27ea..00000000
--- a/bsp/meta-boundary/recipes-boundary/video-input-icon/files/hdmi-input
+++ /dev/null
@@ -1 +0,0 @@
-gst-launch-1.0 imxv4l2videosrc device=/dev/video3 ! autovideosink;
diff --git a/bsp/meta-boundary/recipes-boundary/video-input-icon/files/hdmi-input.desktop b/bsp/meta-boundary/recipes-boundary/video-input-icon/files/hdmi-input.desktop
deleted file mode 100644
index 89ed7565..00000000
--- a/bsp/meta-boundary/recipes-boundary/video-input-icon/files/hdmi-input.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=HDMI Input Test
-Comment=Launches gst-launch to show hdmi input on screen.
-Exec=/usr/bin/hdmi-input
-Icon=video-player
-Terminal=true
-Type=Application
-StartupNotify=true
-Categories=GTK;AudioVideo;Audio;Player;
diff --git a/bsp/meta-boundary/recipes-boundary/video-input-icon/files/ov5640-mipi-test b/bsp/meta-boundary/recipes-boundary/video-input-icon/files/ov5640-mipi-test
deleted file mode 100755
index d1358fed..00000000
--- a/bsp/meta-boundary/recipes-boundary/video-input-icon/files/ov5640-mipi-test
+++ /dev/null
@@ -1 +0,0 @@
-gst-launch-1.0 imxv4l2videosrc device=/dev/video1 ! autovideosink;
diff --git a/bsp/meta-boundary/recipes-boundary/video-input-icon/files/ov5642-test b/bsp/meta-boundary/recipes-boundary/video-input-icon/files/ov5642-test
deleted file mode 100755
index f9ce12c1..00000000
--- a/bsp/meta-boundary/recipes-boundary/video-input-icon/files/ov5642-test
+++ /dev/null
@@ -1 +0,0 @@
-gst-launch-1.0 imxv4l2videosrc device=/dev/video0 ! autovideosink;
diff --git a/bsp/meta-boundary/recipes-boundary/video-input-icon/video-input-icon.bb b/bsp/meta-boundary/recipes-boundary/video-input-icon/video-input-icon.bb
deleted file mode 100644
index 98fdf136..00000000
--- a/bsp/meta-boundary/recipes-boundary/video-input-icon/video-input-icon.bb
+++ /dev/null
@@ -1,60 +0,0 @@
-# Simple recipe to add desktop icon and executable to run gstreamer
-# command to display video input on screen in media player.
-
-DESCRIPTION = "Video Input Desktop Icon/Executable"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://COPYING;md5=b7a244440f5854ed05acee9962562ba4"
-
-PR = "r0"
-
-SRC_URI = " \
- file://hdmi-input \
- file://hdmi-input.desktop \
- file://OV5640-MIPI-Test.desktop \
- file://ov5640-mipi-test \
- file://OV5642.desktop \
- file://ov5642-test \
- file://COPYING \
-"
-
-S = "${WORKDIR}"
-
-do_install_nitrogen6x() {
- mkdir -p ${D}/usr/bin/
- mkdir -p ${D}/usr/share/applications/
- cp ${S}/hdmi-input ${D}/usr/bin/
- cp ${S}/hdmi-input.desktop ${D}/usr/share/applications/
- cp ${S}/ov5640-mipi-test ${D}/usr/bin/
- cp ${S}/OV5640-MIPI-Test.desktop ${D}/usr/share/applications/
- cp ${S}/OV5642.desktop ${D}/usr/share/applications/
- cp ${S}/ov5642-test ${D}/usr/bin/
-}
-
-do_install_nitrogen6sx() {
- mkdir -p ${D}/usr/bin/
- mkdir -p ${D}/usr/share/applications/
- cp ${S}/OV5642.desktop ${D}/usr/share/applications/
- cp ${S}/ov5642-test ${D}/usr/bin/
-}
-
-do_install_nitrogen7() {
- mkdir -p ${D}/usr/bin/
- mkdir -p ${D}/usr/share/applications/
- cp ${S}/ov5640-mipi-test ${D}/usr/bin/
- cp ${S}/OV5640-MIPI-Test.desktop ${D}/usr/share/applications/
-}
-
-FILES_${PN}_nitrogen6x = " \
- /usr/bin/* \
- /usr/share/applications/* \
-"
-
-FILES_${PN}_nitrogen6sx = " \
- /usr/bin/ov5642-test \
- /usr/share/applications/OV5642.desktop \
-"
-
-FILES_${PN}_nitrogen7 = " \
- /usr/bin/ov5640-mipi-test \
- /usr/share/applications/OV5640-MIPI-Test.desktop \
-"