summaryrefslogtreecommitdiffstats
path: root/bsp/meta-boundary/recipes-graphics/wayland
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-boundary/recipes-graphics/wayland')
-rw-r--r--bsp/meta-boundary/recipes-graphics/wayland/weston/mx8mm/weston.ini29
-rw-r--r--bsp/meta-boundary/recipes-graphics/wayland/weston/mx8mq/weston.ini25
-rw-r--r--bsp/meta-boundary/recipes-graphics/wayland/weston_4.0.0.imx.bbappend11
3 files changed, 65 insertions, 0 deletions
diff --git a/bsp/meta-boundary/recipes-graphics/wayland/weston/mx8mm/weston.ini b/bsp/meta-boundary/recipes-graphics/wayland/weston/mx8mm/weston.ini
new file mode 100644
index 00000000..913b13e5
--- /dev/null
+++ b/bsp/meta-boundary/recipes-graphics/wayland/weston/mx8mm/weston.ini
@@ -0,0 +1,29 @@
+[core]
+# i.MX: Disable idle timeout
+idle-time=0
+gbm-format=argb8888
+backend=drm-backend.so
+
+#[output]
+#name=HDMI-A-1
+#mode=1920x1080@60
+#transform=90
+
+[output]
+name=DSI-1
+mode=current
+
+[shell]
+#size=1920x1080
+
+#[output]
+#name=HDMI-A-2
+#mode=off
+# WIDTHxHEIGHT Resolution size width and height in pixels
+# off Disables the output
+# preferred Uses the preferred mode
+# current Uses the current crt controller mode
+#transform=90
+
+[screen-share]
+command=/usr/bin/weston --backend=rdp-backend.so --shell=fullscreen-shell.so --no-clients-resize
diff --git a/bsp/meta-boundary/recipes-graphics/wayland/weston/mx8mq/weston.ini b/bsp/meta-boundary/recipes-graphics/wayland/weston/mx8mq/weston.ini
new file mode 100644
index 00000000..3a98b988
--- /dev/null
+++ b/bsp/meta-boundary/recipes-graphics/wayland/weston/mx8mq/weston.ini
@@ -0,0 +1,25 @@
+[core]
+# i.MX: Disable idle timeout
+idle-time=0
+gbm-format=argb8888
+backend=fbdev-backend.so
+
+#[output]
+#name=HDMI-A-1
+#mode=1920x1080@60
+#transform=90
+
+[shell]
+size=1920x1080
+
+#[output]
+#name=HDMI-A-2
+#mode=off
+# WIDTHxHEIGHT Resolution size width and height in pixels
+# off Disables the output
+# preferred Uses the preferred mode
+# current Uses the current crt controller mode
+#transform=90
+
+[screen-share]
+command=/usr/bin/weston --backend=rdp-backend.so --shell=fullscreen-shell.so --no-clients-resize
diff --git a/bsp/meta-boundary/recipes-graphics/wayland/weston_4.0.0.imx.bbappend b/bsp/meta-boundary/recipes-graphics/wayland/weston_4.0.0.imx.bbappend
new file mode 100644
index 00000000..6401f1a6
--- /dev/null
+++ b/bsp/meta-boundary/recipes-graphics/wayland/weston_4.0.0.imx.bbappend
@@ -0,0 +1,11 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/weston:"
+
+SRC_URI_append = "${@bb.utils.contains('MACHINE', 'nitrogen8mm', "file://mx8mm/weston.ini", "", d)}"
+SRC_URI_append = "${@bb.utils.contains('MACHINE', 'nitrogen8m', "file://mx8mq/weston.ini", "", d)}"
+
+do_install_append_mx8mm() {
+
+ # install default weston.ini
+ install -D -m 0644 ${WORKDIR}/mx8mm/weston.ini ${D}${sysconfdir}/xdg/weston/weston.ini
+}
+