summaryrefslogtreecommitdiffstats
path: root/bsp/meta-boundary/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-boundary/recipes-kernel')
-rw-r--r--bsp/meta-boundary/recipes-kernel/kernel-iio/kernel-iio.bb51
-rw-r--r--bsp/meta-boundary/recipes-kernel/kernel-modules/kernel-module-qcacld_git.bb18
-rw-r--r--bsp/meta-boundary/recipes-kernel/linux-firmware/linux-firmware-bdsdmac_git.bb35
-rw-r--r--bsp/meta-boundary/recipes-kernel/linux-firmware/linux-firmware-gslx680_1.0.bb29
-rw-r--r--bsp/meta-boundary/recipes-kernel/linux-firmware/linux-firmware_git.bbappend16
-rw-r--r--bsp/meta-boundary/recipes-kernel/linux/linux-boundary_%.bbappend23
-rw-r--r--bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.14.x.bb22
-rw-r--r--bsp/meta-boundary/recipes-kernel/linux/linux-imx-headers_4.14.x.bb58
8 files changed, 0 insertions, 252 deletions
diff --git a/bsp/meta-boundary/recipes-kernel/kernel-iio/kernel-iio.bb b/bsp/meta-boundary/recipes-kernel/kernel-iio/kernel-iio.bb
deleted file mode 100644
index 9124f1cb..00000000
--- a/bsp/meta-boundary/recipes-kernel/kernel-iio/kernel-iio.bb
+++ /dev/null
@@ -1,51 +0,0 @@
-SUMMARY = "IIO tools for Linux"
-DESCRIPTION = "Tools to monitor and list Industrial I/O (IIO) devices."
-
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
-
-inherit linux-kernel-base kernel-arch kernelsrc
-
-do_configure[depends] += "virtual/kernel:do_shared_workdir"
-do_populate_lic[depends] += "virtual/kernel:do_patch"
-
-B = "${WORKDIR}/${BPN}-${PV}"
-SPDX_S = "${S}/tools/iio"
-
-EXTRA_OEMAKE = '\
- -C ${S}/tools/iio \
- O=${B} \
- CROSS_COMPILE=${TARGET_PREFIX} \
- ARCH=${ARCH} \
- CC="${CC}" \
- AR="${AR}" \
- LD="${LD}" \
- EXTRA_CFLAGS="-idirafter ${S}/include" \
-'
-
-EXTRA_OEMAKE += "\
- 'INSTALL_ROOT=${D}' \
- 'BINDIR=${bindir}' \
-"
-
-do_compile() {
- # Linux kernel build system is expected to do the right thing
- unset CFLAGS
- oe_runmake all
-}
-
-do_install() {
- # Linux kernel build system is expected to do the right thing
- unset CFLAGS
- oe_runmake install
-}
-
-do_configure_prepend () {
- # Fix for rebuilding
- rm -rf ${B}/
- mkdir -p ${B}/
-}
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-FILES_${PN} += "${bindir}"
diff --git a/bsp/meta-boundary/recipes-kernel/kernel-modules/kernel-module-qcacld_git.bb b/bsp/meta-boundary/recipes-kernel/kernel-modules/kernel-module-qcacld_git.bb
deleted file mode 100644
index add8e8a0..00000000
--- a/bsp/meta-boundary/recipes-kernel/kernel-modules/kernel-module-qcacld_git.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright (C) 2016 Boundary Devices
-SUMMARY = "QCACLD driver for QCA9377-based BD-SDMAC module"
-LICENSE = "ISC"
-LIC_FILES_CHKSUM = "file://${S}/CORE/HDD/src/wlan_hdd_main.c;beginline=1;endline=20;md5=c191a07d6df8a17ee5b865137f729304"
-
-inherit module
-
-SRCREV = "${AUTOREV}"
-
-SRC_URI = "git://github.com/boundarydevices/qcacld-2.0.git;branch=${SRCBRANCH} \
-"
-SRCBRANCH = "boundary-LNX.LEH.4.2.2.2"
-
-S = "${WORKDIR}/git"
-
-EXTRA_OEMAKE_append = " CONFIG_CLD_HL_SDIO_CORE=y"
-
-COMPATIBLE_MACHINE = "mx6|mx7|mx8"
diff --git a/bsp/meta-boundary/recipes-kernel/linux-firmware/linux-firmware-bdsdmac_git.bb b/bsp/meta-boundary/recipes-kernel/linux-firmware/linux-firmware-bdsdmac_git.bb
deleted file mode 100644
index 07956080..00000000
--- a/bsp/meta-boundary/recipes-kernel/linux-firmware/linux-firmware-bdsdmac_git.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-SUMMARY = "WiFi and BT firmware files for BD-SDMAC module"
-SECTION = "kernel"
-
-LICENSE = "Firmware-qca"
-
-LIC_FILES_CHKSUM = "\
- file://LICENSE.qca_firmware;md5=e8b1e9e8ce377ca5b2c1098e5690f470 \
-"
-
-SRCREV = "5e4b71211ecbb79e7693d2ee07361847f5a0cb40"
-
-SRC_URI = "git://github.com/boundarydevices/qca-firmware.git;branch=${SRCBRANCH}"
-SRCBRANCH = "bd-sdmac-qcacld"
-
-S = "${WORKDIR}/git"
-
-# These are not common licenses, set NO_GENERIC_LICENSE for them
-# so that the license files will be copied from fetched source
-NO_GENERIC_LICENSE[Firmware-qca] = "LICENSE.qca_firmware"
-
-inherit allarch
-
-CLEANBROKEN = "1"
-
-do_compile() {
- :
-}
-
-do_install() {
- DESTDIR=${D} make install
-}
-
-FILES_${PN} += "/lib/firmware/* /lib/firmware/*/*"
-
-RDEPENDS_${PN} += "crda"
diff --git a/bsp/meta-boundary/recipes-kernel/linux-firmware/linux-firmware-gslx680_1.0.bb b/bsp/meta-boundary/recipes-kernel/linux-firmware/linux-firmware-gslx680_1.0.bb
deleted file mode 100644
index ff67b998..00000000
--- a/bsp/meta-boundary/recipes-kernel/linux-firmware/linux-firmware-gslx680_1.0.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-SUMMARY = "Firmware files for GSLx680 touch controllers"
-SECTION = "kernel"
-
-LICENSE = "\
- GPLv2+ \
-"
-
-LIC_FILES_CHKSUM = "\
- file://${WORKDIR}/LICENSE.GPLv2+.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
-"
-
-SRC_URI_append = "\
- http://linode.boundarydevices.com/gsl1680.fw;name=gsl1680 \
- http://linode.boundarydevices.com/LICENSE.GPLv2+.txt;name=license \
-"
-
-SRC_URI[gsl1680.sha256sum] = "d0e85f5b601e58ef04dd016f99de89aebdc5e16c7b0173f45196f9593d43e854"
-SRC_URI[license.sha256sum] = "8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643"
-
-inherit allarch update-alternatives
-
-CLEANBROKEN = "1"
-
-do_install() {
- mkdir -p ${D}/lib/firmware/silead
- install -m 0644 ${WORKDIR}/gsl1680.fw ${D}/lib/firmware/silead/
-}
-
-FILES_${PN} += "/lib/firmware/*"
diff --git a/bsp/meta-boundary/recipes-kernel/linux-firmware/linux-firmware_git.bbappend b/bsp/meta-boundary/recipes-kernel/linux-firmware/linux-firmware_git.bbappend
deleted file mode 100644
index fdb63989..00000000
--- a/bsp/meta-boundary/recipes-kernel/linux-firmware/linux-firmware_git.bbappend
+++ /dev/null
@@ -1,16 +0,0 @@
-# Support additional firmware for TiWi-BLE module
-# TIInit_7.6.15.bts is required for bluetooth support but this particular
-# version is not available in the linux-firmware repository.
-#
-SRC_URI_append = "\
- https://git.ti.com/ti-bt/service-packs/blobs/raw/54f5c151dacc608b19ab2ce4c30e27a3983048b2/initscripts/TIInit_7.6.15.bts;name=TIInit_7.6.15 \
-"
-SRC_URI[TIInit_7.6.15.md5sum] = "3f84f0d782376363d0028fc4b2402ccb"
-SRC_URI[TIInit_7.6.15.sha256sum] = "e78156ad81446fdeb46da661290f763f3fe97d111526b2d19cd764a634268888"
-
-do_install_append() {
- cp ${WORKDIR}/TIInit_7.6.15.bts ${D}/lib/firmware/ti-connectivity/
-}
-
-PACKAGE_ARCH_mx7 = "${MACHINE_ARCH}"
-PACKAGE_ARCH_mx6 = "${MACHINE_ARCH}"
diff --git a/bsp/meta-boundary/recipes-kernel/linux/linux-boundary_%.bbappend b/bsp/meta-boundary/recipes-kernel/linux/linux-boundary_%.bbappend
deleted file mode 100644
index a2457cb7..00000000
--- a/bsp/meta-boundary/recipes-kernel/linux/linux-boundary_%.bbappend
+++ /dev/null
@@ -1,23 +0,0 @@
-FILESEXTRAPATHS_prepend_mx6 := "${THISDIR}/files/arm:"
-FILESEXTRAPATHS_prepend_mx7 := "${THISDIR}/files/arm:"
-FILESEXTRAPATHS_prepend_mx8 := "${THISDIR}/files/arm64:"
-
-SRC_URI = "git://github.com/boundarydevices/linux-imx6.git;branch=${SRCBRANCH} \
-"
-
-LOCALVERSION = "-2.0.0-ga+yocto"
-SRCREV = "${AUTOREV}"
-COMPATIBLE_MACHINE = "(nitrogen6x|nitrogen6x-lite|nitrogen6sx|nitrogen7|nitrogen8m|nitrogen8mm)"
-
-S = "${WORKDIR}/git"
-
-do_merge_default_config() {
-
- if [ -f ${S}/arch/${ARCH}/configs/${KERNEL_DEFCONFIG} ]; then
- # create config with make config
- oe_runmake -C ${S} O=${KBUILD_OUTPUT} ${KERNEL_DEFCONFIG}
- cp ${KBUILD_OUTPUT}/.config ${WORKDIR}/defconfig
- fi
-
-}
-addtask merge_default_config before do_preconfigure after do_patch
diff --git a/bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.14.x.bb b/bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.14.x.bb
deleted file mode 100644
index 96cf9cf4..00000000
--- a/bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.14.x.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-# Adapted from linux-imx.inc, copyright (C) 2013, 2014 O.S. Systems Software LTDA
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-require recipes-kernel/linux/linux-imx.inc
-
-SUMMARY = "Linux kernel for Boundary Devices boards"
-
-FILESEXTRAPATHS_prepend_mx6 := "${THISDIR}/${PN}-${PV}/arm:"
-FILESEXTRAPATHS_prepend_mx7 := "${THISDIR}/${PN}-${PV}/arm:"
-FILESEXTRAPATHS_prepend_mx8 := "${THISDIR}/${PN}-${PV}/arm64:"
-
-SRC_URI = "git://github.com/boundarydevices/linux-imx6.git;branch=${SRCBRANCH} \
- file://defconfig \
-"
-
-LOCALVERSION = "-2.0.0-ga+yocto"
-SRCBRANCH = "boundary-imx_4.14.x_2.0.0_ga"
-SRCREV = "${AUTOREV}"
-DEPENDS += "lzop-native bc-native"
-COMPATIBLE_MACHINE = "(nitrogen6x|nitrogen6x-lite|nitrogen6sx|nitrogen7|nitrogen8m)"
-
-KERNEL_DEFCONFIG = "boundary_defconfig"
diff --git a/bsp/meta-boundary/recipes-kernel/linux/linux-imx-headers_4.14.x.bb b/bsp/meta-boundary/recipes-kernel/linux/linux-imx-headers_4.14.x.bb
deleted file mode 100644
index 2040c02f..00000000
--- a/bsp/meta-boundary/recipes-kernel/linux/linux-imx-headers_4.14.x.bb
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 2017-2018 NXP
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-SUMMARY = "Installs i.MX-specific kernel headers"
-DESCRIPTION = "Installs i.MX-specific kernel headers to userspace. \
-New headers are installed in ${includedir}/imx."
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
-
-LOCALVERSION = "-imx"
-SRC_URI = "git://github.com/boundarydevices/linux-imx6.git;branch=${SRCBRANCH}"
-SRCBRANCH = "boundary-imx_4.14.x_2.0.0_ga"
-SRCREV = "${AUTOREV}"
-
-S = "${WORKDIR}/git"
-
-do_compile[noexec] = "1"
-
-IMX_UAPI_HEADERS = " \
- dma-buf.h \
- hantrodec.h \
- hx280enc.h \
- ion.h \
- ipu.h \
- isl29023.h \
- mxc_asrc.h \
- mxc_dcic.h \
- mxc_mlb.h \
- mxc_sim_interface.h \
- mxc_v4l2.h \
- mxcfb.h \
- pxp_device.h \
- pxp_dma.h \
- version.h \
- videodev2.h \
-"
-
-do_install() {
- # We install all headers inside of B so we can copy only the
- # whitelisted ones, and there is no risk of a new header to be
- # installed by mistake.
- oe_runmake headers_install INSTALL_HDR_PATH=${B}${exec_prefix}
-
- # FIXME: The ion.h is still on staging so "promote" it for now
- cp ${S}/drivers/staging/android/uapi/ion.h ${B}${includedir}/linux
-
- # Install whitelisted headers only
- for h in ${IMX_UAPI_HEADERS}; do
- install -D -m 0644 ${B}${includedir}/linux/$h \
- ${D}${includedir}/imx/linux/$h
- done
-}
-
-ALLOW_EMPTY_${PN} = "1"
-
-PACKAGE_ARCH = "${MACHINE_SOCARCH}"
-COMPATIBLE_HOST_imx = ".*"
-COMPATIBLE_HOST ?= "(none)"