summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/dynamic-layers
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-freescale/dynamic-layers')
-rw-r--r--bsp/meta-freescale/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston-init.bbappend3
-rw-r--r--bsp/meta-freescale/dynamic-layers/ivi/recipes-graphics/wayland/weston-init.bbappend1
-rw-r--r--bsp/meta-freescale/dynamic-layers/ivi/recipes-graphics/wayland/weston-init/weston.ini104
-rw-r--r--bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend8
-rw-r--r--bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb2
-rw-r--r--bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch46
-rw-r--r--bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_3.4.%.bbappend5
-rw-r--r--bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_4.%.bbappend3
-rw-r--r--bsp/meta-freescale/dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc2
-rw-r--r--bsp/meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0015-Add-eglfs-to-IMX-GPU.patch13
-rw-r--r--bsp/meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0016-Configure-eglfs-with-egl-pkg-config.patch13
-rw-r--r--bsp/meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend27
-rw-r--r--bsp/meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend3
13 files changed, 136 insertions, 94 deletions
diff --git a/bsp/meta-freescale/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston-init.bbappend b/bsp/meta-freescale/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston-init.bbappend
new file mode 100644
index 00000000..10b66c0e
--- /dev/null
+++ b/bsp/meta-freescale/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston-init.bbappend
@@ -0,0 +1,3 @@
+do_install_append() {
+ rm -f ${D}${sysconfdir}/xdg/weston/weston.ini
+}
diff --git a/bsp/meta-freescale/dynamic-layers/ivi/recipes-graphics/wayland/weston-init.bbappend b/bsp/meta-freescale/dynamic-layers/ivi/recipes-graphics/wayland/weston-init.bbappend
new file mode 100644
index 00000000..72d991c7
--- /dev/null
+++ b/bsp/meta-freescale/dynamic-layers/ivi/recipes-graphics/wayland/weston-init.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/bsp/meta-freescale/dynamic-layers/ivi/recipes-graphics/wayland/weston-init/weston.ini b/bsp/meta-freescale/dynamic-layers/ivi/recipes-graphics/wayland/weston-init/weston.ini
new file mode 100644
index 00000000..6e8e0140
--- /dev/null
+++ b/bsp/meta-freescale/dynamic-layers/ivi/recipes-graphics/wayland/weston-init/weston.ini
@@ -0,0 +1,104 @@
+[core]
+shell=ivi-shell.so
+modules=hmi-controller.so
+#gbm-format=argb8888
+#use-g2d=1
+#xwayland=true
+
+#[shell]
+#size=1920x1080
+
+[ivi-shell]
+ivi-shell-user-interface=weston-ivi-shell-user-interface
+
+#developermode=true
+
+cursor-theme=default
+cursor-size=32
+
+base-layer-id=1000
+base-layer-id-offset=10000
+
+workspace-background-layer-id=2000
+workspace-layer-id=3000
+application-layer-id=4000
+
+transition-duration=300
+
+background-image=/usr/share/weston/background.png
+background-id=1001
+panel-image=/usr/share/weston/panel.png
+panel-id=1002
+surface-id-offset=10
+tiling-image=/usr/share/weston/tiling.png
+tiling-id=1003
+sidebyside-image=/usr/share/weston/sidebyside.png
+sidebyside-id=1004
+fullscreen-image=/usr/share/weston/fullscreen.png
+fullscreen-id=1005
+random-image=/usr/share/weston/random.png
+random-id=1006
+home-image=/usr/share/weston/home.png
+home-id=1007
+workspace-background-color=0x99000000
+workspace-background-id=2001
+
+[ivi-launcher]
+workspace-id=0
+icon-id=4001
+icon=/usr/share/weston/icon_ivi_flower.png
+path=/usr/bin/weston-flower
+
+[ivi-launcher]
+workspace-id=0
+icon-id=4002
+icon=/usr/share/weston/icon_ivi_clickdot.png
+path=/usr/bin/weston-clickdot
+
+[ivi-launcher]
+workspace-id=1
+icon-id=4003
+icon=/usr/share/weston/icon_ivi_simple-egl.png
+path=/usr/bin/weston-simple-egl
+
+[ivi-launcher]
+workspace-id=1
+icon-id=4004
+icon=/usr/share/weston/icon_ivi_simple-shm.png
+path=/usr/bin/weston-simple-shm
+
+[ivi-launcher]
+workspace-id=2
+icon-id=4005
+icon=/usr/share/weston/icon_ivi_smoke.png
+path=/usr/bin/weston-smoke
+
+[ivi-launcher]
+workspace-id=3
+icon-id=4006
+icon=/usr/share/weston/icon_ivi_flower.png
+path=/usr/bin/weston-flower
+
+[ivi-launcher]
+workspace-id=3
+icon-id=4007
+icon=/usr/share/weston/icon_ivi_clickdot.png
+path=/usr/bin/weston-clickdot
+
+[ivi-launcher]
+workspace-id=3
+icon-id=4008
+icon=/usr/share/weston/icon_ivi_simple-egl.png
+path=/usr/bin/weston-simple-egl
+
+[ivi-launcher]
+workspace-id=3
+icon-id=4009
+icon=/usr/share/weston/icon_ivi_simple-shm.png
+path=/usr/bin/weston-simple-shm
+
+[ivi-launcher]
+workspace-id=3
+icon-id=4010
+icon=/usr/share/weston/icon_ivi_smoke.png
+path=/usr/bin/weston-smoke
diff --git a/bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend b/bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend
index b579028b..2e648ba3 100644
--- a/bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend
+++ b/bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend
@@ -1,4 +1,4 @@
-PACKAGECONFIG_imxgpu3d = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland opengl', 'wayland-gles2', \
- bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'x11-gl x11-gles2', '', d), d)}"
-PACKAGECONFIG_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland opengl', '', \
- bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'x11-gl', '', d), d)}"
+# Only _mx8 machine do provide virtual/libgbm required for any drm* flavour
+DRM-REMOVE_imxgpu = "drm-gl drm-gles2"
+DRM-REMOVE_imxgpu_mx8 = ""
+PACKAGECONFIG_remove = "${DRM-REMOVE}"
diff --git a/bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb b/bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb
index cbf8e24f..2f5f1afa 100644
--- a/bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb
+++ b/bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb
@@ -39,7 +39,7 @@ do_install () {
install -m 755 ${S}/source/fmc ${D}/${bindir}
install -d ${D}${sysconfdir}/fmc/config
- install -m 644 ${S}${sysconfdir}/fmc/config/hxs_pdl_v3.xml ${D}${sysconfdir}/fmc/config
+ install -m 644 ${S}${sysconfdir}/fmc/config/* ${D}${sysconfdir}/fmc/config
install -d ${D}/${includedir}/fmc
install ${S}/source/fmc.h ${D}/${includedir}/fmc
diff --git a/bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch b/bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch
deleted file mode 100644
index 274fbe74..00000000
--- a/bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 90f869763026e8ff18aeecde217d778f00e4f294 Mon Sep 17 00:00:00 2001
-From: Shawn Xiao <b49994@freescale.com>
-Date: Tue, 10 Feb 2015 16:11:59 +0800
-Subject: [PATCH] MGS-515 [#ccc] Opencv app can't run on imx6sx with cam
-
-This issue is caused by the no support of VIDIOC_QUERYCTRL ioctl
-item in latest cam driver.
-
-Modified the errno in check logic to compatible with new driver.
-
-Feb 10, 2015
-
-Upstream-Status: Pending
-
-Signed-off-by: Shawn Xiao <b49994@freescale.com>
----
- modules/highgui/src/cap_v4l.cpp | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/modules/highgui/src/cap_v4l.cpp b/modules/highgui/src/cap_v4l.cpp
-index c9fca05..8c46b6c 100644
---- a/modules/highgui/src/cap_v4l.cpp
-+++ b/modules/highgui/src/cap_v4l.cpp
-@@ -707,7 +707,8 @@ static void v4l2_scan_controls(CvCaptureCAM_V4L* capture)
-
- } else {
-
-- if (errno == EINVAL)
-+ if (errno == ENOTTY ||
-+ errno == EINVAL)
- continue;
-
- perror ("VIDIOC_QUERYCTRL");
-@@ -774,7 +775,8 @@ static void v4l2_scan_controls(CvCaptureCAM_V4L* capture)
-
- } else {
-
-- if (errno == EINVAL)
-+ if (errno == ENOTTY ||
-+ errno == EINVAL)
- break;
-
- perror ("VIDIOC_QUERYCTRL");
---
-2.3.0
-
diff --git a/bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_3.4.%.bbappend b/bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_3.4.%.bbappend
deleted file mode 100644
index 3c4c7f5e..00000000
--- a/bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_3.4.%.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI_append_mx6sx = " file://0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch"
-
-PACKAGECONFIG_remove_imxgpu2d = "v4l"
diff --git a/bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_4.%.bbappend b/bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_4.%.bbappend
new file mode 100644
index 00000000..2bae6470
--- /dev/null
+++ b/bsp/meta-freescale/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_4.%.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+PACKAGECONFIG_remove_imxgpu2d = "v4l"
diff --git a/bsp/meta-freescale/dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc b/bsp/meta-freescale/dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc
index b7171ebc..187681a8 100644
--- a/bsp/meta-freescale/dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc
+++ b/bsp/meta-freescale/dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc
@@ -2,7 +2,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/qt4:"
python __anonymous () {
families = ['mx6']
- cur_families = (d.getVar('MACHINEOVERRIDES', True) or '').split(':')
+ cur_families = (d.getVar('MACHINEOVERRIDES') or '').split(':')
if any(map(lambda x: x in cur_families,
families)):
d.appendVarFlag('do_configure', 'depends', ' virtual/kernel:do_shared_workdir')
diff --git a/bsp/meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0015-Add-eglfs-to-IMX-GPU.patch b/bsp/meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0015-Add-eglfs-to-IMX-GPU.patch
deleted file mode 100644
index 8e7129e3..00000000
--- a/bsp/meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0015-Add-eglfs-to-IMX-GPU.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: git/mkspecs/linux-oe-g++/qmake.conf
-===================================================================
---- git.orig/mkspecs/linux-oe-g++/qmake.conf 2016-12-14 17:03:17.000000000 -0600
-+++ git/mkspecs/linux-oe-g++/qmake.conf 2016-12-14 17:06:23.000000000 -0600
-@@ -37,6 +37,8 @@ QMAKE_LINK_C_SHLIB = $$(OE_QMAKE_LINK)
- # for the SDK
- isEmpty(QMAKE_QT_CONFIG):QMAKE_QT_CONFIG = $$(OE_QMAKE_QT_CONFIG)
-
-+EGLFS_DEVICE_INTEGRATION = eglfs_viv
-+
- include(../oe-device-extra.pri)
-
- QMAKE_LIBS_EGL += -lEGL
diff --git a/bsp/meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0016-Configure-eglfs-with-egl-pkg-config.patch b/bsp/meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0016-Configure-eglfs-with-egl-pkg-config.patch
deleted file mode 100644
index a245d79a..00000000
--- a/bsp/meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0016-Configure-eglfs-with-egl-pkg-config.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: git/src/plugins/platforms/eglfs/eglfs-plugin.pro
-===================================================================
---- git.orig/src/plugins/platforms/eglfs/eglfs-plugin.pro 2017-01-04 16:54:05.000000000 -0600
-+++ git/src/plugins/platforms/eglfs/eglfs-plugin.pro 2017-01-04 16:56:25.000000000 -0600
-@@ -2,6 +2,8 @@
-
- QT += platformsupport-private eglfs_device_lib-private
-
-+CONFIG += egl
-+
- SOURCES += $$PWD/qeglfsmain.cpp
-
- OTHER_FILES += $$PWD/eglfs.json
diff --git a/bsp/meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/bsp/meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index 08a2cbe3..bf3fb66e 100644
--- a/bsp/meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/bsp/meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -5,22 +5,20 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI_append_imxgpu2d = " \
+SRC_URI_append_imxgpu = " \
file://0014-Add-IMX-GPU-support.patch \
file://0001-egl.prf-Fix-build-error-when-egl-headers-need-platfo.patch \
"
-SRC_URI_APPEND_3D_NOT_X11 = " \
- file://0015-Add-eglfs-to-IMX-GPU.patch \
- file://0016-Configure-eglfs-with-egl-pkg-config.patch \
-"
-SRC_URI_append_imxgpu3d = " \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', '${SRC_URI_APPEND_3D_NOT_X11}', d)} \
-"
+
+PACKAGECONFIG_GL_IMX_GPU = ""
+PACKAGECONFIG_GL_IMX_GPU_mx8 = "gbm kms"
PACKAGECONFIG_GL_imxpxp = "gles2"
-PACKAGECONFIG_GL_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)}"
-PACKAGECONFIG_GL_imxgpu3d = "gles2"
-PACKAGECONFIG_GL_append_use-mainline-bsp = " gbm kms"
+PACKAGECONFIG_GL_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)} \
+ ${PACKAGECONFIG_GL_IMX_GPU}"
+PACKAGECONFIG_GL_imxgpu3d = "gles2 \
+ ${PACKAGECONFIG_GL_IMX_GPU}"
+PACKAGECONFIG_GL_use-mainline-bsp ?= "gles2 gbm kms"
PACKAGECONFIG_PLATFORM = ""
PACKAGECONFIG_PLATFORM_imxgpu2d = "no-opengl linuxfb"
@@ -30,3 +28,10 @@ PACKAGECONFIG_PLATFORM_imxgpu3d = " \
'eglfs', d), d)}"
PACKAGECONFIG_PLATFORM_use-mainline-bsp = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'eglfs', d)}"
PACKAGECONFIG += "${PACKAGECONFIG_PLATFORM}"
+
+PACKAGECONFIG_VULKAN_IMX_GPU = ""
+PACKAGECONFIG_VULKAN_IMX_GPU_mx8 = "vulkan"
+PACKAGECONFIG_VULKAN_IMX_GPU_mx8mm = ""
+PACKAGECONFIG_VULKAN = ""
+PACKAGECONFIG_VULKAN_imxgpu = "${PACKAGECONFIG_VULKAN_IMX_GPU}"
+PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'vulkan', '${PACKAGECONFIG_VULKAN}', '', d)}"
diff --git a/bsp/meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend b/bsp/meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend
index 7f61dc50..afc728c1 100644
--- a/bsp/meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend
+++ b/bsp/meta-freescale/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend
@@ -1,2 +1,5 @@
# etnaviv mesa does not have glx
PACKAGECONFIG_remove_use-mainline-bsp = "xcomposite-glx"
+
+# i.MX8 does never provide native x11, so required dependencies are not met
+PACKAGECONFIG_remove_mx8 = "xcomposite-egl xcomposite-glx"