summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-bsp/imx-test
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-freescale/recipes-bsp/imx-test')
-rw-r--r--bsp/meta-freescale/recipes-bsp/imx-test/imx-test/0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch39
-rw-r--r--bsp/meta-freescale/recipes-bsp/imx-test/imx-test/0001-test-Makefile-Add-include-path-to-CC-command.patch27
-rw-r--r--bsp/meta-freescale/recipes-bsp/imx-test/imx-test_git.bb29
3 files changed, 51 insertions, 44 deletions
diff --git a/bsp/meta-freescale/recipes-bsp/imx-test/imx-test/0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch b/bsp/meta-freescale/recipes-bsp/imx-test/imx-test/0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch
new file mode 100644
index 00000000..3fb9d4ef
--- /dev/null
+++ b/bsp/meta-freescale/recipes-bsp/imx-test/imx-test/0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch
@@ -0,0 +1,39 @@
+From d2e35983281a811b38e540ab82e7643322e84aab Mon Sep 17 00:00:00 2001
+From: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
+Date: Wed, 4 Dec 2019 14:17:50 +0000
+Subject: [PATCH] mxc_v4l2_test: fix compilation error produced by gcc9
+
+Fix trivial compilation error when GCC9 is used:
+
+error: call to '__open_missing_mode' declared with attribute error: open
+with O_CREAT or O_TMPFILE in second argument needs 3 arguments
+
+This is now caused by not explicitly supplying the mode when O_CREAT is
+used as disposition.
+
+Upstream-Status: Pending
+
+Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
+---
+ test/mxc_v4l2_test/mx8_v4l2_cap_drm.c | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/test/mxc_v4l2_test/mx8_v4l2_cap_drm.c b/test/mxc_v4l2_test/mx8_v4l2_cap_drm.c
+index 6e10744..d63b2db 100644
+--- a/test/mxc_v4l2_test/mx8_v4l2_cap_drm.c
++++ b/test/mxc_v4l2_test/mx8_v4l2_cap_drm.c
+@@ -561,11 +561,7 @@ static int open_save_file(struct video_channel *video_ch)
+
+ for (i = 0; i < NUM_SENSORS; i++) {
+ if ((g_cam >> i) & 0x01) {
+-#ifdef BUILD_FOR_ANDROID
+ fd = open(video_ch[i].save_file_name, O_RDWR | O_CREAT, 0660);
+-#else
+- fd = open(video_ch[i].save_file_name, O_RDWR | O_CREAT);
+-#endif
+ if (fd < 0) {
+ v4l2_err("Channel[%d] unable to create recording file\n", i);
+ while (i)
+--
+2.17.1
+
diff --git a/bsp/meta-freescale/recipes-bsp/imx-test/imx-test/0001-test-Makefile-Add-include-path-to-CC-command.patch b/bsp/meta-freescale/recipes-bsp/imx-test/imx-test/0001-test-Makefile-Add-include-path-to-CC-command.patch
deleted file mode 100644
index 8387a17c..00000000
--- a/bsp/meta-freescale/recipes-bsp/imx-test/imx-test/0001-test-Makefile-Add-include-path-to-CC-command.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From d289d905c64882c58e3b99f74f68e72f9100115e Mon Sep 17 00:00:00 2001
-From: Fabio Berton <fabio.berton@ossystems.com.br>
-Date: Tue, 12 Jun 2018 14:58:40 -0300
-Subject: [PATCH] test/Makefile: Add include path to CC command
-Organization: O.S. Systems Software LTDA.
-
-Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
----
- test/Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/test/Makefile b/test/Makefile
-index f1cfa2a..4f14d2c 100644
---- a/test/Makefile
-+++ b/test/Makefile
-@@ -12,7 +12,7 @@ ALL_OBJS :=
-
- %.o: %.c
- @echo " CC $@"
-- $(Q)$(CC) -c $(CFLAGS) $< -o $@
-+ $(Q)$(CC) -c $(CFLAGS) $(INC) $< -o $@
-
-
- # This creates the build and copy rules for one executable. Because we
---
-2.17.1
-
diff --git a/bsp/meta-freescale/recipes-bsp/imx-test/imx-test_git.bb b/bsp/meta-freescale/recipes-bsp/imx-test/imx-test_git.bb
index bf55f7df..81bbd3a3 100644
--- a/bsp/meta-freescale/recipes-bsp/imx-test/imx-test_git.bb
+++ b/bsp/meta-freescale/recipes-bsp/imx-test/imx-test_git.bb
@@ -1,6 +1,6 @@
-# Copyright (C) 2012-2018 O.S. Systems Software LTDA.
+# Copyright (C) 2012-2016 O.S. Systems Software LTDA.
# Copyright (C) 2013-2016 Freescale Semiconductor
-# Copyright 2017-2018 NXP
+# Copyright (C) 2017-2019 NXP
SUMMARY = "Test programs for i.MX BSP"
DESCRIPTION = "Unit tests for the i.MX BSP"
@@ -16,13 +16,13 @@ DEPENDS_append_imxvpu = " virtual/imxvpu"
PE = "1"
PV = "7.0+${SRCPV}"
-SRCBRANCH = "imx_4.9.123_imx8mm_ga"
+SRCBRANCH = "lf-5.4.y"
SRC_URI = " \
git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \
- file://0001-test-Makefile-Add-include-path-to-CC-command.patch \
+ file://0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch \
file://memtool_profile \
"
-SRCREV = "2cc785f94e5ee8782083d941e6aef24952cc2a38"
+SRCREV = "6d20e84f2dbe5940fe6d629c2839e1390994ee1f"
S = "${WORKDIR}/git"
inherit module-base use-imx-headers
@@ -30,15 +30,15 @@ inherit module-base use-imx-headers
INHIBIT_PACKAGE_STRIP = "1"
INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
-PLATFORM_mx6q = "IMX6Q"
-PLATFORM_mx6dl = "IMX6Q"
-PLATFORM_mx6sl = "IMX6SL"
+PLATFORM_mx6q = "IMX6Q"
+PLATFORM_mx6dl = "IMX6Q"
+PLATFORM_mx6sl = "IMX6SL"
PLATFORM_mx6sll = "IMX6SL"
-PLATFORM_mx6sx = "IMX6SX"
-PLATFORM_mx6ul = "IMX6UL"
-PLATFORM_mx7d = "IMX7D"
+PLATFORM_mx6sx = "IMX6SX"
+PLATFORM_mx6ul = "IMX6UL"
+PLATFORM_mx7d = "IMX7D"
PLATFORM_mx7ulp = "IMX7D"
-PLATFORM_mx8 = "IMX8"
+PLATFORM_mx8 = "IMX8"
PARALLEL_MAKE = "-j 1"
EXTRA_OEMAKE += "${PACKAGECONFIG_CONFARGS}"
@@ -49,9 +49,6 @@ PACKAGECONFIG_append_imxvpu = " vpu"
PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr"
PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu"
-# FIXME: NXP should fix the possible string flaws from their code.
-SECURITY_STRINGFORMAT = ""
-
do_compile() {
CFLAGS="${TOOLCHAIN_OPTIONS}"
oe_runmake V=1 VERBOSE='' \
@@ -82,5 +79,3 @@ FILES_${PN} += "/unit_tests /home/root/.profile"
RDEPENDS_${PN} = "bash"
FILES_${PN}-dbg += "/unit_tests/.debug"
-
-COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"