summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-devtools/utp-com/utp-com_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-freescale/recipes-devtools/utp-com/utp-com_git.bb')
-rw-r--r--bsp/meta-freescale/recipes-devtools/utp-com/utp-com_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-devtools/utp-com/utp-com_git.bb b/bsp/meta-freescale/recipes-devtools/utp-com/utp-com_git.bb
new file mode 100644
index 00000000..db2d7f08
--- /dev/null
+++ b/bsp/meta-freescale/recipes-devtools/utp-com/utp-com_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Tool used to send commands to hardware via NXP's UTP protocol"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8264535c0c4e9c6c335635c4026a8022"
+
+DEPENDS = "sg3-utils"
+
+SRCREV = "dee512ced1e9367d223d22f10797fbf9aeacfab6"
+SRC_URI = " \
+ git://github.com/Freescale/utp_com;protocol=https \
+"
+
+PV = "1.0+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+do_configure[noexec] = "1"
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ install -d -m 0755 ${D}${bindir}
+ install -m 0755 ${S}/utp_com ${D}${bindir}/utp_com
+}
+
+BBCLASSEXTEND = "native nativesdk"