summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-dpaa2/dce/dce_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-freescale/recipes-dpaa2/dce/dce_git.bb')
-rw-r--r--bsp/meta-freescale/recipes-dpaa2/dce/dce_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-dpaa2/dce/dce_git.bb b/bsp/meta-freescale/recipes-dpaa2/dce/dce_git.bb
new file mode 100644
index 00000000..7313ca73
--- /dev/null
+++ b/bsp/meta-freescale/recipes-dpaa2/dce/dce_git.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Decompression Compression Engine Userspace Utils"
+SECTION = "dpaa2"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=338308e2a663929309c9929ab9495bb5"
+
+SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dce;nobranch=1 \
+ git://source.codeaurora.org/external/qoriq/qoriq-components/qbman_userspace;nobranch=1;name=qbman;destsuffix=git/lib/qbman_userspace \
+"
+SRCREV = "49389aa57cc94e0503f53c6b33e4b358ccf42eb5"
+SRCREV_qbman = "383ceac0c09b1e38f2a8b1cf42822686b4cf15f3"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
+
+do_install () {
+ oe_runmake install DESTDIR=${D}
+}
+
+INSANE_SKIP_${PN} = "ldflags"
+COMPATIBLE_MACHINE = "(qoriq-arm64)"