summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-extended/secure-obj
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-freescale/recipes-extended/secure-obj')
-rw-r--r--bsp/meta-freescale/recipes-extended/secure-obj/secure-obj.inc8
-rw-r--r--bsp/meta-freescale/recipes-extended/secure-obj/secure-obj_git.bb4
2 files changed, 7 insertions, 5 deletions
diff --git a/bsp/meta-freescale/recipes-extended/secure-obj/secure-obj.inc b/bsp/meta-freescale/recipes-extended/secure-obj/secure-obj.inc
index 20341261..617601ac 100644
--- a/bsp/meta-freescale/recipes-extended/secure-obj/secure-obj.inc
+++ b/bsp/meta-freescale/recipes-extended/secure-obj/secure-obj.inc
@@ -2,17 +2,17 @@ DESCRIPTION = "Secure Object"
LICENSE = "BSD"
DEPENDS = "openssl optee-os-qoriq optee-client-qoriq"
-RDEPENDS_${PN} = "bash libcrypto libssl python"
+RDEPENDS_${PN} = "bash libcrypto libssl"
-DEPENDS += "python-pycrypto-native"
+DEPENDS += "python3-pycrypto-native"
-inherit pythonnative
+inherit python3native
LDFLAGS += "${TOOLCHAIN_OPTIONS}"
SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/secure_obj;nobranch=1 \
"
-SRCREV = "bc0553a3c7a02555eb6bf46803854f6b49227a26"
+SRCREV = "fb179a861e8e9bfed85ac5ef8387bdd30de48db9"
WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/"
diff --git a/bsp/meta-freescale/recipes-extended/secure-obj/secure-obj_git.bb b/bsp/meta-freescale/recipes-extended/secure-obj/secure-obj_git.bb
index d85d7298..2d723738 100644
--- a/bsp/meta-freescale/recipes-extended/secure-obj/secure-obj_git.bb
+++ b/bsp/meta-freescale/recipes-extended/secure-obj/secure-obj_git.bb
@@ -34,9 +34,11 @@ do_install() {
cp ${S}/secure_storage_ta/ta/b05bcf48-9732-4efa-a9e0-141c7c888c34.ta ${D}${base_libdir}/optee_armtz
cp ${S}/securekey_lib/out/export/lib/libsecure_obj.so ${D}${libdir}
cp ${S}/secure_obj-openssl-engine/libeng_secure_obj.so ${D}${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines
- cp ${S}/securekey_lib/out/export/app/* ${D}${bindir}
+ cp ${S}/securekey_lib/out/export/app/*_app ${D}${bindir}
+ cp ${S}/securekey_lib/out/export/app/mp_verify ${D}${bindir}
cp ${S}/secure_obj-openssl-engine/app/sobj_eng_app ${D}${bindir}
cp ${S}/securekey_lib/out/export/include/* ${D}${includedir}
+ rm -rf ${D}${bindir}/test
}
FILES_${PN} += "${base_libdir}/optee_armtz ${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines"