summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-kernel/cryptodev
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-freescale/recipes-kernel/cryptodev')
-rw-r--r--bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-1.10.inc21
-rw-r--r--bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.10.bb5
-rw-r--r--bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.9.bb16
-rw-r--r--bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.10.bb10
-rw-r--r--bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.9.bb21
-rw-r--r--bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.10.bb8
-rw-r--r--bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.9.bb26
-rw-r--r--bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq_1.9.inc26
-rw-r--r--bsp/meta-freescale/recipes-kernel/cryptodev/files/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch66
-rw-r--r--bsp/meta-freescale/recipes-kernel/cryptodev/files/0001-Disable-installing-header-file-provided-by-another-p.patch24
-rw-r--r--bsp/meta-freescale/recipes-kernel/cryptodev/yocto_patches/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch50
-rw-r--r--bsp/meta-freescale/recipes-kernel/cryptodev/yocto_patches/0001-Disable-installing-header-file-provided-by-another-p.patch22
-rw-r--r--bsp/meta-freescale/recipes-kernel/cryptodev/yocto_patches/0003-update-the-install-path-for-cryptodev-tests.patch28
13 files changed, 134 insertions, 189 deletions
diff --git a/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-1.10.inc b/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-1.10.inc
new file mode 100644
index 00000000..bb785831
--- /dev/null
+++ b/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-1.10.inc
@@ -0,0 +1,21 @@
+HOMEPAGE = "http://cryptodev-linux.org/"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+python() {
+ d.appendVar('PROVIDES', ' ' + d.getVar('BPN').replace('-qoriq', ''))
+ pkgs = d.getVar('PACKAGES').split()
+ for p in pkgs:
+ if '-qoriq' in p:
+ d.appendVar("RPROVIDES_" + p, ' ' + p.replace('-qoriq', ''))
+ d.appendVar("RCONFLICTS_" + p, ' ' + p.replace('-qoriq', ''))
+ d.appendVar("RREPLACES_" + p, ' ' + p.replace('-qoriq', ''))
+}
+
+SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/cryptodev-linux;protocol=https;nobranch=1"
+SRCREV = "f3007431120a1b4ae983c2b9ea09051311aa5e2f"
+
+S = "${WORKDIR}/git"
+
+CLEANBROKEN = "1"
diff --git a/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.10.bb b/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.10.bb
new file mode 100644
index 00000000..c2cbc71b
--- /dev/null
+++ b/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.10.bb
@@ -0,0 +1,5 @@
+require recipes-kernel/cryptodev/cryptodev-linux_${PV}.bb
+require cryptodev-qoriq-${PV}.inc
+
+BBCLASSEXTEND = ""
+COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.9.bb b/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.9.bb
deleted file mode 100644
index 58db5053..00000000
--- a/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.9.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-require cryptodev-qoriq_${PV}.inc
-
-SUMMARY = "A /dev/crypto device driver header file"
-
-PROVIDES = "cryptodev-linux"
-
-do_compile[noexec] = "1"
-
-# Just install cryptodev.h which is the only header file needed to be exported
-do_install() {
- install -D ${S}/crypto/cryptodev.h ${D}${includedir}/crypto/cryptodev.h
-}
-
-ALLOW_EMPTY_${PN} = "1"
-
-COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.10.bb b/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.10.bb
new file mode 100644
index 00000000..86078c57
--- /dev/null
+++ b/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.10.bb
@@ -0,0 +1,10 @@
+require recipes-kernel/cryptodev/cryptodev-module_${PV}.bb
+require cryptodev-qoriq-${PV}.inc
+
+inherit qoriq_build_64bit_kernel
+
+SRC_URI += " \
+file://0001-Disable-installing-header-file-provided-by-another-p.patch \
+"
+
+COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.9.bb b/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.9.bb
deleted file mode 100644
index 412bb0e5..00000000
--- a/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.9.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-require cryptodev-qoriq_${PV}.inc
-
-SUMMARY = "A /dev/crypto device driver kernel module"
-
-PROVIDES = "cryptodev-module"
-
-inherit module qoriq_build_64bit_kernel
-
-# Header file provided by a separate package
-DEPENDS += "cryptodev-linux"
-
-EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" DESTDIR="${D}"'
-
-SRC_URI_append = " \
-file://0001-Disable-installing-header-file-provided-by-another-p.patch \
-"
-
-RCONFLICTS_${PN} = "ocf-linux"
-RREPLACES_${PN} = "ocf-linux"
-
-COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.10.bb b/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.10.bb
new file mode 100644
index 00000000..784c38b7
--- /dev/null
+++ b/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.10.bb
@@ -0,0 +1,8 @@
+require recipes-kernel/cryptodev/cryptodev-tests_${PV}.bb
+require cryptodev-qoriq-${PV}.inc
+
+SRC_URI += " \
+file://0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch \
+"
+
+COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.9.bb b/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.9.bb
deleted file mode 100644
index f7d0b61b..00000000
--- a/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.9.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-require cryptodev-qoriq_${PV}.inc
-
-SUMMARY = "A test suite for /dev/crypto device driver"
-
-DEPENDS = "openssl"
-
-PROVIDES = "cryptodev-tests"
-
-EXTRA_OEMAKE='KERNEL_DIR="${STAGING_EXECPREFIXDIR}" DESTDIR="${D}"'
-
-SRC_URI_append = " \
-file://0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch \
-"
-
-do_compile() {
- oe_runmake testprogs
-}
-
-do_install() {
- oe_runmake install_tests
-}
-
-FILES_${PN}-dbg += "${bindir}/tests_cryptodev/.debug"
-FILES_${PN} = "${bindir}/tests_cryptodev/*"
-
-COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq_1.9.inc b/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq_1.9.inc
deleted file mode 100644
index 0d7249fd..00000000
--- a/bsp/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq_1.9.inc
+++ /dev/null
@@ -1,26 +0,0 @@
-HOMEPAGE = "http://cryptodev-linux.org/"
-
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-
-python() {
- pkgs = d.getVar('PACKAGES', True).split()
- for p in pkgs:
- if 'cryptodev-qoriq' in p:
- d.appendVar("RPROVIDES_%s" % p, p.replace('cryptodev-qoriq', 'cryptodev'))
- d.appendVar("RCONFLICTS_%s" % p, p.replace('cryptodev-qoriq', 'cryptodev'))
- d.appendVar("RREPLACES_%s" % p, p.replace('cryptodev-qoriq', 'cryptodev'))
-}
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/yocto_patches:"
-
-SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/cryptodev-linux;nobranch=1"
-SRCREV = "479e6e7f071e252c0c37ea38d38fdb4cd808f496"
-
-# NOTE: remove this patch and all traces of DISTRO_FEATURE c29x_pkc
-# if pkc-host does not need customized cryptodev patches anymore
-#SRC_URI_append = "${@bb.utils.contains('DISTRO_FEATURES', 'c29x_pkc', ' file://0001-don-t-advertise-RSA-keygen.patch', '', d)}"
-
-S = "${WORKDIR}/git"
-
-CLEANBROKEN = "1"
diff --git a/bsp/meta-freescale/recipes-kernel/cryptodev/files/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch b/bsp/meta-freescale/recipes-kernel/cryptodev/files/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch
new file mode 100644
index 00000000..84fd27e6
--- /dev/null
+++ b/bsp/meta-freescale/recipes-kernel/cryptodev/files/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch
@@ -0,0 +1,66 @@
+From 1980a8f4779a955e73285e7a0d86549b69bea5c8 Mon Sep 17 00:00:00 2001
+From: Yu Zongchun <b40527@freescale.com>
+Date: Sun, 28 Apr 2013 14:39:22 +0800
+Subject: [PATCH] Add the compile and install rules for cryptodev tests folder
+
+This is required to install the cryptodev tests folder to rootfs
+
+Signed-off-by: Yu Zongchun <b40527@freescale.com>
+
+Upstream-Status: Pending
+
+---
+ Makefile | 6 ++++++
+ tests/Makefile | 8 ++++++++
+ 2 files changed, 14 insertions(+), 0 deletions(-)
+
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile
++++ git/Makefile
+@@ -35,6 +35,9 @@ modules_install:
+ $(MAKE) $(KERNEL_MAKE_OPTS) modules_install
+ install -m 644 -D crypto/cryptodev.h $(DESTDIR)/$(includedir)/crypto/cryptodev.h
+
++install_tests:
++ make -C tests install DESTDIR=$(PREFIX)
++
+ clean:
+ $(MAKE) $(KERNEL_MAKE_OPTS) clean
+ rm -f $(hostprogs) *~
+@@ -43,6 +46,9 @@ clean:
+ check:
+ CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests check
+
++testprogs:
++ KERNEL_DIR=$(KERNEL_DIR) make -C tests testprogs
++
+ CPOPTS =
+ ifneq ($(SHOW_TYPES),)
+ CPOPTS += --show-types
+Index: git/tests/Makefile
+===================================================================
+--- git.orig/tests/Makefile
++++ git/tests/Makefile
+@@ -23,6 +23,12 @@ bindir = $(execprefix)/bin
+
+ all: $(hostprogs)
+
++install:
++ install -d $(DESTDIR)/usr/bin/tests_cryptodev
++ for bin in $(hostprogs); do \
++ install -m 755 $${bin} $(DESTDIR)/usr/bin/tests_cryptodev/; \
++ done
++
+ check: $(hostprogs)
+ ./cipher
+ ./hmac
+@@ -38,6 +44,8 @@ install:
+ install -m 755 $$prog $(DESTDIR)/$(bindir); \
+ done
+
++testprogs: $(hostprogs)
++
+ clean:
+ rm -f *.o *~ $(hostprogs)
+
diff --git a/bsp/meta-freescale/recipes-kernel/cryptodev/files/0001-Disable-installing-header-file-provided-by-another-p.patch b/bsp/meta-freescale/recipes-kernel/cryptodev/files/0001-Disable-installing-header-file-provided-by-another-p.patch
new file mode 100644
index 00000000..885b5823
--- /dev/null
+++ b/bsp/meta-freescale/recipes-kernel/cryptodev/files/0001-Disable-installing-header-file-provided-by-another-p.patch
@@ -0,0 +1,24 @@
+From 8a884f55bd1527baa82fab68c186ba546273860c Mon Sep 17 00:00:00 2001
+From: Denys Dmytriyenko <denys@ti.com>
+Date: Sun, 6 Apr 2014 19:51:39 -0400
+Subject: [PATCH] Disable installing header file provided by another package
+
+Signed-off-by: Denys Dmytriyenko <denys@ti.com>
+
+Upstream-Status: Inappropriate [ OE specific ]
+---
+ Makefile | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 5a080e0..bf02396 100644
+--- a/Makefile
++++ b/Makefile
+@@ -33,7 +33,6 @@ install: modules_install
+
+ modules_install:
+ $(MAKE) $(KERNEL_MAKE_OPTS) modules_install
+- install -m 644 -D crypto/cryptodev.h $(DESTDIR)/$(includedir)/crypto/cryptodev.h
+
+ clean:
+ $(MAKE) $(KERNEL_MAKE_OPTS) clean
diff --git a/bsp/meta-freescale/recipes-kernel/cryptodev/yocto_patches/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch b/bsp/meta-freescale/recipes-kernel/cryptodev/yocto_patches/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch
deleted file mode 100644
index 1e7f5843..00000000
--- a/bsp/meta-freescale/recipes-kernel/cryptodev/yocto_patches/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From 03257bf2aff37b78496ccc1b58a87e7baaea042a Mon Sep 17 00:00:00 2001
-From: Cristian Stoica <cristian.stoica@nxp.com>
-Date: Mon, 22 Feb 2016 12:17:52 +0200
-Subject: [PATCH 2/2] Add the compile and install rules for cryptodev tests
-
-(original patch Signed-off-by: Yu Zongchun <b40527@freescale.com>)
-Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com>
-
-Upstream-Status: Inappropriate [ OE specific ]
----
- Makefile | 6 ++++++
- tests/Makefile | 4 ++--
- 2 files changed, 8 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 06202bd..a598b12 100644
---- a/Makefile
-+++ b/Makefile
-@@ -42,6 +42,12 @@ clean:
- check:
- CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests check
-
-+testprogs:
-+ KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests all
-+
-+install_tests:
-+ $(MAKE) -C tests install
-+
- CPOPTS =
- ifneq ($(SHOW_TYPES),)
- CPOPTS += --show-types
-diff --git a/tests/Makefile b/tests/Makefile
-index 5e3111d..cda971c 100644
---- a/tests/Makefile
-+++ b/tests/Makefile
-@@ -35,9 +35,9 @@ check: $(hostprogs)
- ./cipher-aead
-
- install:
-- install -d $(DESTDIR)/$(bindir)
-+ install -d $(DESTDIR)/$(bindir)/tests_cryptodev
- for prog in $(hostprogs); do \
-- install -m 755 $$prog $(DESTDIR)/$(bindir); \
-+ install -m 755 $$prog $(DESTDIR)/$(bindir)/tests_cryptodev/; \
- done
-
- clean:
---
-2.7.0
-
diff --git a/bsp/meta-freescale/recipes-kernel/cryptodev/yocto_patches/0001-Disable-installing-header-file-provided-by-another-p.patch b/bsp/meta-freescale/recipes-kernel/cryptodev/yocto_patches/0001-Disable-installing-header-file-provided-by-another-p.patch
deleted file mode 100644
index 35aad600..00000000
--- a/bsp/meta-freescale/recipes-kernel/cryptodev/yocto_patches/0001-Disable-installing-header-file-provided-by-another-p.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From eedfa57953d2d6255d53cb098c3f81cbde9187f7 Mon Sep 17 00:00:00 2001
-From: Cristian Stoica <cristian.stoica@nxp.com>
-Date: Mon, 22 Feb 2016 11:47:27 +0200
-Subject: [PATCH 1/2] Disable installing header file provided by another
- package
-
-(original patch Signed-off-by: Denys Dmytriyenko <denys@ti.com>)
-Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com>
-
-Upstream-Status: Inappropriate [ OE specific ]
-
-
---- a/Makefileold 2017-04-18 14:54:40.588438842 +0800
-+++ b/Makefile 2017-04-18 14:55:40.308436774 +0800
-@@ -33,7 +33,6 @@
-
- modules_install:
- $(MAKE) $(KERNEL_MAKE_OPTS) modules_install
-- install -m 644 -D crypto/cryptodev.h $(DESTDIR)/$(includedir)/crypto/cryptodev.h
-
- clean:
- $(MAKE) $(KERNEL_MAKE_OPTS) clean
diff --git a/bsp/meta-freescale/recipes-kernel/cryptodev/yocto_patches/0003-update-the-install-path-for-cryptodev-tests.patch b/bsp/meta-freescale/recipes-kernel/cryptodev/yocto_patches/0003-update-the-install-path-for-cryptodev-tests.patch
deleted file mode 100644
index 4f92dbab..00000000
--- a/bsp/meta-freescale/recipes-kernel/cryptodev/yocto_patches/0003-update-the-install-path-for-cryptodev-tests.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 5b0d2cf5abaaa3bffb4a9e874dba88bdab15b69d Mon Sep 17 00:00:00 2001
-From: Ting Liu <ting.liu@nxp.com>
-Date: Mon, 20 Feb 2017 22:43:00 +0800
-Subject: [PATCH] update the install path for cryptodev tests
-
-Signed-off-by: Ting Liu <ting.liu@nxp.com>
----
- tests/Makefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tests/Makefile b/tests/Makefile
-index dd7d5ff..e1c5039 100644
---- a/tests/Makefile
-+++ b/tests/Makefile
-@@ -37,8 +37,8 @@ install:
- for prog in $(hostprogs); do \
- install -m 755 $$prog $(DESTDIR)/$(bindir)/tests_cryptodev/; \
- done
-- install -m 755 speed_multi.sh $(DESTDIR)/$(bindir)
-- install -m 755 run_crypto_tests.sh $(DESTDIR)/$(bindir)
-+ install -m 755 speed_multi.sh $(DESTDIR)/$(bindir)/tests_cryptodev/
-+ install -m 755 run_crypto_tests.sh $(DESTDIR)/$(bindir)/tests_cryptodev/
-
- clean:
- rm -f *.o *~ $(hostprogs)
---
-1.9.2
-