summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-multimedia/imx-codec
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-freescale/recipes-multimedia/imx-codec')
-rw-r--r--bsp/meta-freescale/recipes-multimedia/imx-codec/imx-codec_4.5.3.bb (renamed from bsp/meta-freescale/recipes-multimedia/imx-codec/imx-codec_4.4.2.bb)22
1 files changed, 11 insertions, 11 deletions
diff --git a/bsp/meta-freescale/recipes-multimedia/imx-codec/imx-codec_4.4.2.bb b/bsp/meta-freescale/recipes-multimedia/imx-codec/imx-codec_4.5.3.bb
index 60a3717e..e41469f3 100644
--- a/bsp/meta-freescale/recipes-multimedia/imx-codec/imx-codec_4.4.2.bb
+++ b/bsp/meta-freescale/recipes-multimedia/imx-codec/imx-codec_4.5.3.bb
@@ -5,14 +5,14 @@
DESCRIPTION = "Freescale Multimedia codec libs"
LICENSE = "Proprietary"
SECTION = "multimedia"
-LIC_FILES_CHKSUM = "file://COPYING;md5=5ab1a30d0cd181e3408077727ea5a2db"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fd4b227530cd88a82af6a5982cfb724d"
# Backward compatibility
PROVIDES += "libfslcodec"
-SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
-SRC_URI[md5sum] = "6087fbac97002b7d8c5dd061e6b36417"
-SRC_URI[sha256sum] = "f225968d8efcdb8f1843adae162360df04166e91acea2c32388cf699f410bdda"
+SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true"
+SRC_URI[md5sum] = "a0413b390a473aee862806dd25a4a366"
+SRC_URI[sha256sum] = "ecaecb4afb646efad9a81d67a1a5e50a9e06ed49fa8ea947064465a085b2c578"
inherit fsl-eula-unpack autotools pkgconfig
@@ -23,27 +23,27 @@ EXTRA_OECONF = "${@bb.utils.contains('TUNE_FEATURES', 'aarch64', '--enable-armv8
PACKAGECONFIG ?= ""
PACKAGECONFIG_imxvpu = "vpu"
+# We need to ensure we don't have '-src' package overrided
+PACKAGE_DEBUG_SPLIT_STYLE = 'debug-without-src'
+
PACKAGECONFIG[vpu] = "--enable-vpu,--disable-vpu,virtual/imxvpu"
do_install_append() {
- # FIXME: This link points to nowhere
- if [ -e ${D}${libdir}/imx-mm/audio-codec/lib_src_ppp_arm11_elinux.so ]; then
- rm ${D}${libdir}/imx-mm/audio-codec/lib_src_ppp_arm11_elinux.so
- fi
-
# LTIB move the files around or gst-fsl-plugin won't find them
for p in $(find ${D}${libdir}/imx-mm -mindepth 2 -maxdepth 2 -not -type d); do
mv $p ${D}${libdir}
done
rmdir ${D}${libdir}/imx-mm/video-codec
+ # Fixup ownership of files
+ chown -R root:root ${D}
}
python __set_insane_skip() {
# Ensure we have PACKAGES expanded
bb.build.exec_func("read_subpackage_metadata", d)
- for p in d.getVar('PACKAGES', True).split():
+ for p in d.getVar('PACKAGES').split():
# Even though we are packaging libraries those are plugins so we
# shouldn't rename the packages to follow its sonames.
d.setVar("DEBIAN_NOAUTONAME_%s" % p, "1")
@@ -66,7 +66,7 @@ python __split_libfslcodec_plugins() {
output_pattern='imx-codec-%s',
description='Freescale i.MX Codec (%s)',
extra_depends='')
- pkgs = d.getVar('PACKAGES', True).split()
+ pkgs = d.getVar('PACKAGES').split()
for pkg in pkgs:
meta = pkg[10:]
if meta != '':