summaryrefslogtreecommitdiffstats
path: root/bsp/meta-intel/recipes-bsp/thermald
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-intel/recipes-bsp/thermald')
-rw-r--r--bsp/meta-intel/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch37
-rw-r--r--bsp/meta-intel/recipes-bsp/thermald/thermald_1.8.bb35
2 files changed, 0 insertions, 72 deletions
diff --git a/bsp/meta-intel/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch b/bsp/meta-intel/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch
deleted file mode 100644
index 6897ffc1..00000000
--- a/bsp/meta-intel/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From bb7631163c8f3f44d0dc83690765cdb799664fd5 Mon Sep 17 00:00:00 2001
-From: Anuj Mittal <anuj.mittal@intel.com>
-Date: Wed, 26 Sep 2018 10:34:15 +0800
-Subject: [PATCH] Use correct format specifier for size_t
-
-%zu instead of %lu, otherwise on 32 bit:
-
-| ../git/src/thd_zone.cpp: In member function 'void cthd_zone::sort_and_update_poll_trip()':
-| ../git/src/thd_zone.cpp:106:16: error: format '%lu' expects argument of type 'long unsigned int', but argument 4 has type 'std::vector<cthd_trip_point>::size_type' {aka 'unsigned int'} [-Werror=format=]
-| thd_log_debug("sort_and_update_poll_trip: trip_points_size =%lu\n",
-| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-| trip_points.size());
-
-Upstream-Status: Submitted
-[https://github.com/intel/thermal_daemon/pull/165]
-
-Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
----
- src/thd_zone.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/thd_zone.cpp b/src/thd_zone.cpp
-index b7edf9e..cb7b8e8 100644
---- a/src/thd_zone.cpp
-+++ b/src/thd_zone.cpp
-@@ -103,7 +103,7 @@ int cthd_zone::read_user_set_psv_temp() {
- }
-
- void cthd_zone::sort_and_update_poll_trip() {
-- thd_log_debug("sort_and_update_poll_trip: trip_points_size =%lu\n",
-+ thd_log_debug("sort_and_update_poll_trip: trip_points_size =%zu\n",
- trip_points.size());
- if (trip_points.size()) {
- unsigned int polling_trip = 0;
---
-2.17.1
-
diff --git a/bsp/meta-intel/recipes-bsp/thermald/thermald_1.8.bb b/bsp/meta-intel/recipes-bsp/thermald/thermald_1.8.bb
deleted file mode 100644
index f7725f31..00000000
--- a/bsp/meta-intel/recipes-bsp/thermald/thermald_1.8.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-SUMMARY = "Linux thermal daemon"
-
-DESCRIPTION = "Thermal Daemon is a Linux daemon used to prevent the \
-overheating of platforms. This daemon monitors temperature and applies \
-compensation using available cooling methods."
-
-HOMEPAGE = "https://github.com/01org/thermal_daemon"
-
-DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native"
-DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
-DEPENDS_append_libc-musl = " argp-standalone"
-DEPENDS_append_toolchain-clang = " openmp"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
-
-SRC_URI = "git://github.com/intel/thermal_daemon/ \
- file://0001-Use-correct-format-specifier-for-size_t.patch \
- "
-SRCREV = "517c0e5f92d49aeeef3a22b04caf40d588216827"
-S = "${WORKDIR}/git"
-
-inherit pkgconfig autotools systemd
-
-FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
-
-SYSTEMD_SERVICE_${PN} = "thermald.service"
-
-COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
-
-CONFFILES_${PN} = " \
- ${sysconfdir}/thermald/thermal-conf.xml \
- ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \
- "
-
-UPSTREAM_CHECK_URI = "https://github.com/01org/thermal_daemon/releases"