summaryrefslogtreecommitdiffstats
path: root/bsp/meta-intel/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-intel/recipes-bsp')
-rw-r--r--bsp/meta-intel/recipes-bsp/formfactor/formfactor/machconfig39
-rw-r--r--bsp/meta-intel/recipes-bsp/formfactor/formfactor_0.0.bbappend1
-rw-r--r--bsp/meta-intel/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.conf2
-rw-r--r--bsp/meta-intel/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.sh15
-rw-r--r--bsp/meta-intel/recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bb18
-rw-r--r--bsp/meta-intel/recipes-bsp/systemd-boot/systemd-boot/0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch31
-rw-r--r--bsp/meta-intel/recipes-bsp/systemd-boot/systemd-boot_%.bbappend15
-rw-r--r--bsp/meta-intel/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch37
-rw-r--r--bsp/meta-intel/recipes-bsp/thermald/thermald_1.8.bb35
9 files changed, 0 insertions, 193 deletions
diff --git a/bsp/meta-intel/recipes-bsp/formfactor/formfactor/machconfig b/bsp/meta-intel/recipes-bsp/formfactor/formfactor/machconfig
deleted file mode 100644
index 73695fac..00000000
--- a/bsp/meta-intel/recipes-bsp/formfactor/formfactor/machconfig
+++ /dev/null
@@ -1,39 +0,0 @@
-# Note: superuser permission is required to run usbhid-dump
-# successfully.
-
-# HEX keys are according to the USB HID spec and USB HID usage table
-# We can add more keys as needed in the future.
-
-# This test may not be very accurate, as we only look for the first
-# two lines of a descriptor section. Example:
-#
-# 001:003:000:DESCRIPTOR 1460501386.337809
-# 05 01 09 02 A1 01 09 01 A1 00 05 09 19 01 29 03
-# 15 00 25 01 95 03 75 01 81 02 .. .. .. .. .. ..
-# .. .. .. .. .. .. .. .. .. .. .. .. .. .. .. ..
-#
-# By doing so we eliminate false matches when HEX keys are in the lines
-# in the middle of the whole descriptor section.
-
-if type usbhid-dump &>/dev/null; then
- if USBHID_DUMP_OUTPUT=$(usbhid-dump -e descriptor 2>/dev/null|grep -A1 DESCRIPTOR); then
- # checker for generic USB HID keyboard
- USBHID_KBD_CMD="grep -E '^ 05 01 09 06'"
-
- # checker for touch screen
- USBHID_TS_CMD="grep -E '^ 05 0D 09 04'"
-
- if echo "$USBHID_DUMP_OUTPUT"|eval $USBHID_TS_CMD &>/dev/null; then
- HAVE_TOUCHSCREEN=1
- fi
-
- if echo "$USBHID_DUMP_OUTPUT"|eval $USBHID_KBD_CMD &>/dev/null; then
- HAVE_KEYBOARD=1
- else
- # config script in OE will set HAVE_KEYBOARD=1
- # if we don't set any value. We have to explicitly
- # tell it when keyboard is not detected.
- HAVE_KEYBOARD=0
- fi
- fi
-fi
diff --git a/bsp/meta-intel/recipes-bsp/formfactor/formfactor_0.0.bbappend b/bsp/meta-intel/recipes-bsp/formfactor/formfactor_0.0.bbappend
deleted file mode 100644
index 6dd422ae..00000000
--- a/bsp/meta-intel/recipes-bsp/formfactor/formfactor_0.0.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
diff --git a/bsp/meta-intel/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.conf b/bsp/meta-intel/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.conf
deleted file mode 100644
index 74d33c87..00000000
--- a/bsp/meta-intel/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.conf
+++ /dev/null
@@ -1,2 +0,0 @@
-# Mimic modprobe's install funcitonality with busybox's modprobe
-install gma500_gfx dmesg | grep gma500_gfx_checked || { /etc/modprobe.d/gma500-gfx-check.sh || modprobe gma500_gfx; }
diff --git a/bsp/meta-intel/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.sh b/bsp/meta-intel/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.sh
deleted file mode 100644
index 75cda99f..00000000
--- a/bsp/meta-intel/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.sh
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-
-# Check for devices we wish to avoid gma500_gfx for
-DEVICES="0x8119 0x4108"
-
-# Checked flag to avoid infinite modprobe
-echo "gma500_gfx_checked" >> /dev/kmsg;
-
-for DEVICE in $DEVICES; do
- if udevadm trigger --subsystem-match=pci --verbose --attr-match=device=$DEVICE | grep "pci" >> /dev/null ; then
- echo "Found $DEVICE, avoiding gma500_gfx module" >> /dev/kmsg;
- exit 0
- fi
-done
-exit 1
diff --git a/bsp/meta-intel/recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bb b/bsp/meta-intel/recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bb
deleted file mode 100644
index 7b08064b..00000000
--- a/bsp/meta-intel/recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SUMMARY = "Intel gma500_gfx fix for certain hardware"
-DESCRIPTION = "Avoid inserting gma500_gfx module for certain hardware devices."
-LICENSE="GPLv2"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-
-SRC_URI = "file://gma500-gfx-check.conf \
- file://gma500-gfx-check.sh "
-
-do_install(){
- install -d ${D}${sysconfdir}/modprobe.d/
- install -m 755 ${WORKDIR}/gma500-gfx-check.sh ${D}${sysconfdir}/modprobe.d/gma500-gfx-check.sh
- install -m 644 ${WORKDIR}/gma500-gfx-check.conf ${D}${sysconfdir}/modprobe.d/gma500-gfx-check.conf
-}
-
-FILES_${PN}="${sysconfdir}/modprobe.d/gma500-gfx-check.conf \
- ${sysconfdir}/modprobe.d/gma500-gfx-check.sh"
-
-COMPATIBLE_MACHINE = "intel-core2-32"
diff --git a/bsp/meta-intel/recipes-bsp/systemd-boot/systemd-boot/0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch b/bsp/meta-intel/recipes-bsp/systemd-boot/systemd-boot/0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch
deleted file mode 100644
index 8d0b6149..00000000
--- a/bsp/meta-intel/recipes-bsp/systemd-boot/systemd-boot/0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 58669ad764767afea4de53f8a97357773b1855ef Mon Sep 17 00:00:00 2001
-From: Saul Wold <sgw@linux.intel.com>
-Date: Tue, 25 Oct 2016 12:54:08 -0700
-Subject: [PATCH] efi/boot.c: workaround for Joule BIOS hang
-
-This patch should be removed when the BIOS is fixed
-
-Authored-by: Steve Sakoman <steve@sakoman.com>
-
-Upstream-Status: Inappropriate [machine specific workaround]
-Signed-off-by: Saul Wold <sgw@linux.intel.com>
----
- src/boot/efi/boot.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/boot/efi/boot.c b/src/boot/efi/boot.c
-index 3dcd9a5..3c6ed8c 100644
---- a/src/boot/efi/boot.c
-+++ b/src/boot/efi/boot.c
-@@ -649,7 +649,7 @@ static BOOLEAN menu_run(Config *config, ConfigEntry **chosen_entry, CHAR16 *load
- }
-
- /* timeout disabled, wait for next key */
-- wait = TRUE;
-+ wait = FALSE;
- continue;
- }
-
---
-2.7.4
-
diff --git a/bsp/meta-intel/recipes-bsp/systemd-boot/systemd-boot_%.bbappend b/bsp/meta-intel/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
deleted file mode 100644
index d46ef410..00000000
--- a/bsp/meta-intel/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
+++ /dev/null
@@ -1,15 +0,0 @@
-FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/systemd-boot:"
-
-SRC_URI_append_intel-x86-common = " \
- file://0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch \
- "
-
-PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}"
-
-do_compile_append_intel-x86-common() {
- ninja src/boot/efi/linux${SYSTEMD_BOOT_EFI_ARCH}.efi.stub
-}
-
-do_deploy_append_intel-x86-common() {
- install ${B}/src/boot/efi/linux*.efi.stub ${DEPLOYDIR}
-}
diff --git a/bsp/meta-intel/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch b/bsp/meta-intel/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch
deleted file mode 100644
index 6897ffc1..00000000
--- a/bsp/meta-intel/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From bb7631163c8f3f44d0dc83690765cdb799664fd5 Mon Sep 17 00:00:00 2001
-From: Anuj Mittal <anuj.mittal@intel.com>
-Date: Wed, 26 Sep 2018 10:34:15 +0800
-Subject: [PATCH] Use correct format specifier for size_t
-
-%zu instead of %lu, otherwise on 32 bit:
-
-| ../git/src/thd_zone.cpp: In member function 'void cthd_zone::sort_and_update_poll_trip()':
-| ../git/src/thd_zone.cpp:106:16: error: format '%lu' expects argument of type 'long unsigned int', but argument 4 has type 'std::vector<cthd_trip_point>::size_type' {aka 'unsigned int'} [-Werror=format=]
-| thd_log_debug("sort_and_update_poll_trip: trip_points_size =%lu\n",
-| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-| trip_points.size());
-
-Upstream-Status: Submitted
-[https://github.com/intel/thermal_daemon/pull/165]
-
-Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
----
- src/thd_zone.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/thd_zone.cpp b/src/thd_zone.cpp
-index b7edf9e..cb7b8e8 100644
---- a/src/thd_zone.cpp
-+++ b/src/thd_zone.cpp
-@@ -103,7 +103,7 @@ int cthd_zone::read_user_set_psv_temp() {
- }
-
- void cthd_zone::sort_and_update_poll_trip() {
-- thd_log_debug("sort_and_update_poll_trip: trip_points_size =%lu\n",
-+ thd_log_debug("sort_and_update_poll_trip: trip_points_size =%zu\n",
- trip_points.size());
- if (trip_points.size()) {
- unsigned int polling_trip = 0;
---
-2.17.1
-
diff --git a/bsp/meta-intel/recipes-bsp/thermald/thermald_1.8.bb b/bsp/meta-intel/recipes-bsp/thermald/thermald_1.8.bb
deleted file mode 100644
index f7725f31..00000000
--- a/bsp/meta-intel/recipes-bsp/thermald/thermald_1.8.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-SUMMARY = "Linux thermal daemon"
-
-DESCRIPTION = "Thermal Daemon is a Linux daemon used to prevent the \
-overheating of platforms. This daemon monitors temperature and applies \
-compensation using available cooling methods."
-
-HOMEPAGE = "https://github.com/01org/thermal_daemon"
-
-DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native"
-DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
-DEPENDS_append_libc-musl = " argp-standalone"
-DEPENDS_append_toolchain-clang = " openmp"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
-
-SRC_URI = "git://github.com/intel/thermal_daemon/ \
- file://0001-Use-correct-format-specifier-for-size_t.patch \
- "
-SRCREV = "517c0e5f92d49aeeef3a22b04caf40d588216827"
-S = "${WORKDIR}/git"
-
-inherit pkgconfig autotools systemd
-
-FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
-
-SYSTEMD_SERVICE_${PN} = "thermald.service"
-
-COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
-
-CONFFILES_${PN} = " \
- ${sysconfdir}/thermald/thermal-conf.xml \
- ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \
- "
-
-UPSTREAM_CHECK_URI = "https://github.com/01org/thermal_daemon/releases"