summaryrefslogtreecommitdiffstats
path: root/bsp/meta-intel/recipes-core/microcode
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-intel/recipes-core/microcode')
-rw-r--r--bsp/meta-intel/recipes-core/microcode/intel-microcode_20190514a.bb66
-rw-r--r--bsp/meta-intel/recipes-core/microcode/iucode-tool/0001-Makefile.am-Add-arg-parse-library-for-MUSL-support.patch29
-rw-r--r--bsp/meta-intel/recipes-core/microcode/iucode-tool_2.3.1.bb33
3 files changed, 0 insertions, 128 deletions
diff --git a/bsp/meta-intel/recipes-core/microcode/intel-microcode_20190514a.bb b/bsp/meta-intel/recipes-core/microcode/intel-microcode_20190514a.bb
deleted file mode 100644
index 6e97e90c..00000000
--- a/bsp/meta-intel/recipes-core/microcode/intel-microcode_20190514a.bb
+++ /dev/null
@@ -1,66 +0,0 @@
-SUMMARY = "Intel Processor Microcode Datafile for Linux"
-HOMEPAGE = "http://www.intel.com/"
-DESCRIPTION = "The microcode data file contains the latest microcode\
- definitions for all Intel processors. Intel releases microcode updates\
- to correct processor behavior as documented in the respective processor\
- specification updates. While the regular approach to getting this microcode\
- update is via a BIOS upgrade, Intel realizes that this can be an\
- administrative hassle. The Linux operating system and VMware ESX\
- products have a mechanism to update the microcode after booting.\
- For example, this file will be used by the operating system mechanism\
- if the file is placed in the /etc/firmware directory of the Linux system."
-
-LICENSE = "Intel-Microcode-License"
-LIC_FILES_CHKSUM = "file://license;md5=99b296eb12723fd1eeb52e24971eed84"
-
-SRC_URI = "git://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files.git;protocol=https \
- "
-
-SRCREV = "1dd14da6d1ea5cfbd95923653f31c04aac3aa655"
-
-DEPENDS = "iucode-tool-native"
-S = "${WORKDIR}/git"
-
-COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-inherit deploy
-
-# Use any of the iucode_tool parameters to filter specific microcodes from the data file
-# For further information, check the iucode-tool's manpage : http://manned.org/iucode-tool
-UCODE_FILTER_PARAMETERS ?= ""
-
-do_compile() {
- ${STAGING_DIR_NATIVE}${sbindir_native}/iucode_tool \
- ${UCODE_FILTER_PARAMETERS} \
- --overwrite \
- --write-to=${WORKDIR}/microcode_${PV}.bin \
- ${S}/intel-ucode/* ${S}/intel-ucode-with-caveats/*
-
- ${STAGING_DIR_NATIVE}${sbindir_native}/iucode_tool \
- ${UCODE_FILTER_PARAMETERS} \
- --overwrite \
- --write-earlyfw=${WORKDIR}/microcode_${PV}.cpio \
- ${S}/intel-ucode/* ${S}/intel-ucode-with-caveats/*
-}
-
-do_install() {
- install -d ${D}${base_libdir}/firmware/intel-ucode/
- install ${WORKDIR}/microcode_${PV}.bin ${D}${base_libdir}/firmware/intel-ucode/
- cd ${D}${base_libdir}/firmware/intel-ucode/
- ln -sf microcode_${PV}.bin microcode.bin
-}
-
-do_deploy() {
- install -d ${DEPLOYDIR}
- install ${WORKDIR}/microcode_${PV}.cpio ${DEPLOYDIR}/
- cd ${DEPLOYDIR}
- rm -f microcode.cpio
- ln -sf microcode_${PV}.cpio microcode.cpio
-}
-
-addtask deploy before do_build after do_compile
-
-PACKAGES = "${PN}"
-
-FILES_${PN} = "${base_libdir}"
diff --git a/bsp/meta-intel/recipes-core/microcode/iucode-tool/0001-Makefile.am-Add-arg-parse-library-for-MUSL-support.patch b/bsp/meta-intel/recipes-core/microcode/iucode-tool/0001-Makefile.am-Add-arg-parse-library-for-MUSL-support.patch
deleted file mode 100644
index ca97d2ab..00000000
--- a/bsp/meta-intel/recipes-core/microcode/iucode-tool/0001-Makefile.am-Add-arg-parse-library-for-MUSL-support.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 5f6826b3a59dedf508d5a6122362d69a4813e8e6 Mon Sep 17 00:00:00 2001
-From: Saul Wold <sgw@linux.intel.com>
-Date: Fri, 3 Feb 2017 16:08:51 -0800
-Subject: [PATCH] Makefile.am: Add arg-parse library for MUSL support
-
-iucode-tool needs argp-standalone when used with MUSL, so add this
-patch to the Makefile to link with argp
-
-Upstream-Status: Pending
-Signed-off-by: Saul Wold <sgw@linux.intel.com>
----
- Makefile.am | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/Makefile.am b/Makefile.am
-index 415a241..764fb61 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -5,6 +5,7 @@
- sbin_PROGRAMS = iucode_tool
- man_MANS = iucode_tool.8
-
-+iucode_tool_LDADD = -largp
- iucode_tool_SOURCES = intel_microcode.h intel_microcode.c iucode_tool.c
- EXTRA_DIST = autogen.sh CONTRIBUTING
-
---
-2.7.4
-
diff --git a/bsp/meta-intel/recipes-core/microcode/iucode-tool_2.3.1.bb b/bsp/meta-intel/recipes-core/microcode/iucode-tool_2.3.1.bb
deleted file mode 100644
index df74a8e9..00000000
--- a/bsp/meta-intel/recipes-core/microcode/iucode-tool_2.3.1.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-SUMMARY = "Update Intel CPU microcode"
-
-DESCRIPTION = "iucode_tool is a program to manipulate Intel i686 and X86-64\
- processor microcode update collections, and to use the kernel facilities to\
- update the microcode on Intel system processors. It can load microcode data\
- files in text and binary format, sort, list and filter the microcode updates\
- contained in these files, write selected microcode updates to a new file in\
- binary format, or upload them to the kernel. \
- It operates on microcode data downloaded directly from Intel:\
- http://feeds.downloadcenter.intel.com/rss/?p=2371\
-"
-HOMEPAGE = "https://gitlab.com/iucode-tool/"
-BUGTRACKER = "https://bugs.debian.org/cgi-bin/pkgreport.cgi?ordering=normal;archive=0;src=iucode-tool;repeatmerged=0"
-
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
- file://iucode_tool.c;beginline=1;endline=15;md5=71eeab3190360ff0267101b570874756"
-
-DEPENDS_append_libc-musl = " argp-standalone"
-
-SRC_URI = "https://gitlab.com/iucode-tool/releases/raw/master/iucode-tool_${PV}.tar.xz"
-SRC_URI_append_libc-musl = " file://0001-Makefile.am-Add-arg-parse-library-for-MUSL-support.patch"
-
-SRC_URI[md5sum] = "63b33cc0ea1f8c73b443412abbf39d6f"
-SRC_URI[sha256sum] = "12b88efa4d0d95af08db05a50b3dcb217c0eb2bfc67b483779e33d498ddb2f95"
-
-inherit autotools
-
-BBCLASSEXTEND = "native"
-
-COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
-
-UPSTREAM_CHECK_URI = "https://gitlab.com/iucode-tool/releases"