summaryrefslogtreecommitdiffstats
path: root/bsp/meta-intel/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-intel/recipes-core')
-rw-r--r--bsp/meta-intel/recipes-core/images/core-image-minimal-initramfs.bbappend2
-rw-r--r--bsp/meta-intel/recipes-core/images/core-image-tiny.bb36
-rw-r--r--bsp/meta-intel/recipes-core/microcode/intel-microcode_20190514a.bb66
-rw-r--r--bsp/meta-intel/recipes-core/microcode/iucode-tool/0001-Makefile.am-Add-arg-parse-library-for-MUSL-support.patch29
-rw-r--r--bsp/meta-intel/recipes-core/microcode/iucode-tool_2.3.1.bb33
-rw-r--r--bsp/meta-intel/recipes-core/ovmf/files/0001-ovmf-RefkitTestCA-TEST-UEFI-SecureBoot.patch105
-rw-r--r--bsp/meta-intel/recipes-core/ovmf/ovmf-shell-image-enrollkeys.bb13
-rw-r--r--bsp/meta-intel/recipes-core/ovmf/ovmf_%.bbappend6
8 files changed, 0 insertions, 290 deletions
diff --git a/bsp/meta-intel/recipes-core/images/core-image-minimal-initramfs.bbappend b/bsp/meta-intel/recipes-core/images/core-image-minimal-initramfs.bbappend
deleted file mode 100644
index 132f15b5..00000000
--- a/bsp/meta-intel/recipes-core/images/core-image-minimal-initramfs.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-# Add i915 graphics firmware
-PACKAGE_INSTALL_append_intel-x86-common = " linux-firmware-i915"
diff --git a/bsp/meta-intel/recipes-core/images/core-image-tiny.bb b/bsp/meta-intel/recipes-core/images/core-image-tiny.bb
deleted file mode 100644
index 6b09b0c2..00000000
--- a/bsp/meta-intel/recipes-core/images/core-image-tiny.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-SUMMARY = "A tiny image just capable of allowing a device to boot from RAM, \
-this image recipe generates an image file which rather boots from initrd than \
-from storage, it achieves this by using wic to pick up the artifacts generated \
-by the core-image-tiny-initramfs image"
-
-# The actual rootfs/initrd will be the one from core-image-tiny-initramfs, so
-# we reset IMAGE_INSTALL to avoid building other things that will be pointless
-IMAGE_INSTALL = ""
-
-# Do not pollute the initrd image with rootfs features
-IMAGE_FEATURES = ""
-
-IMAGE_LINGUAS = " "
-
-LICENSE = "MIT"
-
-IMAGE_ROOTFS_SIZE ?= "8192"
-
-IMAGE_FSTYPES = "wic"
-inherit core-image
-
-# We get some parts from image-live that we need in order to boot from initrd
-INITRD_IMAGE_LIVE ?= "core-image-tiny-initramfs"
-
-python() {
- image_b = d.getVar('IMAGE_BASENAME')
- initrd_i = d.getVar('INITRD_IMAGE_LIVE')
- if image_b == initrd_i:
- bb.error('INITRD_IMAGE_LIVE %s cannot use the requested IMAGE_FSTYPE' % initrd_i)
- bb.fatal('Check IMAGE_FSTYPES and INITRAMFS_FSTYPES settings.')
- elif initrd_i:
- d.appendVarFlag('do_image', 'depends', ' %s:do_image_complete' % initrd_i)
-}
-
-WKS_FILE_intel-corei7-64 = "core-image-tiny.wks.in"
-WKS_FILE_intel-core2-32 = "core-image-tiny.wks.in"
diff --git a/bsp/meta-intel/recipes-core/microcode/intel-microcode_20190514a.bb b/bsp/meta-intel/recipes-core/microcode/intel-microcode_20190514a.bb
deleted file mode 100644
index 6e97e90c..00000000
--- a/bsp/meta-intel/recipes-core/microcode/intel-microcode_20190514a.bb
+++ /dev/null
@@ -1,66 +0,0 @@
-SUMMARY = "Intel Processor Microcode Datafile for Linux"
-HOMEPAGE = "http://www.intel.com/"
-DESCRIPTION = "The microcode data file contains the latest microcode\
- definitions for all Intel processors. Intel releases microcode updates\
- to correct processor behavior as documented in the respective processor\
- specification updates. While the regular approach to getting this microcode\
- update is via a BIOS upgrade, Intel realizes that this can be an\
- administrative hassle. The Linux operating system and VMware ESX\
- products have a mechanism to update the microcode after booting.\
- For example, this file will be used by the operating system mechanism\
- if the file is placed in the /etc/firmware directory of the Linux system."
-
-LICENSE = "Intel-Microcode-License"
-LIC_FILES_CHKSUM = "file://license;md5=99b296eb12723fd1eeb52e24971eed84"
-
-SRC_URI = "git://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files.git;protocol=https \
- "
-
-SRCREV = "1dd14da6d1ea5cfbd95923653f31c04aac3aa655"
-
-DEPENDS = "iucode-tool-native"
-S = "${WORKDIR}/git"
-
-COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-inherit deploy
-
-# Use any of the iucode_tool parameters to filter specific microcodes from the data file
-# For further information, check the iucode-tool's manpage : http://manned.org/iucode-tool
-UCODE_FILTER_PARAMETERS ?= ""
-
-do_compile() {
- ${STAGING_DIR_NATIVE}${sbindir_native}/iucode_tool \
- ${UCODE_FILTER_PARAMETERS} \
- --overwrite \
- --write-to=${WORKDIR}/microcode_${PV}.bin \
- ${S}/intel-ucode/* ${S}/intel-ucode-with-caveats/*
-
- ${STAGING_DIR_NATIVE}${sbindir_native}/iucode_tool \
- ${UCODE_FILTER_PARAMETERS} \
- --overwrite \
- --write-earlyfw=${WORKDIR}/microcode_${PV}.cpio \
- ${S}/intel-ucode/* ${S}/intel-ucode-with-caveats/*
-}
-
-do_install() {
- install -d ${D}${base_libdir}/firmware/intel-ucode/
- install ${WORKDIR}/microcode_${PV}.bin ${D}${base_libdir}/firmware/intel-ucode/
- cd ${D}${base_libdir}/firmware/intel-ucode/
- ln -sf microcode_${PV}.bin microcode.bin
-}
-
-do_deploy() {
- install -d ${DEPLOYDIR}
- install ${WORKDIR}/microcode_${PV}.cpio ${DEPLOYDIR}/
- cd ${DEPLOYDIR}
- rm -f microcode.cpio
- ln -sf microcode_${PV}.cpio microcode.cpio
-}
-
-addtask deploy before do_build after do_compile
-
-PACKAGES = "${PN}"
-
-FILES_${PN} = "${base_libdir}"
diff --git a/bsp/meta-intel/recipes-core/microcode/iucode-tool/0001-Makefile.am-Add-arg-parse-library-for-MUSL-support.patch b/bsp/meta-intel/recipes-core/microcode/iucode-tool/0001-Makefile.am-Add-arg-parse-library-for-MUSL-support.patch
deleted file mode 100644
index ca97d2ab..00000000
--- a/bsp/meta-intel/recipes-core/microcode/iucode-tool/0001-Makefile.am-Add-arg-parse-library-for-MUSL-support.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 5f6826b3a59dedf508d5a6122362d69a4813e8e6 Mon Sep 17 00:00:00 2001
-From: Saul Wold <sgw@linux.intel.com>
-Date: Fri, 3 Feb 2017 16:08:51 -0800
-Subject: [PATCH] Makefile.am: Add arg-parse library for MUSL support
-
-iucode-tool needs argp-standalone when used with MUSL, so add this
-patch to the Makefile to link with argp
-
-Upstream-Status: Pending
-Signed-off-by: Saul Wold <sgw@linux.intel.com>
----
- Makefile.am | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/Makefile.am b/Makefile.am
-index 415a241..764fb61 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -5,6 +5,7 @@
- sbin_PROGRAMS = iucode_tool
- man_MANS = iucode_tool.8
-
-+iucode_tool_LDADD = -largp
- iucode_tool_SOURCES = intel_microcode.h intel_microcode.c iucode_tool.c
- EXTRA_DIST = autogen.sh CONTRIBUTING
-
---
-2.7.4
-
diff --git a/bsp/meta-intel/recipes-core/microcode/iucode-tool_2.3.1.bb b/bsp/meta-intel/recipes-core/microcode/iucode-tool_2.3.1.bb
deleted file mode 100644
index df74a8e9..00000000
--- a/bsp/meta-intel/recipes-core/microcode/iucode-tool_2.3.1.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-SUMMARY = "Update Intel CPU microcode"
-
-DESCRIPTION = "iucode_tool is a program to manipulate Intel i686 and X86-64\
- processor microcode update collections, and to use the kernel facilities to\
- update the microcode on Intel system processors. It can load microcode data\
- files in text and binary format, sort, list and filter the microcode updates\
- contained in these files, write selected microcode updates to a new file in\
- binary format, or upload them to the kernel. \
- It operates on microcode data downloaded directly from Intel:\
- http://feeds.downloadcenter.intel.com/rss/?p=2371\
-"
-HOMEPAGE = "https://gitlab.com/iucode-tool/"
-BUGTRACKER = "https://bugs.debian.org/cgi-bin/pkgreport.cgi?ordering=normal;archive=0;src=iucode-tool;repeatmerged=0"
-
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
- file://iucode_tool.c;beginline=1;endline=15;md5=71eeab3190360ff0267101b570874756"
-
-DEPENDS_append_libc-musl = " argp-standalone"
-
-SRC_URI = "https://gitlab.com/iucode-tool/releases/raw/master/iucode-tool_${PV}.tar.xz"
-SRC_URI_append_libc-musl = " file://0001-Makefile.am-Add-arg-parse-library-for-MUSL-support.patch"
-
-SRC_URI[md5sum] = "63b33cc0ea1f8c73b443412abbf39d6f"
-SRC_URI[sha256sum] = "12b88efa4d0d95af08db05a50b3dcb217c0eb2bfc67b483779e33d498ddb2f95"
-
-inherit autotools
-
-BBCLASSEXTEND = "native"
-
-COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
-
-UPSTREAM_CHECK_URI = "https://gitlab.com/iucode-tool/releases"
diff --git a/bsp/meta-intel/recipes-core/ovmf/files/0001-ovmf-RefkitTestCA-TEST-UEFI-SecureBoot.patch b/bsp/meta-intel/recipes-core/ovmf/files/0001-ovmf-RefkitTestCA-TEST-UEFI-SecureBoot.patch
deleted file mode 100644
index 62db0633..00000000
--- a/bsp/meta-intel/recipes-core/ovmf/files/0001-ovmf-RefkitTestCA-TEST-UEFI-SecureBoot.patch
+++ /dev/null
@@ -1,105 +0,0 @@
-From 48e511481d83c1614cd00a5a2edcf6b5d746b9c4 Mon Sep 17 00:00:00 2001
-From: Mikko Ylinen <mikko.ylinen@linux.intel.com>
-Date: Fri, 7 Apr 2017 12:06:14 +0300
-Subject: [PATCH] ovmf: RefkitTestCA: TEST UEFI SecureBoot
-
-This patch adds refkit-db.cer (via xxd -i) in OVMF's db
-signature database when used with EnrollDefaultKeys EFI
-application. It's used for testing purposes only.
-
-Images signed with refkit-db keys are allowed to boot.
-
-Signed-off-by: Mikko Ylinen <mikko.ylinen@linux.intel.com>
----
- OvmfPkg/EnrollDefaultKeys/EnrollDefaultKeys.c | 68 +++++++++++++++++++++++++++
- 1 file changed, 68 insertions(+)
-
-diff --git a/OvmfPkg/EnrollDefaultKeys/EnrollDefaultKeys.c b/OvmfPkg/EnrollDefaultKeys/EnrollDefaultKeys.c
-index 24ab977..a3c12ba 100644
---- a/OvmfPkg/EnrollDefaultKeys/EnrollDefaultKeys.c
-+++ b/OvmfPkg/EnrollDefaultKeys/EnrollDefaultKeys.c
-@@ -516,6 +516,73 @@ STATIC CONST UINT8 MicrosoftUefiCA[] = {
- 0x07, 0x92, 0x9b, 0xf5, 0xa6, 0xbc, 0x59, 0x83, 0x58
- };
-
-+STATIC CONST UINT8 RefkitTestCA[] = {
-+ 0x30, 0x82, 0x02, 0xfb, 0x30, 0x82, 0x01, 0xe3, 0xa0, 0x03, 0x02, 0x01,
-+ 0x02, 0x02, 0x09, 0x00, 0xd4, 0xf6, 0x48, 0xc2, 0x68, 0x19, 0x91, 0xac,
-+ 0x30, 0x0d, 0x06, 0x09, 0x2a, 0x86, 0x48, 0x86, 0xf7, 0x0d, 0x01, 0x01,
-+ 0x0b, 0x05, 0x00, 0x30, 0x14, 0x31, 0x12, 0x30, 0x10, 0x06, 0x03, 0x55,
-+ 0x04, 0x03, 0x0c, 0x09, 0x72, 0x65, 0x66, 0x6b, 0x69, 0x74, 0x2d, 0x64,
-+ 0x62, 0x30, 0x1e, 0x17, 0x0d, 0x31, 0x37, 0x30, 0x34, 0x32, 0x30, 0x31,
-+ 0x32, 0x30, 0x36, 0x33, 0x32, 0x5a, 0x17, 0x0d, 0x31, 0x38, 0x30, 0x34,
-+ 0x32, 0x30, 0x31, 0x32, 0x30, 0x36, 0x33, 0x32, 0x5a, 0x30, 0x14, 0x31,
-+ 0x12, 0x30, 0x10, 0x06, 0x03, 0x55, 0x04, 0x03, 0x0c, 0x09, 0x72, 0x65,
-+ 0x66, 0x6b, 0x69, 0x74, 0x2d, 0x64, 0x62, 0x30, 0x82, 0x01, 0x22, 0x30,
-+ 0x0d, 0x06, 0x09, 0x2a, 0x86, 0x48, 0x86, 0xf7, 0x0d, 0x01, 0x01, 0x01,
-+ 0x05, 0x00, 0x03, 0x82, 0x01, 0x0f, 0x00, 0x30, 0x82, 0x01, 0x0a, 0x02,
-+ 0x82, 0x01, 0x01, 0x00, 0xb4, 0x1c, 0x22, 0xa6, 0x22, 0x01, 0x57, 0xcd,
-+ 0xf1, 0x4f, 0xaf, 0x72, 0xe3, 0xd9, 0x01, 0x80, 0x50, 0x55, 0xef, 0x02,
-+ 0x5e, 0xeb, 0x99, 0x35, 0xcb, 0x7f, 0x2a, 0x79, 0xff, 0xb5, 0x3e, 0xec,
-+ 0x5d, 0x92, 0x06, 0x30, 0x20, 0xe7, 0x95, 0xad, 0xa4, 0x84, 0x2e, 0x3f,
-+ 0xfa, 0xd7, 0x46, 0xdd, 0x49, 0xa8, 0xe8, 0xe3, 0x79, 0x49, 0xf6, 0x8f,
-+ 0x0b, 0x1d, 0xfe, 0x63, 0xa8, 0xd1, 0x63, 0xa3, 0xd6, 0x0d, 0x4e, 0x6c,
-+ 0x66, 0x5c, 0xd6, 0x66, 0x26, 0xd1, 0x26, 0x98, 0xd4, 0x4f, 0x76, 0xc9,
-+ 0x65, 0x48, 0x58, 0x13, 0x08, 0x31, 0xbc, 0xe5, 0x47, 0x25, 0x65, 0x95,
-+ 0x39, 0x89, 0x5f, 0x02, 0xf1, 0xc5, 0x06, 0x17, 0x58, 0xca, 0x09, 0xfd,
-+ 0xf6, 0x1e, 0xc5, 0x97, 0xda, 0xa3, 0x4e, 0x1a, 0x48, 0xbe, 0xcf, 0x96,
-+ 0x27, 0x04, 0x4b, 0xb7, 0x6d, 0x67, 0xb6, 0x50, 0x18, 0x04, 0x73, 0x51,
-+ 0xd2, 0x6a, 0x2d, 0xdf, 0x3b, 0xab, 0xf2, 0x2d, 0x95, 0xd7, 0xa8, 0xb8,
-+ 0xa8, 0x30, 0xa1, 0xab, 0x8b, 0x92, 0x2b, 0x60, 0x3e, 0x3a, 0xe5, 0x86,
-+ 0x40, 0x71, 0xc1, 0x3f, 0x2d, 0x2e, 0x90, 0xe7, 0xd6, 0xec, 0xcc, 0xc2,
-+ 0x0b, 0x79, 0x83, 0x71, 0x6d, 0xf6, 0xa3, 0xa9, 0x4c, 0xcd, 0x46, 0x81,
-+ 0xdc, 0xef, 0xec, 0x51, 0xbe, 0x81, 0x2a, 0xf1, 0x78, 0x73, 0x41, 0xdb,
-+ 0x54, 0xce, 0x7c, 0xce, 0xa2, 0xe3, 0x90, 0x4f, 0x45, 0x1a, 0xf9, 0x3d,
-+ 0x88, 0xfc, 0x0e, 0xed, 0xd3, 0x69, 0x22, 0x4c, 0xfa, 0x0a, 0x69, 0xd1,
-+ 0x48, 0xc0, 0xaa, 0xa9, 0x3a, 0xb3, 0x8f, 0x10, 0x3a, 0x76, 0xa8, 0x0c,
-+ 0x7a, 0x3d, 0xd8, 0x79, 0xce, 0x1c, 0x96, 0x62, 0xf4, 0x06, 0xee, 0x47,
-+ 0xe8, 0xe0, 0x69, 0x91, 0xae, 0xea, 0x34, 0xcf, 0xda, 0xa8, 0xb4, 0x39,
-+ 0x5e, 0xf3, 0x7a, 0xd0, 0x88, 0x48, 0x47, 0x69, 0x02, 0x03, 0x01, 0x00,
-+ 0x01, 0xa3, 0x50, 0x30, 0x4e, 0x30, 0x1d, 0x06, 0x03, 0x55, 0x1d, 0x0e,
-+ 0x04, 0x16, 0x04, 0x14, 0x68, 0x60, 0x11, 0x25, 0x85, 0x14, 0x78, 0x1b,
-+ 0x1a, 0x9f, 0x46, 0x12, 0xe6, 0x21, 0xe4, 0xef, 0xfb, 0x3b, 0xaa, 0xdd,
-+ 0x30, 0x1f, 0x06, 0x03, 0x55, 0x1d, 0x23, 0x04, 0x18, 0x30, 0x16, 0x80,
-+ 0x14, 0x68, 0x60, 0x11, 0x25, 0x85, 0x14, 0x78, 0x1b, 0x1a, 0x9f, 0x46,
-+ 0x12, 0xe6, 0x21, 0xe4, 0xef, 0xfb, 0x3b, 0xaa, 0xdd, 0x30, 0x0c, 0x06,
-+ 0x03, 0x55, 0x1d, 0x13, 0x04, 0x05, 0x30, 0x03, 0x01, 0x01, 0xff, 0x30,
-+ 0x0d, 0x06, 0x09, 0x2a, 0x86, 0x48, 0x86, 0xf7, 0x0d, 0x01, 0x01, 0x0b,
-+ 0x05, 0x00, 0x03, 0x82, 0x01, 0x01, 0x00, 0x8f, 0xd2, 0x84, 0x7c, 0x43,
-+ 0x47, 0xca, 0x6b, 0xfd, 0x87, 0x83, 0xd0, 0xef, 0x75, 0xd3, 0x20, 0x52,
-+ 0x73, 0x18, 0xaa, 0x32, 0x71, 0xfb, 0xa5, 0xf4, 0xc9, 0x11, 0xa3, 0x68,
-+ 0x4d, 0xb7, 0x9d, 0xe6, 0xd9, 0x46, 0x24, 0xdc, 0xc7, 0xc2, 0x3b, 0xf9,
-+ 0xb0, 0x98, 0xfc, 0xee, 0x34, 0x6e, 0x10, 0x9b, 0x3d, 0x44, 0x6e, 0x33,
-+ 0x09, 0x11, 0xb8, 0x29, 0xd6, 0x2d, 0x06, 0xcf, 0x67, 0x8f, 0x96, 0x85,
-+ 0x9d, 0x63, 0x72, 0xbf, 0x64, 0x5f, 0x0d, 0xe3, 0xc9, 0x63, 0x19, 0x71,
-+ 0xd4, 0x7d, 0x4c, 0x9c, 0x77, 0x46, 0xda, 0x20, 0x97, 0x6d, 0xbc, 0xdd,
-+ 0xc2, 0x1f, 0xf3, 0x40, 0x38, 0x1e, 0xe7, 0xcc, 0x55, 0x05, 0x72, 0xba,
-+ 0x24, 0x4f, 0xb3, 0x8a, 0x93, 0x0c, 0x30, 0x60, 0xda, 0x9f, 0x6f, 0x35,
-+ 0xf6, 0xfb, 0xb0, 0x1f, 0xb3, 0x00, 0xdd, 0xc4, 0xa6, 0xbc, 0xe2, 0x37,
-+ 0xc1, 0xa3, 0xef, 0xd9, 0xa1, 0x86, 0xf9, 0xeb, 0xa4, 0xa5, 0x45, 0x38,
-+ 0xff, 0x4e, 0x87, 0x4a, 0x41, 0xcf, 0x6e, 0x69, 0x7e, 0x97, 0xbe, 0x2d,
-+ 0x22, 0xbc, 0x8d, 0xa0, 0x1a, 0x21, 0x8f, 0x4b, 0x72, 0x90, 0x01, 0x5c,
-+ 0xba, 0xa5, 0x9c, 0x2d, 0xd7, 0x25, 0x24, 0xfc, 0xff, 0x5c, 0x58, 0x14,
-+ 0x46, 0x30, 0x09, 0x7c, 0x55, 0x64, 0x83, 0x0b, 0xb9, 0xdf, 0xcf, 0x25,
-+ 0xee, 0xec, 0xf7, 0xcb, 0xdb, 0xd1, 0x5b, 0x93, 0x93, 0xc8, 0x8a, 0x10,
-+ 0x46, 0xb8, 0xb0, 0x35, 0x1c, 0x6c, 0x0d, 0x8f, 0x03, 0x6a, 0x8f, 0x1b,
-+ 0x36, 0x68, 0xf3, 0x53, 0x89, 0x36, 0x5b, 0x21, 0x80, 0xde, 0xe3, 0x92,
-+ 0x52, 0x94, 0x97, 0x9d, 0x49, 0x89, 0x7d, 0x3e, 0xde, 0x29, 0x51, 0xba,
-+ 0x11, 0xf7, 0xba, 0x01, 0xf7, 0xab, 0xea, 0xc1, 0xa7, 0x2e, 0xa3, 0x4d,
-+ 0x65, 0xfd, 0x40, 0x71, 0xf1, 0xe2, 0x3f, 0x6c, 0x28, 0xcb, 0xd3
-+};
-+
- //
- // The most important thing about the variable payload is that it is a list of
- // lists, where the element size of any given *inner* list is constant.
-@@ -908,6 +975,7 @@ ShellAppMain (
- &gEfiImageSecurityDatabaseGuid,
- MicrosoftPCA, sizeof MicrosoftPCA, &gEfiCallerIdGuid,
- MicrosoftUefiCA, sizeof MicrosoftUefiCA, &gEfiCallerIdGuid,
-+ RefkitTestCA, sizeof RefkitTestCA, &gEfiCallerIdGuid,
- NULL);
- if (EFI_ERROR (Status)) {
- return 1;
---
-2.1.4
-
diff --git a/bsp/meta-intel/recipes-core/ovmf/ovmf-shell-image-enrollkeys.bb b/bsp/meta-intel/recipes-core/ovmf/ovmf-shell-image-enrollkeys.bb
deleted file mode 100644
index b20f6e58..00000000
--- a/bsp/meta-intel/recipes-core/ovmf/ovmf-shell-image-enrollkeys.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-require recipes-core/ovmf/ovmf-shell-image.bb
-
-WKS_SEARCH_PATH_append = ":${COREBASE}/meta/recipes-core/ovmf"
-
-QB_DRIVE_TYPE = "/dev/vd"
-
-do_image_append() {
- cat > ${IMAGE_ROOTFS}/startup.nsh << EOF
-EnrollDefaultKeys
-reset
-EOF
-
-}
diff --git a/bsp/meta-intel/recipes-core/ovmf/ovmf_%.bbappend b/bsp/meta-intel/recipes-core/ovmf/ovmf_%.bbappend
deleted file mode 100644
index bbf5fa32..00000000
--- a/bsp/meta-intel/recipes-core/ovmf/ovmf_%.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/files:"
-
-SRC_URI_append_intel-x86-common = " \
- file://0001-ovmf-RefkitTestCA-TEST-UEFI-SecureBoot.patch \
-"
-PACKAGECONFIG_append_intel-x86-common = " secureboot"