summaryrefslogtreecommitdiffstats
path: root/bsp/meta-intel/recipes-kernel/linux/linux-intel-rt_4.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-intel/recipes-kernel/linux/linux-intel-rt_4.14.bb')
-rw-r--r--bsp/meta-intel/recipes-kernel/linux/linux-intel-rt_4.14.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/bsp/meta-intel/recipes-kernel/linux/linux-intel-rt_4.14.bb b/bsp/meta-intel/recipes-kernel/linux/linux-intel-rt_4.14.bb
new file mode 100644
index 00000000..0611304c
--- /dev/null
+++ b/bsp/meta-intel/recipes-kernel/linux/linux-intel-rt_4.14.bb
@@ -0,0 +1,24 @@
+require linux-intel.inc
+
+# Skip processing of this recipe if it is not explicitly specified as the
+# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
+# to build multiple virtual/kernel providers, e.g. as dependency of
+# core-image-rt-sdk, core-image-rt.
+python () {
+ if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
+ raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
+}
+
+KBRANCH = "4.14/preempt-rt"
+KMETA_BRANCH = "yocto-4.14"
+
+# Fix for 32-bit perf issue. Remove when patch is backported to 4.14.
+SRC_URI_append = " file://0001-perf-x86-32-explicitly-include-errno.h.patch"
+
+DEPENDS += "elfutils-native openssl-native util-linux-native"
+
+LINUX_VERSION ?= "4.14.106"
+SRCREV_machine ?= "5cfa4c85d15168b84e40bd38b7d31a62a01e40d3"
+SRCREV_meta ?= "bc35d5bd224ab031440a69f9806d839db382f05c"
+
+LINUX_KERNEL_TYPE = "preempt-rt"