summaryrefslogtreecommitdiffstats
path: root/bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14.bb')
-rw-r--r--bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14.bb b/bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14.bb
new file mode 100644
index 00000000..cc100fe8
--- /dev/null
+++ b/bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14.bb
@@ -0,0 +1,22 @@
+require linux-intel.inc
+
+KBRANCH = "4.14/base"
+KMETA_BRANCH = "yocto-4.14"
+
+# Fix for 32-bit perf issue. Remove when patch is backported to 4.14.
+SRC_URI_append = " file://0001-perf-x86-32-explicitly-include-errno.h.patch \
+ file://0001-menuconfig-check-lxdiaglog.sh-Allow-specification-of.patch \
+ "
+
+DEPENDS += "elfutils-native openssl-native util-linux-native"
+
+LINUX_VERSION ?= "4.14.110"
+SRCREV_machine ?= "f93147df5d96922347d0a4143ad06ae5d45d1caf"
+SRCREV_meta ?= "bc35d5bd224ab031440a69f9806d839db382f05c"
+
+# For Crystalforest and Romley
+KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
+KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
+
+# Functionality flags
+KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"