summaryrefslogtreecommitdiffstats
path: root/bsp/meta-intel/recipes-multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-intel/recipes-multimedia')
-rw-r--r--bsp/meta-intel/recipes-multimedia/libva/intel-vaapi-driver_2.2.0.bb33
-rw-r--r--bsp/meta-intel/recipes-multimedia/libyami/libyami-utils/0001-Fix-build-with-clang.patch96
-rw-r--r--bsp/meta-intel/recipes-multimedia/libyami/libyami-utils_1.3.1.bb26
-rw-r--r--bsp/meta-intel/recipes-multimedia/libyami/libyami/0001-bitWriter.cpp-Delete-unused-CACHEBYTES.patch27
-rw-r--r--bsp/meta-intel/recipes-multimedia/libyami/libyami/0002-typecast-index-from-size_t-to-int.patch42
-rw-r--r--bsp/meta-intel/recipes-multimedia/libyami/libyami/0003-Add-Wno-invalid-offsetof-to-compiler-commandline.patch29
-rw-r--r--bsp/meta-intel/recipes-multimedia/libyami/libyami/0004-Typecast-POWER32SUB2-to-uint8_t.patch33
-rw-r--r--bsp/meta-intel/recipes-multimedia/libyami/libyami/0006-Avoid-namespace-conflicts-by-adding-explicit-using-n.patch41
-rw-r--r--bsp/meta-intel/recipes-multimedia/libyami/libyami/0007-Delete-unused-variables.patch36
-rw-r--r--bsp/meta-intel/recipes-multimedia/libyami/libyami/0008-NalUnit-is-declared-in-different-namespace.patch31
-rw-r--r--bsp/meta-intel/recipes-multimedia/libyami/libyami/0009-Fix-clang-warnings.patch37
-rw-r--r--bsp/meta-intel/recipes-multimedia/libyami/libyami_1.3.1.bb30
12 files changed, 0 insertions, 461 deletions
diff --git a/bsp/meta-intel/recipes-multimedia/libva/intel-vaapi-driver_2.2.0.bb b/bsp/meta-intel/recipes-multimedia/libva/intel-vaapi-driver_2.2.0.bb
deleted file mode 100644
index 9036f74e..00000000
--- a/bsp/meta-intel/recipes-multimedia/libva/intel-vaapi-driver_2.2.0.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-SUMMARY = "VA driver for Intel G45 & HD Graphics family"
-DESCRIPTION = "intel-vaapi-driver is the VA-API implementation \
-for Intel G45 chipsets and Intel HD Graphics for Intel Core \
-processor family."
-
-HOMEPAGE = "https://github.com/intel/intel-vaapi-driver"
-BUGTRACKER = "https://github.com/intel/intel-vaapi-driver/issues"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
-
-COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
-
-DEPENDS = "libva libdrm"
-
-SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.bz2"
-SRC_URI[md5sum] = "e296c52fa1cb5c3d53a6cc994ce0a66c"
-SRC_URI[sha256sum] = "e8a5f54694eb76aad42653b591030b8a53b1513144c09a80defb3d8d8c875c18"
-
-UPSTREAM_CHECK_URI = "https://github.com/intel/intel-vaapi-driver/releases"
-
-inherit autotools pkgconfig distro_features_check
-
-REQUIRED_DISTRO_FEATURES = "opengl"
-
-PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "x11", "", d)} \
- ${@bb.utils.contains("DISTRO_FEATURES", "opengl wayland", "wayland", "", d)}"
-PACKAGECONFIG[x11] = "--enable-x11,--disable-x11"
-PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland wayland-native virtual/egl"
-
-FILES_${PN} += "${libdir}/dri/*.so"
-FILES_${PN}-dev += "${libdir}/dri/*.la"
-FILES_${PN}-dbg += "${libdir}/dri/.debug"
diff --git a/bsp/meta-intel/recipes-multimedia/libyami/libyami-utils/0001-Fix-build-with-clang.patch b/bsp/meta-intel/recipes-multimedia/libyami/libyami-utils/0001-Fix-build-with-clang.patch
deleted file mode 100644
index f7de9d16..00000000
--- a/bsp/meta-intel/recipes-multimedia/libyami/libyami-utils/0001-Fix-build-with-clang.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-From f2e6d2ecfea635ab952649156e31ca893d4b1a47 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sat, 12 Aug 2017 08:49:20 -0700
-Subject: [PATCH] Fix build with clang
-
-Fix errors e.g.
-error: comparison of constant -1 with expression of type 'char' is always true [-Werror,-Wtautological-constant-out-of-range-compare]error: comparison of constant -1 with expression of type 'char' is always true [-Werror,-Wtautological-constant-out-of-range-compare]
-
-and
-
-psnr.cpp:225:17: error: bool literal returned from 'main' [-Werror,-Wmain]
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Upstream-Status: Pending
-
----
- tests/decodehelp.cpp | 2 +-
- tests/encodehelp.h | 2 +-
- tests/vpp.cpp | 2 +-
- tests/yamitranscode.cpp | 2 +-
- testscripts/psnr.cpp | 4 ++--
- 5 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/tests/decodehelp.cpp b/tests/decodehelp.cpp
-index b27b977..62cca63 100644
---- a/tests/decodehelp.cpp
-+++ b/tests/decodehelp.cpp
-@@ -81,7 +81,7 @@ bool processCmdLine(int argc, char** argv, DecodeParameter* parameters)
- { NULL, no_argument, NULL, 0 }
- };
-
-- char opt;
-+ int opt;
- while ((opt = getopt_long_only(argc, argv, "h:m:n:i:f:o:w:?", long_opts,&option_index)) != -1){
- switch (opt) {
- case 'h':
-diff --git a/tests/encodehelp.h b/tests/encodehelp.h
-index 63580a4..651ec08 100644
---- a/tests/encodehelp.h
-+++ b/tests/encodehelp.h
-@@ -109,7 +109,7 @@ static VideoRateControl string_to_rc_mode(char *str)
-
- static bool process_cmdline(int argc, char *argv[])
- {
-- char opt;
-+ int opt;
- const struct option long_opts[] = {
- { "help", no_argument, NULL, 'h' },
- { "qp", required_argument, NULL, 0 },
-diff --git a/tests/vpp.cpp b/tests/vpp.cpp
-index 5a60c0a..52da43b 100644
---- a/tests/vpp.cpp
-+++ b/tests/vpp.cpp
-@@ -151,7 +151,7 @@ public:
- private:
- bool processCmdLine(int argc, char* argv[])
- {
-- char opt;
-+ int opt;
- const struct option long_opts[] = {
- { "help", no_argument, NULL, 'h' },
- { "sharpening", required_argument, NULL, 's' },
-diff --git a/tests/yamitranscode.cpp b/tests/yamitranscode.cpp
-index 6207209..00164ce 100755
---- a/tests/yamitranscode.cpp
-+++ b/tests/yamitranscode.cpp
-@@ -100,7 +100,7 @@ static VideoRateControl string_to_rc_mode(char *str)
-
- static bool processCmdLine(int argc, char *argv[], TranscodeParams& para)
- {
-- char opt;
-+ int opt;
- const struct option long_opts[] = {
- { "help", no_argument, NULL, 'h' },
- { "qp", required_argument, NULL, 0 },
-diff --git a/testscripts/psnr.cpp b/testscripts/psnr.cpp
-index 5cc24c9..68bd668 100644
---- a/testscripts/psnr.cpp
-+++ b/testscripts/psnr.cpp
-@@ -215,14 +215,14 @@ int main(int argc, char *argv[])
- const char* psnrresult = "average_psnr.txt";
- int width=0,height=0;
- int standardpsnr = NORMAL_PSNR;
-- char opt;
-+ int opt;
- while ((opt = getopt(argc, argv, "h:W:H:i:o:s:?")) != -1)
- {
- switch (opt) {
- case 'h':
- case '?':
- print_help(argv[0]);
-- return false;
-+ return -1;
- case 'i':
- filename1 = optarg;
- break;
diff --git a/bsp/meta-intel/recipes-multimedia/libyami/libyami-utils_1.3.1.bb b/bsp/meta-intel/recipes-multimedia/libyami/libyami-utils_1.3.1.bb
deleted file mode 100644
index ab1b83aa..00000000
--- a/bsp/meta-intel/recipes-multimedia/libyami/libyami-utils_1.3.1.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-SUMMARY = "Applications and Scripts for libyami."
-DESCRIPTION = "Applications and Scripts for libyami."
-
-HOMEPAGE = "https://github.com/intel/libyami-utils"
-BUGTRACKER = "https://github.com/intel/libyami-utils/issues/new"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-
-SRC_URI = "git://github.com/intel/libyami-utils.git \
- file://0001-Fix-build-with-clang.patch \
- "
-SRCREV = "7e801b5cc3066b176c2dccffda0af8d762184650"
-S = "${WORKDIR}/git"
-
-DEPENDS = "libva libyami"
-
-inherit autotools pkgconfig distro_features_check
-
-REQUIRED_DISTRO_FEATURES = "opengl"
-
-PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
-
-# --enable-x11 needs libva-x11
-# gles-tests fail to build without x11: see https://github.com/intel/libyami-utils/issues/91
-PACKAGECONFIG[x11] = "--enable-x11 --enable-egl,--disable-x11 --disable-egl, virtual/libx11"
diff --git a/bsp/meta-intel/recipes-multimedia/libyami/libyami/0001-bitWriter.cpp-Delete-unused-CACHEBYTES.patch b/bsp/meta-intel/recipes-multimedia/libyami/libyami/0001-bitWriter.cpp-Delete-unused-CACHEBYTES.patch
deleted file mode 100644
index a96c9b85..00000000
--- a/bsp/meta-intel/recipes-multimedia/libyami/libyami/0001-bitWriter.cpp-Delete-unused-CACHEBYTES.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 294874b610a5b8af9b736b3afc938010af58785e Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 11 Aug 2017 17:15:45 -0700
-Subject: [PATCH 1/9] bitWriter.cpp: Delete unused CACHEBYTES
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
-Upstream-Status: Pending
-
- codecparsers/bitWriter.cpp | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/codecparsers/bitWriter.cpp b/codecparsers/bitWriter.cpp
-index 9bcb14d..08469bf 100644
---- a/codecparsers/bitWriter.cpp
-+++ b/codecparsers/bitWriter.cpp
-@@ -24,7 +24,6 @@
-
- namespace YamiParser {
-
--const uint32_t CACHEBYTES = sizeof(unsigned long int);
- const uint32_t CACHEBITS = sizeof(unsigned long int) * 8;
-
- // clip to keep lowest n bits
---
-2.14.1
-
diff --git a/bsp/meta-intel/recipes-multimedia/libyami/libyami/0002-typecast-index-from-size_t-to-int.patch b/bsp/meta-intel/recipes-multimedia/libyami/libyami/0002-typecast-index-from-size_t-to-int.patch
deleted file mode 100644
index a216566c..00000000
--- a/bsp/meta-intel/recipes-multimedia/libyami/libyami/0002-typecast-index-from-size_t-to-int.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 88fa048e22ad00b04054b8a64df53bd440e01537 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 11 Aug 2017 17:29:02 -0700
-Subject: [PATCH 2/9] typecast index from size_t to int
-
-size_t is not consistent across architectures e.g. on arm its unsigned int
-
-Fixes
-error: comparison of unsigned expression < 0 is always false [-Werror,-Wtautological-compare]
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
-Upstream-Status: Pending
-
- codecparsers/jpegParser.cpp | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/codecparsers/jpegParser.cpp b/codecparsers/jpegParser.cpp
-index 2217028..6da5c36 100644
---- a/codecparsers/jpegParser.cpp
-+++ b/codecparsers/jpegParser.cpp
-@@ -639,7 +639,7 @@ bool Parser::parseDAC()
-
- length -= 2;
-
-- if (index < 0 || index >= (2 * NUM_ARITH_TBLS)) {
-+ if ((int)index < 0 || index >= (2 * NUM_ARITH_TBLS)) {
- ERROR("Invalid DAC Index");
- return false;
- }
-@@ -747,7 +747,7 @@ bool Parser::parseDHT()
- huffTables = &m_dcHuffTables;
- }
-
-- if (index < 0 || index >= NUM_HUFF_TBLS) {
-+ if ((int)index < 0 || index >= NUM_HUFF_TBLS) {
- ERROR("Bad Huff Table Index");
- return false;
- }
---
-2.14.1
-
diff --git a/bsp/meta-intel/recipes-multimedia/libyami/libyami/0003-Add-Wno-invalid-offsetof-to-compiler-commandline.patch b/bsp/meta-intel/recipes-multimedia/libyami/libyami/0003-Add-Wno-invalid-offsetof-to-compiler-commandline.patch
deleted file mode 100644
index 17289602..00000000
--- a/bsp/meta-intel/recipes-multimedia/libyami/libyami/0003-Add-Wno-invalid-offsetof-to-compiler-commandline.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 533d63287e9dd8f269b137c18fbe6c19206c8668 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 11 Aug 2017 17:49:43 -0700
-Subject: [PATCH 3/9] Add -Wno-invalid-offsetof to compiler commandline
-
-clang++ is fussy about offsetof on non-POD types
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
-Upstream-Status: Pending
-
- codecparsers/Makefile.am | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/codecparsers/Makefile.am b/codecparsers/Makefile.am
-index 720bf81..d9226b3 100644
---- a/codecparsers/Makefile.am
-+++ b/codecparsers/Makefile.am
-@@ -118,6 +118,7 @@ libyami_codecparser_cppflags = \
- -Dvp8dx_start_decode=libyami_vp8dx_start_decode \
- -Dvp8dx_bool_decoder_fill=libyami_vp8dx_bool_decoder_fill \
- -I$(top_srcdir)/interface \
-+ -Wno-invalid-offsetof \
- $(extra_includes) \
- $(NULL)
-
---
-2.14.1
-
diff --git a/bsp/meta-intel/recipes-multimedia/libyami/libyami/0004-Typecast-POWER32SUB2-to-uint8_t.patch b/bsp/meta-intel/recipes-multimedia/libyami/libyami/0004-Typecast-POWER32SUB2-to-uint8_t.patch
deleted file mode 100644
index 27eca39b..00000000
--- a/bsp/meta-intel/recipes-multimedia/libyami/libyami/0004-Typecast-POWER32SUB2-to-uint8_t.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From d9c831ee38da4551396fad5cd53c3dfc0e5e0cf8 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 11 Aug 2017 17:57:34 -0700
-Subject: [PATCH 4/9] Typecast POWER32SUB2 to uint8_t
-
-Fixes
-
-h265Parser.cpp:1064:5: error: comparison of constant 4294967294 with expression
-of type 'uint8_t' (aka 'unsigned char') is always false [-Werror,-Wtautological-constant-out-of-range-compare]
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
-Upstream-Status: Pending
-
- codecparsers/h265Parser.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/codecparsers/h265Parser.cpp b/codecparsers/h265Parser.cpp
-index 0dea3a6..c6cded2 100644
---- a/codecparsers/h265Parser.cpp
-+++ b/codecparsers/h265Parser.cpp
-@@ -125,7 +125,7 @@ namespace H265 {
- \
- CHECK_READ_UE(var->var##_max_num_reorder_pics[i], 0, var->var##_max_dec_pic_buffering_minus1[i]); \
- \
-- CHECK_READ_UE(var->var##_max_latency_increase_plus1[i], 0, POWER32SUB2); \
-+ CHECK_READ_UE(var->var##_max_latency_increase_plus1[i], 0, (uint8_t)POWER32SUB2); \
- } \
- }
-
---
-2.14.1
-
diff --git a/bsp/meta-intel/recipes-multimedia/libyami/libyami/0006-Avoid-namespace-conflicts-by-adding-explicit-using-n.patch b/bsp/meta-intel/recipes-multimedia/libyami/libyami/0006-Avoid-namespace-conflicts-by-adding-explicit-using-n.patch
deleted file mode 100644
index c9c74520..00000000
--- a/bsp/meta-intel/recipes-multimedia/libyami/libyami/0006-Avoid-namespace-conflicts-by-adding-explicit-using-n.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 27b61f5ab1b1643436f56517e4980734b4b9acca Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 11 Aug 2017 18:38:05 -0700
-Subject: [PATCH 6/9] Avoid namespace conflicts by adding explicit using
- <namespace>
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
-Upstream-Status: Pending
-
- decoder/vaapidecoder_h264.h | 1 +
- decoder/vaapidecoder_h265.h | 1 +
- 2 files changed, 2 insertions(+)
-
-diff --git a/decoder/vaapidecoder_h264.h b/decoder/vaapidecoder_h264.h
-index 57e2c27..ea5c2f2 100644
---- a/decoder/vaapidecoder_h264.h
-+++ b/decoder/vaapidecoder_h264.h
-@@ -30,6 +30,7 @@ namespace YamiMediaCodec {
-
- class VaapiDecPictureH264;
- class VaapiDecoderH264 : public VaapiDecoderBase {
-+using YamiMediaCodec::VaapiDecoderBase::createPicture;
- public:
- typedef SharedPtr<VaapiDecPictureH264> PicturePtr;
- typedef std::vector<PicturePtr> RefSet;
-diff --git a/decoder/vaapidecoder_h265.h b/decoder/vaapidecoder_h265.h
-index f7e2303..159e25f 100644
---- a/decoder/vaapidecoder_h265.h
-+++ b/decoder/vaapidecoder_h265.h
-@@ -38,6 +38,7 @@ namespace YamiMediaCodec {
-
- class VaapiDecPictureH265;
- class VaapiDecoderH265:public VaapiDecoderBase {
-+ using YamiMediaCodec::VaapiDecoderBase::createPicture;
- typedef YamiParser::H265::SPS SPS;
- typedef YamiParser::H265::SliceHeader SliceHeader;
- typedef YamiParser::H265::NalUnit NalUnit;
---
-2.14.1
-
diff --git a/bsp/meta-intel/recipes-multimedia/libyami/libyami/0007-Delete-unused-variables.patch b/bsp/meta-intel/recipes-multimedia/libyami/libyami/0007-Delete-unused-variables.patch
deleted file mode 100644
index b80774c9..00000000
--- a/bsp/meta-intel/recipes-multimedia/libyami/libyami/0007-Delete-unused-variables.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From b982997c96e11b9c0b3cd58a31af2d0a219713a3 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 11 Aug 2017 18:39:58 -0700
-Subject: [PATCH 7/9] Delete unused variables
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
-Upstream-Status: Pending
-
- decoder/vaapidecoder_vp8.cpp | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/decoder/vaapidecoder_vp8.cpp b/decoder/vaapidecoder_vp8.cpp
-index 5fc89ec..ff5b896 100644
---- a/decoder/vaapidecoder_vp8.cpp
-+++ b/decoder/vaapidecoder_vp8.cpp
-@@ -32,12 +32,12 @@ typedef VaapiDecoderVP8::PicturePtr PicturePtr;
-
- // the following parameter apply to Intra-Predicted Macroblocks,
- // $11.2 $11.4: key frame default probs
--static const uint8_t keyFrameYModeProbs[4] = { 145, 156, 163, 128 };
--static const uint8_t keyFrameUVModeProbs[3] = { 142, 114, 183 };
-+//static const uint8_t keyFrameYModeProbs[4] = { 145, 156, 163, 128 };
-+//static const uint8_t keyFrameUVModeProbs[3] = { 142, 114, 183 };
-
- // $16.1: non-key frame default probs
--static const uint8_t nonKeyFrameDefaultYModeProbs[4] = { 112, 86, 140, 37 };
--static const uint8_t nonKeyFrameDefaultUVModeProbs[3] = { 162, 101, 204 };
-+//static const uint8_t nonKeyFrameDefaultYModeProbs[4] = { 112, 86, 140, 37 };
-+//static const uint8_t nonKeyFrameDefaultUVModeProbs[3] = { 162, 101, 204 };
-
- static const uint32_t surfaceNumVP8 = 3;
-
---
-2.14.1
-
diff --git a/bsp/meta-intel/recipes-multimedia/libyami/libyami/0008-NalUnit-is-declared-in-different-namespace.patch b/bsp/meta-intel/recipes-multimedia/libyami/libyami/0008-NalUnit-is-declared-in-different-namespace.patch
deleted file mode 100644
index 18b98be8..00000000
--- a/bsp/meta-intel/recipes-multimedia/libyami/libyami/0008-NalUnit-is-declared-in-different-namespace.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From c54130511c91e457f1c5bb47729f5e3a0fc0cb91 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 11 Aug 2017 18:42:28 -0700
-Subject: [PATCH 8/9] NalUnit is declared in different namespace
-
-Fixes
-vaapidecoder_h265.h:32:5: error: struct 'NalUnit' was previously declared as a class [-Werror,-Wmismatched-tags] struct NalUnit;
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
-Upstream-Status: Pending
-
- decoder/vaapidecoder_h265.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/decoder/vaapidecoder_h265.h b/decoder/vaapidecoder_h265.h
-index 159e25f..674638f 100644
---- a/decoder/vaapidecoder_h265.h
-+++ b/decoder/vaapidecoder_h265.h
-@@ -29,7 +29,7 @@ namespace YamiParser {
- namespace H265 {
- struct SPS;
- struct SliceHeader;
-- struct NalUnit;
-+ class NalUnit;
- class Parser;
- };
- };
---
-2.14.1
-
diff --git a/bsp/meta-intel/recipes-multimedia/libyami/libyami/0009-Fix-clang-warnings.patch b/bsp/meta-intel/recipes-multimedia/libyami/libyami/0009-Fix-clang-warnings.patch
deleted file mode 100644
index 08ef455b..00000000
--- a/bsp/meta-intel/recipes-multimedia/libyami/libyami/0009-Fix-clang-warnings.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From a54dc7b6a777882f55a3f31bd97748a261db03d2 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 11 Aug 2017 18:53:06 -0700
-Subject: [PATCH 9/9] Fix clang warnings
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
-Upstream-Status: Pending
-
- encoder/vaapiencoder_h264.cpp | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/encoder/vaapiencoder_h264.cpp b/encoder/vaapiencoder_h264.cpp
-index 98bc2ed..94015cb 100644
---- a/encoder/vaapiencoder_h264.cpp
-+++ b/encoder/vaapiencoder_h264.cpp
-@@ -509,7 +509,7 @@ bit_writer_write_sps(BitWriter* bitwriter,
- }
- /* vcl_hrd_parameters_present_flag */
- bitwriter->writeBits(0, 1);
-- if (nal_hrd_parameters_present_flag || 0/*vcl_hrd_parameters_present_flag*/) {
-+ if (nal_hrd_parameters_present_flag || !!(0)/*vcl_hrd_parameters_present_flag*/) {
- /* low_delay_hrd_flag */
- bitwriter->writeBits(0, 1);
- }
-@@ -1889,7 +1889,7 @@ bool VaapiEncoderH264::addSliceHeaders (const PicturePtr& picture) const
- sliceParam->num_macroblocks = curSliceMbs;
- sliceParam->macroblock_info = VA_INVALID_ID;
- sliceParam->slice_type = h264_get_slice_type (picture->m_type);
-- assert (sliceParam->slice_type != -1);
-+ assert ((int)sliceParam->slice_type != -1);
- sliceParam->idr_pic_id = m_idrNum;
- sliceParam->pic_order_cnt_lsb = picture->m_poc % m_maxPicOrderCnt;
-
---
-2.14.1
-
diff --git a/bsp/meta-intel/recipes-multimedia/libyami/libyami_1.3.1.bb b/bsp/meta-intel/recipes-multimedia/libyami/libyami_1.3.1.bb
deleted file mode 100644
index 58895c81..00000000
--- a/bsp/meta-intel/recipes-multimedia/libyami/libyami_1.3.1.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-SUMMARY = "Yami is media infrastructure base on libva"
-DESCRIPTION = "Yet Another Media Infrastructure \
-light weight hardware codec library base on VA-API "
-
-HOMEPAGE = "https://github.com/intel/libyami"
-BUGTRACKER = "https://github.com/intel/libyami/issues/new"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE.md;md5=3b83ef96387f14655fc854ddc3c6bd57"
-
-SRC_URI = "git://github.com/intel/libyami.git;branch=apache \
- file://0001-bitWriter.cpp-Delete-unused-CACHEBYTES.patch \
- file://0002-typecast-index-from-size_t-to-int.patch \
- file://0003-Add-Wno-invalid-offsetof-to-compiler-commandline.patch \
- file://0004-Typecast-POWER32SUB2-to-uint8_t.patch \
- file://0006-Avoid-namespace-conflicts-by-adding-explicit-using-n.patch \
- file://0007-Delete-unused-variables.patch \
- file://0008-NalUnit-is-declared-in-different-namespace.patch \
- file://0009-Fix-clang-warnings.patch \
-"
-SRCREV = "fb48083de91f837ddbf599dd4b5ad1eb1239e1cf"
-S = "${WORKDIR}/git"
-
-PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "x11", "", d)}"
-PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender"
-
-DEPENDS = "libva"
-inherit autotools pkgconfig distro_features_check
-
-REQUIRED_DISTRO_FEATURES = "opengl"