summaryrefslogtreecommitdiffstats
path: root/bsp/meta-qcom/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-qcom/recipes-devtools')
-rw-r--r--bsp/meta-qcom/recipes-devtools/qdl/files/0001-Makefile-Use-pkg-config-for-libxml2-detection.patch35
-rw-r--r--bsp/meta-qcom/recipes-devtools/qdl/qdl_git.bb25
-rw-r--r--bsp/meta-qcom/recipes-devtools/skales/files/0002-mkbootimg-use-python3.patch23
-rw-r--r--bsp/meta-qcom/recipes-devtools/skales/skales_git.bb7
4 files changed, 86 insertions, 4 deletions
diff --git a/bsp/meta-qcom/recipes-devtools/qdl/files/0001-Makefile-Use-pkg-config-for-libxml2-detection.patch b/bsp/meta-qcom/recipes-devtools/qdl/files/0001-Makefile-Use-pkg-config-for-libxml2-detection.patch
new file mode 100644
index 00000000..2aca1811
--- /dev/null
+++ b/bsp/meta-qcom/recipes-devtools/qdl/files/0001-Makefile-Use-pkg-config-for-libxml2-detection.patch
@@ -0,0 +1,35 @@
+From d0ecd95e8935a9fe3e94921d10bfb153f5e0ce52 Mon Sep 17 00:00:00 2001
+From: Nicolas Dechesne <nicolas.dechesne@linaro.org>
+Date: Wed, 28 Aug 2019 17:54:50 +0200
+Subject: [PATCH] Makefile: Use pkg-config for libxml2 detection.
+
+xml2-config does not work. Use pkgconfig to set CPPFLAGS and LIBS.
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org>
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- a/Makefile
++++ b/Makefile
+@@ -1,14 +1,14 @@
+ OUT := qdl
+
+-CFLAGS := -O2 -Wall -g `xml2-config --cflags`
+-LDFLAGS := `xml2-config --libs` -ludev
+-prefix := /usr/local
++CFLAGS += -O2 -Wall -g `pkg-config --cflags libxml-2.0`
++LDFLAGS += `pkg-config --libs libxml-2.0` -ludev
++prefix ?= /usr/local
+
+ SRCS := firehose.c qdl.c sahara.c util.c patch.c program.c ufs.c
+ OBJS := $(SRCS:.c=.o)
+
+ $(OUT): $(OBJS)
+- $(CC) -o $@ $^ $(LDFLAGS)
++ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
+
+ clean:
+ rm -f $(OUT) $(OBJS)
diff --git a/bsp/meta-qcom/recipes-devtools/qdl/qdl_git.bb b/bsp/meta-qcom/recipes-devtools/qdl/qdl_git.bb
new file mode 100644
index 00000000..aba3cec1
--- /dev/null
+++ b/bsp/meta-qcom/recipes-devtools/qdl/qdl_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "QDL flasing tool"
+HOMEPAGE = "https://github.com/andersson/qdl.git"
+SECTION = "devel"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://qdl.c;beginline=1;endline=31;md5=1c7d712d897368d3d3c161e5493efc6a"
+
+DEPENDS = "libxml2"
+DEPENDS_append_class-target = " udev "
+
+inherit pkgconfig
+
+SRCREV = "760b3dffb03d2b7dfb82c6eac652a092f51c572d"
+SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https \
+ file://0001-Makefile-Use-pkg-config-for-libxml2-detection.patch"
+
+PV = "0.0+${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+do_install () {
+ oe_runmake install DESTDIR=${D} prefix=${prefix}
+}
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/bsp/meta-qcom/recipes-devtools/skales/files/0002-mkbootimg-use-python3.patch b/bsp/meta-qcom/recipes-devtools/skales/files/0002-mkbootimg-use-python3.patch
new file mode 100644
index 00000000..2abac7df
--- /dev/null
+++ b/bsp/meta-qcom/recipes-devtools/skales/files/0002-mkbootimg-use-python3.patch
@@ -0,0 +1,23 @@
+From aadbb5dd64abc2efbb5548d1d0b168d476875157 Mon Sep 17 00:00:00 2001
+From: Peter Griffin <peter.griffin@linaro.org>
+Date: Wed, 29 Jan 2020 22:55:41 +0100
+Subject: [PATCH 2/2] mkbootimg: use python3
+
+Signed-off-by: Peter Griffin <peter.griffin@linaro.org>
+---
+ mkbootimg | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/mkbootimg b/mkbootimg
+index c0e7dcb..adfc54b 100755
+--- a/mkbootimg
++++ b/mkbootimg
+@@ -1,4 +1,4 @@
+-#! /usr/bin/env python
++#! /usr/bin/env python3
+ #
+ # Copyright (c) 2013, The Linux Foundation. All rights reserved.
+ #
+--
+2.7.4
+
diff --git a/bsp/meta-qcom/recipes-devtools/skales/skales_git.bb b/bsp/meta-qcom/recipes-devtools/skales/skales_git.bb
index 71928e86..782d20ca 100644
--- a/bsp/meta-qcom/recipes-devtools/skales/skales_git.bb
+++ b/bsp/meta-qcom/recipes-devtools/skales/skales_git.bb
@@ -6,19 +6,18 @@ SECTION = "devel"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://mkbootimg;beginline=3;endline=29;md5=114b84083e657f3886bfa2c1e5de7deb"
-DEPENDS = "python dtc"
-
SRCREV = "6eac9e943de53c4aaaede3697e9226a47686fe25"
PV = "1.5.0+git${SRCPV}"
-SRC_URI = "git://codeaurora.org/quic/kernel/skales"
+SRC_URI = "git://source.codeaurora.org/quic/kernel/skales;protocol=http \
+ file://0002-mkbootimg-use-python3.patch \
+ "
S = "${WORKDIR}/git"
do_install () {
install -d ${D}${bindir}/skales
install -m 0755 ${S}/mkbootimg ${D}${bindir}/skales
- install -m 0755 ${S}/dtbTool ${D}${bindir}/skales
}
BBCLASSEXTEND = "native"