summaryrefslogtreecommitdiffstats
path: root/bsp/meta-qcom/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-qcom/recipes-support')
-rw-r--r--bsp/meta-qcom/recipes-support/fastrpc/fastrpc_git.bb15
-rw-r--r--bsp/meta-qcom/recipes-support/pd-mapper/pd-mapper/0001-pd-mapper-Include-limits.h-for-PATH_MAX.patch29
-rw-r--r--bsp/meta-qcom/recipes-support/pd-mapper/pd-mapper_git.bb28
-rw-r--r--bsp/meta-qcom/recipes-support/qrtr/files/qrtr.service11
-rw-r--r--bsp/meta-qcom/recipes-support/qrtr/qrtr_git.bb14
-rw-r--r--bsp/meta-qcom/recipes-support/rmtfs/files/rmtfs.service15
-rw-r--r--bsp/meta-qcom/recipes-support/rmtfs/rmtfs_git.bb11
-rw-r--r--bsp/meta-qcom/recipes-support/tqftpserv/tqftpserv/0001-include-limits.h-for-PATH_MAX.patch25
-rw-r--r--bsp/meta-qcom/recipes-support/tqftpserv/tqftpserv_git.bb28
9 files changed, 131 insertions, 45 deletions
diff --git a/bsp/meta-qcom/recipes-support/fastrpc/fastrpc_git.bb b/bsp/meta-qcom/recipes-support/fastrpc/fastrpc_git.bb
new file mode 100644
index 00000000..3aa67a79
--- /dev/null
+++ b/bsp/meta-qcom/recipes-support/fastrpc/fastrpc_git.bb
@@ -0,0 +1,15 @@
+HOMEPAGE = "https://git.linaro.org/landing-teams/working/qualcomm/fastrpc.git"
+SUMMARY = "Qualcomm FastRPC applications and library"
+SECTION = "devel"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://src/fastrpc_apps_user.c;beginline=1;endline=29;md5=f94f3a7beba14ae2f59f817e9634f891"
+
+SRCREV = "388d868b3146fa7ccbeb6aa8c71485ebbbf5e1b9"
+SRC_URI = "git://git.linaro.org/landing-teams/working/qualcomm/fastrpc.git;branch=automake;protocol=https"
+
+PV = "0.0+${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
diff --git a/bsp/meta-qcom/recipes-support/pd-mapper/pd-mapper/0001-pd-mapper-Include-limits.h-for-PATH_MAX.patch b/bsp/meta-qcom/recipes-support/pd-mapper/pd-mapper/0001-pd-mapper-Include-limits.h-for-PATH_MAX.patch
new file mode 100644
index 00000000..de3fea87
--- /dev/null
+++ b/bsp/meta-qcom/recipes-support/pd-mapper/pd-mapper/0001-pd-mapper-Include-limits.h-for-PATH_MAX.patch
@@ -0,0 +1,29 @@
+From 874dadf1168f8a1b2b1bd4ab5bb4a20097147ab0 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 28 May 2020 08:01:37 -0700
+Subject: [PATCH] pd-mapper: Include limits.h for PATH_MAX
+
+Fixes
+pd-mapper.c:199:22: error: 'PATH_MAX' undeclared (first use in this function); did you mean 'AF_MAX'?
+
+Upstream-Status: Submitted [https://github.com/andersson/pd-mapper/pull/4]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ pd-mapper.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/pd-mapper.c b/pd-mapper.c
+index 45177ae..f5d45ee 100644
+--- a/pd-mapper.c
++++ b/pd-mapper.c
+@@ -36,6 +36,7 @@
+ #include <fcntl.h>
+ #include <libgen.h>
+ #include <libqrtr.h>
++#include <limits.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+--
+2.26.2
+
diff --git a/bsp/meta-qcom/recipes-support/pd-mapper/pd-mapper_git.bb b/bsp/meta-qcom/recipes-support/pd-mapper/pd-mapper_git.bb
new file mode 100644
index 00000000..9e5ca116
--- /dev/null
+++ b/bsp/meta-qcom/recipes-support/pd-mapper/pd-mapper_git.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Qualcomm pd-mapper application"
+HOMEPAGE = "https://github.com/andersson/pd-mapper.git"
+SECTION = "devel"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c5d4ab97bca4e843c5afdbf78aa5fdee"
+
+DEPENDS = "qrtr"
+
+inherit systemd
+
+SRCREV = "ab5074fdd5e4130578aa4c99b00d44527a79636f"
+SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https \
+ file://0001-pd-mapper-Include-limits.h-for-PATH_MAX.patch \
+"
+
+PV = "0.0+${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "prefix=${prefix} bindir=${bindir} libdir=${libdir} includedir=${includedir} LDFLAGS='${LDFLAGS} -Wl,-lqrtr'"
+
+do_install () {
+ oe_runmake install DESTDIR=${D} prefix=${prefix} servicedir=${systemd_unitdir}/system
+}
+
+SYSTEMD_SERVICE_${PN} = "pd-mapper.service"
+RDEPENDS_${PN} += "qrtr"
diff --git a/bsp/meta-qcom/recipes-support/qrtr/files/qrtr.service b/bsp/meta-qcom/recipes-support/qrtr/files/qrtr.service
deleted file mode 100644
index e2f1952a..00000000
--- a/bsp/meta-qcom/recipes-support/qrtr/files/qrtr.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=QRTR service
-After=systemd-remount-fs.service
-
-[Service]
-ExecStartPre=/usr/bin/qrtr-cfg 1
-ExecStart=/usr/bin/qrtr-ns
-RemainAfterExit=yes
-
-[Install]
-WantedBy=multi-user.target
diff --git a/bsp/meta-qcom/recipes-support/qrtr/qrtr_git.bb b/bsp/meta-qcom/recipes-support/qrtr/qrtr_git.bb
index e5e74636..51c342b0 100644
--- a/bsp/meta-qcom/recipes-support/qrtr/qrtr_git.bb
+++ b/bsp/meta-qcom/recipes-support/qrtr/qrtr_git.bb
@@ -7,9 +7,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=15329706fbfcb5fc5edcc1bc7c139da5"
inherit systemd
-SRCREV = "a1694a1c938fdcd047553841370ebe2cd7384299"
+SRCREV = "7bd5cf302437755b0d741c9dc1805395a9654597"
SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https"
-SRC_URI += "file://qrtr.service"
PV = "0.0+${SRCPV}"
@@ -18,14 +17,7 @@ S = "${WORKDIR}/git"
EXTRA_OEMAKE = "prefix=${prefix} bindir=${bindir} libdir=${libdir} includedir=${includedir} LDFLAGS='${LDFLAGS}'"
do_install () {
- oe_runmake install DESTDIR=${D}
-
- sed -i -e s:/usr/bin:${bindir}:g ${WORKDIR}/qrtr.service
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/qrtr.service ${D}${systemd_unitdir}/system
+ oe_runmake install DESTDIR=${D} prefix=${prefix} servicedir=${systemd_unitdir}/system
}
-SYSTEMD_SERVICE_${PN} = "qrtr.service"
-
-PACKAGES =+ "qrtr-apps"
-FILES_qrtr-apps = "${bindir}/*"
+SYSTEMD_SERVICE_${PN} = "qrtr-ns.service"
diff --git a/bsp/meta-qcom/recipes-support/rmtfs/files/rmtfs.service b/bsp/meta-qcom/recipes-support/rmtfs/files/rmtfs.service
deleted file mode 100644
index 2002fd6d..00000000
--- a/bsp/meta-qcom/recipes-support/rmtfs/files/rmtfs.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=RMTFS setup
-After=systemd-remount-fs.service qrtr.service
-Requires=qrtr.service
-
-[Service]
-ExecStartPre=/bin/sh -c "[ ! -f /boot/modem_fs1 ] && dd if=/dev/zero of=/boot/modem_fs1 bs=1M count=2 || :"
-ExecStartPre=/bin/sh -c "[ ! -f /boot/modem_fs2 ] && dd if=/dev/zero of=/boot/modem_fs2 bs=1M count=2 || :"
-ExecStartPre=/bin/sh -c "[ ! -f /boot/modem_fsc ] && dd if=/dev/zero of=/boot/modem_fsc bs=1M count=2 || :"
-ExecStartPre=/bin/sh -c "[ ! -f /boot/modem_fsg ] && dd if=/dev/zero of=/boot/modem_fsg bs=1M count=2 || :"
-ExecStart=/usr/bin/rmtfs -v
-ExecStartPost=/bin/sh -c "[ -d /sys/bus/platform/devices/*.hexagon ] && modprobe qcom_q6v5_pil"
-
-[Install]
-WantedBy=multi-user.target
diff --git a/bsp/meta-qcom/recipes-support/rmtfs/rmtfs_git.bb b/bsp/meta-qcom/recipes-support/rmtfs/rmtfs_git.bb
index 2e79bc04..86553467 100644
--- a/bsp/meta-qcom/recipes-support/rmtfs/rmtfs_git.bb
+++ b/bsp/meta-qcom/recipes-support/rmtfs/rmtfs_git.bb
@@ -7,23 +7,18 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ca25dbf5ebfc1a058bfc657c895aac2f"
inherit systemd
-SRCREV = "0d3c49ec5aa27517afec9f18a3afc4b0800e6cbb"
+SRCREV = "dfb8f3ed1c8fbde621cd08aaf9e7724a4c55cbd1"
SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https"
-SRC_URI += "file://rmtfs.service"
DEPENDS = "qmic-native qrtr udev"
PV = "0.0+${SRCPV}"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = "'LDFLAGS=${TARGET_LDFLAGS} -L${STAGING_LIBDIR} -lqrtr -ludev'"
+EXTRA_OEMAKE = "'LDFLAGS=${TARGET_LDFLAGS} -L${STAGING_LIBDIR} -lqrtr -ludev -lpthread'"
do_install () {
- oe_runmake install DESTDIR=${D} prefix=${prefix}
-
- sed -i -e s:/usr/bin:${bindir}:g ${WORKDIR}/rmtfs.service
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/rmtfs.service ${D}${systemd_unitdir}/system
+ oe_runmake install DESTDIR=${D} prefix=${prefix} servicedir=${systemd_unitdir}/system
}
SYSTEMD_SERVICE_${PN} = "rmtfs.service"
diff --git a/bsp/meta-qcom/recipes-support/tqftpserv/tqftpserv/0001-include-limits.h-for-PATH_MAX.patch b/bsp/meta-qcom/recipes-support/tqftpserv/tqftpserv/0001-include-limits.h-for-PATH_MAX.patch
new file mode 100644
index 00000000..5a58c586
--- /dev/null
+++ b/bsp/meta-qcom/recipes-support/tqftpserv/tqftpserv/0001-include-limits.h-for-PATH_MAX.patch
@@ -0,0 +1,25 @@
+From c21250e08cc5e6815340244693437e6372b5eca4 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 29 Nov 2019 17:52:33 -0800
+Subject: [PATCH] include limits.h for PATH_MAX
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ translate.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/translate.c b/translate.c
+index 34c419e..e95dee5 100644
+--- a/translate.c
++++ b/translate.c
+@@ -35,6 +35,7 @@
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <libgen.h>
++#include <limits.h>
+ #include <stdio.h>
+ #include <string.h>
+ #include <unistd.h>
+--
+2.24.0
+
diff --git a/bsp/meta-qcom/recipes-support/tqftpserv/tqftpserv_git.bb b/bsp/meta-qcom/recipes-support/tqftpserv/tqftpserv_git.bb
new file mode 100644
index 00000000..8973434b
--- /dev/null
+++ b/bsp/meta-qcom/recipes-support/tqftpserv/tqftpserv_git.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Qualcomm tqftpserv application"
+HOMEPAGE = "https://github.com/andersson/tqftpserv.git"
+SECTION = "devel"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=424e013ed97b36284f3b9ce27bb16a56"
+
+DEPENDS = "qrtr"
+
+inherit systemd
+
+SRCREV = "fe53d2a810abe0e1ee7cc0bb20fd520dc6605ecb"
+SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https \
+ file://0001-include-limits.h-for-PATH_MAX.patch \
+"
+
+PV = "0.0+${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "prefix=${prefix} bindir=${bindir} libdir=${libdir} includedir=${includedir} LDFLAGS='${LDFLAGS} -Wl,-lqrtr'"
+
+do_install () {
+ oe_runmake install DESTDIR=${D} prefix=${prefix} servicedir=${systemd_unitdir}/system
+}
+
+SYSTEMD_SERVICE_${PN} = "tqftpserv.service"
+RDEPENDS_${PN} += "qrtr"