summaryrefslogtreecommitdiffstats
path: root/bsp/meta-raspberrypi/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-raspberrypi/recipes-devtools/python')
-rw-r--r--bsp/meta-raspberrypi/recipes-devtools/python/python3-rtimu/0001-include-asm-ioctl.h-for-ioctl-define.patch (renamed from bsp/meta-raspberrypi/recipes-devtools/python/python-rtimu/0001-include-asm-ioctl.h-for-ioctl-define.patch)0
-rw-r--r--bsp/meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb (renamed from bsp/meta-raspberrypi/recipes-devtools/python/python-rtimu_git.bb)2
-rw-r--r--bsp/meta-raspberrypi/recipes-devtools/python/python3-sense-hat_2.2.0.bb (renamed from bsp/meta-raspberrypi/recipes-devtools/python/python-sense-hat_2.2.0.bb)8
-rw-r--r--bsp/meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-Remove-nested-functions.patch33
-rw-r--r--bsp/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb (renamed from bsp/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.6.3.bb)8
-rw-r--r--bsp/meta-raspberrypi/recipes-devtools/python/rpio_0.10.0.bb6
6 files changed, 14 insertions, 43 deletions
diff --git a/bsp/meta-raspberrypi/recipes-devtools/python/python-rtimu/0001-include-asm-ioctl.h-for-ioctl-define.patch b/bsp/meta-raspberrypi/recipes-devtools/python/python3-rtimu/0001-include-asm-ioctl.h-for-ioctl-define.patch
index 4a93a1ce..4a93a1ce 100644
--- a/bsp/meta-raspberrypi/recipes-devtools/python/python-rtimu/0001-include-asm-ioctl.h-for-ioctl-define.patch
+++ b/bsp/meta-raspberrypi/recipes-devtools/python/python3-rtimu/0001-include-asm-ioctl.h-for-ioctl-define.patch
diff --git a/bsp/meta-raspberrypi/recipes-devtools/python/python-rtimu_git.bb b/bsp/meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb
index 63c92b38..c0cb3110 100644
--- a/bsp/meta-raspberrypi/recipes-devtools/python/python-rtimu_git.bb
+++ b/bsp/meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb
@@ -12,4 +12,4 @@ SRCREV = "b949681af69b45f0f7f4bb53b6770037b5b02178"
S = "${WORKDIR}/git/Linux/python/"
-inherit setuptools
+inherit setuptools3
diff --git a/bsp/meta-raspberrypi/recipes-devtools/python/python-sense-hat_2.2.0.bb b/bsp/meta-raspberrypi/recipes-devtools/python/python3-sense-hat_2.2.0.bb
index f7c4e349..5ea00142 100644
--- a/bsp/meta-raspberrypi/recipes-devtools/python/python-sense-hat_2.2.0.bb
+++ b/bsp/meta-raspberrypi/recipes-devtools/python/python3-sense-hat_2.2.0.bb
@@ -4,7 +4,7 @@ SECTION = "devel/python"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=d80fe312e1ff5fbd97369b093bf21cda"
-inherit setuptools pypi
+inherit setuptools3 pypi
PYPI_PACKAGE = "sense-hat"
@@ -18,7 +18,7 @@ DEPENDS += " \
"
RDEPENDS_${PN} += " \
- python-numpy \
- python-rtimu \
- python-imaging \
+ ${PYTHON_PN}-numpy \
+ ${PYTHON_PN}-rtimu \
+ ${PYTHON_PN}-imaging \
"
diff --git a/bsp/meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-Remove-nested-functions.patch b/bsp/meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-Remove-nested-functions.patch
index bd971793..5c94bc24 100644
--- a/bsp/meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-Remove-nested-functions.patch
+++ b/bsp/meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-Remove-nested-functions.patch
@@ -30,6 +30,8 @@ silence this warning
uint32_t peri_base;
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+[Pierre-Jean: update for version 0.7.0]
+Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io>
---
Upstream-Status: Submitted
@@ -37,37 +39,6 @@ Upstream-Status: Submitted
source/py_gpio.c | 135 ++++++++++++++++++++++++++++---------------------------
2 files changed, 71 insertions(+), 70 deletions(-)
-diff --git a/source/c_gpio.c b/source/c_gpio.c
-index c96a2b0..b69880f 100644
---- a/source/c_gpio.c
-+++ b/source/c_gpio.c
-@@ -61,7 +61,7 @@ int setup(void)
- {
- int mem_fd;
- uint8_t *gpio_mem;
-- uint32_t peri_base;
-+ uint32_t peri_base = 0;
- uint32_t gpio_base;
- unsigned char buf[4];
- FILE *fp;
-@@ -73,7 +73,7 @@ int setup(void)
- if ((mem_fd = open("/dev/gpiomem", O_RDWR|O_SYNC)) > 0)
- {
- gpio_map = (uint32_t *)mmap(NULL, BLOCK_SIZE, PROT_READ|PROT_WRITE, MAP_SHARED, mem_fd, 0);
-- if ((uint32_t)gpio_map < 0) {
-+ if (gpio_map == MAP_FAILED) {
- return SETUP_MMAP_FAIL;
- } else {
- return SETUP_OK;
-@@ -127,7 +127,7 @@ int setup(void)
-
- gpio_map = (uint32_t *)mmap( (void *)gpio_mem, BLOCK_SIZE, PROT_READ|PROT_WRITE, MAP_SHARED|MAP_FIXED, mem_fd, gpio_base);
-
-- if ((uint32_t)gpio_map < 0)
-+ if (gpio_map == MAP_FAILED)
- return SETUP_MMAP_FAIL;
-
- return SETUP_OK;
diff --git a/source/py_gpio.c b/source/py_gpio.c
index d54cc7f..007bad5 100644
--- a/source/py_gpio.c
diff --git a/bsp/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.6.3.bb b/bsp/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb
index d0ff00af..fcce88f8 100644
--- a/bsp/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.6.3.bb
+++ b/bsp/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb
@@ -1,14 +1,14 @@
DESCRIPTION = "A module to control Raspberry Pi GPIO channels"
-HOMEPAGE = "http://code.google.com/p/raspberry-gpio-python/"
+HOMEPAGE = "https://sourceforge.net/projects/raspberry-gpio-python/"
SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=9b95630a648966b142f1a0dcea001cb7"
PYPI_PACKAGE = "RPi.GPIO"
-inherit pypi distutils
+inherit pypi distutils3
SRC_URI += "file://0001-Remove-nested-functions.patch"
-SRC_URI[md5sum] = "e4abe1cfb5eacebe53078032256eb837"
-SRC_URI[sha256sum] = "a5fc0eb5e401963b6c0a03650da6b42c4005f02d962b81241d96c98d0a578516"
+SRC_URI[md5sum] = "777617f9dea9a1680f9af43db0cf150e"
+SRC_URI[sha256sum] = "7424bc6c205466764f30f666c18187a0824077daf20b295c42f08aea2cb87d3f"
COMPATIBLE_MACHINE = "^rpi$"
diff --git a/bsp/meta-raspberrypi/recipes-devtools/python/rpio_0.10.0.bb b/bsp/meta-raspberrypi/recipes-devtools/python/rpio_0.10.0.bb
index c3254bcf..d5653cb0 100644
--- a/bsp/meta-raspberrypi/recipes-devtools/python/rpio_0.10.0.bb
+++ b/bsp/meta-raspberrypi/recipes-devtools/python/rpio_0.10.0.bb
@@ -10,13 +10,13 @@ inherit pypi
SRC_URI += "file://0001-include-sys-types.h-explicitly-for-getting-caddr_t-d.patch"
-inherit setuptools
+inherit setuptools3
COMPATIBLE_MACHINE = "^rpi$"
RDEPENDS_${PN} = "\
- python-logging \
- python-threading \
+ python3-logging \
+ python3-threading \
"
SRC_URI[md5sum] = "cefc45422833dcafcd59b78dffc540f4"