summaryrefslogtreecommitdiffstats
path: root/bsp/meta-renesas/meta-rcar-gen3/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-renesas/meta-rcar-gen3/recipes-core')
-rw-r--r--bsp/meta-renesas/meta-rcar-gen3/recipes-core/base-files/base-files/fstab11
-rw-r--r--bsp/meta-renesas/meta-rcar-gen3/recipes-core/base-files/base-files_%.bbappend11
-rw-r--r--bsp/meta-renesas/meta-rcar-gen3/recipes-core/images/core-image-minimal.bbappend1
-rw-r--r--bsp/meta-renesas/meta-rcar-gen3/recipes-core/ncurses/ncurses_%.bbappend2
-rw-r--r--bsp/meta-renesas/meta-rcar-gen3/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend6
-rw-r--r--bsp/meta-renesas/meta-rcar-gen3/recipes-core/systemd/systemd/add-non-owned-item-for-safe-transitioning.patch14
-rw-r--r--bsp/meta-renesas/meta-rcar-gen3/recipes-core/systemd/systemd_%.bbappend3
7 files changed, 48 insertions, 0 deletions
diff --git a/bsp/meta-renesas/meta-rcar-gen3/recipes-core/base-files/base-files/fstab b/bsp/meta-renesas/meta-rcar-gen3/recipes-core/base-files/base-files/fstab
new file mode 100644
index 00000000..30898a42
--- /dev/null
+++ b/bsp/meta-renesas/meta-rcar-gen3/recipes-core/base-files/base-files/fstab
@@ -0,0 +1,11 @@
+# stock fstab - you probably want to override this with a machine specific one
+
+/dev/root / auto defaults 1 1
+proc /proc proc defaults 0 0
+devpts /dev/pts devpts mode=0620,gid=5 0 0
+tmpfs /run tmpfs mode=0755,nodev,nosuid,strictatime 0 0
+tmpfs /var/volatile tmpfs uid=65534,gid=65534 0 0
+
+# uncomment this if your device has a SD/MMC/Transflash slot
+#/dev/mmcblk0p1 /media/card auto defaults,sync,noauto 0 0
+
diff --git a/bsp/meta-renesas/meta-rcar-gen3/recipes-core/base-files/base-files_%.bbappend b/bsp/meta-renesas/meta-rcar-gen3/recipes-core/base-files/base-files_%.bbappend
new file mode 100644
index 00000000..0dca3d62
--- /dev/null
+++ b/bsp/meta-renesas/meta-rcar-gen3/recipes-core/base-files/base-files_%.bbappend
@@ -0,0 +1,11 @@
+require include/rcar-gen3-path-common.inc
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
+
+SRC_URI_append_rcar-gen3 = " \
+ file://fstab \
+"
+
+do_install_append_rcar-gen3 () {
+ echo "export LD_LIBRARY_PATH=\"\${LD_LIBRARY_PATH}:${RENESAS_DATADIR}/lib\"" >> ${D}${sysconfdir}/profile
+}
diff --git a/bsp/meta-renesas/meta-rcar-gen3/recipes-core/images/core-image-minimal.bbappend b/bsp/meta-renesas/meta-rcar-gen3/recipes-core/images/core-image-minimal.bbappend
new file mode 100644
index 00000000..70688000
--- /dev/null
+++ b/bsp/meta-renesas/meta-rcar-gen3/recipes-core/images/core-image-minimal.bbappend
@@ -0,0 +1 @@
+require ${@"recipes-graphics/images/core-image-renesas-base.inc" if "rcar-gen3" in d.getVar("OVERRIDES") else ""}
diff --git a/bsp/meta-renesas/meta-rcar-gen3/recipes-core/ncurses/ncurses_%.bbappend b/bsp/meta-renesas/meta-rcar-gen3/recipes-core/ncurses/ncurses_%.bbappend
new file mode 100644
index 00000000..7efa4695
--- /dev/null
+++ b/bsp/meta-renesas/meta-rcar-gen3/recipes-core/ncurses/ncurses_%.bbappend
@@ -0,0 +1,2 @@
+# nativesdk don't generally look in base_libdir
+base_libdir_class-nativesdk = "${libdir}"
diff --git a/bsp/meta-renesas/meta-rcar-gen3/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend b/bsp/meta-renesas/meta-rcar-gen3/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
new file mode 100644
index 00000000..84eca35f
--- /dev/null
+++ b/bsp/meta-renesas/meta-rcar-gen3/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
@@ -0,0 +1,6 @@
+# In YP2.1.2, nativesdk-wayland is lacking.
+RDEPENDS_${PN}_append = " \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'nativesdk-wayland nativesdk-wayland-dev', '', d)} \
+ nativesdk-perl nativesdk-perl-dev \
+ nativesdk-perl-modules \
+"
diff --git a/bsp/meta-renesas/meta-rcar-gen3/recipes-core/systemd/systemd/add-non-owned-item-for-safe-transitioning.patch b/bsp/meta-renesas/meta-rcar-gen3/recipes-core/systemd/systemd/add-non-owned-item-for-safe-transitioning.patch
new file mode 100644
index 00000000..631db30e
--- /dev/null
+++ b/bsp/meta-renesas/meta-rcar-gen3/recipes-core/systemd/systemd/add-non-owned-item-for-safe-transitioning.patch
@@ -0,0 +1,14 @@
+diff --git a/src/basic/fs-util.c b/src/basic/fs-util.c
+index b2ac648..553a77a 100644
+--- a/src/basic/fs-util.c
++++ b/src/basic/fs-util.c
+@@ -668,6 +668,9 @@ static bool unsafe_transition(const struct stat *a, const struct stat *b) {
+ if (a->st_uid == 0) /* Transitioning from privileged to unprivileged is always fine */
+ return false;
+
++ if (b->st_uid == 65534) /* Transitioning to a non-owned is OK too */
++ return false;
++
+ return a->st_uid != b->st_uid; /* Otherwise we need to stay within the same UID */
+ }
+
diff --git a/bsp/meta-renesas/meta-rcar-gen3/recipes-core/systemd/systemd_%.bbappend b/bsp/meta-renesas/meta-rcar-gen3/recipes-core/systemd/systemd_%.bbappend
new file mode 100644
index 00000000..b2d76b79
--- /dev/null
+++ b/bsp/meta-renesas/meta-rcar-gen3/recipes-core/systemd/systemd_%.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI_append_rcar-gen3 = " file://add-non-owned-item-for-safe-transitioning.patch"