summaryrefslogtreecommitdiffstats
path: root/bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images')
-rw-r--r--bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-renesas-base.inc68
-rw-r--r--bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-renesas-mmp-base.inc102
-rw-r--r--bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-weston-sdk.bb15
-rw-r--r--bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-weston.bbappend2
-rw-r--r--bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-weston.inc16
5 files changed, 203 insertions, 0 deletions
diff --git a/bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-renesas-base.inc b/bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-renesas-base.inc
new file mode 100644
index 00000000..b64abad9
--- /dev/null
+++ b/bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-renesas-base.inc
@@ -0,0 +1,68 @@
+require include/iccom-control.inc
+
+COMPATIBLE_MACHINE = "(salvator-x|ulcb|ebisu)"
+
+# Basic packages
+IMAGE_INSTALL_append = " \
+ bash \
+ v4l-utils \
+ i2c-tools \
+ coreutils \
+"
+
+# Support secure environment
+IMAGE_INSTALL_append = " \
+ optee-client \
+"
+
+# Add overrides for selection 32 bit or 64 bit target
+OVERRIDES .= ":${TARGET_SYS}"
+
+# Qos user packages only supports 64bit.
+QOS_USER_PKGS = ""
+QOS_USER_PKGS_aarch64-poky-linux = " \
+ qosif-user-module \
+ qosif-tp-user-module \
+"
+
+# Installation for QoS packages
+IMAGE_INSTALL_append = " \
+ kernel-module-qos \
+ ${QOS_USER_PKGS} \
+"
+
+# Renesas Basic packages for 32bit
+BASIC_32BIT_PKGS = " \
+ lib32-coreutils \
+ lib32-libstdc++ \
+ lib32-optee-client \
+"
+
+# Installation for 32bit packages
+IMAGE_INSTALL_append = " \
+ ${@oe.utils.conditional("USE_32BIT_PKGS", "1", "${BASIC_32BIT_PKGS}", "", d)} \
+"
+
+# Kernel modules of ICCOM
+ICCOM_KERNEL_PKGS = " \
+ kernel-module-iccom-mfis \
+ kernel-module-iccom-hwspinlock-sample \
+"
+
+# User modules of ICCOM only supports 64bit
+ICCOM_USER_PKGS = ""
+ICCOM_USER_PKGS_aarch64-poky-linux = " \
+ iccom-user-module \
+ iccom-tp-user-module \
+"
+
+# ICCOM Packages
+ICCOM_PKGS = " \
+ ${ICCOM_KERNEL_PKGS} \
+ ${ICCOM_USER_PKGS} \
+"
+
+# Installation for ICCOM Packages
+IMAGE_INSTALL_append = " \
+ ${@oe.utils.conditional("USE_ICCOM", "1", " ${ICCOM_PKGS}", "", d)} \
+"
diff --git a/bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-renesas-mmp-base.inc b/bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-renesas-mmp-base.inc
new file mode 100644
index 00000000..88062204
--- /dev/null
+++ b/bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-renesas-mmp-base.inc
@@ -0,0 +1,102 @@
+require include/multimedia-control.inc
+require include/cms-control.inc
+require include/adsp-control.inc
+require include/dtv-dvd-control.inc
+require include/avb-control.inc
+require include/omx-control.inc
+
+# Common Multi Media Packages (MMP)
+MULTIMEDIA_PKGS = " \
+ packagegroup-multimedia-kernel-modules \
+ packagegroup-multimedia-libs \
+"
+
+# MMP test Packages
+MULTIMEDIA_TP_PKGS = " \
+ vspmif-tp-user-module \
+"
+
+# OMX MMP Packages
+OMX_MULTIMEDIA_PKGS = " \
+ omx-user-module \
+"
+
+# CMS MMP Packages
+CMS_MULTIMEDIA_PKGS = " \
+ cms-user-module \
+"
+
+# Kernel modules of DTV
+DTV_KERNEL_PKGS = " \
+ kernel-module-scu-src \
+ kernel-module-ssp \
+ kernel-module-tddmac \
+ kernel-module-tsif \
+"
+
+# DTV Packages
+DTV_PKGS = " \
+ ${DTV_KERNEL_PKGS} \
+ dtv-user-module \
+"
+
+# DVD Packages
+DVD_PKGS = " \
+ dvd-user-module \
+"
+
+# DVD Encryption Library packages
+DVD_ENCRYPTION_PKGS = " \
+ dvd-encryption-module \
+"
+
+# ADSP Packages
+ADSP_PKGS = " \
+ kernel-module-xtensa-hifi \
+ adsp-if-module \
+ adsp-fw-module \
+"
+
+# Kernel modules of AVB
+AVB_KERNEL_PKGS = " \
+ kernel-module-avb-streaming \
+ kernel-module-avb-mch \
+ kernel-module-avb-mse \
+"
+
+# AVB Packages
+AVB_PKGS = " \
+ ${AVB_KERNEL_PKGS} \
+ avbtool \
+ linuxptp \
+ openavnu-mrpd \
+ openavnu-gptp \
+ openavnu-maap \
+ avb-demoapps-avblauncher \
+ avb-demoapps-mrpdummy \
+ avb-demoapps-simple \
+"
+
+# Renesas MMP 32bit packages
+MMP_32BIT_PKGS = " \
+ ${@oe.utils.conditional("USE_MULTIMEDIA", "1", "lib32-packagegroup-multimedia-libs lib32-omx-user-module", "", d)} \
+ ${@oe.utils.conditional("USE_MULTIMEDIA_TP", "1", "lib32-vspmif-tp-user-module", "", d)} \
+ ${@oe.utils.conditional("USE_CMS", "1", "lib32-cms-user-module", "", d)} \
+ ${@oe.utils.conditional("USE_DTV", "1", "lib32-dtv-user-module", "", d)} \
+ ${@oe.utils.conditional("USE_DVD", "1", "lib32-dvd-user-module", "", d)} \
+ ${@oe.utils.conditional("USE_ADSP", "1", "lib32-adsp-if-module", "", d)} \
+"
+
+# Install pkg selection
+IMAGE_INSTALL_append = " \
+ ${@oe.utils.conditional("USE_MULTIMEDIA", "1", " ${MULTIMEDIA_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_MULTIMEDIA_TP", "1", " ${MULTIMEDIA_TP_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_OMX_USER_MODULE", "1", " ${OMX_MULTIMEDIA_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_CMS", "1", " ${CMS_MULTIMEDIA_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_DTV", "1", " ${DTV_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_DVD", "1", " ${DVD_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_DVD_ENCRYPTION_LIB", "1", " ${DVD_ENCRYPTION_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_ADSP", "1", " ${ADSP_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_AVB", "1", " ${AVB_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_32BIT_MMP", "1", " ${MMP_32BIT_PKGS}", "", d)} \
+"
diff --git a/bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-weston-sdk.bb b/bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-weston-sdk.bb
new file mode 100644
index 00000000..fd4e6a09
--- /dev/null
+++ b/bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-weston-sdk.bb
@@ -0,0 +1,15 @@
+require recipes-graphics/images/core-image-weston.bb
+require core-image-renesas-base.inc
+require core-image-weston.inc
+
+DESCRIPTION = "Image with weston support that includes everything within \
+core-image-weston plus meta-toolchain, development headers and libraries to \
+form a standalone SDK."
+
+IMAGE_FEATURES += " \
+ dev-pkgs tools-sdk \
+ tools-debug debug-tweaks \
+ ssh-server-openssh \
+"
+
+IMAGE_INSTALL_append = " kernel-devsrc ltp"
diff --git a/bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-weston.bbappend b/bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-weston.bbappend
new file mode 100644
index 00000000..41f1cb04
--- /dev/null
+++ b/bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-weston.bbappend
@@ -0,0 +1,2 @@
+require ${@"core-image-renesas-base.inc" if "rcar-gen3" in d.getVar("OVERRIDES") else ""}
+require ${@"core-image-weston.inc" if "rcar-gen3" in d.getVar("OVERRIDES") else ""}
diff --git a/bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-weston.inc b/bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-weston.inc
new file mode 100644
index 00000000..4ae567a1
--- /dev/null
+++ b/bsp/meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-weston.inc
@@ -0,0 +1,16 @@
+require include/gles-control.inc
+require core-image-renesas-mmp-base.inc
+
+# Gstreamer Packages
+GSTREAMER_PKGS = "packagegroup-gstreamer1.0-plugins"
+
+# Install packages for Wayland Env
+# default: Basic packages, Gstreamer packages
+# optional: GFX packages
+IMAGE_INSTALL_append = " \
+ ${GSTREAMER_PKGS} \
+ packagegroup-wayland-community \
+ packagegroup-graphics-renesas-proprietary \
+ packagegroup-graphics-renesas-wayland \
+ libx11-locale \
+"