summaryrefslogtreecommitdiffstats
path: root/bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/mmngr-module
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/mmngr-module')
-rw-r--r--bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/mmngr-module/mmngr-user-module.bb25
-rw-r--r--bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/mmngr-module/mmngr_lib.inc19
-rw-r--r--bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/mmngr-module/mmngrbuf-user-module.bb25
3 files changed, 69 insertions, 0 deletions
diff --git a/bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/mmngr-module/mmngr-user-module.bb b/bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/mmngr-module/mmngr-user-module.bb
new file mode 100644
index 00000000..ac4cf30b
--- /dev/null
+++ b/bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/mmngr-module/mmngr-user-module.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Memory Manager User module for Renesas R-Car Gen3"
+require mmngr_lib.inc
+require include/rcar-gen3-path-common.inc
+
+DEPENDS = "kernel-module-mmngr"
+PN = "mmngr-user-module"
+PR = "r0"
+
+S = "${WORKDIR}/git/libmmngr/mmngr"
+
+EXTRA_OECONF = "${@bb.utils.contains("DISTRO_FEATURES", "mm-test", \
+ " --enable-mmngr-test", "", d)}"
+
+exec_prefix = "/usr"
+bindir = "${RENESAS_DATADIR}/bin"
+includedir = "${RENESAS_DATADIR}/include"
+CFLAGS += " -I${STAGING_DIR_HOST}${RENESAS_DATADIR}/include"
+
+do_install_append() {
+ if [ -f ${D}${RENESAS_DATADIR}/bin/mmtp ]; then
+ if [ X${WS} = "X32" ]; then
+ mv ${D}${RENESAS_DATADIR}/bin/mmtp ${D}${RENESAS_DATADIR}/bin/mmtp${WS}
+ fi
+ fi
+}
diff --git a/bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/mmngr-module/mmngr_lib.inc b/bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/mmngr-module/mmngr_lib.inc
new file mode 100644
index 00000000..8afa6a50
--- /dev/null
+++ b/bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/mmngr-module/mmngr_lib.inc
@@ -0,0 +1,19 @@
+# Common path of MMNGR and MMNGRBUF module
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "\
+ file://${WORKDIR}/git/COPYING.MIT;md5=30a99e0d36a3da1f5cf93c070ad7888a"
+
+MMNGR_LIB_URI = "git://github.com/renesas-rcar/mmngr_lib.git"
+
+SRC_URI = "${MMNGR_LIB_URI};branch=rcar_gen3"
+SRCREV = "e55a8356c906486ee0be78b2a1fde227e7a578f4"
+
+# Get Wordsize of test app and change their names later to avoid override
+WS_aarch64 = ""
+WS_virtclass-multilib-lib32 = "32"
+
+# These modules are machine specific.
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = "(salvator-x|ulcb|ebisu)"
+
+inherit autotools
diff --git a/bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/mmngr-module/mmngrbuf-user-module.bb b/bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/mmngr-module/mmngrbuf-user-module.bb
new file mode 100644
index 00000000..690169fd
--- /dev/null
+++ b/bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/mmngr-module/mmngrbuf-user-module.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Memory Manager Buffer User module for Renesas R-Car Gen3"
+require mmngr_lib.inc
+require include/rcar-gen3-path-common.inc
+
+DEPENDS = "kernel-module-mmngrbuf"
+PN = "mmngrbuf-user-module"
+PR = "r0"
+
+S = "${WORKDIR}/git/libmmngr/mmngrbuf"
+
+EXTRA_OECONF = "${@bb.utils.contains("DISTRO_FEATURES", "mm-test", \
+ " --enable-mmngrbuf-test", "", d)}"
+
+exec_prefix = "/usr"
+bindir = "${RENESAS_DATADIR}/bin"
+includedir = "${RENESAS_DATADIR}/include"
+CFLAGS += " -I${STAGING_DIR_HOST}${RENESAS_DATADIR}/include"
+
+do_install_append() {
+ if [ -f ${D}${RENESAS_DATADIR}/bin/mmbuftp ]; then
+ if [ X${WS} = "X32" ]; then
+ mv ${D}${RENESAS_DATADIR}/bin/mmbuftp ${D}${RENESAS_DATADIR}/bin/mmbuftp${WS}
+ fi
+ fi
+}