summaryrefslogtreecommitdiffstats
path: root/bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8723bu.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8723bu.bb')
-rw-r--r--bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8723bu.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8723bu.bb b/bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8723bu.bb
new file mode 100644
index 00000000..38cb38a2
--- /dev/null
+++ b/bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8723bu.bb
@@ -0,0 +1,34 @@
+SUMMARY = "RTL8723 kernel driver (wifi + bluetooth)"
+DESCRIPTION = "RTL8723 kernel driver"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://Kconfig;md5=ce4c7adf40ddcf6cfca7ee2b333165f0"
+
+PV = "1.0-git"
+SRCREV = "db024b4c130283a0372d2f89a015a3a5c36f9419"
+SRC_URI = "git://github.com/lwfinger/rtl8723bu.git;protocol=https \
+ file://0002-realtek-Disable-IPS-mode.patch "
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "virtual/kernel"
+
+inherit module
+
+EXTRA_OEMAKE = "ARCH=${ARCH} \
+ KSRC=${STAGING_KERNEL_BUILDDIR} \
+ USER_EXTRA_CFLAGS='-DCONFIG_IOCTL_CFG80211 -DRTW_USE_CFG80211_STA_EVENT' \
+ "
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}
+ install -m 0755 ${B}/8723bu.ko ${D}/lib/modules/${KERNEL_VERSION}/8723bu.ko
+
+ install -d ${D}${sysconfdir}/modprobe.d
+ echo "blacklist rtl8xxxu" > ${D}${sysconfdir}/modprobe.d/rtl8723-blacklist.conf
+}
+
+FILES_${PN} += "${sysconfdir}"