summaryrefslogtreecommitdiffstats
path: root/bsp/meta-rtlwifi
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-rtlwifi')
-rw-r--r--bsp/meta-rtlwifi/conf/layer.conf2
-rw-r--r--bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8723bu.bb2
-rw-r--r--bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8812au.bb30
-rw-r--r--bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8812au/0001-Use-modules_install-as-wanted-by-yocto.patch28
-rw-r--r--bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8821cu.bb29
5 files changed, 68 insertions, 23 deletions
diff --git a/bsp/meta-rtlwifi/conf/layer.conf b/bsp/meta-rtlwifi/conf/layer.conf
index ca6c3745..7281f63f 100644
--- a/bsp/meta-rtlwifi/conf/layer.conf
+++ b/bsp/meta-rtlwifi/conf/layer.conf
@@ -4,7 +4,7 @@ BBPATH .= ":${LAYERDIR}"
# Append recipe dir to BBFILES
BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
-LAYERSERIES_COMPAT_rtlwifi = "rocko sumo thud"
+LAYERSERIES_COMPAT_rtlwifi = "rocko sumo thud warrior zeus dunfell"
BBFILE_COLLECTIONS += "rtlwifi"
BBFILE_PRIORITY_rtlwifi = "1"
diff --git a/bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8723bu.bb b/bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8723bu.bb
index 38cb38a2..a703d997 100644
--- a/bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8723bu.bb
+++ b/bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8723bu.bb
@@ -4,7 +4,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://Kconfig;md5=ce4c7adf40ddcf6cfca7ee2b333165f0"
PV = "1.0-git"
-SRCREV = "db024b4c130283a0372d2f89a015a3a5c36f9419"
+SRCREV = "a8bd4b6c0481479408e67ac2e1c6fd5dc499e37f"
SRC_URI = "git://github.com/lwfinger/rtl8723bu.git;protocol=https \
file://0002-realtek-Disable-IPS-mode.patch "
diff --git a/bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8812au.bb b/bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8812au.bb
index 1d358323..17133e57 100644
--- a/bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8812au.bb
+++ b/bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8812au.bb
@@ -1,29 +1,17 @@
-SUMMARY = "RTL8812AU kernel driver (wifi)"
-DESCRIPTION = "RTL8812AU kernel driver"
+SUMMARY = "Realtek 802.11n WLAN Adapter Linux driver"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://Kconfig;md5=4b85004ff83dd932ff28f7f348fb2a28"
-
-SRC_URI = "git://github.com/EmbeddedAndroid/rtl8812AU_8821AU_linux.git;protocol=https"
-SRCREV = "d1f7e7a3675c5895d9eb00f5b303e350fdccc0b2"
-
-S = "${WORKDIR}/git"
-
-PV = "1.0-git"
-
-DEPENDS = "virtual/kernel"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
inherit module
-EXTRA_OEMAKE = "ARCH=${ARCH}"
-EXTRA_OEMAKE += "KSRC=${STAGING_KERNEL_BUILDDIR}"
+SRC_URI = " \
+ git://github.com/gordboy/rtl8812au.git;protocol=https \
+ file://0001-Use-modules_install-as-wanted-by-yocto.patch \
+"
-do_compile () {
- unset LDFLAGS
- oe_runmake
-}
+SRCREV = "30d47a0a3f43ccb19e8fd59fe93d74a955147bf2"
-do_install () {
- install -d ${D}/lib/modules/${KERNEL_VERSION}
- install -m 0755 ${B}/rtl8812au.ko ${D}/lib/modules/${KERNEL_VERSION}/rtl8812au.ko
-}
+S = "${WORKDIR}/git"
+EXTRA_OEMAKE_append = " KSRC=${STAGING_KERNEL_DIR}"
diff --git a/bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8812au/0001-Use-modules_install-as-wanted-by-yocto.patch b/bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8812au/0001-Use-modules_install-as-wanted-by-yocto.patch
new file mode 100644
index 00000000..c68020c2
--- /dev/null
+++ b/bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8812au/0001-Use-modules_install-as-wanted-by-yocto.patch
@@ -0,0 +1,28 @@
+From 30836d3579b3536ce174082f451acf7fea638a8d Mon Sep 17 00:00:00 2001
+From: Andrei Gherzan <andrei@resin.io>
+Date: Mon, 1 Aug 2016 23:51:45 +0200
+Subject: [PATCH] Use modules_install as wanted by yocto
+
+Upstream-Status: Pending
+
+Signed-off-by: Andrei Gherzan <andrei@resin.io>
+---
+ Makefile | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/Makefile b/Makefile
+index 70c609a..b5ecf55 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1051,6 +1051,9 @@ all: modules
+ modules:
+ $(MAKE) ARCH=$(ARCH) CROSS_COMPILE=$(CROSS_COMPILE) -C $(KSRC) M=$(shell pwd) modules
+
++modules_install:
++ $(MAKE) ARCH=$(ARCH) CROSS_COMPILE=$(CROSS_COMPILE) -C $(KSRC) M=$(shell pwd) modules_install
++
+ strip:
+ $(CROSS_COMPILE)strip $(MODULE_NAME).ko --strip-unneeded
+
+--
+2.1.4
diff --git a/bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8821cu.bb b/bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8821cu.bb
new file mode 100644
index 00000000..1aa4f3b4
--- /dev/null
+++ b/bsp/meta-rtlwifi/recipes-bsp/drivers/rtl8821cu.bb
@@ -0,0 +1,29 @@
+SUMMARY = "RTL8821CU kernel driver (wifi)"
+DESCRIPTION = "RTL8821CU kernel driver"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://Kconfig;md5=bc2a2406eb72158dee196a8486a2aec9"
+
+SRCREV = "3d9d2401a8912fd96efdec3bf0c88a4e8bab2d76"
+SRC_URI = "git://github.com/spriteguard/rtl8821CU;protocol=https "
+
+S = "${WORKDIR}/git"
+
+PV = "1.0-git"
+
+DEPENDS = "virtual/kernel"
+
+inherit module
+
+EXTRA_OEMAKE = "ARCH=${ARCH}"
+EXTRA_OEMAKE += "KSRC=${STAGING_KERNEL_BUILDDIR}"
+
+MODULES_INSTALL_TARGET="install"
+
+do_install () {
+ install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
+ install -m 0644 ${B}/8821cu.ko ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless/rtl8821cu.ko
+}
+
+FILES_${PN} += "${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless/rtl8821cu.ko"
+RPROVIDES_${PN} += "kernel-module-${PN}-${KERNEL_VERSION}"
+