summaryrefslogtreecommitdiffstats
path: root/bsp/meta-sancloud/kas/patches
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-sancloud/kas/patches')
-rw-r--r--bsp/meta-sancloud/kas/patches/meta-arago/0001-linux-copy-defconfig-Only-move-do_create_srcipk-task.patch32
-rw-r--r--bsp/meta-sancloud/kas/patches/meta-arago/0001-packagegroup-arago-sysvinit-boot-Skip-recipe-if-sysv.patch35
2 files changed, 67 insertions, 0 deletions
diff --git a/bsp/meta-sancloud/kas/patches/meta-arago/0001-linux-copy-defconfig-Only-move-do_create_srcipk-task.patch b/bsp/meta-sancloud/kas/patches/meta-arago/0001-linux-copy-defconfig-Only-move-do_create_srcipk-task.patch
new file mode 100644
index 00000000..dce9abb7
--- /dev/null
+++ b/bsp/meta-sancloud/kas/patches/meta-arago/0001-linux-copy-defconfig-Only-move-do_create_srcipk-task.patch
@@ -0,0 +1,32 @@
+From aa5193801eb5052eba389f51deacbce7ec74c589 Mon Sep 17 00:00:00 2001
+From: Paul Barker <pbarker@konsulko.com>
+Date: Sun, 21 Jun 2020 15:20:02 +0100
+Subject: [master/dunfell][PATCH] linux: copy-defconfig: Only move
+ do_create_srcipk task if it is defined
+To: meta-arago@arago-project.org
+
+Signed-off-by: Paul Barker <pbarker@konsulko.com>
+---
+ .../recipes-kernel/linux/copy-defconfig.inc | 9 ++++++---
+ 1 file changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/meta-arago-distro/recipes-kernel/linux/copy-defconfig.inc b/meta-arago-distro/recipes-kernel/linux/copy-defconfig.inc
+index 10ecf8ea..65b615cb 100644
+--- a/meta-arago-distro/recipes-kernel/linux/copy-defconfig.inc
++++ b/meta-arago-distro/recipes-kernel/linux/copy-defconfig.inc
+@@ -17,6 +17,9 @@ do_configure_append() {
+ fi
+ }
+
+-# Move create_srcipk task so that the release defconfig is included.
+-deltask do_create_srcipk
+-addtask create_srcipk after do_configure before do_compile
++python __anonymous() {
++ # Move create_srcipk task so that the release defconfig is included.
++ if d.getVarFlag('do_create_srcipk', "task"):
++ bb.build.deltask('do_create_srcipk', d)
++ bb.build.addtask('do_create_srcipk', 'do_configure', 'do_compile', d)
++}
+--
+2.27.0
+
diff --git a/bsp/meta-sancloud/kas/patches/meta-arago/0001-packagegroup-arago-sysvinit-boot-Skip-recipe-if-sysv.patch b/bsp/meta-sancloud/kas/patches/meta-arago/0001-packagegroup-arago-sysvinit-boot-Skip-recipe-if-sysv.patch
new file mode 100644
index 00000000..df66e945
--- /dev/null
+++ b/bsp/meta-sancloud/kas/patches/meta-arago/0001-packagegroup-arago-sysvinit-boot-Skip-recipe-if-sysv.patch
@@ -0,0 +1,35 @@
+From 39c79d5d514ff05fa749bda20d72af18f4b95e12 Mon Sep 17 00:00:00 2001
+From: Paul Barker <pbarker@konsulko.com>
+Date: Tue, 9 Jun 2020 11:22:06 +0100
+Subject: [master/dunfell][PATCH] packagegroup-arago-sysvinit-boot: Skip recipe
+ if sysvinit is not enabled
+To: meta-arago@arago-project.org
+
+This change fixes the following error seen at parse time when the
+meta-arago-distro layer is present but sysvinit is not in
+DISTRO_FEATURES:
+
+ ERROR: .../meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-sysvinit-boot.bb: Please ensure that your setting of VIRTUAL-RUNTIME_init_manager (sysvinit) matches the entries enabled in DISTRO_FEATURES
+ ERROR: Failed to parse recipe: .../meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-sysvinit-boot.bb
+
+Signed-off-by: Paul Barker <pbarker@konsulko.com>
+---
+ .../packagegroups/packagegroup-arago-sysvinit-boot.bb | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-sysvinit-boot.bb b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-sysvinit-boot.bb
+index 2eb2d777..a6e21745 100644
+--- a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-sysvinit-boot.bb
++++ b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-sysvinit-boot.bb
+@@ -1,3 +1,8 @@
++python __anonymous() {
++ if not "sysvinit" in d.getVar("DISTRO_FEATURES").split():
++ raise bb.parse.SkipRecipe("sysvinit is not enabled")
++}
++
+ require recipes-core/packagegroups/packagegroup-core-boot.bb
+
+ PR = "r0"
+--
+2.26.2
+