summaryrefslogtreecommitdiffstats
path: root/bsp/meta-sancloud/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-sancloud/recipes-bsp')
-rw-r--r--bsp/meta-sancloud/recipes-bsp/u-boot/files/boot.cmd17
-rw-r--r--bsp/meta-sancloud/recipes-bsp/u-boot/u-boot-bbe.bb16
-rw-r--r--bsp/meta-sancloud/recipes-bsp/u-boot/u-boot-script-bbe.bb20
3 files changed, 37 insertions, 16 deletions
diff --git a/bsp/meta-sancloud/recipes-bsp/u-boot/files/boot.cmd b/bsp/meta-sancloud/recipes-bsp/u-boot/files/boot.cmd
new file mode 100644
index 00000000..4adec45b
--- /dev/null
+++ b/bsp/meta-sancloud/recipes-bsp/u-boot/files/boot.cmd
@@ -0,0 +1,17 @@
+# Select MMC partition containing this script
+setenv devtype mmc
+setenv bootpart ${devnum}:${distro_bootpart}
+
+# Load kernel
+run loadimage
+
+# Load devicetree
+run findfdt
+run loadfdt
+
+# Set kernel arguments
+part uuid ${devtype} ${bootpart} uuid
+setenv bootargs console=${console} root=PARTUUID=${uuid} rw rootwait ${optargs}
+
+# Boot Linux
+bootz ${loadaddr} - ${fdtaddr}
diff --git a/bsp/meta-sancloud/recipes-bsp/u-boot/u-boot-bbe.bb b/bsp/meta-sancloud/recipes-bsp/u-boot/u-boot-bbe.bb
deleted file mode 100644
index 85c56a15..00000000
--- a/bsp/meta-sancloud/recipes-bsp/u-boot/u-boot-bbe.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
-SECTION = "bootloaders"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e"
-
-DEPENDS += "flex-native bison-native"
-
-require recipes-bsp/u-boot/u-boot.inc
-
-SRC_URI = "git://github.com/SanCloudLtd/u-boot.git;protocol=https;branch=uboot-bbe-2019.10"
-SRCREV = "81a1432e5c4514cc3ca1fec78023afbee638c4f0"
-PV = "2019.10+git${SRCPV}"
-
-S = "${WORKDIR}/git"
-
-PROVIDES += "u-boot"
diff --git a/bsp/meta-sancloud/recipes-bsp/u-boot/u-boot-script-bbe.bb b/bsp/meta-sancloud/recipes-bsp/u-boot/u-boot-script-bbe.bb
new file mode 100644
index 00000000..d97f0708
--- /dev/null
+++ b/bsp/meta-sancloud/recipes-bsp/u-boot/u-boot-script-bbe.bb
@@ -0,0 +1,20 @@
+SUMMARY = "U-boot script for the BBE"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+DEPENDS = "u-boot-mkimage-native"
+
+SRC_URI = "file://boot.cmd"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_compile() {
+ mkimage -A arm -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr
+}
+
+do_install() {
+ install -d ${D}/boot
+ install -m 0644 boot.scr ${D}/boot
+}
+
+FILES_${PN} = "/boot"