summaryrefslogtreecommitdiffstats
path: root/bsp/meta-synopsys/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-synopsys/conf/layer.conf')
-rw-r--r--bsp/meta-synopsys/conf/layer.conf21
1 files changed, 21 insertions, 0 deletions
diff --git a/bsp/meta-synopsys/conf/layer.conf b/bsp/meta-synopsys/conf/layer.conf
new file mode 100644
index 00000000..005bbf67
--- /dev/null
+++ b/bsp/meta-synopsys/conf/layer.conf
@@ -0,0 +1,21 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "synopsys"
+BBFILE_PATTERN_synopsys = "^${LAYERDIR}/"
+BBFILE_PRIORITY_synopsys = "6"
+
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_synopsys = "1"
+LAYERSERIES_COMPAT_synopsys-layer = "sumo thud"
+
+LAYERDEPENDS_synopsys = "core"
+BBFILES += "${@' '.join('${LAYERDIR}/dynamic-layers/%s/recipes*/*/*.bbappend' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+BBFILES += "${@' '.join('${LAYERDIR}/dynamic-layers/%s/recipes*/*/*.bb' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+