summaryrefslogtreecommitdiffstats
path: root/bsp/meta-synopsys/recipes-devtools/gcc
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-synopsys/recipes-devtools/gcc')
-rw-r--r--bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc.inc11
-rw-r--r--bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0003-gcc-poison-system-directories.patch65
-rw-r--r--bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0007-optional-libstdc.patch38
-rw-r--r--bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0012-cpp-honor-sysroot.patch22
-rw-r--r--bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0014-Define-GLIBC_DYNAMIC_LINKER-and-UCLIBC_DYNAMIC_LINKE.patch63
-rw-r--r--bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0037-sync-gcc-stddef.h-with-musl.patch32
-rw-r--r--bsp/meta-synopsys/recipes-devtools/gcc/gcc-cross-initial_arc.bb2
-rw-r--r--bsp/meta-synopsys/recipes-devtools/gcc/gcc-crosssdk-initial_arc.bb2
-rw-r--r--bsp/meta-synopsys/recipes-devtools/gcc/libgcc_arc.bb7
l---------bsp/meta-synopsys/recipes-devtools/gcc/ltmain.sh1
10 files changed, 120 insertions, 123 deletions
diff --git a/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc.inc b/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc.inc
index 3807a697..f0f8146c 100644
--- a/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc.inc
+++ b/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc.inc
@@ -6,7 +6,7 @@ PV = "arc"
# BINV should be incremented to a revision after a minor gcc release
-BINV = "8.2.1"
+BINV = "9.2.1"
FILESEXTRAPATHS =. "${FILE_DIRNAME}/gcc-arc:"
@@ -23,10 +23,10 @@ LIC_FILES_CHKSUM = "\
file://COPYING.RUNTIME;md5=fe60d87048567d4fe8c8a0ed2448bcc8 \
"
-SRCREV ?= "arc-2018.09-release"
+SRCREV ?= "arc-2019.09-release"
SRC_URI = "\
- git://github.com/foss-for-synopsys-dwc-arc-processors/gcc.git;protocol=https;branch=arc-2018.09; \
+ git://github.com/foss-for-synopsys-dwc-arc-processors/gcc.git;protocol=https;branch=arc-2019.09; \
file://0001-gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch \
file://0003-gcc-poison-system-directories.patch \
file://0005-gcc-4.3.3-SYSROOT_CFLAGS_FOR_TARGET.patch \
@@ -36,7 +36,7 @@ SRC_URI = "\
file://0009-COLLECT_GCC_OPTIONS.patch \
file://0010-Use-the-defaults.h-in-B-instead-of-S-and-t-oe-in-B.patch \
file://0011-fortran-cross-compile-hack.patch \
- file://0012-cpp-honor-sysroot.patch \
+ file://0012-cpp-honor-sysroot.patch \
file://0014-Define-GLIBC_DYNAMIC_LINKER-and-UCLIBC_DYNAMIC_LINKE.patch \
file://0015-gcc-Fix-argument-list-too-long-error.patch \
file://0016-Disable-sdt.patch \
@@ -61,8 +61,7 @@ SRC_URI = "\
file://0038-fix-segmentation-fault-in-precompiled-header-generat.patch \
file://0039-Fix-for-testsuite-failure.patch \
file://0040-Re-introduce-spe-commandline-options.patch \
- file://0041-ARC-Emit-blockage-regardless-to-avoid-delay-slot-sch.patch \
- file://0042-ARC-Dont-throw-errors-when-compiling-for-xarch.patch \
+ file://0042-ARC-Dont-throw-errors-when-compiling-for-xarch.patch \
${BACKPORTS} \
"
BACKPORTS = "\
diff --git a/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0003-gcc-poison-system-directories.patch b/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0003-gcc-poison-system-directories.patch
index 05138976..a1116e75 100644
--- a/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0003-gcc-poison-system-directories.patch
+++ b/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0003-gcc-poison-system-directories.patch
@@ -1,11 +1,20 @@
-From 48c670d2678e0323d88eb72205e039f393cabe05 Mon Sep 17 00:00:00 2001
+From 68e78bc15de215fa15c7d8b56bd2e2b0539b34fa Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 29 Mar 2013 08:59:00 +0400
-Subject: [PATCH 03/39] gcc: poison-system-directories
+Subject: [PATCH 02/36] gcc: poison-system-directories
+Add /sw/include and /opt/include based on the original
+zecke-no-host-includes.patch patch. The original patch checked for
+/usr/include, /sw/include and /opt/include and then triggered a failure and
+aborted.
+
+Instead, we add the two missing items to the current scan. If the user
+wants this to be a failure, they can add "-Werror=poison-system-directories".
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Upstream-Status: Inappropriate [distribution: codesourcery]
+Upstream-Status: Pending
---
gcc/common.opt | 4 ++++
gcc/config.in | 6 ++++++
@@ -13,14 +22,14 @@ Upstream-Status: Inappropriate [distribution: codesourcery]
gcc/configure.ac | 10 ++++++++++
gcc/doc/invoke.texi | 9 +++++++++
gcc/gcc.c | 2 ++
- gcc/incpath.c | 19 +++++++++++++++++++
- 7 files changed, 66 insertions(+)
+ gcc/incpath.c | 21 +++++++++++++++++++++
+ 7 files changed, 68 insertions(+)
diff --git a/gcc/common.opt b/gcc/common.opt
-index d6ef85928f3..7b29efe3882 100644
+index d342c4f3749..c64fd4a6c50 100644
--- a/gcc/common.opt
+++ b/gcc/common.opt
-@@ -679,6 +679,10 @@ Wreturn-local-addr
+@@ -684,6 +684,10 @@ Wreturn-local-addr
Common Var(warn_return_local_addr) Init(1) Warning
Warn about returning a pointer/reference to a local or temporary variable.
@@ -32,10 +41,10 @@ index d6ef85928f3..7b29efe3882 100644
Common Var(warn_shadow) Warning
Warn when one variable shadows another. Same as -Wshadow=global.
diff --git a/gcc/config.in b/gcc/config.in
-index 5bccb408016..1c784a8276b 100644
+index a718ceaf3da..5713342efb1 100644
--- a/gcc/config.in
+++ b/gcc/config.in
-@@ -194,6 +194,12 @@
+@@ -200,6 +200,12 @@
#endif
@@ -49,10 +58,10 @@ index 5bccb408016..1c784a8276b 100644
optimizer and back end) to be checked for dynamic type safety at runtime.
This is quite expensive. */
diff --git a/gcc/configure b/gcc/configure
-index 5c345ce0fd7..cafd05fd150 100755
+index 481071b4265..a6ea3a8a84c 100755
--- a/gcc/configure
+++ b/gcc/configure
-@@ -953,6 +953,7 @@ with_system_zlib
+@@ -995,6 +995,7 @@ with_system_zlib
enable_maintainer_mode
enable_link_mutex
enable_version_specific_runtime_libs
@@ -60,7 +69,7 @@ index 5c345ce0fd7..cafd05fd150 100755
enable_plugin
enable_host_shared
enable_libquadmath_support
-@@ -1696,6 +1697,8 @@ Optional Features:
+@@ -1748,6 +1749,8 @@ Optional Features:
--enable-version-specific-runtime-libs
specify that runtime libraries should be installed
in a compiler-specific directory
@@ -69,7 +78,7 @@ index 5c345ce0fd7..cafd05fd150 100755
--enable-plugin enable plugin support
--enable-host-shared build host code as shared libraries
--disable-libquadmath-support
-@@ -29715,6 +29718,19 @@ if test "${enable_version_specific_runtime_libs+set}" = set; then :
+@@ -29750,6 +29753,19 @@ if test "${enable_version_specific_runtime_libs+set}" = set; then :
fi
@@ -90,10 +99,10 @@ index 5c345ce0fd7..cafd05fd150 100755
diff --git a/gcc/configure.ac b/gcc/configure.ac
-index 65dbf1f2f80..dd5b38195ce 100644
+index ce2825580c6..d42bbd4fd1c 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
-@@ -6341,6 +6341,16 @@ AC_ARG_ENABLE(version-specific-runtime-libs,
+@@ -6378,6 +6378,16 @@ AC_ARG_ENABLE(version-specific-runtime-libs,
[specify that runtime libraries should be
installed in a compiler-specific directory])])
@@ -111,18 +120,18 @@ index 65dbf1f2f80..dd5b38195ce 100644
AC_SUBST(subdirs)
AC_SUBST(srcdir)
diff --git a/gcc/doc/invoke.texi b/gcc/doc/invoke.texi
-index 255149fcfb8..cb71b60fe3c 100644
+index 6ef36ce02aa..09414d8cc05 100644
--- a/gcc/doc/invoke.texi
+++ b/gcc/doc/invoke.texi
-@@ -303,6 +303,7 @@ Objective-C and Objective-C++ Dialects}.
- -Wpacked -Wpacked-bitfield-compat -Wpacked-not-aligned -Wpadded @gol
+@@ -332,6 +332,7 @@ Objective-C and Objective-C++ Dialects}.
+ -Wpacked -Wpacked-bitfield-compat -Wpacked-not-aligned -Wpadded @gol
-Wparentheses -Wno-pedantic-ms-format @gol
-Wplacement-new -Wplacement-new=@var{n} @gol
+-Wno-poison-system-directories @gol
-Wpointer-arith -Wpointer-compare -Wno-pointer-to-int-cast @gol
- -Wno-pragmas -Wredundant-decls -Wrestrict -Wno-return-local-addr @gol
- -Wreturn-type -Wsequence-point -Wshadow -Wno-shadow-ivar @gol
-@@ -5712,6 +5713,14 @@ made up of data only and thus requires no special treatment. But, for
+ -Wno-pragmas -Wno-prio-ctor-dtor -Wredundant-decls @gol
+ -Wrestrict -Wno-return-local-addr @gol
+@@ -6289,6 +6290,14 @@ made up of data only and thus requires no special treatment. But, for
most targets, it is made up of code and thus requires the stack to be
made executable in order for the program to work properly.
@@ -138,20 +147,20 @@ index 255149fcfb8..cb71b60fe3c 100644
@opindex Wfloat-equal
@opindex Wno-float-equal
diff --git a/gcc/gcc.c b/gcc/gcc.c
-index a716f708259..02b3cd39fc2 100644
+index 4f57765b012..a2601a6bb06 100644
--- a/gcc/gcc.c
+++ b/gcc/gcc.c
-@@ -1037,6 +1037,8 @@ proper position among the other output files. */
+@@ -1042,6 +1042,8 @@ proper position among the other output files. */
"%{fuse-ld=*:-fuse-ld=%*} " LINK_COMPRESS_DEBUG_SPEC \
"%X %{o*} %{e*} %{N} %{n} %{r}\
- %{s} %{t} %{u*} %{z} %{Z} %{!nostdlib:%{!nostartfiles:%S}} \
+ %{s} %{t} %{u*} %{z} %{Z} %{!nostdlib:%{!r:%{!nostartfiles:%S}}} \
+ %{Wno-poison-system-directories:--no-poison-system-directories} \
+ %{Werror=poison-system-directories:--error-poison-system-directories} \
- %{static|no-pie|static-pie:} %{L*} %(mfwrap) %(link_libgcc) " \
- VTABLE_VERIFICATION_SPEC " " SANITIZER_EARLY_SPEC " %o " CHKP_SPEC " \
+ %{static|no-pie|static-pie:} %@{L*} %(mfwrap) %(link_libgcc) " \
+ VTABLE_VERIFICATION_SPEC " " SANITIZER_EARLY_SPEC " %o "" \
%{fopenacc|fopenmp|%:gt(%{ftree-parallelize-loops=*:%*} 1):\
diff --git a/gcc/incpath.c b/gcc/incpath.c
-index b11c6a57939..e3b7a21966f 100644
+index bcbe2082905..5752298bbf2 100644
--- a/gcc/incpath.c
+++ b/gcc/incpath.c
@@ -26,6 +26,7 @@
@@ -190,5 +199,5 @@ index b11c6a57939..e3b7a21966f 100644
/* Use given -I paths for #include "..." but not #include <...>, and
--
-2.17.0
+2.22.1
diff --git a/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0007-optional-libstdc.patch b/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0007-optional-libstdc.patch
index 721ea03f..f4fac914 100644
--- a/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0007-optional-libstdc.patch
+++ b/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0007-optional-libstdc.patch
@@ -1,7 +1,7 @@
-From fb7df63e9548c29b70601d642a1850fc455f8565 Mon Sep 17 00:00:00 2001
+From e7e504f4a90cfa395e7f8ee779f8c3ed687802ca Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 29 Mar 2013 09:12:56 +0400
-Subject: [PATCH 07/39] optional libstdc
+Subject: [PATCH 05/36] optional libstdc
gcc-runtime builds libstdc++ separately from gcc-cross-*. Its configure tests using g++
will not run correctly since by default the linker will try to link against libstdc++
@@ -25,10 +25,10 @@ Upstream-Status: Inappropriate [embedded specific]
4 files changed, 37 insertions(+), 1 deletion(-)
diff --git a/gcc/c-family/c.opt b/gcc/c-family/c.opt
-index 5013501b232..6312f2c8f90 100644
+index 916cc67b453..41619fa591c 100644
--- a/gcc/c-family/c.opt
+++ b/gcc/c-family/c.opt
-@@ -1900,6 +1900,10 @@ nostdinc++
+@@ -1952,6 +1952,10 @@ nostdinc++
C++ ObjC++
Do not search standard system include directories for C++.
@@ -40,7 +40,7 @@ index 5013501b232..6312f2c8f90 100644
C ObjC C++ ObjC++ Joined Separate
; Documented in common.opt
diff --git a/gcc/cp/g++spec.c b/gcc/cp/g++spec.c
-index 443a1746da3..e9b51be62ef 100644
+index 6c4574a837d..0e2657f00ee 100644
--- a/gcc/cp/g++spec.c
+++ b/gcc/cp/g++spec.c
@@ -137,6 +137,7 @@ lang_specific_driver (struct cl_decoded_option **in_decoded_options,
@@ -52,10 +52,10 @@ index 443a1746da3..e9b51be62ef 100644
library = -1;
break;
diff --git a/gcc/doc/invoke.texi b/gcc/doc/invoke.texi
-index cb71b60fe3c..b0d481e3a30 100644
+index 09414d8cc05..a43969bc9f0 100644
--- a/gcc/doc/invoke.texi
+++ b/gcc/doc/invoke.texi
-@@ -211,6 +211,9 @@ in the following sections.
+@@ -228,6 +228,9 @@ in the following sections.
-fno-weak -nostdinc++ @gol
-fvisibility-inlines-hidden @gol
-fvisibility-ms-compat @gol
@@ -64,19 +64,19 @@ index cb71b60fe3c..b0d481e3a30 100644
+-nostdlib++ @gol
-fext-numeric-literals @gol
-Wabi=@var{n} -Wabi-tag -Wconversion-null -Wctor-dtor-privacy @gol
- -Wdelete-non-virtual-dtor -Wliteral-suffix -Wmultiple-inheritance @gol
-@@ -509,7 +512,7 @@ Objective-C and Objective-C++ Dialects}.
- -s -static -static-pie -static-libgcc -static-libstdc++ @gol
+ -Wdelete-non-virtual-dtor -Wdeprecated-copy -Wdeprecated-copy-dtor @gol
+@@ -538,7 +541,7 @@ Objective-C and Objective-C++ Dialects}.
+ -pie -pthread -r -rdynamic @gol
+ -s -static -static-pie -static-libgcc -static-libstdc++ @gol
-static-libasan -static-libtsan -static-liblsan -static-libubsan @gol
- -static-libmpx -static-libmpxwrappers @gol
--shared -shared-libgcc -symbolic @gol
+-shared -shared-libgcc -symbolic -nostdlib++ @gol
-T @var{script} -Wl,@var{option} -Xlinker @var{option} @gol
-u @var{symbol} -z @var{keyword}}
-@@ -12331,6 +12334,33 @@ library subroutines.
- constructors are called; @pxref{Collect2,,@code{collect2}, gccint,
- GNU Compiler Collection (GCC) Internals}.)
+@@ -13312,6 +13315,33 @@ Specify that the program entry point is @var{entry}. The argument is
+ interpreted by the linker; the GNU linker accepts either a symbol name
+ or an address.
+@item -nostdlib++
+@opindex nostdlib++
@@ -109,17 +109,17 @@ index cb71b60fe3c..b0d481e3a30 100644
@opindex pie
Produce a dynamically linked position independent executable on targets
diff --git a/gcc/gcc.c b/gcc/gcc.c
-index 02b3cd39fc2..8cd27a5dad5 100644
+index a2601a6bb06..cd6c6fc95db 100644
--- a/gcc/gcc.c
+++ b/gcc/gcc.c
-@@ -1047,6 +1047,7 @@ proper position among the other output files. */
+@@ -1052,6 +1052,7 @@ proper position among the other output files. */
%(mflib) " STACK_SPLIT_SPEC "\
%{fprofile-arcs|fprofile-generate*|coverage:-lgcov} " SANITIZER_SPEC " \
- %{!nostdlib:%{!nodefaultlibs:%(link_ssp) %(link_gcc_c_sequence)}}\
+ %{!nostdlib:%{!r:%{!nodefaultlibs:%(link_ssp) %(link_gcc_c_sequence)}}}\
+ %{!nostdlib++:}\
- %{!nostdlib:%{!nostartfiles:%E}} %{T*} \n%(post_link) }}}}}}"
+ %{!nostdlib:%{!r:%{!nostartfiles:%E}}} %{T*} \n%(post_link) }}}}}}"
#endif
--
-2.17.0
+2.22.1
diff --git a/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0012-cpp-honor-sysroot.patch b/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0012-cpp-honor-sysroot.patch
index 961f96f1..6af0a012 100644
--- a/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0012-cpp-honor-sysroot.patch
+++ b/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0012-cpp-honor-sysroot.patch
@@ -1,7 +1,7 @@
-From b3e8e7e8ae106e3207e9edc3d23dcce1464b755f Mon Sep 17 00:00:00 2001
+From 45e9cd39d9c62454d46b9e9473a0c1034ceca15d Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 29 Mar 2013 09:22:00 +0400
-Subject: [PATCH 12/39] cpp: honor sysroot.
+Subject: [PATCH 09/36] cpp: honor sysroot.
Currently, if the gcc toolchain is relocated and installed from sstate, then you try and compile
preprocessed source (.i or .ii files), the compiler will try and access the builtin sysroot location
@@ -26,21 +26,21 @@ Upstream-Status: Pending
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/gcc/cp/lang-specs.h b/gcc/cp/lang-specs.h
-index f0802b8915c..f324d299849 100644
+index c6e42eda283..e1ddf066467 100644
--- a/gcc/cp/lang-specs.h
+++ b/gcc/cp/lang-specs.h
-@@ -64,5 +64,5 @@ along with GCC; see the file COPYING3. If not see
+@@ -66,5 +66,5 @@ along with GCC; see the file COPYING3. If not see
{".ii", "@c++-cpp-output", 0, 0, 0},
{"@c++-cpp-output",
- "%{!M:%{!MM:%{!E:\
-- cc1plus -fpreprocessed %i %(cc1_options) %2\
-+ cc1plus -fpreprocessed %i %I %(cc1_options) %2\
- %{!fsyntax-only:%(invoke_as)}}}}", 0, 0, 0},
+ "%{!E:%{!M:%{!MM:"
+- " cc1plus -fpreprocessed %i %(cc1_options) %2"
++ " cc1plus -fpreprocessed %i %I %(cc1_options) %2"
+ " %{!fsyntax-only:%(invoke_as)}}}}", 0, 0, 0},
diff --git a/gcc/gcc.c b/gcc/gcc.c
-index d355d65583a..570cdc00034 100644
+index 7da9c5d457b..4e7c45b268c 100644
--- a/gcc/gcc.c
+++ b/gcc/gcc.c
-@@ -1343,7 +1343,7 @@ static const struct compiler default_compilers[] =
+@@ -1349,7 +1349,7 @@ static const struct compiler default_compilers[] =
%W{o*:--output-pch=%*}}%V}}}}}}}", 0, 0, 0},
{".i", "@cpp-output", 0, 0, 0},
{"@cpp-output",
@@ -50,5 +50,5 @@ index d355d65583a..570cdc00034 100644
{"@assembler",
"%{!M:%{!MM:%{!E:%{!S:as %(asm_debug) %(asm_options) %i %A }}}}", 0, 0, 0},
--
-2.17.0
+2.22.1
diff --git a/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0014-Define-GLIBC_DYNAMIC_LINKER-and-UCLIBC_DYNAMIC_LINKE.patch b/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0014-Define-GLIBC_DYNAMIC_LINKER-and-UCLIBC_DYNAMIC_LINKE.patch
index 043bb9dd..66fb24d4 100644
--- a/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0014-Define-GLIBC_DYNAMIC_LINKER-and-UCLIBC_DYNAMIC_LINKE.patch
+++ b/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0014-Define-GLIBC_DYNAMIC_LINKER-and-UCLIBC_DYNAMIC_LINKE.patch
@@ -1,7 +1,7 @@
-From 53f1c382b1366c5621c8edead9c766950c290fd9 Mon Sep 17 00:00:00 2001
+From 72fc3975bcd720b2f8040fa87cd23d3db4c5975a Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 29 Mar 2013 09:24:50 +0400
-Subject: [PATCH 14/39] Define GLIBC_DYNAMIC_LINKER and UCLIBC_DYNAMIC_LINKER
+Subject: [PATCH] Define GLIBC_DYNAMIC_LINKER and UCLIBC_DYNAMIC_LINKER
relative to SYSTEMLIBS_DIR
This patch defines GLIBC_DYNAMIC_LINKER and UCLIBC_DYNAMIC_LINKER
@@ -24,14 +24,14 @@ Upstream-Status: Inappropriate [OE configuration]
gcc/config/linux.h | 8 ++++----
gcc/config/mips/linux.h | 12 ++++++------
gcc/config/riscv/linux.h | 2 +-
- gcc/config/rs6000/linux64.h | 16 ++++++----------
+ gcc/config/rs6000/linux64.h | 15 +++++----------
gcc/config/sh/linux.h | 2 +-
gcc/config/sparc/linux.h | 2 +-
gcc/config/sparc/linux64.h | 4 ++--
- 12 files changed, 30 insertions(+), 34 deletions(-)
+ 12 files changed, 29 insertions(+), 34 deletions(-)
diff --git a/gcc/config/alpha/linux-elf.h b/gcc/config/alpha/linux-elf.h
-index 36b74dc1993..02373578af8 100644
+index 824861befec..6afacce3292 100644
--- a/gcc/config/alpha/linux-elf.h
+++ b/gcc/config/alpha/linux-elf.h
@@ -23,8 +23,8 @@ along with GCC; see the file COPYING3. If not see
@@ -46,10 +46,10 @@ index 36b74dc1993..02373578af8 100644
#define CHOOSE_DYNAMIC_LINKER(G, U) "%{mglibc:" G ";:" U "}"
#elif DEFAULT_LIBC == LIBC_GLIBC
diff --git a/gcc/config/arm/linux-eabi.h b/gcc/config/arm/linux-eabi.h
-index 8585fde3d41..b3af68cac57 100644
+index 66ec0ea3980..e4ade2e2ab0 100644
--- a/gcc/config/arm/linux-eabi.h
+++ b/gcc/config/arm/linux-eabi.h
-@@ -62,8 +62,8 @@
+@@ -65,8 +65,8 @@
GLIBC_DYNAMIC_LINKER_DEFAULT and TARGET_DEFAULT_FLOAT_ABI. */
#undef GLIBC_DYNAMIC_LINKER
@@ -61,7 +61,7 @@ index 8585fde3d41..b3af68cac57 100644
#define GLIBC_DYNAMIC_LINKER \
diff --git a/gcc/config/arm/linux-elf.h b/gcc/config/arm/linux-elf.h
-index cfcd9cb1a5c..a798e987ecb 100644
+index 9a360defd21..98f6e960b64 100644
--- a/gcc/config/arm/linux-elf.h
+++ b/gcc/config/arm/linux-elf.h
@@ -60,7 +60,7 @@
@@ -74,7 +74,7 @@ index cfcd9cb1a5c..a798e987ecb 100644
#define LINUX_TARGET_LINK_SPEC "%{h*} \
%{static:-Bstatic} \
diff --git a/gcc/config/i386/linux.h b/gcc/config/i386/linux.h
-index 69f97f15b0d..71bc31d9231 100644
+index 9a6e2d99896..31efbb73016 100644
--- a/gcc/config/i386/linux.h
+++ b/gcc/config/i386/linux.h
@@ -20,7 +20,7 @@ along with GCC; see the file COPYING3. If not see
@@ -87,7 +87,7 @@ index 69f97f15b0d..71bc31d9231 100644
#undef MUSL_DYNAMIC_LINKER
#define MUSL_DYNAMIC_LINKER "/lib/ld-musl-i386.so.1"
diff --git a/gcc/config/i386/linux64.h b/gcc/config/i386/linux64.h
-index f2d913e30ac..8725f33d8a5 100644
+index c08221c4210..dbb474d792b 100644
--- a/gcc/config/i386/linux64.h
+++ b/gcc/config/i386/linux64.h
@@ -27,9 +27,9 @@ see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
@@ -104,10 +104,10 @@ index f2d913e30ac..8725f33d8a5 100644
#undef MUSL_DYNAMIC_LINKER32
#define MUSL_DYNAMIC_LINKER32 "/lib/ld-musl-i386.so.1"
diff --git a/gcc/config/linux.h b/gcc/config/linux.h
-index 2ea4ff92c1d..487b0c0923b 100644
+index c3c4a219e67..4b05d8e93d1 100644
--- a/gcc/config/linux.h
+++ b/gcc/config/linux.h
-@@ -81,10 +81,10 @@ see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
+@@ -94,10 +94,10 @@ see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
GLIBC_DYNAMIC_LINKER must be defined for each target using them, or
GLIBC_DYNAMIC_LINKER32 and GLIBC_DYNAMIC_LINKER64 for targets
supporting both 32-bit and 64-bit compilation. */
@@ -123,7 +123,7 @@ index 2ea4ff92c1d..487b0c0923b 100644
#define BIONIC_DYNAMIC_LINKER32 "/system/bin/linker"
#define BIONIC_DYNAMIC_LINKER64 "/system/bin/linker64"
diff --git a/gcc/config/mips/linux.h b/gcc/config/mips/linux.h
-index 2dfd0c18b90..12057c51b5e 100644
+index 6f79ac9c01a..25de96f9561 100644
--- a/gcc/config/mips/linux.h
+++ b/gcc/config/mips/linux.h
@@ -22,20 +22,20 @@ along with GCC; see the file COPYING3. If not see
@@ -154,10 +154,10 @@ index 2dfd0c18b90..12057c51b5e 100644
#undef MUSL_DYNAMIC_LINKER32
#define MUSL_DYNAMIC_LINKER32 \
diff --git a/gcc/config/riscv/linux.h b/gcc/config/riscv/linux.h
-index aa8a28d5d..ebf9551c9 100644
+index 58dd18b89f3..112ba9cd764 100644
--- a/gcc/config/riscv/linux.h
+++ b/gcc/config/riscv/linux.h
-@@ -22,7 +22,7 @@ along with GCC; see the file COPYING3.
+@@ -22,7 +22,7 @@ along with GCC; see the file COPYING3. If not see
GNU_USER_TARGET_OS_CPP_BUILTINS(); \
} while (0)
@@ -167,10 +167,10 @@ index aa8a28d5d..ebf9551c9 100644
#define MUSL_ABI_SUFFIX \
"%{mabi=ilp32:-sf}" \
diff --git a/gcc/config/rs6000/linux64.h b/gcc/config/rs6000/linux64.h
-index 90fe6566255..55695dadd91 100644
+index 9946d3fed94..45a9a7cae59 100644
--- a/gcc/config/rs6000/linux64.h
+++ b/gcc/config/rs6000/linux64.h
-@@ -420,16 +420,11 @@ extern int dot_symbols;
+@@ -423,24 +423,19 @@ extern int dot_symbols;
#undef LINK_OS_DEFAULT_SPEC
#define LINK_OS_DEFAULT_SPEC "%(link_os_linux)"
@@ -189,21 +189,19 @@ index 90fe6566255..55695dadd91 100644
+#define GLIBC_DYNAMIC_LINKER64 "%{mabi=elfv2:" SYSTEMLIBS_DIR "ld64.so.2;:" SYSTEMLIBS_DIR "ld64.so.1}"
#endif
+ #undef MUSL_DYNAMIC_LINKER32
#define MUSL_DYNAMIC_LINKER32 \
-@@ -437,8 +432,9 @@ extern int dot_symbols;
+- "/lib/ld-musl-powerpc" MUSL_DYNAMIC_LINKER_E "%{msoft-float:-sf}.so.1"
++ SYSTEMLIBS_DIR "ld-musl-powerpc" MUSL_DYNAMIC_LINKER_E "%{msoft-float:-sf}.so.1"
+ #undef MUSL_DYNAMIC_LINKER64
#define MUSL_DYNAMIC_LINKER64 \
- "/lib/ld-musl-powerpc64" MUSL_DYNAMIC_LINKER_E "%{msoft-float:-sf}.so.1"
+- "/lib/ld-musl-powerpc64" MUSL_DYNAMIC_LINKER_E "%{msoft-float:-sf}.so.1"
++ SYSTEMLIBS_DIR "ld-musl-powerpc64" MUSL_DYNAMIC_LINKER_E "%{msoft-float:-sf}.so.1"
--#define UCLIBC_DYNAMIC_LINKER32 "/lib/ld-uClibc.so.0"
--#define UCLIBC_DYNAMIC_LINKER64 "/lib/ld64-uClibc.so.0"
-+#define UCLIBC_DYNAMIC_LINKER32 SYSTEMLIBS_DIR "ld-uClibc.so.0"
-+#define UCLIBC_DYNAMIC_LINKER64 SYSTEMLIBS_DIR "ld64-uClibc.so.0"
-+
- #if DEFAULT_LIBC == LIBC_UCLIBC
- #define CHOOSE_DYNAMIC_LINKER(G, U, M) \
- "%{mglibc:" G ";:%{mmusl:" M ";:" U "}}"
+ #undef DEFAULT_ASM_ENDIAN
+ #if (TARGET_DEFAULT & MASK_LITTLE_ENDIAN)
diff --git a/gcc/config/sh/linux.h b/gcc/config/sh/linux.h
-index 6d2ccd012ba..ec78a89ce15 100644
+index c9897b7aca5..82f275319cc 100644
--- a/gcc/config/sh/linux.h
+++ b/gcc/config/sh/linux.h
@@ -64,7 +64,7 @@ along with GCC; see the file COPYING3. If not see
@@ -216,10 +214,10 @@ index 6d2ccd012ba..ec78a89ce15 100644
#undef SUBTARGET_LINK_EMUL_SUFFIX
#define SUBTARGET_LINK_EMUL_SUFFIX "%{mfdpic:_fd;:_linux}"
diff --git a/gcc/config/sparc/linux.h b/gcc/config/sparc/linux.h
-index 9fb03af0fe9..401fddbbb22 100644
+index 08476f1d94d..80440e712ad 100644
--- a/gcc/config/sparc/linux.h
+++ b/gcc/config/sparc/linux.h
-@@ -83,7 +83,7 @@ extern const char *host_detect_local_cpu (int argc, const char **argv);
+@@ -84,7 +84,7 @@ extern const char *host_detect_local_cpu (int argc, const char **argv);
When the -shared link option is used a final link is not being
done. */
@@ -229,7 +227,7 @@ index 9fb03af0fe9..401fddbbb22 100644
#undef LINK_SPEC
#define LINK_SPEC "-m elf32_sparc %{shared:-shared} \
diff --git a/gcc/config/sparc/linux64.h b/gcc/config/sparc/linux64.h
-index c1fe42165b7..26a79bfa2e3 100644
+index 789d1df4bd5..b920c680fb1 100644
--- a/gcc/config/sparc/linux64.h
+++ b/gcc/config/sparc/linux64.h
@@ -84,8 +84,8 @@ along with GCC; see the file COPYING3. If not see
@@ -243,6 +241,3 @@ index c1fe42165b7..26a79bfa2e3 100644
#ifdef SPARC_BI_ARCH
---
-2.17.0
-
diff --git a/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0037-sync-gcc-stddef.h-with-musl.patch b/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0037-sync-gcc-stddef.h-with-musl.patch
index f8a7f41a..b99ac429 100644
--- a/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0037-sync-gcc-stddef.h-with-musl.patch
+++ b/bsp/meta-synopsys/recipes-devtools/gcc/gcc-arc/0037-sync-gcc-stddef.h-with-musl.patch
@@ -1,23 +1,23 @@
-From 602abaab15ffb60bf1797187a71b485042c56360 Mon Sep 17 00:00:00 2001
+From 39e2f61d262f9f6c7a91068998dea80791ef665e Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 3 Feb 2017 12:56:00 -0800
-Subject: [PATCH 37/39] sync gcc stddef.h with musl
+Subject: [PATCH 33/36] sync gcc stddef.h with musl
musl defines ptrdiff_t size_t and wchar_t
so dont define them here if musl is definining them
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
gcc/ginclude/stddef.h | 9 +++++++++
1 file changed, 9 insertions(+)
diff --git a/gcc/ginclude/stddef.h b/gcc/ginclude/stddef.h
-index 31b96a7e5e1..438a3ce7c56 100644
+index da692e1c01a..9a00c261adb 100644
--- a/gcc/ginclude/stddef.h
+++ b/gcc/ginclude/stddef.h
-@@ -134,6 +134,7 @@ _TYPE_wchar_t;
+@@ -128,6 +128,7 @@ _TYPE_wchar_t;
#ifndef ___int_ptrdiff_t_h
#ifndef _GCC_PTRDIFF_T
#ifndef _PTRDIFF_T_DECLARED /* DragonFly */
@@ -25,7 +25,7 @@ index 31b96a7e5e1..438a3ce7c56 100644
#define _PTRDIFF_T
#define _T_PTRDIFF_
#define _T_PTRDIFF
-@@ -143,10 +144,12 @@ _TYPE_wchar_t;
+@@ -137,10 +138,12 @@ _TYPE_wchar_t;
#define ___int_ptrdiff_t_h
#define _GCC_PTRDIFF_T
#define _PTRDIFF_T_DECLARED
@@ -38,7 +38,7 @@ index 31b96a7e5e1..438a3ce7c56 100644
#endif /* _PTRDIFF_T_DECLARED */
#endif /* _GCC_PTRDIFF_T */
#endif /* ___int_ptrdiff_t_h */
-@@ -184,6 +187,7 @@ typedef __PTRDIFF_TYPE__ ptrdiff_t;
+@@ -178,6 +181,7 @@ typedef __PTRDIFF_TYPE__ ptrdiff_t;
#ifndef _GCC_SIZE_T
#ifndef _SIZET_
#ifndef __size_t
@@ -46,15 +46,15 @@ index 31b96a7e5e1..438a3ce7c56 100644
#define __size_t__ /* BeOS */
#define __SIZE_T__ /* Cray Unicos/Mk */
#define _SIZE_T
-@@ -200,6 +204,7 @@ typedef __PTRDIFF_TYPE__ ptrdiff_t;
+@@ -194,6 +198,7 @@ typedef __PTRDIFF_TYPE__ ptrdiff_t;
#define ___int_size_t_h
#define _GCC_SIZE_T
#define _SIZET_
+#define __DEFINED_size_t /* musl */
- #if (defined (__FreeBSD__) && (__FreeBSD__ >= 5)) \
+ #if defined (__FreeBSD__) \
|| defined(__DragonFly__) \
- || defined(__FreeBSD_kernel__)
-@@ -235,6 +240,7 @@ typedef long ssize_t;
+ || defined(__FreeBSD_kernel__) \
+@@ -228,6 +233,7 @@ typedef long ssize_t;
#endif /* _SIZE_T */
#endif /* __SIZE_T__ */
#endif /* __size_t__ */
@@ -62,7 +62,7 @@ index 31b96a7e5e1..438a3ce7c56 100644
#undef __need_size_t
#endif /* _STDDEF_H or __need_size_t. */
-@@ -264,6 +270,7 @@ typedef long ssize_t;
+@@ -257,6 +263,7 @@ typedef long ssize_t;
#ifndef ___int_wchar_t_h
#ifndef __INT_WCHAR_T_H
#ifndef _GCC_WCHAR_T
@@ -70,7 +70,7 @@ index 31b96a7e5e1..438a3ce7c56 100644
#define __wchar_t__ /* BeOS */
#define __WCHAR_T__ /* Cray Unicos/Mk */
#define _WCHAR_T
-@@ -279,6 +286,7 @@ typedef long ssize_t;
+@@ -272,6 +279,7 @@ typedef long ssize_t;
#define __INT_WCHAR_T_H
#define _GCC_WCHAR_T
#define _WCHAR_T_DECLARED
@@ -78,7 +78,7 @@ index 31b96a7e5e1..438a3ce7c56 100644
/* On BSD/386 1.1, at least, machine/ansi.h defines _BSD_WCHAR_T_
instead of _WCHAR_T_, and _BSD_RUNE_T_ (which, unlike the other
-@@ -344,6 +352,7 @@ typedef __WCHAR_TYPE__ wchar_t;
+@@ -337,6 +345,7 @@ typedef __WCHAR_TYPE__ wchar_t;
#endif
#endif /* __WCHAR_T__ */
#endif /* __wchar_t__ */
@@ -87,5 +87,5 @@ index 31b96a7e5e1..438a3ce7c56 100644
#endif /* _STDDEF_H or __need_wchar_t. */
--
-2.17.0
+2.22.1
diff --git a/bsp/meta-synopsys/recipes-devtools/gcc/gcc-cross-initial_arc.bb b/bsp/meta-synopsys/recipes-devtools/gcc/gcc-cross-initial_arc.bb
index 22d4b05c..d9354f42 100644
--- a/bsp/meta-synopsys/recipes-devtools/gcc/gcc-cross-initial_arc.bb
+++ b/bsp/meta-synopsys/recipes-devtools/gcc/gcc-cross-initial_arc.bb
@@ -1,2 +1,2 @@
require recipes-devtools/gcc/gcc-cross_${PV}.bb
-require recipes-devtools/gcc/gcc-cross-initial.inc
+require recipes-devtools/gcc/gcc-cross.inc
diff --git a/bsp/meta-synopsys/recipes-devtools/gcc/gcc-crosssdk-initial_arc.bb b/bsp/meta-synopsys/recipes-devtools/gcc/gcc-crosssdk-initial_arc.bb
index c0b66267..886c7f12 100644
--- a/bsp/meta-synopsys/recipes-devtools/gcc/gcc-crosssdk-initial_arc.bb
+++ b/bsp/meta-synopsys/recipes-devtools/gcc/gcc-crosssdk-initial_arc.bb
@@ -1,3 +1,3 @@
require recipes-devtools/gcc/gcc-cross-initial_${PV}.bb
-require recipes-devtools/gcc/gcc-crosssdk-initial.inc
+require recipes-devtools/gcc/gcc-crosssdk.inc
diff --git a/bsp/meta-synopsys/recipes-devtools/gcc/libgcc_arc.bb b/bsp/meta-synopsys/recipes-devtools/gcc/libgcc_arc.bb
index 21ad7653..340300cd 100644
--- a/bsp/meta-synopsys/recipes-devtools/gcc/libgcc_arc.bb
+++ b/bsp/meta-synopsys/recipes-devtools/gcc/libgcc_arc.bb
@@ -1,9 +1,2 @@
require recipes-devtools/gcc/gcc-${PV}.inc
require recipes-devtools/gcc/libgcc.inc
-INSANE_SKIP_${PN} = "ldflags staticdev"
-INSANE_SKIP_${PN}-dev = "ldflags staticdev"
-INSANE_SKIP_${PN} = "staticdev"
-INSANE_SKIP_libgcc_eh = "staticdev"
-INSANE_SKIP_libgcc_eh-dev = "staticdev"
-INSANE_SKIP_libgcov-dev = "staticdev"
-INSANE_SKIP_libgcov = "staticdev"
diff --git a/bsp/meta-synopsys/recipes-devtools/gcc/ltmain.sh b/bsp/meta-synopsys/recipes-devtools/gcc/ltmain.sh
new file mode 120000
index 00000000..00e62a0e
--- /dev/null
+++ b/bsp/meta-synopsys/recipes-devtools/gcc/ltmain.sh
@@ -0,0 +1 @@
+/global/freeware/Linux/RHEL7/libtool/share/libtool/build-aux/ltmain.sh \ No newline at end of file