summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/board-rtos/board-rtos_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/board-rtos/board-rtos_git.bb')
-rw-r--r--bsp/meta-ti/recipes-bsp/board-rtos/board-rtos_git.bb23
1 files changed, 10 insertions, 13 deletions
diff --git a/bsp/meta-ti/recipes-bsp/board-rtos/board-rtos_git.bb b/bsp/meta-ti/recipes-bsp/board-rtos/board-rtos_git.bb
index d85f8c94..99530d19 100644
--- a/bsp/meta-ti/recipes-bsp/board-rtos/board-rtos_git.bb
+++ b/bsp/meta-ti/recipes-bsp/board-rtos/board-rtos_git.bb
@@ -1,6 +1,10 @@
SUMMARY = "TI RTOS Board Library"
-inherit ti-pdk
+inherit ti-pdk ti-pdk-fetch
+
+TI_PDK_COMP = "ti.board"
+
+PE = "1"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://board.h;beginline=1;endline=32;md5=9bed8e4ac2fb37fc627cefe49eb1c919"
@@ -8,18 +12,8 @@ LIC_FILES_CHKSUM = "file://board.h;beginline=1;endline=32;md5=9bed8e4ac2fb37fc62
COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|omapl1|c66x|k3"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-BOARD_GIT_URI = "git://git.ti.com/keystone-rtos/board.git"
-BOARD_GIT_PROTOCOL = "git"
-BOARD_GIT_BRANCH = "master"
-
-# Below commit ID corresponds to "DEV.BOARD.01.00.10.04C"
-BOARD_SRCREV = "e794b8d6a58dc800cb406b05f45b46652c9d4f4c"
-BRANCH ="${BOARD_GIT_BRANCH}"
-SRC_URI = "${BOARD_GIT_URI};protocol=${BOARD_GIT_PROTOCOL};branch=${BRANCH}"
-SRCREV = "${BOARD_SRCREV}"
-PV = "01.00.10.04C"
PR = "r0"
DEPENDS_append = " i2c-lld-rtos \
@@ -61,10 +55,13 @@ DEPENDS_append_dra7xx = " pm-lld-rtos \
mmcsd-lld-rtos \
"
-DEPENDS_append_k3 = " sciclient-rtos \
+DEPENDS_append_am65xx = " sciclient-rtos \
pm-lld-rtos \
"
-
+DEPENDS_append_j7-evm = " udma-lld-rtos \
+ sciclient-rtos \
+ mmcsd-lld-rtos \
+"
# Build with make instead of XDC
TI_PDK_XDCMAKE = "0"