summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb')
-rw-r--r--bsp/meta-ti/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb26
1 files changed, 19 insertions, 7 deletions
diff --git a/bsp/meta-ti/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb b/bsp/meta-ti/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb
index ed30ef45..59b75b3a 100644
--- a/bsp/meta-ti/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb
+++ b/bsp/meta-ti/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb
@@ -9,15 +9,27 @@ LIC_FILES_CHKSUM = "file://src/ibl.h;beginline=1;endline=34;md5=ee7d7a3305d1e524
require recipes-ti/includes/ti-paths.inc
-DEPENDS = "ti-cgt6x-7-native"
+DEPENDS = " ti-cgt6x-7-native \
+ bison-native \
+ flex-native \
+"
PACKAGE_ARCH = "${MACHINE_ARCH}"
COMPATIBLE_MACHINE = "c66x"
-BRANCH = "master"
-SRC_URI = "git://git.ti.com/keystone-rtos/ibl.git;protocol=git;branch=${BRANCH}"
-SRCREV = "f7ed32cc8911e3353dd01080da9b725b44a12285"
-PR = "r0"
+CLEANBROKEN = "1"
+
+IBL_BOOT_GIT_URI = "git://git.ti.com/keystone-rtos/ibl.git"
+IBL_BOOT_GIT_PROTOCOL = "git"
+IBL_BOOT_GIT_BRANCH = "master"
+IBL_BOOT_SRCREV = "ed3f0989d8cdc813b7ca1ed899c4d84b63de3a75"
+
+BRANCH = "${IBL_BOOT_GIT_BRANCH}"
+SRC_URI = "${IBL_BOOT_GIT_URI};protocol=${IBL_BOOT_GIT_PROTOCOL};branch=${BRANCH}"
+SRCREV = "${IBL_BOOT_SRCREV}"
+
+
+PR = "r2"
S = "${WORKDIR}/git"
@@ -28,8 +40,8 @@ IBLTARGETS_c665x-evm = "evm_c6657_i2c"
IBLTARGETS_c667x-evm = "evm_c6678_i2c"
IBLENDIAN = ""
-IBLENDIAN_c665x-evm = "little big"
-IBLENDIAN_c667x-evm = "little big"
+IBLENDIAN_c665x-evm = "little"
+IBLENDIAN_c667x-evm = "little"
export C6X_BASE_DIR="${TI_CGT6X_7_INSTALL_DIR}"
export TOOLSC6X="${C6X_BASE_DIR}"