summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/mmap-lld
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/mmap-lld')
-rw-r--r--bsp/meta-ti/recipes-bsp/mmap-lld/mmap-lld-rtos_git.bb10
-rw-r--r--bsp/meta-ti/recipes-bsp/mmap-lld/mmap-lld-test_git.bb44
-rw-r--r--bsp/meta-ti/recipes-bsp/mmap-lld/mmap-lld.inc22
-rw-r--r--bsp/meta-ti/recipes-bsp/mmap-lld/mmap-lld_git.bb15
4 files changed, 91 insertions, 0 deletions
diff --git a/bsp/meta-ti/recipes-bsp/mmap-lld/mmap-lld-rtos_git.bb b/bsp/meta-ti/recipes-bsp/mmap-lld/mmap-lld-rtos_git.bb
new file mode 100644
index 00000000..faee5973
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/mmap-lld/mmap-lld-rtos_git.bb
@@ -0,0 +1,10 @@
+inherit ti-pdk
+
+require recipes-bsp/mmap-lld/mmap-lld.inc
+
+PR = "${INC_PR}.0"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+# HTML doc link params
+PDK_COMP_LINK_TEXT = "MMAP LLD"
diff --git a/bsp/meta-ti/recipes-bsp/mmap-lld/mmap-lld-test_git.bb b/bsp/meta-ti/recipes-bsp/mmap-lld/mmap-lld-test_git.bb
new file mode 100644
index 00000000..8a09524e
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/mmap-lld/mmap-lld-test_git.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "TI KEYSTONE MMAP driver test binaries "
+include mmap-lld.inc
+
+PR = "${INC_PR}.0"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+DEPENDS="common-csl-ip mmap-lld"
+RDEPENDS_${PN}="uio-module-drv"
+
+DEVICELIST_k2hk = "k2h k2k"
+DEVICELIST_k2e = "k2e"
+DEVICELIST_k2l = "k2l"
+DEVICELIST_k2g = "k2g"
+
+CHOICELIST = " yes \
+ no \
+"
+
+do_compile () {
+ for device in ${DEVICELIST}
+ do
+ make -f makefile_armv7 clean \
+ PDK_INSTALL_PATH="${STAGING_INCDIR}" \
+ DEVICE="$device" MPAX_SRC_DIR="${S}"
+ for choice in ${CHOICELIST}
+ do
+ make -f makefile_armv7 tests examples \
+ PDK_INSTALL_PATH=${STAGING_INCDIR} \
+ DEVICE="$device" MPAX_SRC_DIR="${S}" \
+ USEDYNAMIC_LIB="$choice"
+ done
+ done
+}
+
+do_install () {
+ for device in ${DEVICELIST}
+ do
+ make -f makefile_armv7 installbin \
+ PDK_INSTALL_PATH=${STAGING_INCDIR} \
+ DEVICE="$device" MPAX_SRC_DIR="${S}" \
+ INSTALL_BIN_BASE_DIR="${D}/${bindir}"
+ done
+}
diff --git a/bsp/meta-ti/recipes-bsp/mmap-lld/mmap-lld.inc b/bsp/meta-ti/recipes-bsp/mmap-lld/mmap-lld.inc
new file mode 100644
index 00000000..e6c4cd62
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/mmap-lld/mmap-lld.inc
@@ -0,0 +1,22 @@
+LICENSE = "BSD-3-Clause"
+
+COMPATIBLE_MACHINE = "keystone"
+
+LIC_FILES_CHKSUM = "file://COPYING.txt;md5=b3315b8190036fe1c6a8263d02e15606"
+
+MMAP_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/mmap-lld.git"
+MMAP_LLD_GIT_PROTOCOL = "git"
+MMAP_LLD_GIT_BRANCH = "master"
+MMAP_LLD_GIT_DESTSUFFIX = "git/ti/runtime/mmap"
+
+# Commit correspond to DEV.MMAP.02.00.00.08A
+MMAP_LLD_SRCREV = "bbccde8da6c87f59af3b0494e2d75ba52c69df20"
+
+BRANCH="${MMAP_LLD_GIT_BRANCH}"
+SRC_URI = "${MMAP_LLD_GIT_URI};destsuffix=${MMAP_LLD_GIT_DESTSUFFIX};protocol=${MMAP_LLD_GIT_PROTOCOL};branch=${BRANCH}"
+SRCREV = "${MMAP_LLD_SRCREV}"
+
+PV = "2.0.0.8A"
+INC_PR = "r0"
+
+S = "${WORKDIR}/git/ti/runtime/mmap"
diff --git a/bsp/meta-ti/recipes-bsp/mmap-lld/mmap-lld_git.bb b/bsp/meta-ti/recipes-bsp/mmap-lld/mmap-lld_git.bb
new file mode 100644
index 00000000..cfc5d4c9
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/mmap-lld/mmap-lld_git.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "TI KEYSTONE mmap driver using Keystone MPAX Programming"
+include mmap-lld.inc
+
+PR = "${INC_PR}.0"
+
+DEPENDS="common-csl-ip"
+
+do_compile () {
+ make -f makefile_armv7 clean lib PDK_INSTALL_PATH=${STAGING_INCDIR}
+}
+
+do_install () {
+ make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
+ chown -R root:root ${D}
+}