summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/powervr-drivers
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/powervr-drivers')
-rw-r--r--bsp/meta-ti/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.10.5371573.bb14
-rw-r--r--bsp/meta-ti/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb18
2 files changed, 19 insertions, 13 deletions
diff --git a/bsp/meta-ti/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.10.5371573.bb b/bsp/meta-ti/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.10.5371573.bb
index 2f4b7ac5..da4ec6e6 100644
--- a/bsp/meta-ti/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.10.5371573.bb
+++ b/bsp/meta-ti/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.10.5371573.bb
@@ -3,26 +3,28 @@ HOMEPAGE = "http://git.ti.com/graphics/ti-img-rogue-driver"
LICENSE = "MIT | GPLv2"
LIC_FILES_CHKSUM = "file://README;beginline=15;endline=20;md5=0403c7dea01a2b8232261e805325fac2"
-inherit module
+inherit module features_check
-MACHINE_KERNEL_PR_append = "e"
+REQUIRED_MACHINE_FEATURES = "gpu"
+
+MACHINE_KERNEL_PR_append = "f"
PR = "${MACHINE_KERNEL_PR}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "j7-evm"
+COMPATIBLE_MACHINE = "j7"
DEPENDS = "virtual/kernel"
PROVIDES = "virtual/gpudriver"
-BRANCH = "linuxws/thud/k4.19/${PV}"
+BRANCH = "linuxws/zeus/k5.4/${PV}"
SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-driver.git;branch=${BRANCH} \
file://0001-km-support-general-toolchain.patch \
"
S = "${WORKDIR}/git"
-SRCREV = "fe40a51f33987c59aca300f8a976a9a9c8112703"
+SRCREV = "e0bc128ee5098e30c9fb096634ba6bec01b5fc17"
PVR_SOC = "j721e_linux"
PVR_BVNC = "22.104.208.318"
@@ -32,5 +34,5 @@ PVR_WS = "wayland"
EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" RGX_BVNC=${PVR_BVNC} BUILD=${PVR_BUILD} PVR_BUILD_DIR=${PVR_SOC} WINDOW_SYSTEM=${PVR_WS}'
do_install() {
- make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B}/binary_${PVR_SOC}_${PVR_WS}_${PVR_BUILD}/target_aarch64/kbuild INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install
+ make -C ${STAGING_KERNEL_DIR} M=${B}/binary_${PVR_SOC}_${PVR_WS}_${PVR_BUILD}/target_aarch64/kbuild INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install
}
diff --git a/bsp/meta-ti/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb b/bsp/meta-ti/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb
index 5c1a50de..734e780e 100644
--- a/bsp/meta-ti/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb
+++ b/bsp/meta-ti/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb
@@ -3,11 +3,13 @@ HOMEPAGE = "https://git.ti.com/graphics/omap5-sgx-ddk-linux"
LICENSE = "MIT | GPLv2"
LIC_FILES_CHKSUM = "file://eurasia_km/README;beginline=13;endline=22;md5=74506d9b8e5edbce66c2747c50fcef12"
-inherit module
+inherit module features_check
-COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k3"
+REQUIRED_MACHINE_FEATURES = "gpu"
-MACHINE_KERNEL_PR_append = "s"
+COMPATIBLE_MACHINE = "pandaboard|beagleboard|ti33x|ti43x|omap-a15|k3"
+
+MACHINE_KERNEL_PR_append = "v"
PR = "${MACHINE_KERNEL_PR}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -16,7 +18,7 @@ DEPENDS = "virtual/kernel"
PROVIDES = "virtual/gpudriver"
-BRANCH = "ti-img-sgx/${PV}/k4.19"
+BRANCH = "ti-img-sgx/${PV}/k5.4"
SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-linux.git;protocol=git;branch=${BRANCH} \
file://0001-km-support-OpenEmbedded-hardfp-toolchain-w-o-gnueabi.patch \
@@ -24,12 +26,14 @@ SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-linux.git;protocol=git;branch
S = "${WORKDIR}/git"
-SRCREV = "4519ed3b83d1d72207ddc2874c7eb5e5a7f20d8d"
+SRCREV = "50c1ec2308b9f64488d252ac55d65b51a0dfe287"
TARGET_PRODUCT_omap-a15 = "jacinto6evm"
TARGET_PRODUCT_ti33x = "ti335x"
TARGET_PRODUCT_ti43x = "ti437x"
TARGET_PRODUCT_k3 = "ti654x"
+TARGET_PRODUCT_beagleboard = "ti343x"
+TARGET_PRODUCT_pandaboard = "ti443x"
EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" TARGET_PRODUCT=${TARGET_PRODUCT} WINDOW_SYSTEM=nulldrmws'
@@ -38,9 +42,9 @@ do_compile_prepend() {
}
do_install() {
- make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B}/eurasia_km/eurasiacon/binary_omap_linux_nulldrmws_release/target_armhf/kbuild INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install
+ make -C ${STAGING_KERNEL_DIR} M=${B}/eurasia_km/eurasiacon/binary_omap_linux_nulldrmws_release/target_armhf/kbuild INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install
}
do_install_k3() {
- make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B}/eurasia_km/eurasiacon/binary_omap_linux_nulldrmws_release/target_aarch64/kbuild INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install
+ make -C ${STAGING_KERNEL_DIR} M=${B}/eurasia_km/eurasiacon/binary_omap_linux_nulldrmws_release/target_aarch64/kbuild INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install
}