summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/utils-rtos
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/utils-rtos')
-rw-r--r--bsp/meta-ti/recipes-bsp/utils-rtos/profiling-rtos_git.bb18
-rw-r--r--bsp/meta-ti/recipes-bsp/utils-rtos/trace-rtos_git.bb28
2 files changed, 33 insertions, 13 deletions
diff --git a/bsp/meta-ti/recipes-bsp/utils-rtos/profiling-rtos_git.bb b/bsp/meta-ti/recipes-bsp/utils-rtos/profiling-rtos_git.bb
index f578b7e5..9846804d 100644
--- a/bsp/meta-ti/recipes-bsp/utils-rtos/profiling-rtos_git.bb
+++ b/bsp/meta-ti/recipes-bsp/utils-rtos/profiling-rtos_git.bb
@@ -1,6 +1,10 @@
SUMMARY = "TI RTOS profiling utilities"
-inherit ti-pdk
+inherit ti-pdk ti-pdk-fetch
+
+TI_PDK_COMP = "ti.utils.profiling"
+
+PE = "1"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://profilingver.h;beginline=1;endline=46;md5=974494ad60f33cfc0340e421c5a5a7a0"
@@ -8,21 +12,9 @@ LIC_FILES_CHKSUM = "file://profilingver.h;beginline=1;endline=46;md5=974494ad60f
COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|c66x|k3"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-PROFILING_GIT_URI = "git://git.ti.com/keystone-rtos/utils.git"
-PROFILING_GIT_PROTOCOL = "git"
-PROFILING_GIT_BRANCH = "master"
-
-# Below commit ID corresponds to "DEV.UTILS.01.00.00.08"
-PROFILING_SRCREV = "9c30f4df9ece2d5589d5f7e977d54acf1062185c"
-
-BRANCH = "${PROFILING_GIT_BRANCH}"
-SRC_URI = "${PROFILING_GIT_URI};protocol=${PROFILING_GIT_PROTOCOL};branch=${BRANCH}"
-SRCREV = "${PROFILING_SRCREV}"
-PV = "01.00.00.08"
PR = "r0"
-S = "${WORKDIR}/git/profiling"
# Build with make instead of XDC
TI_PDK_XDCMAKE = "0"
diff --git a/bsp/meta-ti/recipes-bsp/utils-rtos/trace-rtos_git.bb b/bsp/meta-ti/recipes-bsp/utils-rtos/trace-rtos_git.bb
new file mode 100644
index 00000000..249ffc79
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/utils-rtos/trace-rtos_git.bb
@@ -0,0 +1,28 @@
+SUMMARY = "TI RTOS Trace utility"
+
+DESCRIPTION = "This utility allows for tracing support in PDK drivers"
+
+inherit ti-pdk ti-pdk-fetch
+
+TI_PDK_COMP = "ti.utils.trace"
+
+PE = "1"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://tracever.h;beginline=19;endline=47;md5=983f531ecfc9fc8c4bc3af9333ab6696"
+
+COMPATIBLE_MACHINE = "k3"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+
+PR = "r0"
+
+
+# Build with make instead of XDC
+TI_PDK_XDCMAKE = "0"
+
+export PDK_TRACE_ROOT_PATH ="${WORKDIR}/build"
+export DEST_ROOT="${S}"
+
+# HTML doc link params
+PDK_COMP_LINK_TEXT = "Trace Utility"