summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/vps-lld/vps-lld-rtos_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/vps-lld/vps-lld-rtos_git.bb')
-rw-r--r--bsp/meta-ti/recipes-bsp/vps-lld/vps-lld-rtos_git.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/bsp/meta-ti/recipes-bsp/vps-lld/vps-lld-rtos_git.bb b/bsp/meta-ti/recipes-bsp/vps-lld/vps-lld-rtos_git.bb
index a06aae49..e2834a63 100644
--- a/bsp/meta-ti/recipes-bsp/vps-lld/vps-lld-rtos_git.bb
+++ b/bsp/meta-ti/recipes-bsp/vps-lld/vps-lld-rtos_git.bb
@@ -25,7 +25,9 @@ PR = "r0"
S = "${WORKDIR}/${VPS_LLD_GIT_DESTSUFFIX}"
-DEPENDS = " ti-sysbios \
+# Add to DEPENDS set in ti-pdk.bbclass
+DEPENDS_append = " \
+ ti-sysbios \
osal-rtos \
edma3-lld-rtos \
board-rtos \
@@ -39,6 +41,9 @@ export DEST_ROOT="${S}"
# Build with make instead of XDC
TI_PDK_XDCMAKE = "0"
+# The makefile will push these on the XDCPATH
+export EDMA3LLD_BIOS6_INSTALLDIR = "${EDMA3_LLD_INSTALL_DIR}"
+
do_compile_append() {
# Delete archive created by XDC release command since it does not contain all content
find -name "*.tar" -exec rm -f {} \;