summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-ti/recipes-graphics')
-rw-r--r--bsp/meta-ti/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb8
-rw-r--r--bsp/meta-ti/recipes-graphics/libgles/ti-img-rogue-umlibs_1.10.5371573.bb17
-rw-r--r--bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_1.17.4948957.bb25
-rw-r--r--bsp/meta-ti/recipes-graphics/omapfbplay/files/0001-omapfbplay-switch-CODEC_TYPE_VIDEO-to-AVMEDIA_TYPE_V.patch26
-rw-r--r--bsp/meta-ti/recipes-graphics/omapfbplay/files/omapfbplay-errorhandling.patch34
-rw-r--r--bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay-cmem_git.bb16
-rw-r--r--bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay-dce_git.bb7
-rw-r--r--bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay-xv_git.bb3
-rw-r--r--bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay.inc37
-rw-r--r--bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay_git.bb3
-rw-r--r--bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config/omap3/xorg.conf29
-rw-r--r--bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config/omap4/xorg.conf15
-rw-r--r--bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config/omapl138/xorg.conf29
-rw-r--r--bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config/ti33x/xorg.conf29
-rw-r--r--bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend1
15 files changed, 31 insertions, 248 deletions
diff --git a/bsp/meta-ti/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb b/bsp/meta-ti/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
index e8c2f011..55758682 100644
--- a/bsp/meta-ti/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
+++ b/bsp/meta-ti/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
@@ -3,7 +3,11 @@ HOMEPAGE = "https://git.ti.com/graphics/ti-gc320-libs"
LICENSE = "TI-TSPA"
LIC_FILES_CHKSUM = "file://Manifest.html;md5=a9121e8936ace09820d23f7626daaca5"
-COMPATIBLE_MACHINE = "dra7xx"
+inherit features_check
+
+REQUIRED_MACHINE_FEATURES = "gc320"
+
+COMPATIBLE_MACHINE = "omap-a15"
CLEANBROKEN = "1"
@@ -12,6 +16,8 @@ BRANCH = "ti-${PV}"
SRC_URI = "git://git.ti.com/graphics/ti-gc320-libs.git;protocol=git;branch=${BRANCH}"
SRCREV = "c0afab259de59909cfe74c01f3f7fbaa147f94b5"
+RRECOMMENDS_${PN} = "ti-gc320-driver"
+
# There's only hardfp version available
python __anonymous() {
tunes = d.getVar("TUNE_FEATURES")
diff --git a/bsp/meta-ti/recipes-graphics/libgles/ti-img-rogue-umlibs_1.10.5371573.bb b/bsp/meta-ti/recipes-graphics/libgles/ti-img-rogue-umlibs_1.10.5371573.bb
index 9cb863a5..edb4b753 100644
--- a/bsp/meta-ti/recipes-graphics/libgles/ti-img-rogue-umlibs_1.10.5371573.bb
+++ b/bsp/meta-ti/recipes-graphics/libgles/ti-img-rogue-umlibs_1.10.5371573.bb
@@ -3,15 +3,19 @@ HOMEPAGE = "http://git.ti.com/graphics/ti-img-rogue-umlibs"
LICENSE = "TI-TFL"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7232b98c1c58f99e3baa03de5207e76f"
+inherit features_check
+
+REQUIRED_MACHINE_FEATURES = "gpu"
+
PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "j7-evm"
+COMPATIBLE_MACHINE = "j7"
-PR = "r5"
+PR = "r8"
-BRANCH = "linuxws/thud/k4.19/${PV}"
+BRANCH = "linuxws/zeus/k5.4/${PV}"
SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-umlibs.git;branch=${BRANCH}"
-SRCREV = "0721cdfc1fc86f40c93745159e3f1bcad5beda17"
+SRCREV = "6b4d8e538566bbaf6b9c4a24dbecd740d58c1871"
PVR_SOC ?= "j721e_linux"
PVR_BUILD ?= "release"
@@ -26,8 +30,7 @@ PROVIDES += "virtual/egl virtual/libgles1 virtual/libgles2 virtual/libgbm"
DEPENDS += "libdrm wayland expat"
RDEPENDS_${PN} += "bash"
-RDEPENDS_${PN} += "python-core"
-RDEPENDS_${PN} += "ti-img-rogue-driver wayland expat"
+RDEPENDS_${PN} += "wayland expat"
RPROVIDES_${PN} = "libegl libgles1 libgles2 libgbm"
RPROVIDES_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev libgbm-dev"
@@ -41,6 +44,8 @@ RCONFLICTS_${PN} = "libegl libgles1 libgles2 libgbm"
RCONFLICTS_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev libgbm-dev"
RCONFLICTS_${PN}-dbg = "libegl-dbg libgles1-dbg libgles2-dbg"
+RRECOMMENDS_${PN} += "ti-img-rogue-driver"
+
S = "${WORKDIR}/git"
do_install () {
diff --git a/bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_1.17.4948957.bb b/bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_1.17.4948957.bb
index ecf3ffcc..6639ec5c 100644
--- a/bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_1.17.4948957.bb
+++ b/bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_1.17.4948957.bb
@@ -3,20 +3,26 @@ HOMEPAGE = "https://git.ti.com/graphics/omap5-sgx-ddk-um-linux"
LICENSE = "TI-TSPA"
LIC_FILES_CHKSUM = "file://TI-Linux-Graphics-DDK-UM-Manifest.doc;md5=b17390502bc89535c86cfbbae961a2a8"
+inherit features_check
+
+REQUIRED_MACHINE_FEATURES = "gpu"
+
PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k3"
+COMPATIBLE_MACHINE = "pandaboard|beagleboard|ti33x|ti43x|omap-a15|k3"
-PR = "r34"
+PR = "r35"
-BRANCH = "ti-img-sgx/thud/${PV}"
+BRANCH = "ti-img-sgx/zeus/${PV}"
SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-um-linux.git;protocol=git;branch=${BRANCH}"
-SRCREV = "2a2e5bb090ced870d73ed4edbc54793e952cc6d8"
+SRCREV = "ce7b96b88d31da27af5b3a2a890aba180a014fc4"
TARGET_PRODUCT_omap-a15 = "jacinto6evm"
TARGET_PRODUCT_ti33x = "ti335x"
TARGET_PRODUCT_ti43x = "ti437x"
TARGET_PRODUCT_k3 = "ti654x"
+TARGET_PRODUCT_beagleboard = "ti343x"
+TARGET_PRODUCT_pandaboard = "ti443x"
INITSCRIPT_NAME = "rc.pvr"
INITSCRIPT_PARAMS = "defaults 8"
@@ -43,6 +49,8 @@ RCONFLICTS_${PN}-dbg = "libegl-dbg libgles1-dbg libgles2-dbg libgbm-dbg"
# The actual SONAME is libGLESv2.so.2, so need to explicitly specify RPROVIDES for .so.1 here
RPROVIDES_${PN} += "libGLESv2.so.1"
+RRECOMMENDS_${PN} += "ti-sgx-ddk-km"
+
S = "${WORKDIR}/git"
do_install () {
@@ -59,14 +67,7 @@ FILES_${PN} += " ${libdir}/*"
FILES_${PN} += "${includedir}/*"
FILES_${PN} += "${sysconfdir}/*"
-PACKAGES =+ "${PN}-plugins"
-FILES_${PN}-plugins = "${libdir}/libsrv_init.so ${libdir}/libsrv_um.so ${libdir}/libglslcompiler.so ${libdir}/libPVRScopeServices.so ${libdir}/libGLESv2.so ${libdir}/libEGL.so ${libdir}/libGLESv1_CM.so ${libdir}/libGLES_CM.so ${libdir}/libGLESv1_PVR_MESA.so ${libdir}/libGLESv2_PVR_MESA.so"
-RDEPENDS_${PN} += "${PN}-plugins"
-
-ALLOW_EMPTY_${PN}-plugins = "1"
-
INSANE_SKIP_${PN} += "dev-so ldflags useless-rpaths"
-INSANE_SKIP_${PN}-plugins = "dev-so"
-INSANE_SKIP_${PN} += "already-stripped"
+INSANE_SKIP_${PN} += "already-stripped dev-deps"
CLEANBROKEN = "1"
diff --git a/bsp/meta-ti/recipes-graphics/omapfbplay/files/0001-omapfbplay-switch-CODEC_TYPE_VIDEO-to-AVMEDIA_TYPE_V.patch b/bsp/meta-ti/recipes-graphics/omapfbplay/files/0001-omapfbplay-switch-CODEC_TYPE_VIDEO-to-AVMEDIA_TYPE_V.patch
deleted file mode 100644
index e01fddbf..00000000
--- a/bsp/meta-ti/recipes-graphics/omapfbplay/files/0001-omapfbplay-switch-CODEC_TYPE_VIDEO-to-AVMEDIA_TYPE_V.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 71670f4a067efc169018a9ec9321ccc9af3bbd59 Mon Sep 17 00:00:00 2001
-From: Roger Monk <r-monk@ti.com>
-Date: Thu, 10 May 2012 14:50:11 +0100
-Subject: [PATCH] omapfbplay: switch CODEC_TYPE_VIDEO to AVMEDIA_TYPE_VIDEO
-
-Signed-off-by: Roger Monk <r-monk@ti.com>
----
- omapfbplay.c | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/omapfbplay.c b/omapfbplay.c
-index ad35bd5..818cf2c 100644
---- a/omapfbplay.c
-+++ b/omapfbplay.c
-@@ -74,7 +74,7 @@ find_stream(AVFormatContext *afc)
- int i;
-
- for (i = 0; i < afc->nb_streams; i++) {
-- if (afc->streams[i]->codec->codec_type == CODEC_TYPE_VIDEO && !st)
-+ if (afc->streams[i]->codec->codec_type == AVMEDIA_TYPE_VIDEO && !st)
- st = afc->streams[i];
- else
- afc->streams[i]->discard = AVDISCARD_ALL;
---
-1.7.0.4
-
diff --git a/bsp/meta-ti/recipes-graphics/omapfbplay/files/omapfbplay-errorhandling.patch b/bsp/meta-ti/recipes-graphics/omapfbplay/files/omapfbplay-errorhandling.patch
deleted file mode 100644
index 7dd544f8..00000000
--- a/bsp/meta-ti/recipes-graphics/omapfbplay/files/omapfbplay-errorhandling.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From e321ae7df57ada9ecc8c155fa4e5511c96ef5db3 Mon Sep 17 00:00:00 2001
-From: Rob Clark <rob@ti.com>
-Date: Fri, 18 Mar 2011 12:40:51 -0500
-Subject: [PATCH] dce: differentiate between fatal and non-fatal errors
-
-For streams with errors, the codec will throw back an error. But not
-all errors are fatal.
----
- dce.c | 10 ++++++++--
- 1 files changed, 8 insertions(+), 2 deletions(-)
-
-diff --git a/dce.c b/dce.c
-index ab7ad0a..88f175e 100644
---- a/dce.c
-+++ b/dce.c
-@@ -270,8 +270,14 @@ static int dce_decode(AVPacket *p)
-
- err = VIDDEC3_process(codec, inbufs, outbufs, in_args, out_args);
- if (err) {
-- fprintf(stderr, "VIDDEC3_process() error %d\n", err);
-- return -1;
-+ fprintf(stderr, "VIDDEC3_process() error %d %08x\n", err,
-+ out_args->extendedError);
-+ /* for non-fatal errors, keep going.. a non-fatal error could
-+ * just indicate an error in the input stream which the codec
-+ * was able to conceal
-+ */
-+ if (XDM_ISFATALERROR(out_args->extendedError))
-+ return -1;
- }
-
- for (i = 0; i < out_args->outputID[i]; i++) {
---
-1.7.1
diff --git a/bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay-cmem_git.bb b/bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay-cmem_git.bb
deleted file mode 100644
index a0392f6c..00000000
--- a/bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay-cmem_git.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-require omapfbplay.inc
-
-DEPENDS += "ti-linuxutils"
-
-require recipes-ti/includes/ti-paths.inc
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-SDMA_CFLAGS = " -I${LINUXUTILS_INSTALL_DIR}/packages/ti/sdo/linuxutils/sdma/include/"
-CMEM_CFLAGS = " -I${LINUXUTILS_INSTALL_DIR}/packages/ti/sdo/linuxutils/cmem/include/"
-CFLAGS += " -I. -I${STAGING_KERNEL_DIR}/include ${SDMA_CFLAGS} ${CMEM_CFLAGS}"
-
-export SDMA_LIBS = "-L${LINUXUTILS_INSTALL_DIR}/packages/ti/sdo/linuxutils/sdma/lib -l:sdma.a470MV"
-export CMEM_LIBS = "-L${LINUXUTILS_INSTALL_DIR}/packages/ti/sdo/linuxutils/cmem/lib -l:cmem.a470MV"
-
-OMAPFBPLAYOPTS = "V4L2=y OMAPFB=y NETSYNC=y CMEM=y SDMA=y"
diff --git a/bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay-dce_git.bb b/bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay-dce_git.bb
deleted file mode 100644
index e70ac729..00000000
--- a/bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay-dce_git.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-require omapfbplay.inc
-
-DEPENDS += "libdce"
-
-CFLAGS += " -I. -I${STAGING_INCDIR}/dce -I${STAGING_KERNEL_DIR}/include "
-
-OMAPFBPLAYOPTS = "V4L2=y OMAPFB=y NETSYNC=y DCE=y"
diff --git a/bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay-xv_git.bb b/bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay-xv_git.bb
deleted file mode 100644
index cadf6d8e..00000000
--- a/bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay-xv_git.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require omapfbplay.inc
-
-OMAPFBPLAYOPTS = "V4L2=y NETSYNC=y XV=y"
diff --git a/bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay.inc b/bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay.inc
deleted file mode 100644
index 744eb8f7..00000000
--- a/bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay.inc
+++ /dev/null
@@ -1,37 +0,0 @@
-DESCRIPTION = "Simple libav-based player that uses the omapfb overlays"
-DEPENDS = "bzip2 lame libav virtual/kernel"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://omapfbplay.c;beginline=2;endline=22;md5=05d3789ab362e6f4a9682e98100ea0fa"
-
-PV = "0.0+${PR}+gitr${SRCREV}"
-
-SRCREV = "34293052c5a2ae328eac6903512e6b4ce19b5639"
-SRC_URI = "git://git.mansr.com/omapfbplay;protocol=git \
- file://omapfbplay-errorhandling.patch \
- file://0001-omapfbplay-switch-CODEC_TYPE_VIDEO-to-AVMEDIA_TYPE_V.patch \
- "
-
-S = "${WORKDIR}/git"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_HOST ?= "null"
-COMPATIBLE_HOST_ti-soc = "(.*)"
-
-# We want a kernel header for armv7a, but we don't want to make mplayer machine specific for that
-STAGING_KERNEL_DIR = "${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"
-CFLAGS += " -I. -I${STAGING_KERNEL_DIR}/include "
-
-OMAPFBPLAYVARIANT ?= "${PN}"
-OMAPFBPLAYOPTS ?= "V4L2=y NETSYNC=y"
-
-do_compile() {
- cp ${STAGING_KERNEL_DIR}/arch/arm/plat-omap/include/mach/omapfb.h ${S} || true
- cp ${STAGING_KERNEL_DIR}/include/asm-arm/arch-omap/omapfb.h ${S} || true
- cp ${STAGING_KERNEL_DIR}/include/linux/omapfb.h ${S} || true
- oe_runmake ${TARGET_ARCH}=y ${OMAPFBPLAYOPTS} -e
-}
-
-do_install() {
- install -d ${D}/${bindir}
- install -m 0755 ${S}/omapfbplay ${D}/${bindir}/${OMAPFBPLAYVARIANT}
-}
diff --git a/bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay_git.bb b/bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay_git.bb
deleted file mode 100644
index 0d3956f1..00000000
--- a/bsp/meta-ti/recipes-graphics/omapfbplay/omapfbplay_git.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require omapfbplay.inc
-
-OMAPFBPLAYOPTS = "V4L2=y OMAPFB=y NETSYNC=y"
diff --git a/bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config/omap3/xorg.conf b/bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config/omap3/xorg.conf
deleted file mode 100644
index 983bb082..00000000
--- a/bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config/omap3/xorg.conf
+++ /dev/null
@@ -1,29 +0,0 @@
-Section "Module"
- Load "extmod"
- Load "dbe"
- Load "glx"
- Load "freetype"
- Load "type1"
- Load "record"
- Load "dri"
-EndSection
-
-Section "Monitor"
- Identifier "Builtin Default Monitor"
-EndSection
-
-Section "Device"
- Identifier "Builtin Default fbdev Device 0"
- Driver "omapfb"
-EndSection
-
-Section "Screen"
- Identifier "Builtin Default fbdev Screen 0"
- Device "Builtin Default fbdev Device 0"
- Monitor "Builtin Default Monitor"
-EndSection
-
-Section "ServerLayout"
- Identifier "Builtin Default Layout"
- Screen "Builtin Default fbdev Screen 0"
-EndSection
diff --git a/bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config/omap4/xorg.conf b/bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config/omap4/xorg.conf
deleted file mode 100644
index 87ded4dd..00000000
--- a/bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config/omap4/xorg.conf
+++ /dev/null
@@ -1,15 +0,0 @@
-# more /usr/share/X11/xorg.conf.d/99-omap.conf
-# X.Org X server configuration file
-
-Section "Device"
- Identifier "Video Device"
- Driver "omap"
- Option "Debug" "false"
- Option "HWcursor" "false"
-EndSection
-
-Section "Screen"
- Identifier "Screen"
- Monitor "Monitor"
- Device "Video Device"
-EndSection
diff --git a/bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config/omapl138/xorg.conf b/bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config/omapl138/xorg.conf
deleted file mode 100644
index 0d6ab435..00000000
--- a/bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config/omapl138/xorg.conf
+++ /dev/null
@@ -1,29 +0,0 @@
-Section "Module"
- Load "extmod"
- Load "dbe"
- Load "glx"
- Load "freetype"
- Load "type1"
- Load "record"
- Load "dri"
-EndSection
-
-Section "Monitor"
- Identifier "Builtin Default Monitor"
-EndSection
-
-Section "Device"
- Identifier "Builtin Default fbdev Device 0"
- Driver "fbdev"
-EndSection
-
-Section "Screen"
- Identifier "Builtin Default fbdev Screen 0"
- Device "Builtin Default fbdev Device 0"
- Monitor "Builtin Default Monitor"
-EndSection
-
-Section "ServerLayout"
- Identifier "Builtin Default Layout"
- Screen "Builtin Default fbdev Screen 0"
-EndSection
diff --git a/bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config/ti33x/xorg.conf b/bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config/ti33x/xorg.conf
deleted file mode 100644
index 0d6ab435..00000000
--- a/bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config/ti33x/xorg.conf
+++ /dev/null
@@ -1,29 +0,0 @@
-Section "Module"
- Load "extmod"
- Load "dbe"
- Load "glx"
- Load "freetype"
- Load "type1"
- Load "record"
- Load "dri"
-EndSection
-
-Section "Monitor"
- Identifier "Builtin Default Monitor"
-EndSection
-
-Section "Device"
- Identifier "Builtin Default fbdev Device 0"
- Driver "fbdev"
-EndSection
-
-Section "Screen"
- Identifier "Builtin Default fbdev Screen 0"
- Device "Builtin Default fbdev Device 0"
- Monitor "Builtin Default Monitor"
-EndSection
-
-Section "ServerLayout"
- Identifier "Builtin Default Layout"
- Screen "Builtin Default fbdev Screen 0"
-EndSection
diff --git a/bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
deleted file mode 100644
index 72d991c7..00000000
--- a/bsp/meta-ti/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"