summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_4.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_4.19.bb')
-rw-r--r--bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_4.19.bb20
1 files changed, 15 insertions, 5 deletions
diff --git a/bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_4.19.bb b/bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_4.19.bb
index c7cf13b4..ab9653e1 100644
--- a/bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_4.19.bb
+++ b/bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_4.19.bb
@@ -45,10 +45,14 @@ RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2l = " netcp-pa-fw"
# Add run-time dependency for PRU Ethernet firmware to the rootfs
RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am57xx-evm = " prueth-fw"
-RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am437x-evm = " prueth-fw"
-RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am335x-evm = " prueth-fw"
+RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am57xx-hs-evm = " prueth-fw"
+RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti43x = " prueth-fw"
+RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti33x = " prueth-fw"
RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2g = " prueth-fw"
-RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx-evm = " prueth-fw-bin"
+RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx = " prueth-fw-am65x"
+
+# Add run-time dependency for Cadence MHDP firmware to the rootfs
+RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7-evm = " cadence-mhdp-fw"
KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
@@ -56,8 +60,8 @@ S = "${WORKDIR}/git"
BRANCH = "ti-linux-4.19.y"
-SRCREV = "c17c3766610f07dc0549e51694b4149b92f3ce97"
-PV = "4.19.38+git${SRCPV}"
+SRCREV = "5a23bc00e08d26bb83952953d909c95b42fab70c"
+PV = "4.19.94+git${SRCPV}"
# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
MACHINE_KERNEL_PR_append = "a"
@@ -69,3 +73,9 @@ SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \
file://defconfig"
FILES_${KERNEL_PACKAGE_NAME}-devicetree += "/${KERNEL_IMAGEDEST}/*.itb"
+
+# Special configuration for remoteproc/rpmsg IPC modules
+module_conf_rpmsg_client_sample = "blacklist rpmsg_client_sample"
+module_conf_ti_k3_r5_remoteproc = "softdep ti_k3_r5_remoteproc pre: virtio_rpmsg_bus"
+module_conf_ti_k3_dsp_remoteproc = "softdep ti_k3_dsp_remoteproc pre: virtio_rpmsg_bus"
+KERNEL_MODULE_PROBECONF += "rpmsg_client_sample ti_k3_r5_remoteproc ti_k3_dsp_remoteproc"