summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-ti/beagleboard
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-ti/recipes-ti/beagleboard')
-rw-r--r--bsp/meta-ti/recipes-ti/beagleboard/beaglebone-capes.bb2
-rw-r--r--bsp/meta-ti/recipes-ti/beagleboard/beaglebone-getting-started.bb11
-rw-r--r--bsp/meta-ti/recipes-ti/beagleboard/gadget-init.bb2
3 files changed, 8 insertions, 7 deletions
diff --git a/bsp/meta-ti/recipes-ti/beagleboard/beaglebone-capes.bb b/bsp/meta-ti/recipes-ti/beagleboard/beaglebone-capes.bb
index e74033a1..569a3e5a 100644
--- a/bsp/meta-ti/recipes-ti/beagleboard/beaglebone-capes.bb
+++ b/bsp/meta-ti/recipes-ti/beagleboard/beaglebone-capes.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Userspace setup for beaglebone capes"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
PR = "r4"
diff --git a/bsp/meta-ti/recipes-ti/beagleboard/beaglebone-getting-started.bb b/bsp/meta-ti/recipes-ti/beagleboard/beaglebone-getting-started.bb
index 6c61a4e9..adde30b4 100644
--- a/bsp/meta-ti/recipes-ti/beagleboard/beaglebone-getting-started.bb
+++ b/bsp/meta-ti/recipes-ti/beagleboard/beaglebone-getting-started.bb
@@ -1,13 +1,13 @@
-DESCRIPTION = "BeagleBone Getting Started Guide"
+SUMMARY = "BeagleBone Getting Started Guide"
-PR = "r21"
+PR = "r22"
inherit allarch
-LICENSE = "GPLv2+ & MIT & PD & others"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=603591dea023c3c75b48e07cb47ce639"
+LICENSE = "CC-BY-SA-3.0 & GPLv3+ & MIT & PD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f6f02761e31334c48f7021fb94c89aaa"
-SRCREV = "6c548a307c948b28a99d48fd17d9790b56182196"
+SRCREV = "05bedba192646152b7bc80b0accaea75aef864e5"
SRC_URI = "git://github.com/jadonk/beaglebone-getting-started.git"
S = "${WORKDIR}/git"
@@ -18,3 +18,4 @@ do_install() {
}
FILES_${PN} += "${datadir}/${PN}"
+INSANE_SKIP_${PN} = "file-rdeps"
diff --git a/bsp/meta-ti/recipes-ti/beagleboard/gadget-init.bb b/bsp/meta-ti/recipes-ti/beagleboard/gadget-init.bb
index 8b899c51..b546efbb 100644
--- a/bsp/meta-ti/recipes-ti/beagleboard/gadget-init.bb
+++ b/bsp/meta-ti/recipes-ti/beagleboard/gadget-init.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Units to initialize usb gadgets"
PR = "r19"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
COMPATIBLE_MACHINE = "(ti33x)"
PACKAGE_ARCH = "${MACHINE_ARCH}"