summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-ti/devtools
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-ti/recipes-ti/devtools')
-rw-r--r--bsp/meta-ti/recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb6
-rw-r--r--bsp/meta-ti/recipes-ti/devtools/ti-cgt-arm_18.12.5.bb (renamed from bsp/meta-ti/recipes-ti/devtools/ti-cgt-arm.inc)13
-rw-r--r--bsp/meta-ti/recipes-ti/devtools/ti-cgt-pru_2.3.2.bb (renamed from bsp/meta-ti/recipes-ti/devtools/ti-cgt-pru_2.2.1.bb)14
-rw-r--r--bsp/meta-ti/recipes-ti/devtools/ti-cgt6x-7_7.4.16.bb (renamed from bsp/meta-ti/recipes-ti/devtools/ti-cgt6x-7-native_7.4.16.bb)9
-rw-r--r--bsp/meta-ti/recipes-ti/devtools/ti-cgt7x_1.2.0.bb47
-rw-r--r--bsp/meta-ti/recipes-ti/devtools/ti-xdctools_3.51.01.18.bb9
-rw-r--r--bsp/meta-ti/recipes-ti/devtools/ti-xdctools_3.55.02.22.bb9
7 files changed, 80 insertions, 27 deletions
diff --git a/bsp/meta-ti/recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb b/bsp/meta-ti/recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb
deleted file mode 100644
index 7df9660c..00000000
--- a/bsp/meta-ti/recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-include ti-cgt-arm.inc
-
-LIC_FILES_CHKSUM = "file://ti-cgt-arm_${PV}.LTS/README.txt;md5=ab7a61241e90fcd144a756d88294cf30"
-
-BINFILE_MD5 = "af2378cf8d5d6f200ef3329f5a065529"
-BINFILE_SHA256 = "d90ae2360cd5b22912715ae7898d99352da1b97fd655f9a55d0d19a2a46bab0e"
diff --git a/bsp/meta-ti/recipes-ti/devtools/ti-cgt-arm.inc b/bsp/meta-ti/recipes-ti/devtools/ti-cgt-arm_18.12.5.bb
index d2d768ce..9e651819 100644
--- a/bsp/meta-ti/recipes-ti/devtools/ti-cgt-arm.inc
+++ b/bsp/meta-ti/recipes-ti/devtools/ti-cgt-arm_18.12.5.bb
@@ -2,7 +2,8 @@ SUMMARY = "TI ARM Code Generation Tools"
HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm"
LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Hewlett-Packard & Patrick-Powell & AFL-3.0 & MIT & BSD-2-Clause & PD & BSD-4-Clause"
-inherit native
+LIC_FILES_CHKSUM = "file://ti-cgt-arm_${PV}.LTS/README.txt;md5=79631eb21b2e5b7190cd3ff1dfd41108"
+
require recipes-ti/includes/ti-unpack.inc
require recipes-ti/includes/ti-staging.inc
require recipes-ti/includes/ti-paths.inc
@@ -17,13 +18,17 @@ BINFILE = "ti_cgt_tms470_${PV}.LTS_linux_installer_x86.bin"
TI_BIN_UNPK_ARGS = "--prefix ${S}"
TI_BIN_UNPK_CMDS = ""
+# only x86_64 is supported
+COMPATIBLE_HOST = "x86_64.*-linux"
+COMPATIBLE_HOST_class-target = "null"
+
do_install() {
install -d ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}
cp -r ${S}/ti-cgt-arm*/. ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}
}
-SRC_URI[cgt_arm_installer.md5sum] = "${BINFILE_MD5}"
-SRC_URI[cgt_arm_installer.sha256sum] = "${BINFILE_SHA256}"
+SRC_URI[cgt_arm_installer.md5sum] = "e9e668332cf86c965b4da9d1d488426b"
+SRC_URI[cgt_arm_installer.sha256sum] = "da976143128c619a278cb4214a4295c409d100f9e65ad2f4d0d1039db7cf98f4"
BINFILE_NAME = "cgt_arm_installer"
@@ -34,3 +39,5 @@ INHIBIT_SYSROOT_STRIP = "1"
INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
INSANE_SKIP_${PN} += "arch staticdev"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/bsp/meta-ti/recipes-ti/devtools/ti-cgt-pru_2.2.1.bb b/bsp/meta-ti/recipes-ti/devtools/ti-cgt-pru_2.3.2.bb
index 8d3887e5..ed10e272 100644
--- a/bsp/meta-ti/recipes-ti/devtools/ti-cgt-pru_2.2.1.bb
+++ b/bsp/meta-ti/recipes-ti/devtools/ti-cgt-pru_2.3.2.bb
@@ -2,8 +2,8 @@ DESCRIPTION = "TI PRU Code Generation Tools"
HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm"
LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Hewlett-Packard & AFL-3.0 & MIT & BSD-2-Clause & PD"
-LIC_FILES_CHKSUM = "file://ti-cgt-pru_${PV}/PRU_Code_Generation_Tools_2.2.x_manifest.html;md5=e84b4022808f66b075095cb896747758"
-LIC_FILES_CHKSUM_class-target = "file://usr/share/doc/ti/cgt-pru/PRU_Code_Generation_Tools_2.2.x_manifest.html;md5=e84b4022808f66b075095cb896747758"
+LIC_FILES_CHKSUM = "file://ti-cgt-pru_${PV}/PRU_Code_Generation_Tools_2.3.x_manifest.html;md5=e22f9d8240f7cca0c0aa5242d9ffa5bc"
+LIC_FILES_CHKSUM_class-target = "file://usr/share/doc/ti/cgt-pru/PRU_Code_Generation_Tools_2.3.x_manifest.html;md5=e22f9d8240f7cca0c0aa5242d9ffa5bc"
require recipes-ti/includes/ti-paths.inc
require recipes-ti/includes/ti-unpack.inc
@@ -18,11 +18,11 @@ BINFILE_NAME_class-target = "cgt-pru-arm"
SRC_URI = "http://software-dl.ti.com/codegen/esd/cgt_public_sw/PRU/${PV}/${BINFILE};name=${BINFILE_NAME}"
-SRC_URI[cgt-pru-x86.md5sum] = "749d75841eef7b465c7cb08beaa1d135"
-SRC_URI[cgt-pru-x86.sha256sum] = "7dc37fd689d1d506bf410d2a00af658b93a58d4bc10ac32c2210129dab617377"
+SRC_URI[cgt-pru-x86.md5sum] = "270a0ecca383f66cad3a0e2a738c6ab0"
+SRC_URI[cgt-pru-x86.sha256sum] = "af1178a059d46d67d5672df053dd2fbebb0b89a513b17b8739dbe915b4a5d71a"
-SRC_URI[cgt-pru-arm.md5sum] = "389eef56777e30e6dab337efca4af2bf"
-SRC_URI[cgt-pru-arm.sha256sum] = "b47a032f67cb3a3e5bea8ee3ed1908038f42938dd08e2ff72fc64f7aae2c1ff8"
+SRC_URI[cgt-pru-arm.md5sum] = "fbf10083af1b0e5d69b018126603bb58"
+SRC_URI[cgt-pru-arm.sha256sum] = "75ac84775a5624ea7e4fad4efc1acb7e869c79160550d48ba780068a3dce879c"
do_install() {
install -d ${D}${TI_CGT_PRU_INSTALL_DIR_RECIPE}
@@ -44,6 +44,6 @@ INHIBIT_PACKAGE_STRIP = "1"
INHIBIT_SYSROOT_STRIP = "1"
INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
-INSANE_SKIP_${PN} += "arch staticdev already-stripped"
+INSANE_SKIP_${PN} += "arch staticdev already-stripped file-rdeps"
BBCLASSEXTEND = "native nativesdk"
diff --git a/bsp/meta-ti/recipes-ti/devtools/ti-cgt6x-7-native_7.4.16.bb b/bsp/meta-ti/recipes-ti/devtools/ti-cgt6x-7_7.4.16.bb
index 7bb4c75e..a67a2d8a 100644
--- a/bsp/meta-ti/recipes-ti/devtools/ti-cgt6x-7-native_7.4.16.bb
+++ b/bsp/meta-ti/recipes-ti/devtools/ti-cgt6x-7_7.4.16.bb
@@ -13,7 +13,6 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b6311962635a4f15630e36ec2d875eca"
S = "${WORKDIR}/c6000_7.4.16"
-inherit native
require recipes-ti/includes/ti-paths.inc
require recipes-ti/includes/ti-unpack.inc
@@ -27,6 +26,10 @@ SRC_URI = "http://install.source.dir.local/${BINFILE};name=${BINFILE_NAME}"
SRC_URI[cgt6x_7.4.16_x86_installer.md5sum] = "21ca55c5b1f6b2d8d4fb7570d5eb5513"
SRC_URI[cgt6x_7.4.16_x86_installer.sha256sum] = "baa0d1ef20397383f99f45068a6d160963a01419d42fbbb851263b54c91df82f"
+# only x86_64 is supported
+COMPATIBLE_HOST = "x86_64.*-linux"
+COMPATIBLE_HOST_class-target = "null"
+
do_install() {
install -d ${D}/${TI_CGT6X_7_INSTALL_DIR_RECIPE}
cp -rP --preserve=mode,links,timestamps --no-preserve=ownership ${WORKDIR}/c6000_7.4.16/. ${D}/${TI_CGT6X_7_INSTALL_DIR_RECIPE}
@@ -34,8 +37,10 @@ do_install() {
FILES_${PN} += "${TI_CGT6X_7_INSTALL_DIR_RECIPE}"
-INSANE_SKIP_${PN} += "arch staticdev"
+INSANE_SKIP_${PN} += "arch staticdev textrel"
INHIBIT_PACKAGE_STRIP = "1"
INHIBIT_SYSROOT_STRIP = "1"
INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/bsp/meta-ti/recipes-ti/devtools/ti-cgt7x_1.2.0.bb b/bsp/meta-ti/recipes-ti/devtools/ti-cgt7x_1.2.0.bb
new file mode 100644
index 00000000..09178af8
--- /dev/null
+++ b/bsp/meta-ti/recipes-ti/devtools/ti-cgt7x_1.2.0.bb
@@ -0,0 +1,47 @@
+SUMMARY = "TI DSP Code Generation Tools"
+DESCRIPTION = "Texas Instruments (TI) Code Generation Tools are custom \
+utilities targeted for TI embedded processors. This Digital Signal \
+Processor (DSP) suite contains tools needed to create and debug \
+applications for the C7000 DSP family. This includes tools such as: \
+compiler, linker, assembler, etc. This also includes C runtime \
+libraries and standard header files needed to produce a working DSP application."
+HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm"
+LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Patrick-Powell & AFL-3.0 & MIT & BSD-2-Clause & PD"
+
+LIC_FILES_CHKSUM = "file://ti-cgt-c7000_${PV}.STS/C7000_Code_Generation_Tools_1.x_manifest.html;md5=f1156d241d104c281bc64a6ec8eadc64"
+
+require recipes-ti/includes/ti-unpack.inc
+require recipes-ti/includes/ti-paths.inc
+
+# only x86_64 is supported
+COMPATIBLE_HOST = "x86_64.*-linux"
+COMPATIBLE_HOST_class-target = "null"
+
+BINFILE = "ti_cgt_c7000_${PV}.STS_linux_installer_x86.bin"
+BINFILE_NAME = "cgt7x_x86_installer"
+
+SRC_URI = "http://software-dl.ti.com/codegen/esd/cgt_public_sw/C7000/${PV}.STS/${BINFILE};name=${BINFILE_NAME}"
+
+TI_BIN_UNPK_ARGS = "--prefix ${S}"
+TI_BIN_UNPK_CMDS = ""
+
+SRC_URI[cgt7x_x86_installer.md5sum] = "813840908f333dd2a31f92edec71c1fb"
+SRC_URI[cgt7x_x86_installer.sha256sum] = "21379811a8857489f72ca8ec45a46eb086ced0bdbb58e78f73a86e63984ab2f5"
+
+S = "${WORKDIR}/c7000_${PV}"
+
+do_install() {
+ install -d ${D}/${TI_CGT7X_INSTALL_DIR_RECIPE}
+ cp -rP --preserve=mode,links,timestamps --no-preserve=ownership ${WORKDIR}/c7000_${PV}/ti-cgt-c7000_${PV}.STS/. ${D}/${TI_CGT7X_INSTALL_DIR_RECIPE}
+}
+
+
+FILES_${PN} += "${TI_CGT7X_INSTALL_DIR_RECIPE}"
+
+INSANE_SKIP_${PN} += "arch staticdev textrel"
+
+INHIBIT_PACKAGE_STRIP = "1"
+INHIBIT_SYSROOT_STRIP = "1"
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/bsp/meta-ti/recipes-ti/devtools/ti-xdctools_3.51.01.18.bb b/bsp/meta-ti/recipes-ti/devtools/ti-xdctools_3.51.01.18.bb
deleted file mode 100644
index 35258b4d..00000000
--- a/bsp/meta-ti/recipes-ti/devtools/ti-xdctools_3.51.01.18.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require recipes-ti/devtools/ti-xdctools-core.inc
-
-PV = "3_51_01_18"
-PR = "r0"
-
-LIC_FILES_CHKSUM = "file://docs/license/xdc/shelf/package.html;beginline=1;endline=140;md5=7d8508a640d8e76fe372141df01c351f"
-
-SRC_URI[xdczip.md5sum] = "54b80b603471623c1dbb0cfeb75b0fe2"
-SRC_URI[xdczip.sha256sum] = "9bbbf433f0970bcb0cbf938615afe4d54420ecc56bc6e872f1a004338a8f19d5"
diff --git a/bsp/meta-ti/recipes-ti/devtools/ti-xdctools_3.55.02.22.bb b/bsp/meta-ti/recipes-ti/devtools/ti-xdctools_3.55.02.22.bb
new file mode 100644
index 00000000..74817835
--- /dev/null
+++ b/bsp/meta-ti/recipes-ti/devtools/ti-xdctools_3.55.02.22.bb
@@ -0,0 +1,9 @@
+require recipes-ti/devtools/ti-xdctools-core.inc
+
+PV = "3_55_02_22"
+PR = "r0"
+
+LIC_FILES_CHKSUM = "file://docs/license/xdc/shelf/package.html;beginline=1;endline=140;md5=2e742b9757bc9ce0241aadba9f627ab8"
+
+SRC_URI[xdczip.md5sum] = "bb9154d677ce4724a5eac73817b23a0f"
+SRC_URI[xdczip.sha256sum] = "bf90dfbbe298458c736d81d5631db25b335e79146923a4a50fab217e02723e7b"