summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-ti/ipc
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-ti/recipes-ti/ipc')
-rw-r--r--bsp/meta-ti/recipes-ti/ipc/ipc-transport-qmss_git.bb2
-rw-r--r--bsp/meta-ti/recipes-ti/ipc/ipc-transport-srio_git.bb2
-rw-r--r--bsp/meta-ti/recipes-ti/ipc/ti-ipc-common.inc3
-rw-r--r--bsp/meta-ti/recipes-ti/ipc/ti-ipc-examples_git.bb2
-rw-r--r--bsp/meta-ti/recipes-ti/ipc/ti-ipc-rtos.inc17
-rw-r--r--bsp/meta-ti/recipes-ti/ipc/ti-ipc-rtos_git.bb17
-rw-r--r--bsp/meta-ti/recipes-ti/ipc/ti-ipc.inc6
-rw-r--r--bsp/meta-ti/recipes-ti/ipc/ti-ipc/0001-Add-kernel-build-dir.patch12
-rw-r--r--bsp/meta-ti/recipes-ti/ipc/ti-ipc_git.bb1
9 files changed, 18 insertions, 44 deletions
diff --git a/bsp/meta-ti/recipes-ti/ipc/ipc-transport-qmss_git.bb b/bsp/meta-ti/recipes-ti/ipc/ipc-transport-qmss_git.bb
index 4c9aaded..93136670 100644
--- a/bsp/meta-ti/recipes-ti/ipc/ipc-transport-qmss_git.bb
+++ b/bsp/meta-ti/recipes-ti/ipc/ipc-transport-qmss_git.bb
@@ -15,3 +15,5 @@ do_install () {
INSTALL_LIB_BASE_DIR=${D}${libdir}
chown -R root:root ${D}
}
+
+INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libdir}/libTransportQmss.a"
diff --git a/bsp/meta-ti/recipes-ti/ipc/ipc-transport-srio_git.bb b/bsp/meta-ti/recipes-ti/ipc/ipc-transport-srio_git.bb
index ca7f7b6c..6001585a 100644
--- a/bsp/meta-ti/recipes-ti/ipc/ipc-transport-srio_git.bb
+++ b/bsp/meta-ti/recipes-ti/ipc/ipc-transport-srio_git.bb
@@ -15,3 +15,5 @@ do_install () {
INSTALL_LIB_BASE_DIR=${D}${libdir}
chown -R root:root ${D}
}
+
+INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libdir}/libTransportSrio.a"
diff --git a/bsp/meta-ti/recipes-ti/ipc/ti-ipc-common.inc b/bsp/meta-ti/recipes-ti/ipc/ti-ipc-common.inc
index 86a0fd0c..449903f1 100644
--- a/bsp/meta-ti/recipes-ti/ipc/ti-ipc-common.inc
+++ b/bsp/meta-ti/recipes-ti/ipc/ti-ipc-common.inc
@@ -1,4 +1,4 @@
-PV = "3.50.04.08"
+PV = "3.51.00.00"
INC_PR = "r0"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -15,7 +15,6 @@ PLATFORM_k2g = "66AK2G"
PLATFORM_omapl138 = "OMAPL138"
PLATFORM_c667x-evm = "C6678"
PLATFORM_c665x-evm = "C6678"
-PLATFORM_am65xx = "AM65XX"
ALT_PLATFORM_k2hk = "TCI6636"
ALT_PLATFORM_am57xx-evm = "AM572X AM571X"
diff --git a/bsp/meta-ti/recipes-ti/ipc/ti-ipc-examples_git.bb b/bsp/meta-ti/recipes-ti/ipc/ti-ipc-examples_git.bb
index 43e45e64..c46e5c81 100644
--- a/bsp/meta-ti/recipes-ti/ipc/ti-ipc-examples_git.bb
+++ b/bsp/meta-ti/recipes-ti/ipc/ti-ipc-examples_git.bb
@@ -3,8 +3,6 @@ require ti-ipc-examples.inc
DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native"
-DEPENDS_append_am65xx = " sciclient-rtos"
-
do_compile_append() {
if [ "${PLATFORM}" != "UNKNOWN" ]; then
diff --git a/bsp/meta-ti/recipes-ti/ipc/ti-ipc-rtos.inc b/bsp/meta-ti/recipes-ti/ipc/ti-ipc-rtos.inc
index 4d0d449c..a68ba806 100644
--- a/bsp/meta-ti/recipes-ti/ipc/ti-ipc-rtos.inc
+++ b/bsp/meta-ti/recipes-ti/ipc/ti-ipc-rtos.inc
@@ -24,9 +24,9 @@ protocol=${TI_IPC_METADATA_GIT_PROTOCOL};\
branch=${TI_IPC_METADATA_GIT_BRANCH};\
name=${TI_IPC_METADATA_NAME}"
-# Corresponds to tag: 3.50.04.08
-TI_IPC_METADATA_SRCREV = "48788ea79190c4995df4c802e8aa4e17f332943d"
-# Corresponds to tag: 3.50.04.08
+# Corresponds to tag: 3.51.00.00
+TI_IPC_METADATA_SRCREV = "1bf668fd6b0ec2ef6956fa55b8484d0b21a9f9e2"
+# Corresponds to tag: 3.51.00.00
TI_IPC_EXAMPLES_SRCREV = "4707fcbbe0d136e781c4a7ffdc072be407c34358"
SRCREV_FORMAT = "default"
@@ -39,7 +39,7 @@ S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
RELEASE_TYPE = "GA"
RELEASE_SUFFIX = ""
-PR = "${INC_PR}.r2"
+PR = "${INC_PR}.r0"
DEPENDS_append_keystone = " ti-cgt6x-native \
gcc-arm-none-eabi-native \
@@ -53,9 +53,6 @@ DEPENDS_append_omapl138 = " ti-cgt6x-native \
DEPENDS_append_c66x = " ti-cgt6x-native \
"
-DEPENDS_append_am65xx = " ti-cgt-arm-native \
- gcc-linaro-baremetal-aarch64-native"
-
IPC_TARGETS = ""
IPC_TARGETS_omap-a15 = "\
@@ -79,11 +76,6 @@ IPC_TARGETS_c66x = " \
ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
"
-IPC_TARGETS_am65xx = "\
- gnu.targets.arm.A53F="${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN}" \
- ti.targets.arm.elf.R5F="${M4_TOOLCHAIN_INSTALL_DIR}" \
-"
-
PARALLEL_XDC = "${@oe.utils.parallel_make_argument(d, '--jobs=%d')}"
EXTRA_OEMAKE = "\
PLATFORM=${PLATFORM} \
@@ -93,5 +85,4 @@ EXTRA_OEMAKE = "\
${PARALLEL_XDC} \
JAVA_TOOL_OPTIONS=-Xss2560k \
"
-EXTRA_OEMAKE_append_am65xx = " PDK_INSTALL_DIR=${PDK_INSTALL_DIR}"
diff --git a/bsp/meta-ti/recipes-ti/ipc/ti-ipc-rtos_git.bb b/bsp/meta-ti/recipes-ti/ipc/ti-ipc-rtos_git.bb
index 4c0e71e6..b292d677 100644
--- a/bsp/meta-ti/recipes-ti/ipc/ti-ipc-rtos_git.bb
+++ b/bsp/meta-ti/recipes-ti/ipc/ti-ipc-rtos_git.bb
@@ -3,7 +3,6 @@ require ti-ipc-common.inc
require ti-ipc-rtos.inc
DEPENDS = "ti-xdctools-native ti-sysbios doxygen-native zip-native"
-DEPENDS_append_am65xx = " sciclient-rtos"
PACKAGES =+ "${PN}-fw"
FILES_${PN}-fw = "${base_libdir}/firmware/*"
@@ -62,12 +61,6 @@ do_compile() {
fi
}
-do_install_prepend_am65xx () {
- # Trim directory name
- mv ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_false_R5F0 ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_R5F0
- mv ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_false_R5F1 ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_R5F1
-}
-
do_install() {
CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
@@ -129,13 +122,3 @@ pkg_postinst_${PN}-fw_omapl138 () {
pkg_postrm_${PN}-fw_omapl138 () {
update-alternatives --remove rproc-dsp-fw ipc/ti_platforms_evmOMAPL138_DSP/messageq_single.xe674
}
-
-pkg_postinst_${PN}-fw_am65xx () {
- update-alternatives --install /lib/firmware/am65x-mcu-r5f0_0-fw am65x-mcu-r5f0_0-fw ipc/ti_platforms_cortexR_AM65X_R5F0/messageq_single.xer5f ${ALTERNATIVE_PRIORITY}
- update-alternatives --install /lib/firmware/am65x-mcu-r5f0_1-fw am65x-mcu-r5f0_1-fw ipc/ti_platforms_cortexR_AM65X_R5F1/messageq_single.xer5f ${ALTERNATIVE_PRIORITY}
-}
-
-pkg_postrm_${PN}-fw_am65xx () {
- update-alternatives --remove am65x-mcu-r5f0_0-fw ipc/ti_platforms_cortexR_AM65X_R5F0/messageq_single.xer5f
- update-alternatives --remove am65x-mcu-r5f0_1-fw ipc/ti_platforms_cortexR_AM65X_R5F1/messageq_single.xer5f
-}
diff --git a/bsp/meta-ti/recipes-ti/ipc/ti-ipc.inc b/bsp/meta-ti/recipes-ti/ipc/ti-ipc.inc
index d1eaad2a..3b0115eb 100644
--- a/bsp/meta-ti/recipes-ti/ipc/ti-ipc.inc
+++ b/bsp/meta-ti/recipes-ti/ipc/ti-ipc.inc
@@ -6,10 +6,10 @@ LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=7b327f9
TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git"
TI_IPC_GIT_PROTOCOL = "git"
-TI_IPC_GIT_BRANCH = "3.50"
+TI_IPC_GIT_BRANCH = "master"
-#Corresponds to 3.50.04.08
-TI_IPC_SRCREV = "1d53b856338b86d1979fe09345c0b382913a848a"
+#Corresponds to 3.51.00.00A
+TI_IPC_SRCREV = "7a6e343a208d2849139b7272a67abc01db806e00"
BRANCH = "${TI_IPC_GIT_BRANCH}"
SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev"
diff --git a/bsp/meta-ti/recipes-ti/ipc/ti-ipc/0001-Add-kernel-build-dir.patch b/bsp/meta-ti/recipes-ti/ipc/ti-ipc/0001-Add-kernel-build-dir.patch
index e612ddc1..71d5b2be 100644
--- a/bsp/meta-ti/recipes-ti/ipc/ti-ipc/0001-Add-kernel-build-dir.patch
+++ b/bsp/meta-ti/recipes-ti/ipc/ti-ipc/0001-Add-kernel-build-dir.patch
@@ -1,4 +1,4 @@
-From 7d9f57983c6d14ac14f26987eddc555ea5c75d61 Mon Sep 17 00:00:00 2001
+From c3ada6bf49e6fcf7bc49e5bf09754f384838ca6a Mon Sep 17 00:00:00 2001
From: Denys Dmytriyenko <denys@ti.com>
Date: Mon, 27 Jul 2015 11:51:52 -0400
Subject: [PATCH] Add kernel build dir
@@ -17,18 +17,18 @@ Signed-off-by: Denys Dmytriyenko <denys@ti.com>
4 files changed, 14 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
-index f0b4b61..9b5d07c 100644
+index 4d4a559..84ac78b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,6 +71,7 @@ AC_SUBST([AM_LDFLAGS])
- AC_ARG_VAR(PLATFORM, Platform to build. Options are: 'OMAPL138' 'OMAP54XX' '66AK2E' 'TCI6630' 'TCI6636' 'TCI6638' '66AK2G' and 'DRA7XX'. If not defined all platforms will be built.)
+ AC_ARG_VAR(PLATFORM, Platform to build. Options are: 'OMAPL138' 'OMAP54XX' '66AK2E' 'TCI6630' 'TCI6636' 'TCI6638' '66AK2G' 'DRA7XX' and 'AM65XX'. If not defined all platforms will be built.)
AC_ARG_VAR(CMEM_INSTALL_DIR, Installation path directory to the CMEM libraries)
AC_ARG_VAR(KERNEL_INSTALL_DIR, Installation path to the Linux kernel.)
+AC_ARG_VAR(KERNEL_BUILD_DIR, Path to the Linux kernel build artifacts.)
AC_ARG_VAR(AF_RPMSG, Address Family used by the RPMSG driver)
AC_ARG_VAR(DRM_PREFIX, Installation location to the DRM library.)
-@@ -111,6 +112,7 @@ AS_IF([test "x$PLATFORM" = "x"], [CMEM_INSTALL_DIR=])
+@@ -113,6 +114,7 @@ AS_IF([test "x$PLATFORM" = "x"], [CMEM_INSTALL_DIR=])
AC_SUBST([PLATFORM])
AC_SUBST([CMEM_INSTALL_DIR])
AC_SUBST([KERNEL_INSTALL_DIR])
@@ -36,7 +36,7 @@ index f0b4b61..9b5d07c 100644
AC_SUBST([AF_RPMSG])
AC_SUBST([DRM_PREFIX])
-@@ -127,6 +129,7 @@ AM_CONDITIONAL([DRA7XX], [test "x$PLATFORM" = "xDRA7XX"])
+@@ -130,6 +132,7 @@ AM_CONDITIONAL([AM65XX], [test "x$PLATFORM" = "xAM65XX"])
AM_CONDITIONAL([CMEM], [test "x$CMEM_INSTALL_DIR" != "x"])
AM_CONDITIONAL([KDIR], [test "x$KERNEL_INSTALL_DIR" != "x"])
AM_CONDITIONAL([KERNEL_INSTALL_DIR], [test -n "$KERNEL_INSTALL_DIR"])
@@ -44,7 +44,7 @@ index f0b4b61..9b5d07c 100644
AM_CONDITIONAL([DRM], [test "x$DRM_PREFIX" != "x"])
AM_CONDITIONAL([AF_RPMSG], [test -n "$AF_RPMSG"])
-@@ -157,6 +160,9 @@ You have configured to build for the '${PLATFORM}' platform
+@@ -160,6 +163,9 @@ You have configured to build for the '${PLATFORM}' platform
Your KERNEL installation directory is set to:
'${KERNEL_INSTALL_DIR}'
diff --git a/bsp/meta-ti/recipes-ti/ipc/ti-ipc_git.bb b/bsp/meta-ti/recipes-ti/ipc/ti-ipc_git.bb
index 2ebd03fd..425ca4e1 100644
--- a/bsp/meta-ti/recipes-ti/ipc/ti-ipc_git.bb
+++ b/bsp/meta-ti/recipes-ti/ipc/ti-ipc_git.bb
@@ -22,7 +22,6 @@ DAEMON_k2l = "lad_tci6630"
DAEMON_k2e = "lad_66ak2e"
DAEMON_k2g = "lad_66ak2g"
DAEMON_omapl138 = "lad_omapl138"
-DAEMON_k3 = "lad_am65xx"
inherit autotools-brokensep pkgconfig update-rc.d systemd