summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-ti/multiprocmgr
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-ti/recipes-ti/multiprocmgr')
-rw-r--r--bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb7
-rw-r--r--bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr.inc4
-rw-r--r--bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch27
-rw-r--r--bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr_git.bb7
4 files changed, 5 insertions, 40 deletions
diff --git a/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb b/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
index f01d6513..7c3f9e1b 100644
--- a/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
+++ b/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
@@ -1,4 +1,4 @@
-DESCRIPTION = "TI Multiproc Manager test code"
+SUMMARY = "TI Multiproc Manager test code"
include multiprocmgr.inc
@@ -8,11 +8,6 @@ DEPENDS = "multiprocmgr cmem"
RDEPENDS_${PN} = "multiprocmgr mpm-transport cmem"
RDEPENDS_${PN} += "multiprocmgr-rtos-test bash"
-CC += "-I${STAGING_KERNEL_DIR}/include"
-
-# Assuming the multiprocmgr kernel API is safe
-CC[vardepsexclude] = "STAGING_KERNEL_DIR"
-
FILES_${PN} += "\
${datadir}/ti/examples/mpm \
"
diff --git a/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr.inc b/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr.inc
index 40a20af9..64fb6f6f 100644
--- a/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr.inc
+++ b/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr.inc
@@ -9,10 +9,10 @@ MULTIPROCMGR_GIT_PROTOCOL = "git"
MULTIPROCMGR_GIT_BRANCH = "master"
# The following commits correspond to DEV.MPM-3.00.05.00
-MULTIPROCMGR_SRCREV = "f7fb3b7c21b3f6dd8b4adeef5df5be1824b9be73"
+MULTIPROCMGR_SRCREV = "810d8a31c797d07abe808cb3fa89465fa934d4dd"
PV = "3.0.5.0"
-INC_PR = "r0"
+INC_PR = "r1"
BRANCH = "${MULTIPROCMGR_GIT_BRANCH}"
SRC_URI = "${MULTIPROCMGR_GIT_URI};protocol=${MULTIPROCMGR_GIT_PROTOCOL};branch=${BRANCH}"
diff --git a/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch b/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch
deleted file mode 100644
index 25deedcc..00000000
--- a/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 17c307ff6e67af43f243366baa2ccc01f89cdddd Mon Sep 17 00:00:00 2001
-From: Denys Dmytriyenko <denys@ti.com>
-Date: Mon, 23 Apr 2018 15:35:44 -0400
-Subject: [PATCH] mpmdlif.c: don't hardcode kernel's "uapi" location
- keystone_remoteproc.h
-
-Signed-off-by: Denys Dmytriyenko <denys@ti.com>
----
- src/daemon/mpmdlif.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/daemon/mpmdlif.c b/src/daemon/mpmdlif.c
-index 0c31604..d287bbc 100644
---- a/src/daemon/mpmdlif.c
-+++ b/src/daemon/mpmdlif.c
-@@ -47,7 +47,7 @@
- #include <stdint.h>
-
- #define _LINUX_TYPES_H
--#include "uapi/linux/keystone_remoteproc.h"
-+#include "linux/keystone_remoteproc.h"
- #include "internal/rsc_types.h"
- //#include <elf.h>
- // #define LOADER_DEBUG
---
-2.7.4
-
diff --git a/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr_git.bb b/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr_git.bb
index 6143341d..07512603 100644
--- a/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr_git.bb
+++ b/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr_git.bb
@@ -1,11 +1,10 @@
-DESCRIPTION = "TI Multiproc Manager for KeyStone II"
-SUMMARY = "Provides download, debug and other utilities for other cores in the SOC like DSP"
+SUMMARY = "TI Multiproc Manager for KeyStone II"
+DESCRIPTION = "Provides download, debug and other utilities for other cores in the SOC like DSP"
include multiprocmgr.inc
SRC_URI += " \
file://mpmsrv-daemon.service \
- file://0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch \
"
PR = "${INC_PR}.2"
@@ -14,8 +13,6 @@ DEPENDS = "mpm-transport libdaemon virtual/kernel cmem"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-CC += "-I${STAGING_KERNEL_DIR}/include -I${STAGING_KERNEL_DIR}/include/uapi"
-
INITSCRIPT_NAME = "mpmsrv-daemon.sh"
INITSCRIPT_PARAMS = "defaults 10"