summaryrefslogtreecommitdiffstats
path: root/external/meta-gplv2/recipes-extended/diffutils
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-gplv2/recipes-extended/diffutils')
-rw-r--r--external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/0001-Make-it-build-with-compile-time-hardening-enabled.patch32
-rw-r--r--external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/diffutils_fix_for_automake-1.12.patch27
-rw-r--r--external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/fix_gcc6.patch31
-rw-r--r--external/meta-gplv2/recipes-extended/diffutils/diffutils.inc18
-rw-r--r--external/meta-gplv2/recipes-extended/diffutils/diffutils_2.8.1.bb19
5 files changed, 127 insertions, 0 deletions
diff --git a/external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/0001-Make-it-build-with-compile-time-hardening-enabled.patch b/external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/0001-Make-it-build-with-compile-time-hardening-enabled.patch
new file mode 100644
index 00000000..dc03aa6e
--- /dev/null
+++ b/external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/0001-Make-it-build-with-compile-time-hardening-enabled.patch
@@ -0,0 +1,32 @@
+From 7448c928240aafbfec08a92530a150bc206673bf Mon Sep 17 00:00:00 2001
+From: Peter Kjellerstedt <pkj@axis.com>
+Date: Thu, 26 Apr 2018 02:40:52 +0200
+Subject: [PATCH] Make it build with compile time hardening enabled
+
+This avoids the following error:
+
+ src/diff3.c: In function 'output_diff3':
+ src/diff3.c:1405:5: error: format not a string literal and no format
+ arguments [-Werror=format-security]
+ fprintf (outputfile, line_prefix);
+ ^~~~~~~
+
+Upstream-Status: Inappropriate [legacy version]
+Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
+---
+ src/diff3.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/diff3.c b/src/diff3.c
+index f3d3dcf..7237dea 100644
+--- a/src/diff3.c
++++ b/src/diff3.c
+@@ -1402,7 +1402,7 @@ output_diff3 (FILE *outputfile, struct diff3_block *diff,
+ line = 0;
+ do
+ {
+- fprintf (outputfile, line_prefix);
++ fprintf (outputfile, "%s", line_prefix);
+ cp = D_RELNUM (ptr, realfile, line);
+ length = D_RELLEN (ptr, realfile, line);
+ fwrite (cp, sizeof (char), length, outputfile);
diff --git a/external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/diffutils_fix_for_automake-1.12.patch b/external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/diffutils_fix_for_automake-1.12.patch
new file mode 100644
index 00000000..f8638bbf
--- /dev/null
+++ b/external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/diffutils_fix_for_automake-1.12.patch
@@ -0,0 +1,27 @@
+Upstream-Status: Pending
+
+automake 1.12 has depricated automatic de-ANSI-fication support
+
+this patch avoids these kinds of errors:
+
+| configure.ac:90: error: automatic de-ANSI-fication support has been removed
+| /srv/home/nitin/builds/build-gcc47/tmp/sysroots/x86_64-linux/usr/share/aclocal-1.12/protos.m4:12: AM_C_PROTOTYPES is expanded from...
+| /srv/home/nitin/builds/build-gcc47/tmp/work/i586-poky-linux/diffutils-2.8.1-r4/diffutils-2.8.1/m4/prereq.m4:110: jm_PREREQ_QUOTEARG is expanded from...
+| configure.ac:90: the top level
+| autom4te: m4 failed with exit status: 1
+
+Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
+2012/05/04
+
+Index: diffutils-2.8.1/m4/prereq.m4
+===================================================================
+--- diffutils-2.8.1.orig/m4/prereq.m4
++++ diffutils-2.8.1/m4/prereq.m4
+@@ -115,7 +115,6 @@ AC_DEFUN([jm_PREREQ_QUOTEARG],
+ AC_HEADER_STDC
+ AC_C_BACKSLASH_A
+ AC_MBSTATE_T
+- AM_C_PROTOTYPES
+ ])
+
+ AC_DEFUN([jm_PREREQ_REGEX],
diff --git a/external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/fix_gcc6.patch b/external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/fix_gcc6.patch
new file mode 100644
index 00000000..f915287f
--- /dev/null
+++ b/external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/fix_gcc6.patch
@@ -0,0 +1,31 @@
+Fixes to allow diffutils to build with gcc v6.
+
+RP
+2016/5/25
+
+Index: diffutils-2.8.1/lib/posix/regex.h
+===================================================================
+--- diffutils-2.8.1.orig/lib/posix/regex.h
++++ diffutils-2.8.1/lib/posix/regex.h
+@@ -529,7 +529,9 @@ extern int re_exec _RE_ARGS ((const char
+ /* For now unconditionally define __restrict_arr to expand to nothing.
+ Ideally we would have a test for the compiler which allows defining
+ it to restrict. */
++#ifndef __restrict_arr
+ #define __restrict_arr
++#endif
+
+ /* POSIX compatibility. */
+ extern int regcomp _RE_ARGS ((regex_t *__restrict __preg,
+Index: diffutils-2.8.1/src/diff.c
+===================================================================
+--- diffutils-2.8.1.orig/src/diff.c
++++ diffutils-2.8.1/src/diff.c
+@@ -71,6 +71,7 @@ static void usage (void);
+ static bool recursive;
+
+ /* In context diffs, show previous lines that match these regexps. */
++struct re_pattern_buffer function_regexp;
+ static struct regexp_list function_regexp_list;
+
+ /* Ignore changes affecting only lines that match these regexps. */
diff --git a/external/meta-gplv2/recipes-extended/diffutils/diffutils.inc b/external/meta-gplv2/recipes-extended/diffutils/diffutils.inc
new file mode 100644
index 00000000..243341aa
--- /dev/null
+++ b/external/meta-gplv2/recipes-extended/diffutils/diffutils.inc
@@ -0,0 +1,18 @@
+SUMMARY = "Diffutils contains tools used for finding differences between files"
+DESCRIPTION = "Diffutils contains the GNU diff, diff3, \
+sdiff, and cmp utilities. These programs are usually \
+used for creating patch files."
+SECTION = "base"
+
+inherit autotools texinfo update-alternatives gettext
+
+# diffutils assumes non-glibc compilation with uclibc and
+# this causes it to generate its own implementations of
+# standard functionality. regex.c actually breaks compilation
+# because it uses __mempcpy, there are other things (TBD:
+# see diffutils.mk in buildroot)
+EXTRA_OECONF_libc-uclibc = "--without-included-regex"
+
+ALTERNATIVE_${PN} = "diff cmp"
+ALTERNATIVE_PRIORITY = "100"
+
diff --git a/external/meta-gplv2/recipes-extended/diffutils/diffutils_2.8.1.bb b/external/meta-gplv2/recipes-extended/diffutils/diffutils_2.8.1.bb
new file mode 100644
index 00000000..466bf285
--- /dev/null
+++ b/external/meta-gplv2/recipes-extended/diffutils/diffutils_2.8.1.bb
@@ -0,0 +1,19 @@
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+require diffutils.inc
+
+PR = "r7.0"
+
+SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.gz \
+ file://diffutils_fix_for_automake-1.12.patch \
+ file://fix_gcc6.patch \
+ file://0001-Make-it-build-with-compile-time-hardening-enabled.patch \
+ "
+
+SRC_URI[md5sum] = "71f9c5ae19b60608f6c7f162da86a428"
+SRC_URI[sha256sum] = "c5001748b069224dd98bf1bb9ee877321c7de8b332c8aad5af3e2a7372d23f5a"
+
+do_configure_prepend () {
+ chmod u+w ${S}/po/Makefile.in.in
+}