summaryrefslogtreecommitdiffstats
path: root/external/meta-gplv2/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-gplv2/recipes-extended')
-rw-r--r--external/meta-gplv2/recipes-extended/bc/bc_1.06.bb2
-rw-r--r--external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/0002-included-libc-use-mempcpy-instead-of.patch56
-rw-r--r--external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/0003-context-fix-compilation-with-64bit-time_t-on-32bit-a.patch46
-rw-r--r--external/meta-gplv2/recipes-extended/diffutils/diffutils.inc7
-rw-r--r--external/meta-gplv2/recipes-extended/diffutils/diffutils_2.8.1.bb7
-rw-r--r--external/meta-gplv2/recipes-extended/grep/grep-2.5.1a/0001-Fix-builds-with-gettext-0.20.patch63
-rw-r--r--external/meta-gplv2/recipes-extended/grep/grep_2.5.1a.bb3
-rw-r--r--external/meta-gplv2/recipes-extended/gzip/gzip-1.3.12/fix-shell.patch16
-rw-r--r--external/meta-gplv2/recipes-extended/gzip/gzip_1.3.12.bb1
-rw-r--r--external/meta-gplv2/recipes-extended/mc/mc/0001-Fix-builds-wit-the-gettext-0.20.patch52
-rw-r--r--external/meta-gplv2/recipes-extended/mc/mc_4.7.5.2.bb11
-rw-r--r--external/meta-gplv2/recipes-extended/sed/sed-4.1.2/0001-Fix-builds-with-gettext-0.20.patch38
-rw-r--r--external/meta-gplv2/recipes-extended/sed/sed_4.1.2.bb4
-rw-r--r--external/meta-gplv2/recipes-extended/tar/tar/0001-lib-argp-parse.c-Fix-compiler-error.patch35
-rw-r--r--external/meta-gplv2/recipes-extended/tar/tar_1.17.bb1
15 files changed, 326 insertions, 16 deletions
diff --git a/external/meta-gplv2/recipes-extended/bc/bc_1.06.bb b/external/meta-gplv2/recipes-extended/bc/bc_1.06.bb
index d8c8a860..3de1b24f 100644
--- a/external/meta-gplv2/recipes-extended/bc/bc_1.06.bb
+++ b/external/meta-gplv2/recipes-extended/bc/bc_1.06.bb
@@ -20,7 +20,7 @@ SRC_URI[sha256sum] = "4ef6d9f17c3c0d92d8798e35666175ecd3d8efac4009d6457b5c99cea7
inherit autotools texinfo update-alternatives
-ALTERNATIVE_${PN} = "dc"
+ALTERNATIVE_${PN} = "bc dc"
ALTERNATIVE_PRIORITY = "100"
BBCLASSEXTEND = "native"
diff --git a/external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/0002-included-libc-use-mempcpy-instead-of.patch b/external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/0002-included-libc-use-mempcpy-instead-of.patch
new file mode 100644
index 00000000..6994ec77
--- /dev/null
+++ b/external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/0002-included-libc-use-mempcpy-instead-of.patch
@@ -0,0 +1,56 @@
+From 61db4da387676690c0f731ef2eccc014d85c23a6 Mon Sep 17 00:00:00 2001
+From: Nicola Lunghi <nicola.lunghi@jci.com>
+Date: Wed, 20 Nov 2019 18:30:10 +0000
+Subject: [PATCH] included libc: use mempcpy instead of __mempcpy
+
+Fix to use mempcpy instead of __mempcpy. This is needed for uclibc and musl
+which doesn't define __mempcpy, only mempcpy. Since they all have
+mempcpy, we'll just use that instead.
+
+Signed-off-by: Nicola Lunghi <nick83ola@gmail.com>
+
+Patch source: OpenEmbedded (grep)
+Upstream-Status: Inappropriate [licensing]
+---
+ lib/getopt.c | 4 ++--
+ lib/regex.c | 2 +-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/lib/getopt.c b/lib/getopt.c
+index ed32692..6626f5e 100644
+--- a/lib/getopt.c
++++ b/lib/getopt.c
+@@ -334,7 +334,7 @@ exchange (argv)
+ nonoption_flags_len = nonoption_flags_max_len = 0;
+ else
+ {
+- memset (__mempcpy (new_str, __getopt_nonoption_flags,
++ memset (mempcpy (new_str, __getopt_nonoption_flags,
+ nonoption_flags_max_len),
+ '\0', top + 1 - nonoption_flags_max_len);
+ nonoption_flags_max_len = top + 1;
+@@ -445,7 +445,7 @@ _getopt_initialize (argc, argv, optstring)
+ if (__getopt_nonoption_flags == NULL)
+ nonoption_flags_max_len = -1;
+ else
+- memset (__mempcpy (__getopt_nonoption_flags, orig_str, len),
++ memset (mempcpy (__getopt_nonoption_flags, orig_str, len),
+ '\0', nonoption_flags_max_len - len);
+ }
+ }
+diff --git a/lib/regex.c b/lib/regex.c
+index 6daec76..797b20a 100644
+--- a/lib/regex.c
++++ b/lib/regex.c
+@@ -8314,7 +8314,7 @@ regerror (errcode, preg, errbuf, errbuf_size)
+ if (msg_size > errbuf_size)
+ {
+ #if defined HAVE_MEMPCPY || defined _LIBC
+- *((char *) __mempcpy (errbuf, msg, errbuf_size - 1)) = '\0';
++ *((char *) mempcpy (errbuf, msg, errbuf_size - 1)) = '\0';
+ #else
+ memcpy (errbuf, msg, errbuf_size - 1);
+ errbuf[errbuf_size - 1] = 0;
+--
+2.20.1
+
diff --git a/external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/0003-context-fix-compilation-with-64bit-time_t-on-32bit-a.patch b/external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/0003-context-fix-compilation-with-64bit-time_t-on-32bit-a.patch
new file mode 100644
index 00000000..a8fcde09
--- /dev/null
+++ b/external/meta-gplv2/recipes-extended/diffutils/diffutils-2.8.1/0003-context-fix-compilation-with-64bit-time_t-on-32bit-a.patch
@@ -0,0 +1,46 @@
+From 07c75310fecbaec62a24a3ee98b4209e1bf9ff62 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andr=C3=A9=20Draszik?= <git@andred.net>
+Date: Mon, 6 Jan 2020 13:31:50 +0000
+Subject: [PATCH] context: fix compilation with 64bit time_t on 32bit arches
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+In file included from ../../diffutils-2.8.1/src/diff.h:23,
+ from ../../diffutils-2.8.1/src/context.c:23:
+../../diffutils-2.8.1/src/context.c: In function 'print_context_label':
+../../diffutils-2.8.1/src/system.h:41:52: error: size of array 'a' is negative
+ 41 | #define verify(name, assertion) struct name { char a[(assertion) ? 1 : -1]; }
+ | ^
+../../diffutils-2.8.1/src/context.c:65:4: note: in expansion of macro 'verify'
+ 65 | verify (info_preserved, sizeof inf->stat.st_mtime <= sizeof sec);
+ | ^~~~~~
+
+struct stat::st_mtime is a time_t and will not fit into a
+long (when 64bit time_t has been requested on a 32bit machine).
+
+Signed-off-by: André Draszik <git@andred.net>
+Upstream-Status: Inappropriate [fixing an old version]
+---
+ src/context.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/context.c b/src/context.c
+index 18d7023..d41efde 100644
+--- a/src/context.c
++++ b/src/context.c
+@@ -61,9 +61,9 @@ print_context_label (char const *mark,
+ int nsec = TIMESPEC_NS (inf->stat.st_mtim);
+ if (! (tm && nstrftime (buf, sizeof buf, time_format, tm, 0, nsec)))
+ {
+- long sec = inf->stat.st_mtime;
++ time_t sec = inf->stat.st_mtime;
+ verify (info_preserved, sizeof inf->stat.st_mtime <= sizeof sec);
+- sprintf (buf, "%ld.%.9d", sec, nsec);
++ sprintf (buf, "%lld.%.9d", (long long) sec, nsec);
+ }
+ fprintf (outfile, "%s %s\t%s\n", mark, inf->name, buf);
+ }
+--
+2.23.0.rc1
+
diff --git a/external/meta-gplv2/recipes-extended/diffutils/diffutils.inc b/external/meta-gplv2/recipes-extended/diffutils/diffutils.inc
index 243341aa..c81348b3 100644
--- a/external/meta-gplv2/recipes-extended/diffutils/diffutils.inc
+++ b/external/meta-gplv2/recipes-extended/diffutils/diffutils.inc
@@ -6,13 +6,6 @@ SECTION = "base"
inherit autotools texinfo update-alternatives gettext
-# diffutils assumes non-glibc compilation with uclibc and
-# this causes it to generate its own implementations of
-# standard functionality. regex.c actually breaks compilation
-# because it uses __mempcpy, there are other things (TBD:
-# see diffutils.mk in buildroot)
-EXTRA_OECONF_libc-uclibc = "--without-included-regex"
-
ALTERNATIVE_${PN} = "diff cmp"
ALTERNATIVE_PRIORITY = "100"
diff --git a/external/meta-gplv2/recipes-extended/diffutils/diffutils_2.8.1.bb b/external/meta-gplv2/recipes-extended/diffutils/diffutils_2.8.1.bb
index 466bf285..7c43c4be 100644
--- a/external/meta-gplv2/recipes-extended/diffutils/diffutils_2.8.1.bb
+++ b/external/meta-gplv2/recipes-extended/diffutils/diffutils_2.8.1.bb
@@ -9,11 +9,18 @@ SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.gz \
file://diffutils_fix_for_automake-1.12.patch \
file://fix_gcc6.patch \
file://0001-Make-it-build-with-compile-time-hardening-enabled.patch \
+ file://0002-included-libc-use-mempcpy-instead-of.patch \
+ file://0003-context-fix-compilation-with-64bit-time_t-on-32bit-a.patch \
"
SRC_URI[md5sum] = "71f9c5ae19b60608f6c7f162da86a428"
SRC_URI[sha256sum] = "c5001748b069224dd98bf1bb9ee877321c7de8b332c8aad5af3e2a7372d23f5a"
+CACHED_CONFIGUREVARS = "\
+ jm_cv_func_working_malloc=yes \
+ jm_cv_func_working_realloc=yes \
+"
+
do_configure_prepend () {
chmod u+w ${S}/po/Makefile.in.in
}
diff --git a/external/meta-gplv2/recipes-extended/grep/grep-2.5.1a/0001-Fix-builds-with-gettext-0.20.patch b/external/meta-gplv2/recipes-extended/grep/grep-2.5.1a/0001-Fix-builds-with-gettext-0.20.patch
new file mode 100644
index 00000000..ee9a6b1b
--- /dev/null
+++ b/external/meta-gplv2/recipes-extended/grep/grep-2.5.1a/0001-Fix-builds-with-gettext-0.20.patch
@@ -0,0 +1,63 @@
+From cd814b2203a1b5e71eaf97c3b9efedc94b680a19 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Tue, 17 Dec 2019 16:46:05 +0100
+Subject: [PATCH] Fix builds with gettext 0.20
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+André:
+Updated patch to also AC_CHECK_FUNCS([setlocale]).
+Various #include <locale.h> are guarded by the outcome of that,
+and otherwise compilation fails, e.g.:
+| ../../grep-2.5.1a/src/dfa.c:1366:34: error: 'LC_COLLATE' undeclared (first use in this function); did you mean 'REG_ECOLLATE'?
+| 1366 | hard_LC_COLLATE = hard_locale (LC_COLLATE);
+| | ^~~~~~~~~~
+| | REG_ECOLLATE
+
+Upstream-Status: Inappropriate [fixing an old version]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+Signed-off-by: André Draszik <git@andred.net>
+---
+ Makefile.am | 2 +-
+ configure.in | 4 +++-
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index e4b58c4..a851b9d 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,7 +1,7 @@
+ ## Process this file with automake to create Makefile.in
+ AUTOMAKE_OPTIONS = no-dependencies
+
+-SUBDIRS = intl po lib doc src tests m4 vms bootstrap
++SUBDIRS = po lib doc src tests m4 vms bootstrap
+
+ EXTRA_DIST = TODO README README-alpha PATCHES.AC PATCHES.AM
+
+diff --git a/configure.in b/configure.in
+index 2fa6c71..e1e04ea 100644
+--- a/configure.in
++++ b/configure.in
+@@ -48,6 +48,8 @@ AC_FUNC_ALLOCA
+ AC_FUNC_CLOSEDIR_VOID
+ AC_FUNC_MMAP
+
++AC_CHECK_FUNCS([setlocale])
++
+ dnl getpagesize is checked for by AC_FUNC_MMAP.
+ AC_CHECK_FUNCS(btowc isascii memmove setmode strerror wctype mbrtowc)
+ AC_REPLACE_FUNCS(memchr stpcpy strtoul atexit fnmatch)
+@@ -70,7 +72,7 @@ esac
+
+ dnl I18N feature
+ ALL_LINGUAS="cs de el eo es et fr gl hr id it ja ko nl no pl pt_BR ru sl sv"
+-AM_GNU_GETTEXT
++AM_GNU_GETTEXT([external])
+
+ dnl DOS file name convention
+ dnl sets HAVE_DOS_FILE_NAMES
+--
+2.23.0.rc1
+
diff --git a/external/meta-gplv2/recipes-extended/grep/grep_2.5.1a.bb b/external/meta-gplv2/recipes-extended/grep/grep_2.5.1a.bb
index b331feeb..d3b4ddc4 100644
--- a/external/meta-gplv2/recipes-extended/grep/grep_2.5.1a.bb
+++ b/external/meta-gplv2/recipes-extended/grep/grep_2.5.1a.bb
@@ -17,7 +17,8 @@ SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.bz2 \
file://fix-for-texinfo-5.1.patch \
file://grep-egrep-fgrep-Fix-LSB-NG-cases.patch \
file://search-fix-compilation-error-with-security-flags-ena.patch \
- "
+ file://0001-Fix-builds-with-gettext-0.20.patch \
+ "
SRC_URI[md5sum] = "52202fe462770fa6be1bb667bd6cf30c"
SRC_URI[sha256sum] = "38c8a2bb9223d1fb1b10bdd607cf44830afc92fd451ac4cd07619bf92bdd3132"
diff --git a/external/meta-gplv2/recipes-extended/gzip/gzip-1.3.12/fix-shell.patch b/external/meta-gplv2/recipes-extended/gzip/gzip-1.3.12/fix-shell.patch
new file mode 100644
index 00000000..13b479bf
--- /dev/null
+++ b/external/meta-gplv2/recipes-extended/gzip/gzip-1.3.12/fix-shell.patch
@@ -0,0 +1,16 @@
+We want /bin/sh left as the shell, not bash for example
+Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
+Upstream-Status: Inappropriate [fixed differently in new versions]
+
+Index: gzip-1.3.12/Makefile.am
+===================================================================
+--- gzip-1.3.12.orig/Makefile.am
++++ gzip-1.3.12/Makefile.am
+@@ -55,7 +55,6 @@ gzip.doc.gz: gzip.doc
+ SUFFIXES = .in
+ .in:
+ sed \
+- -e 's|/bin/sh|$(SHELL)|g' \
+ -e 's|BINDIR|$${GZIP_BINDIR-'\''$(bindir)'\''}|g' \
+ -e 's|[@]VERSION@|$(VERSION)|g' \
+ $(srcdir)/$@.in >$@
diff --git a/external/meta-gplv2/recipes-extended/gzip/gzip_1.3.12.bb b/external/meta-gplv2/recipes-extended/gzip/gzip_1.3.12.bb
index e4062827..5f7f6cdf 100644
--- a/external/meta-gplv2/recipes-extended/gzip/gzip_1.3.12.bb
+++ b/external/meta-gplv2/recipes-extended/gzip/gzip_1.3.12.bb
@@ -7,6 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
SRC_URI = "${GNU_MIRROR}/gzip/gzip-${PV}.tar.gz \
file://m4-extensions-fix.patch \
+ file://fix-shell.patch \
file://dup-def-fix.patch"
SRC_URI[md5sum] = "b5bac2d21840ae077e0217bc5e4845b1"
diff --git a/external/meta-gplv2/recipes-extended/mc/mc/0001-Fix-builds-wit-the-gettext-0.20.patch b/external/meta-gplv2/recipes-extended/mc/mc/0001-Fix-builds-wit-the-gettext-0.20.patch
new file mode 100644
index 00000000..dbf18cab
--- /dev/null
+++ b/external/meta-gplv2/recipes-extended/mc/mc/0001-Fix-builds-wit-the-gettext-0.20.patch
@@ -0,0 +1,52 @@
+From 56aef108be94019c7828c14f0c4849336f811847 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Tue, 17 Dec 2019 16:34:06 +0100
+Subject: [PATCH] Fix builds wit the gettext 0.20
+
+Upstream-Status: Inappropriate [fixing an old version]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ Makefile.am | 2 +-
+ configure.ac | 2 +-
+ src/Makefile.am | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index ab4f9b7..b27ab4a 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,7 +1,7 @@
+ ## Process this file with automake to create Makefile.in.
+ AUTOMAKE_OPTIONS = 1.5
+
+-SUBDIRS = intl po lib src doc contrib misc
++SUBDIRS = po lib src doc contrib misc
+
+ EXTRA_DIST =
+
+diff --git a/configure.ac b/configure.ac
+index c05902d..0430714 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -88,7 +88,7 @@ fi
+ dnl
+ dnl Internationalization
+ dnl
+-AM_GNU_GETTEXT(no-libtool, need-ngettext)
++AM_GNU_GETTEXT([external],no-libtool, need-ngettext)
+ AM_GNU_GETTEXT_VERSION(0.14.3)
+
+ if test "x$USE_INCLUDED_LIBINTL" = xyes; then
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 2da86c3..1859f0d 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -52,7 +52,7 @@ else
+ mc_LDADD += $(GLIB_LIBS)
+ endif
+
+-mc_LDADD += $(PCRE_LIBS) $(LIBICONV) $(INTLLIBS)
++mc_LDADD += $(PCRE_LIBS) $(INTLLIBS)
+
+ SRC_mc_conssaver = \
+ cons.handler.c consaver/cons.saver.h
diff --git a/external/meta-gplv2/recipes-extended/mc/mc_4.7.5.2.bb b/external/meta-gplv2/recipes-extended/mc/mc_4.7.5.2.bb
index ca849663..5f56641b 100644
--- a/external/meta-gplv2/recipes-extended/mc/mc_4.7.5.2.bb
+++ b/external/meta-gplv2/recipes-extended/mc/mc_4.7.5.2.bb
@@ -11,6 +11,7 @@ PR = "r3"
SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \
file://mc-CTRL.patch \
file://0001-disable-Ctrl-g-key-and-Ctrl-key.patch \
+ file://0001-Fix-builds-wit-the-gettext-0.20.patch \
"
SRC_URI[md5sum] = "bdae966244496cd4f6d282d80c9cf3c6"
@@ -22,10 +23,12 @@ EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --without-
do_install_append () {
sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
- sed -i -e '1s,#!.*python,#!${bindir}/env python,' ${D}${libexecdir}/mc/extfs.d/*
+ # These use python2 which is no longer supported
+ rm ${D}${libexecdir}/mc/extfs.d/s3+
+ rm ${D}${libexecdir}/mc/extfs.d/uc1541
}
-PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers-python ${BPN}-helpers ${BPN}-fish"
+PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers ${BPN}-fish"
SUMMARY_${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts"
FILES_${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
@@ -36,10 +39,6 @@ FILES_${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.
${libexecdir}/mc/extfs.d/uzip"
RDEPENDS_${BPN}-helpers-perl = "perl"
-SUMMARY_${BPN}-helpers-python = "Midnight Commander Python-based helper scripts"
-FILES_${BPN}-helpers-python = "${libexecdir}/mc/extfs.d/s3+ ${libexecdir}/mc/extfs.d/uc1541"
-RDEPENDS_${BPN}-helpers-python = "python"
-
SUMMARY_${BPN}-helpers = "Midnight Commander shell helper scripts"
FILES_${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
diff --git a/external/meta-gplv2/recipes-extended/sed/sed-4.1.2/0001-Fix-builds-with-gettext-0.20.patch b/external/meta-gplv2/recipes-extended/sed/sed-4.1.2/0001-Fix-builds-with-gettext-0.20.patch
new file mode 100644
index 00000000..e366b5aa
--- /dev/null
+++ b/external/meta-gplv2/recipes-extended/sed/sed-4.1.2/0001-Fix-builds-with-gettext-0.20.patch
@@ -0,0 +1,38 @@
+From 2792bccbfd41427a79edd462906aba78144b8c6a Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Tue, 17 Dec 2019 16:40:58 +0100
+Subject: [PATCH] Fix builds with gettext 0.20
+
+Upstream-Status: Inappropriate [fixing an old version]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ Makefile.am | 2 +-
+ configure.ac | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index f0aaa7f..1ebc805 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -6,7 +6,7 @@ ACLOCAL_AMFLAGS = -I config
+
+ PACKAGE = sed
+
+-SUBDIRS = intl lib po sed doc testsuite
++SUBDIRS = lib po sed testsuite
+
+ noinst_DATA = bootstrap.sh
+ noinst_HEADERS = basicdefs.h
+diff --git a/configure.ac b/configure.ac
+index e08c9a3..df20044 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -130,7 +130,7 @@ AM_CONDITIONAL(TEXI2HTML_HTML, test "x$enable_html" = xtexi2html)
+
+ ALL_LINGUAS="af ca cs da de el eo es et fi fr ga gl he hr hu id it ja ko nl pl pt_BR ro ru sk sl sr sv tr zh_CN"
+ AM_GNU_GETTEXT_VERSION(0.11)
+-AM_GNU_GETTEXT(, need-ngettext)
++AM_GNU_GETTEXT([external], need-ngettext)
+
+ AC_CONFIG_FILES([bootstrap.sh], chmod +x bootstrap.sh)
+ AC_CONFIG_FILES([Makefile doc/Makefile \
diff --git a/external/meta-gplv2/recipes-extended/sed/sed_4.1.2.bb b/external/meta-gplv2/recipes-extended/sed/sed_4.1.2.bb
index 40e3a53c..4a584426 100644
--- a/external/meta-gplv2/recipes-extended/sed/sed_4.1.2.bb
+++ b/external/meta-gplv2/recipes-extended/sed/sed_4.1.2.bb
@@ -9,7 +9,9 @@ PR = "r7"
SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz \
file://fix_return_type.patch \
file://sed-4.1.2_fix_for_automake-1.12.patch \
- file://Makevars"
+ file://Makevars \
+ file://0001-Fix-builds-with-gettext-0.20.patch \
+ "
SRC_URI[md5sum] = "928f0e06422f414091917401f1a834d0"
SRC_URI[sha256sum] = "638e837ba765d5da0a30c98b57c2953cecea96827882f594612acace93ceeeab"
diff --git a/external/meta-gplv2/recipes-extended/tar/tar/0001-lib-argp-parse.c-Fix-compiler-error.patch b/external/meta-gplv2/recipes-extended/tar/tar/0001-lib-argp-parse.c-Fix-compiler-error.patch
new file mode 100644
index 00000000..001d2b68
--- /dev/null
+++ b/external/meta-gplv2/recipes-extended/tar/tar/0001-lib-argp-parse.c-Fix-compiler-error.patch
@@ -0,0 +1,35 @@
+From 153c0aab9e2a4a97b1a2c6b530594cd9a211e9ec Mon Sep 17 00:00:00 2001
+From: Joakim Roubert <joakimr@axis.com>
+Date: Thu, 6 Dec 2018 10:33:14 +0100
+Subject: [PATCH] lib/argp-parse.c: Fix compiler error
+
+This avoids the following error:
+
+ lib/argp-parse.c: In function 'argp_version_parser':
+ lib/argp-parse.c:158:2: error: format not a string literal and no
+ format arguments [-Werror=format-security]
+ __argp_error (state, dgettext (state->root_argp->argp_domain,
+ ^~~~~~~~~~~~
+
+Upstream-Status: Inappropriate [old version]
+Signed-off-by: Joakim Roubert <joakim.roubert@axis.com>
+---
+ lib/argp-parse.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/argp-parse.c b/lib/argp-parse.c
+index a7de729..09511ba 100644
+--- a/lib/argp-parse.c
++++ b/lib/argp-parse.c
+@@ -155,7 +155,7 @@ argp_version_parser (int key, char *arg, struct argp_state *state)
+ else if (argp_program_version)
+ fprintf (state->out_stream, "%s\n", argp_program_version);
+ else
+- __argp_error (state, dgettext (state->root_argp->argp_domain,
++ __argp_error (state, "%s", dgettext (state->root_argp->argp_domain,
+ "(PROGRAM ERROR) No version known!?"));
+ if (! (state->flags & ARGP_NO_EXIT))
+ exit (0);
+--
+2.11.0
+
diff --git a/external/meta-gplv2/recipes-extended/tar/tar_1.17.bb b/external/meta-gplv2/recipes-extended/tar/tar_1.17.bb
index b9ca2063..1ee5e342 100644
--- a/external/meta-gplv2/recipes-extended/tar/tar_1.17.bb
+++ b/external/meta-gplv2/recipes-extended/tar/tar_1.17.bb
@@ -8,6 +8,7 @@ PR = "r3"
SRC_URI += "file://m4extensions.patch \
file://gcc43build.patch \
file://avoid_heap_overflow.patch \
+ file://0001-lib-argp-parse.c-Fix-compiler-error.patch \
"
SRC_URI[md5sum] = "c6c4f1c075dbf0f75c29737faa58f290"