summaryrefslogtreecommitdiffstats
path: root/external/meta-gplv2/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-gplv2/recipes-support')
-rw-r--r--external/meta-gplv2/recipes-support/gnupg/gnupg-1.4.7/0001-Make-it-build-with-gettext-0.20.patch80
-rw-r--r--external/meta-gplv2/recipes-support/gnupg/gnupg_1.4.7.bb8
-rw-r--r--external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info.inc37
-rw-r--r--external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info/install-data-hook.patch25
-rw-r--r--external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch33
-rw-r--r--external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info_1.10.bb7
6 files changed, 189 insertions, 1 deletions
diff --git a/external/meta-gplv2/recipes-support/gnupg/gnupg-1.4.7/0001-Make-it-build-with-gettext-0.20.patch b/external/meta-gplv2/recipes-support/gnupg/gnupg-1.4.7/0001-Make-it-build-with-gettext-0.20.patch
new file mode 100644
index 00000000..a8eddbe7
--- /dev/null
+++ b/external/meta-gplv2/recipes-support/gnupg/gnupg-1.4.7/0001-Make-it-build-with-gettext-0.20.patch
@@ -0,0 +1,80 @@
+From 26076b28b79f6a2f2989a301ad7474cfa1153ebd Mon Sep 17 00:00:00 2001
+From: Peter Kjellerstedt <pkj@axis.com>
+Date: Tue, 7 Jan 2020 11:08:39 +0100
+Subject: [PATCH] Make it build with gettext 0.20
+
+Upstream-Status: Inappropriate [legacy version]
+Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
+---
+ Makefile.am | 2 +-
+ configure.ac | 2 +-
+ g10/Makefile.am | 2 +-
+ keyserver/Makefile.am | 2 +-
+ tools/Makefile.am | 2 +-
+ 5 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 3423e70..1eebbc2 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -28,7 +28,7 @@ else
+ checks = checks
+ endif
+
+-SUBDIRS = m4 intl zlib util mpi cipher tools g10 keyserver po doc ${checks}
++SUBDIRS = m4 zlib util mpi cipher tools g10 keyserver po doc ${checks}
+ EXTRA_DIST = scripts/config.rpath PROJECTS BUGS config.h.in autogen.sh
+ DISTCLEANFILES =
+
+diff --git a/configure.ac b/configure.ac
+index 9f64b75..d9e5f69 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -813,7 +813,7 @@ dnl Checks for libraries.
+
+ AM_GNU_GETTEXT_VERSION(0.14.1)
+ if test "$try_gettext" = yes; then
+- AM_GNU_GETTEXT(,[need-ngettext])
++ AM_GNU_GETTEXT([external],[need-ngettext])
+
+ # gettext requires some extra checks. These really should be part of
+ # the basic AM_GNU_GETTEXT macro. TODO: move other gettext-specific
+diff --git a/g10/Makefile.am b/g10/Makefile.am
+index 74a8db1..ff51b7f 100644
+--- a/g10/Makefile.am
++++ b/g10/Makefile.am
+@@ -32,7 +32,7 @@ AM_CPPFLAGS += -DGNUPG_LIBDIR="\"$(libdir)/@PACKAGE@\""
+ endif
+
+ needed_libs = ../cipher/libcipher.a ../mpi/libmpi.a ../util/libutil.a
+-other_libs = $(LIBICONV) $(DNSLIBS) $(LIBINTL) $(CAPLIBS)
++other_libs = $(DNSLIBS) $(LIBINTL) $(CAPLIBS)
+
+ bin_PROGRAMS = gpg gpgv
+ dist_pkgdata_DATA = options.skel
+diff --git a/keyserver/Makefile.am b/keyserver/Makefile.am
+index 3379910..3527c60 100644
+--- a/keyserver/Makefile.am
++++ b/keyserver/Makefile.am
+@@ -33,7 +33,7 @@ gpgkeys_hkp_SOURCES = gpgkeys_hkp.c ksutil.c ksutil.h
+ gpgkeys_finger_SOURCES = gpgkeys_finger.c ksutil.c ksutil.h
+ gpgkeys_curl_SOURCES = gpgkeys_curl.c ksutil.c ksutil.h
+
+-other_libs = $(LIBICONV) $(LIBINTL) $(CAPLIBS)
++other_libs = $(LIBINTL) $(CAPLIBS)
+
+ gpgkeys_ldap_CPPFLAGS = @LDAP_CPPFLAGS@
+ gpgkeys_ldap_LDADD = ../util/libcompat.a @LDAPLIBS@ @NETLIBS@ $(other_libs) @GETOPT@ @W32LIBS@
+diff --git a/tools/Makefile.am b/tools/Makefile.am
+index 8a9c035..22cdb1e 100644
+--- a/tools/Makefile.am
++++ b/tools/Makefile.am
+@@ -28,7 +28,7 @@ AM_CPPFLAGS += -DLOCALEDIR="\"$(localedir)\""
+ endif
+
+ needed_libs = ../cipher/libcipher.a ../mpi/libmpi.a ../util/libutil.a
+-other_libs = $(LIBICONV) $(LIBINTL) $(CAPLIBS)
++other_libs = $(LIBINTL) $(CAPLIBS)
+
+
+ bin_PROGRAMS = gpgsplit
diff --git a/external/meta-gplv2/recipes-support/gnupg/gnupg_1.4.7.bb b/external/meta-gplv2/recipes-support/gnupg/gnupg_1.4.7.bb
index 85636ab8..6a950fdd 100644
--- a/external/meta-gplv2/recipes-support/gnupg/gnupg_1.4.7.bb
+++ b/external/meta-gplv2/recipes-support/gnupg/gnupg_1.4.7.bb
@@ -19,7 +19,8 @@ SRC_URI = "${GNUPG_MIRROR}/gnupg/gnupg-${PV}.tar.bz2 \
file://CVE-2013-4576.patch \
file://CVE-2013-4242.patch \
file://fix-ustar-check-issue.patch \
- "
+ file://0001-Make-it-build-with-gettext-0.20.patch \
+ "
SRC_URI[md5sum] = "b06a141cca5cd1a55bbdd25ab833303c"
SRC_URI[sha256sum] = "69d18b7d193f62ca27ed4febcb4c9044aa0c95305d3258fe902e2fae5fc6468d"
@@ -84,6 +85,7 @@ EXTRA_OECONF = "--disable-ldap \
"
# Force gcc's traditional handling of inline to avoid issues with gcc 5
+BUILD_CFLAGS += "-fgnu89-inline"
CFLAGS += "-fgnu89-inline"
do_install () {
@@ -95,6 +97,8 @@ do_install () {
# split out gpgv from main package
RDEPENDS_${PN} = "gpgv"
+RDEPENDS_${PN}_class-native = ""
+
PACKAGES =+ "gpgv"
FILES_gpgv = "${bindir}/gpgv"
@@ -104,3 +108,5 @@ FILES_${PN} = "${bindir}/* ${datadir}/${BPN} ${libexecdir}/${BPN}/*"
PACKAGECONFIG ??= ""
PACKAGECONFIG[curl] = "--with-libcurl=${STAGING_LIBDIR},--without-libcurl,curl"
PACKAGECONFIG[libusb] = "--with-libusb=${STAGING_LIBDIR},--without-libusb,libusb-compat"
+
+BBCLASSEXTEND += "native"
diff --git a/external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info.inc b/external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info.inc
new file mode 100644
index 00000000..2614d3ad
--- /dev/null
+++ b/external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info.inc
@@ -0,0 +1,37 @@
+SUMMARY = "Shared MIME type database and specification"
+HOMEPAGE = "http://freedesktop.org/wiki/Software/shared-mime-info"
+SECTION = "base"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "libxml2 intltool-native glib-2.0 shared-mime-info-native"
+
+SRC_URI = "http://freedesktop.org/~hadess/shared-mime-info-${PV}.tar.xz"
+
+inherit autotools pkgconfig gettext mime
+
+EXTRA_OECONF = "--disable-update-mimedb"
+
+FILES_${PN} += "${datadir}/mime"
+FILES_${PN}-dev += "${datadir}/pkgconfig/shared-mime-info.pc"
+
+# freedesktop.org.xml is only required when updating the mime database,
+# package it separately
+PACKAGES =+ "shared-mime-info-data"
+FILES_shared-mime-info-data = "${datadir}/mime/packages/freedesktop.org.xml"
+RDEPENDS_shared-mime-info-data = "shared-mime-info"
+
+do_install () {
+ autotools_do_install
+
+ update-mime-database ${D}${datadir}/mime
+}
+
+do_install_class-native () {
+ autotools_do_install
+
+ ${B}/update-mime-database ${D}${datadir}/mime
+}
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info/install-data-hook.patch b/external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info/install-data-hook.patch
new file mode 100644
index 00000000..262ff756
--- /dev/null
+++ b/external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info/install-data-hook.patch
@@ -0,0 +1,25 @@
+fix shared-mime-info build race condition
+
+The definition of install-data-hook in Makefile.am leads
+to multiple, overlapping, executions of install-binPROGRAMS
+target. We modify the definition to avoid that.
+
+Upstream-Status: Pending
+
+Signed-off-by: Joe Slater <jslater@windriver.com>
+
+Index: shared-mime-info-1.9/Makefile.am
+===================================================================
+--- shared-mime-info-1.9.orig/Makefile.am
++++ shared-mime-info-1.9/Makefile.am
+@@ -50,7 +50,9 @@ else
+ update_mime_database="$(top_builddir)/update-mime-database$(EXEEXT)"
+ endif
+
+-install-data-hook: install-binPROGRAMS
++# do NOT make this dependent on anything!
++#
++install-data-hook:
+ if ENABLE_UPDATE_MIMEDB
+ $(update_mime_database) -V "$(DESTDIR)$(datadir)/mime"
+ endif
diff --git a/external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch b/external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch
new file mode 100644
index 00000000..fea34a55
--- /dev/null
+++ b/external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch
@@ -0,0 +1,33 @@
+The Makefile used by shared-mime-info is one big race with the SUBDIRS
+option and the dependency specifically calling make all combining to
+create multiple make instances all of which may try and build targets
+like update-mime-database.
+
+This patch removes those options meaning make can correctly identify
+dependencies and stop itself racing itself.
+
+RP 10/10/2011
+
+Upstream-Status: Pending
+Signed-off-by: Constantin Musca <constantinx.musca@intel.com>
+
+Index: shared-mime-info-1.9/Makefile.am
+===================================================================
+--- shared-mime-info-1.9.orig/Makefile.am
++++ shared-mime-info-1.9/Makefile.am
+@@ -1,5 +1,3 @@
+-SUBDIRS=. po
+-
+ AM_CPPFLAGS = $(ALL_CFLAGS)
+
+ packagesdir = $(datadir)/mime/packages
+@@ -81,8 +79,7 @@ endif
+
+ all: $(defaultmakedeps)
+
+-create-pot:
+- $(AM_V_GEN) $(MAKE) -C po shared-mime-info.pot
++create-pot: po
+
+ local-test: create-pot freedesktop.org.xml update-mime-database$(EXEEXT)
+ if CROSS_COMPILING
diff --git a/external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info_1.10.bb b/external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info_1.10.bb
new file mode 100644
index 00000000..9fc210b7
--- /dev/null
+++ b/external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info_1.10.bb
@@ -0,0 +1,7 @@
+require shared-mime-info.inc
+
+SRC_URI += "file://parallelmake.patch \
+ file://install-data-hook.patch"
+
+SRC_URI[md5sum] = "418c2ced9dc4dd5ca8b06a755e6d64e9"
+SRC_URI[sha256sum] = "c625a83b4838befc8cafcd54e3619946515d9e44d63d61c4adf7f5513ddfbebf"