summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-gnome/recipes-gnome/dconf
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-gnome/recipes-gnome/dconf')
-rw-r--r--external/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf-editor_3.34.2.bb (renamed from external/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf-editor_3.28.0.bb)4
-rw-r--r--external/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf/fix-meson-0.52.patch25
-rw-r--r--external/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf_0.28.0.bb18
-rw-r--r--external/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf_0.34.0.bb27
4 files changed, 54 insertions, 20 deletions
diff --git a/external/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf-editor_3.28.0.bb b/external/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf-editor_3.34.2.bb
index 70f917ea..699511f7 100644
--- a/external/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf-editor_3.28.0.bb
+++ b/external/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf-editor_3.34.2.bb
@@ -8,8 +8,8 @@ DEPENDS = "dconf gtk+3"
inherit gnomebase vala gettext gsettings bash-completion
-SRC_URI[archive.md5sum] = "cc9eb8020cc848812972d8519c3d05cf"
-SRC_URI[archive.sha256sum] = "455b53d827820efd28a176ee52e13eda5cda8cdf4e31e0145cfdd69931bf0c5a"
+SRC_URI[archive.md5sum] = "2907205ad1a0e2774c981932cb7ff25b"
+SRC_URI[archive.sha256sum] = "cecc2a5cb44af68be80e970e83fb9e3e92e2a74df7c90b63324e6da19a929d5f"
FILES_${PN} += " \
${datadir}/dbus-1 \
diff --git a/external/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf/fix-meson-0.52.patch b/external/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf/fix-meson-0.52.patch
new file mode 100644
index 00000000..485c4650
--- /dev/null
+++ b/external/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf/fix-meson-0.52.patch
@@ -0,0 +1,25 @@
+With meson 0.52 the build fails due to duplicate symbols. There is a fix
+to meson but the dconf build also needs tweaking.
+
+https://gitlab.gnome.org/GNOME/dconf/issues/59
+https://github.com/mesonbuild/meson/pull/5936
+
+Despite the comments there about this being incorrect, libdconf is unchanged
+between 0.51 and 0.52 and this patch.
+
+Upstream-Status: Pending [under discussion, see above links]
+Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
+
+Index: dconf-0.34.0/client/meson.build
+===================================================================
+--- dconf-0.34.0.orig/client/meson.build
++++ dconf-0.34.0/client/meson.build
+@@ -28,7 +28,7 @@ libdconf_client = static_library(
+
+ libdconf_client_dep = declare_dependency(
+ dependencies: gio_dep,
+- link_whole: libdconf_client,
++ link_with: libdconf_client,
+ )
+
+ libdconf = shared_library(
diff --git a/external/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf_0.28.0.bb b/external/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf_0.28.0.bb
deleted file mode 100644
index 99292a88..00000000
--- a/external/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf_0.28.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SUMMARY = "configuation database system"
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
-SECTION = "x11/gnome"
-
-SRC_URI[archive.md5sum] = "81faa8e68e5ea71ff0ee75050fc0759c"
-SRC_URI[archive.sha256sum] = "61d3b3865ef58b729c3b39aa0979f886c014aa8362f93dcfc74bf5648ed9c742"
-
-DEPENDS = "dbus glib-2.0 intltool-native"
-
-GNOMEBASEBUILDCLASS = "meson"
-
-inherit gnomebase gsettings bash-completion vala
-
-FILES_${PN} += " \
- ${datadir}/dbus-1 \
- ${libdir}/gio/modules/*.so \
-"
diff --git a/external/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf_0.34.0.bb b/external/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf_0.34.0.bb
new file mode 100644
index 00000000..3c3802f3
--- /dev/null
+++ b/external/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf_0.34.0.bb
@@ -0,0 +1,27 @@
+SUMMARY = "configuation database system"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
+SECTION = "x11/gnome"
+
+SRC_URI[archive.md5sum] = "a3ab18ed51a0494a1c8436fef20cc1b0"
+SRC_URI[archive.sha256sum] = "943a94ab16121de5580ceaed2605b87444d1bca1c6cd8beefb778bcb0aa2da52"
+
+DEPENDS = "dbus glib-2.0 intltool-native"
+
+GNOMEBASEBUILDCLASS = "meson"
+
+inherit gnomebase bash-completion vala
+
+SRC_URI += "file://fix-meson-0.52.patch"
+
+# I/O error : Attempt to load network entity http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
+EXTRA_OEMESON = "-Dman=false"
+# no bash-completion for native
+EXTRA_OEMESON_append_class-native = "-Dbash_completion=false"
+
+FILES_${PN} += " \
+ ${datadir}/dbus-1 \
+ ${libdir}/gio/modules/*.so \
+"
+
+BBCLASSEXTEND = "native"