summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-networking/recipes-connectivity/openconnect
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-networking/recipes-connectivity/openconnect')
-rw-r--r--external/meta-openembedded/meta-networking/recipes-connectivity/openconnect/openconnect/0001-trojans-tncc-wrapper.py-convert-to-python3.patch71
-rw-r--r--external/meta-openembedded/meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb (renamed from external/meta-openembedded/meta-networking/recipes-connectivity/openconnect/openconnect_git.bb)14
2 files changed, 79 insertions, 6 deletions
diff --git a/external/meta-openembedded/meta-networking/recipes-connectivity/openconnect/openconnect/0001-trojans-tncc-wrapper.py-convert-to-python3.patch b/external/meta-openembedded/meta-networking/recipes-connectivity/openconnect/openconnect/0001-trojans-tncc-wrapper.py-convert-to-python3.patch
new file mode 100644
index 00000000..623ec101
--- /dev/null
+++ b/external/meta-openembedded/meta-networking/recipes-connectivity/openconnect/openconnect/0001-trojans-tncc-wrapper.py-convert-to-python3.patch
@@ -0,0 +1,71 @@
+From de78bcac5e1fd13de0371c8e14b062b8786ade56 Mon Sep 17 00:00:00 2001
+From: Max Krummenacher <max.krummenacher@toradex.com>
+Date: Sun, 2 Feb 2020 15:53:05 +0000
+Subject: [PATCH] trojans/tncc-wrapper.py: convert to python3
+
+Use 2to3 to convert the script to python3.
+
+Upstream-Status: Pending
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+---
+ trojans/tncc-wrapper.py | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/trojans/tncc-wrapper.py b/trojans/tncc-wrapper.py
+index 0d4587bf..1a9a1f4d 100755
+--- a/trojans/tncc-wrapper.py
++++ b/trojans/tncc-wrapper.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python2
++#!/usr/bin/python3
+
+ # Lifted from Russ Dill's juniper-vpn-wrap.py, thus:
+ #
+@@ -18,19 +18,19 @@
+
+ import subprocess
+ import mechanize
+-import cookielib
++import http.cookiejar
+ import getpass
+ import sys
+ import os
+ import zipfile
+-import urllib
++import urllib.request, urllib.parse, urllib.error
+ import socket
+ import ssl
+ import errno
+ import argparse
+ import atexit
+ import signal
+-import ConfigParser
++import configparser
+ import time
+ import binascii
+ import hmac
+@@ -39,7 +39,7 @@ import hashlib
+ def mkdir_p(path):
+ try:
+ os.mkdir(path)
+- except OSError, exc:
++ except OSError as exc:
+ if exc.errno == errno.EEXIST and os.path.isdir(path):
+ pass
+ else:
+@@ -64,9 +64,9 @@ class Tncc:
+ if zipfile.ZipFile(self.tncc_jar, 'r').testzip() is not None:
+ raise Exception()
+ except:
+- print 'Downloading tncc.jar...'
++ print('Downloading tncc.jar...')
+ mkdir_p(os.path.expanduser('~/.juniper_networks'))
+- urllib.urlretrieve('https://' + self.vpn_host
++ urllib.request.urlretrieve('https://' + self.vpn_host
+ + '/dana-cached/hc/tncc.jar', self.tncc_jar)
+
+ with zipfile.ZipFile(self.tncc_jar, 'r') as jar:
+--
+2.20.1
+
diff --git a/external/meta-openembedded/meta-networking/recipes-connectivity/openconnect/openconnect_git.bb b/external/meta-openembedded/meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb
index c944144e..597c1920 100644
--- a/external/meta-openembedded/meta-networking/recipes-connectivity/openconnect/openconnect_git.bb
+++ b/external/meta-openembedded/meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb
@@ -2,7 +2,14 @@ SUMMARY = "Open client for Cisco AnyConnect VPN"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=243b725d71bb5df4a1e5920b344b86ad"
+SRC_URI = " \
+ git://git.infradead.org/users/dwmw2/openconnect.git \
+ file://0001-trojans-tncc-wrapper.py-convert-to-python3.patch \
+"
+SRCREV = "ea73851969ae7a6ea54fdd2d2b8c94776af24b2a"
+
DEPENDS = "vpnc libxml2 krb5 gettext-native"
+RDEPENDS_${PN} = "bash python3-core vpnc-script"
PACKAGECONFIG ??= "gnutls lz4 libproxy"
@@ -14,14 +21,9 @@ PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy,"
# not config defaults
PACKAGECONFIG[pcsc-lite] = "--with-libpcsclite,--without-libpcsclite,pcsc-lite,"
-PV = "7.08"
-
-SRCREV = "9697bea0e50952cab57063238b43a7099e498cbb"
-SRC_URI = "git://git.infradead.org/users/dwmw2/openconnect.git"
-
S = "${WORKDIR}/git"
inherit autotools pkgconfig
-EXTRA_OECONF += "--with-vpnc-script=${SYSROOT_DESTDIR}${sysconfdir}/vpnc/vpnc-script \
+EXTRA_OECONF += "--with-vpnc-script=${sysconfdir}/vpnc/vpnc-script \
--disable-static"