summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-networking/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-networking/recipes-devtools/python')
-rw-r--r--external/meta-openembedded/meta-networking/recipes-devtools/python/python3-ldap_3.2.0.bb (renamed from external/meta-openembedded/meta-networking/recipes-devtools/python/python-ldap_2.4.45.bb)14
1 files changed, 8 insertions, 6 deletions
diff --git a/external/meta-openembedded/meta-networking/recipes-devtools/python/python-ldap_2.4.45.bb b/external/meta-openembedded/meta-networking/recipes-devtools/python/python3-ldap_3.2.0.bb
index dde8a52d..f46ddbf4 100644
--- a/external/meta-openembedded/meta-networking/recipes-devtools/python/python-ldap_2.4.45.bb
+++ b/external/meta-openembedded/meta-networking/recipes-devtools/python/python3-ldap_3.2.0.bb
@@ -9,21 +9,23 @@ OpenLDAP 2.x libraries. Errors will appear as exceptions."
LICENSE = "PSF"
HOMEPAGE = "http://www.python-ldap.org/"
-DEPENDS = "python openldap cyrus-sasl"
+DEPENDS = "python3 openldap cyrus-sasl"
PYPI_PACKAGE = "python-ldap"
-inherit pypi setuptools
+inherit pypi setuptools3
LIC_FILES_CHKSUM = "file://LICENCE;md5=36ce9d726d0321b73c1521704d07db1b"
-SRC_URI[md5sum] = "6108e189a44eea8bc7d1cc281c222978"
-SRC_URI[sha256sum] = "824fde180a53772e23edc031c4dd64ac1af4a3eade78f00d9d510937d562f64e"
+SRC_URI[md5sum] = "fe22522208dc9b06d16eb70f8553eaab"
+SRC_URI[sha256sum] = "7d1c4b15375a533564aad3d3deade789221e450052b21ebb9720fb822eccdb8e"
do_configure_prepend() {
- sed -i -e 's:^library_dirs =.*::' setup.cfg
- sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' setup.cfg
+ sed -i -e 's:^library_dirs =.*::' ${S}/setup.cfg
+ sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' ${S}/setup.cfg
}
RDEPENDS_${PN} = " \
${PYTHON_PN}-pprint \
${PYTHON_PN}-threading \
+ ${PYTHON_PN}-pyasn1 \
+ ${PYTHON_PN}-pyasn1-modules \
"